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お客様へのご注意 
 

重要:  
どのような文書でも内容は時間が経つにつれ古くなります。本書も例外ではありません。Microchip社
の製品は、お客様のニーズを満たすために常に改良を重ねており、実際のダイアログやツールが本書

の内容とは異なる場合があります。最新文書はMicrochip社のウェブサイト(www.microchip.com)をご

覧ください。 

文書は「DS」番号によって識別します。この識別番号は各ページのフッタのページ番号の前に表記し

ています。DS番号「DSXXXXXA」の「XXXXX」は文書番号、「A」は文書のリビジョンレベルを表し

ます。 

開発ツールの最新情報はMPLAB® X IDEのオンラインヘルプでご覧になれます。[Help]メニューから

[Help Content]を選択すると、オンラインヘルプ ファイルのリストが表示されます。 

 
 

注意: この日本語版文書は参考資料としてご利用ください。 
最新情報は必ずオリジナルの英語版をご参照願います。 
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1. MPLAB X IDEとは 

MPLAB® X IDEは、Microchip社製マイクロコントローラ(MCU)とデジタルシグナル コントローラ(DSC)向けのアプ

リケーション開発用ソフトウェアです。 

この開発ツールは統合開発環境(IDE)と呼ばれ、組み込みマイクロコントローラのコード開発向けに1つに統合され

た「環境」を提供します。MPLAB X IDEは組み込み回路設計の案出、設定、開発、デバッグ、認証に役立つ強力な

ツールを備えています。MPLAB X IDEはソフトウェアとツールのMPLAB開発エコシステムとシームレスに連携し、

多くは無償で提供しています。 
 
 
1.1 組み込みシステムの概要 

一般的に組み込みシステムとは、Microchip社のPIC®やAVR®マイクロコントローラ(MCU)等の小型MCUの機能を利

用したシステムを指します。このようなMCUは、マイクロプロセッサ ユニット(PCのCPUに相当)と「周辺モジュ

ール」と呼ぶ付加回路で構成され、さらに、外部デバイスの数を減らすために、小規模の制御モジュール回路が同

一チップ上に追加されています。このように1つのチップに集積されたデバイスを電子/機械装置に組み込む事によ

り、低コストのデジタル制御が実現します。 
 

1.1.1 組み込みコントローラとPCの違い 
組み込みコントローラは、1つまたは複数の限定されたタスクだけを実行するという点で、PCとは大きく異なります。

PCは不特定のプログラムを実行でき、各種の外部デバイスへ接続できます。組み込みコントローラは1つのプログラ

ムだけを実行するため、そのタスクの実行に必要な処理能力とハードウェアだけを実装するだけで済み、結果として

価格を低く抑える事ができます。 

対してPCは、比較的高価な汎用中央演算装置(CPU)を核とし、多数の外部デバイス (メモリ、ディスクドライブ、ビ

デオ コントローラ、ネットワーク インターフェイス回路等)を備える必要があります。組み込みシステムは演算装

置として低コストMCUを使い、同一チップに各種の周辺回路を含める事により、比較的少数の外部デバイスしか必

要としません。 

多くの場合、組み込みシステムは各種製品(コードレスドリル、冷蔵庫、車庫用のオートシャッター等)の内部製品ま

たはサブモジュールとして使われます。このようなコントローラは、製品の全体機能の中のごく限られた部分だけ

に関与します。また、コントローラはデバイス内の重要サブシステムの一部に低コストのインテリジェンス機能を

付加します。 

組み込みシステムの例として煙感知器があります。煙感知器はセンサの信号を評価し、煙の発生を示す信号を検出

すると警報を鳴らします。煙感知器が内蔵する小規模のプログラムは、無限ループを実行して煙センサの信号をサ

ンプリングするか、あるいは普段は低消費電力の「スリープ」モードで待機し、センサからの信号によって復帰し

ます。復帰したプログラムは、その時点で警報を鳴らします。通常、このようなプログラムは動作テストや電池残

量アラーム等の機能も備えています。 

センサとオーディオ出力を備えたPCにも同様の機能を持たせる事は可能ですが、9 Vのバッテリ1個だけで何年間も

無人稼動させる事はできず、低コストにはなりません。煙感知器、カメラ、携帯電話、家電製品、自動車、スマー

トカード、セキュリティ システム等の日用品へのインテリジェンス機能の組み込みには、多くの場合安価なMCUが

使われます。 
 

1.1.2 MCUの構成要素 
MCUは、プログラムを実行するためのファームウェアを格納するプログラムメモリ(図1-1、図1-2)またはコード化さ

れた命令(図1-3、図1-4)を内蔵しています。プログラムメモリのアドレス (リセットおよび割り込みアドレスを含む)
指定にはプログラム カウンタ(PC)を使います。コード内のコールおよびリターン命令ではハードウェア スタックを

使います。このスタックはプログラムメモリと連携して動作しますが、プログラムメモリの一部ではありません。 
プログラムメモリの動作の詳細(ベクタ、スタック等)はデバイス データシートに記載しています。 
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図1-1 PIC® MCUのデータシート – プログラムメモリとスタック 
 

図1-2 AVR® MCUのデータシート – プログラムメモリ 
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図1-3 PIC® MCUのデータシート – 命令セット(抜粋) 
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図1-4 AVR® MCUの命令セット(抜粋) 
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MCUはデータ(またはファイルレジスタ) メモリも内蔵しています。このメモリは特殊機能レジスタ(SFR)と汎用レジ

スタ(GPR)で構成されます。SFRはデバイスの動作を制御するためにCPUと周辺機能が使うレジスタです。GPRは

プログラムの計算に必要な変数等の一時的なデータの保存用に使います。MCUにはデータEEPROMメモリを内蔵す

るものもあります。プログラムメモリと同様に、データメモリの使い方と動作の詳細もデバイス データシートに記

載しています。 

表1-1PIC® MCUのデータシート – ファイルレジスタの例 
 

Bank 0 File 
Address 

Bank 1 File 
Address 

Bank 2 File 
Address 

Bank 3 File 
Address 

Indirect addr. 
(1) 

00h Indirect addr.(1) 80h Indirect addr. 
(1) 

100h Indirect addr.(1) 180h 

TMR0 01h OPTION_REG 81h TMR0 101h OPTION_REG 181h 

PCL 02h PCL 82h PCL 102h: PCL 182h: 

STATUS 03h STATUS 83h STATUS 103h STATUS 183h 

FSR 04h: FSR 84h: FSR 104h FSR 184h: 

PORTA 05h: TRISA 85h PORTA 105h: TRISA 185h 

PORTB 06h: TRISB 86h: PORTB 106h: TRISB 186h: 

PORTC 07h TRISC 87h: PORTC 107h TRISC 187h: 
 08h  88h  108h  188h 
 09h  89h  109h  189h 

PCLATH 0Ah PCLATH 8Ah PCLATH 10Ah PCLATH 18Ah: 

INTCON 0Bh INTCON 8Bh: INTCON 10Bh: INTCON 18Bh 

PIR1 0Ch PIE1 8Ch EEDAT 10Ch EECON1 18Ch 

PIR2 0Dh PIE2 8Dh EEADR 10Dh EECON2(1) 18Dh 

TMR1L 0Eh PCON 8Eh EEDATH 10Eh:  18Eh 

TMR1H 0Fh OSCCON 8Fh EEADRH 10Fh  18Fh 

T1CON 10h OSCTUNE 90h:  110h  190h 

TMR2 11h  91h  111h  191h 

T2CON 12h PR2 92h  112h  192h 

SSPBUF 13h SSPADD(2) 93h  113h  193h 

SSPCON 14h SSPSTAT 94h  114h  194h 

CCPR1L 15h WPUA 95h WPUB 115h  195h 

CCPR1H 16h IOCA 96h IOCB 116h  196h 

CCP1CON 17h WDTCON 97h  117h  197h 

RCSTA 18h TXSTA 98h VRCON 118h  198h 

TX1REG 19h SPBRG 99h CM1CON0 119h  199h 

RC1REG 1Ah SPBRGH 9Ah CM2CON0 11Ah  19Ah 
 1Bh BAUDCTL 9Bh CM2CON1 11Bh  19Bh 

PWM1CON 1Ch  9Ch  11Ch  19Ch 

ECCPAS 1Dh  9Dh  11Dh PSTRCON 19Dh 
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(続き) 
Bank 0 File 

Address 
Bank 1 File 

Address 
Bank 2 File 

Address 
Bank 3 File 

Address 

ADRESH 1Eh: ADRESL 9Eh ANSEL 11Eh
: 

SRCON 19Eh 

ADCON0 1Fh ADCON1 9Fh ANSELH 11Fh  19Fh 

General 
Purpose 
Register 
96 Bytes 

20h General 
Purpose 
Register 
80 Bytes 

A0h General 
Purpose 
Register 
80 Bytes 

120h  1A0h 
 EFh 16Fh  

 accesses 
70h-7Fh 

F0h accesses 
70h-7Fh 

170h accesses 
70h-7Fh 

1F0h 

7Fh FFh 17Fh 1FFh 

表内の空白セル: 未実装のデータメモリ領域、「0」として読み出し 
Note 1: 物理レジスタではありません。 
Note 2: アドレス93hは、特定条件においてSSPマスク(SSPMSK)にもアクセスします。 
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図1-5 AVR® MCUのデータシート – SRAMデータメモリとスタック 
 

メモリ以外にも、MCUは各種周辺モジュールを内蔵しています。周辺モジュールは入出力(I/Oポート)を含みます。

I/Oポートとは出力として使えるMCUのピンであり、HighまたはLowに駆動する事で信号の送信、ランプの点滅、ス

ピーカの駆動等を実行できます。多くの場合これらのピンは双方向であり、入力として構成する事もできます。入力

として使う場合、外部スイッチまたはセンサからの入力に対する応答、外部デバイスとの通信が可能です。 
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図1-6 PIC® MCUのデータシート – ブロック図(抜粋) 
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図1-7 AVR® MCUのデータシート – ブロック図(抜粋) 
 

 
このようなシステムを設計する場合、アプリケーションに必要な周辺モジュールを選択します。 

一般的な周辺モジュールは以下の通りです。 

• A/Dコンバータ(ADC)を使うと、MCUに接続したセンサから電圧信号を取り込めます。 
• シリアル通信モジュールを使うと、別のMCU、ローカル ネットワーク、インターネットと通信できます。 
• PIC MCUのタイマモジュールを使うと、信号イベントの正確な計測、通信用信号の生成と受信、正確な波形の

生成が可能な他、電源の瞬断やハードウェアの誤作動によるハングアップやフリーズが発生した場合に、MCU
を自動的にリセットできます。 
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• その他に、外部電源が危険レベルまで低下した事を検出し、電力供給が完全に途絶える前に重要な情報を保存

し、MCUを安全にシャットダウンするための周辺モジュールもあります。 

使うべきPIC MCUは、アプリケーションが必要とする周辺モジュールとメモリ容量によってほぼ決まります。その

他の選択基準としては、MCUの消費電力とサイズが挙げられます。 

図1-8 PIC® MCUのパッケージ例 
 



MPLAB X IDEユーザガイド 
MPLAB X IDEとは 

ユーザガイド DS-50002027E_JP - p. 17 © 2019 Microchip Technology 
 

 

 

 
 

図1-9 AVR® MCUのパッケージ例 
 

 
電力が供給され、オシレータがクロック信号を生成し始めるとMCUはアクティブになります。MCUによっては、

複数の内部または外部オシレータ動作モードを備えているものがあります。 

図1-10 PIC® MCUのデータシート – タイミング図(抜粋) 
 

図1-11 AVR® MCUのデータシート – タイミング図(抜粋) 
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1.1.3 MPLAB X IDEによる組み込みシステム回路の実装 
組み込みコントローラ用開発システムはPC上で動作し、組み込みシステム アプリケーションのコーディング、編集、

デバッグと、MCUへの書き込みを支援するソフトウェアです。MPLAB X IDEは、組み込みシステム アプリケーショ

ンの設計と実装に必要な要素を備えています。

組み込みコントローラ アプリケーションの開発における代表的な作業手順は以下の通りです。

1. まず全体的な回路構成を設計します。次に、必要な機能と性能に基づいて、そのアプリケーションに最適な

MCUを選択し、関連するハードウェア回路を設計します。ハードウェアを制御する周辺モジュールとピンを

決定したら、ファームウェア(組み込みアプリケーションのハードウェアを制御するためのソフトウェア)を作

成します。これには、マシンコードに直接変換可能なアセンブラや、高級プログラミング言語(C言語、BASIC
等)用のコンパイラを使います。アセンブラやコンパイラでは、関数や変数にプログラム内の参照先ルーチン

や用途に対応した名前を付けてコードを読みやすくできます。また、コードを構造化する事により、良好な保

守性が得られます。

2. アセンブラ、コンパイラ、リンカを使ってソフトウェアをコンパイル、アセンブル、リンクします。これによ

り、コードを1と0だけで記述したマシンコード(MCUが実行できるコード)に変換します。このマシンコードが

MCUに書き込まれることになるファームウェアです。

3. 作成したコードをMCUに書き込む前に、動作をテストします。複雑なプログラムでは、最初から期待通りに

動作する事は稀であり、正しく動作させるにはプログラムのバグを取り除く必要があります。デバッガを使う

と、マシンコードの実行状態をソースコード内の関数名と変数名に対応させて観察できます。デバッグ作業で

は、プログラムのシングルステップ実行による変数値の確認や、その値を変更してルーチンの動作を確認する

「what if」チェックが可能です。

4. 最後に、マシンコードをMCUに書き込んで、正しく動作する事を確認します。

上の手順はいずれも非常に複雑な作業になりかねません。このような作業では、設計そのものに専念できる環境が重

要です。MPLAB X IDEを使う事により、煩わしい操作の習得に時間を費やさずに設計作業に集中できます。 

ステップ1は設計段階ですが、設計上の重要な判断を下すために、MPLAB X IDEを回路とコードのモデル化に役立て

る事ができます。

MPLAB X IDEは、特にステップ2～4で真価を発揮します。コーディング用のエディタは各種言語ツールに対応して

おり、コーディングを支援します。このエディタは、アセンブラとコンパイラのプログラミング構造を認識して、自

動的にソースコードを色分け表示します。このため、構文の誤り等を容易に見つけ出せます。プロジェクト マネー

ジャにより、アプリケーションで使う各種ファイル (ソースファイル、プロセッサ記述ヘッダファイル、ライブラリ 
ファイル)を容易に管理できます。コードをビルドする際に、コンパイラによるコードの最適化レベル(実行速度優先

またはバイナリサイズ優先)、変数とプログラムデータのメモリ格納領域を設定できます。MCUのメモリをアプリケ

ーション用に最大限に活用するために、「メモリモデル」を指定する事もできます。アプリケーションのビルド中に

言語ツールでエラーが発生すると、エラー発生行が表示されます。その行をダブルクリックしてソースファイルを即

座に修正できます。コード修正後にアプリケーションを再ビルドして、エラーがないか確認します。複雑なコードで

は、複数のサブセクションを作成してテストする必要があるため、記述 - コンパイル - 修正のループを繰り返すのが

普通です。MPLAB X IDEを使うと、このループを最短時間で終わらせて次のステップへ進む事ができます。

コードのビルドでエラーが発生しなくなったら、次はコードの動作をテストします。MPLAB X IDEは、コードのテ

ストを支援するために、全てのMCUに対応するデバッガと無償ソフトウェア シミュレータを備えています。ソフト

ウェア シミュレータを使うと、ハードウェアが完成する前にMCUの動作をシミュレートしてコードをテストできま

す。シミュレータは外部信号に対するファームウェアの応答をモデル化します。このため、シミュレートした外部信

号(スティミュラス)を入力する必要があります。シミュレータでは実行時間の計測、コードのシングルステップ実行

による変数と周辺モジュールの観察、コードのトレースによるプログラム実行状態の詳細な記録等が可能です。

プロトタイプのハードウェアをアプリケーションに組み込める段階になると、インサーキット エミュレータやイン

サーキット デバッガ等のハードウェア デバッガを使えます。これらのデバッグツールは、フラッシュメモリ内蔵デ

バイスの多くが備える特殊な回路を使って、実際のアプリケーション上でコードをリアルタイムに実行します。これ

らのツールを使うと、プログラムの実行を停止/再開して、ターゲットMCUのプログラムメモリとデータメモリの内

容を観察できるため、アプリケーションにMCUを組み込んだ状態でコードをテストできます。

アプリケーションが正常に動作したら、Microchip社のデバイスプログラマまたは開発用プログラマを使って、MCU
にプログラムを書き込みます。これらのプログラマは、コードがデバイスに正しく書き込まれたかベリファイします。
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MPLAB X IDEはほとんどのPIC MCU、全てのdsPIC DSC、多くのAVRおよびSAM MCUをサポートしています。 
 
 
1.2 開発サイクル 

アプリケーション コードを作成するプロセスは、しばしば開発「サイクル」と呼ばれます。これは、設計から実装

までの一連のステップを1回で問題なく完了できる事は稀なためです。正しく動作するアプリケーションを開発する

には、コードの記述/テスト/修正を何度も繰り返す必要があります。 

統合開発環境は、このような開発において複数のツールを何度も切り換える煩わしさからエンジニアを解放します。

全ての機能を統合するMPLAB X IDEを使えば、ツールや動作モードの切り換えのたびに作業を中断する必要がなく

なるため、アプリケーション開発に集中できます。 

図1-12 設計サイクル 
 

MPLAB X IDEは、共通のグラフィカル ユーザ インターフェイスを介して全てのツールを(通常は自動的に)連動させ

る「ラッパー」として機能します。例えば、ソースコードを記述し、これを実行可能なマシンコードに変換し、

MCUに書き込み、その動作を確認するといった一連の作業を共通の環境内で実行できます。開発プロセスでは、コ

ードを記述するためのエディタ、ファイルと設定を管理するためのプロジェクト マネージャ、ソースコードをマシ

ンコードに変換するためのコンパイラまたはアセンブラ、MCUと接続またはMCUの動作をシミュレートするための

各種ハードウェア/ソフトウェア等、複数のツールが必要です。 
 
 
1.3 プロジェクト マネージャ 

プロジェクト マネージャは、編集したファイルを他の関連ファイルと一緒にまとめて、アセンブルまたはコンパイ

ル用の言語ツールに渡します。これらのファイルは最終的にリンカへ渡されます。 

リンカは、アセンブラ/コンパイラ/ライブラリから受け取った複数のオブジェクト コードを組み込みコントローラの

メモリ領域に適切に配置して、各モジュールが相互に機能できるようにリンクさせます。 

このようなアセンブル/コンパイルからリンクまでのプロセス全体を、プロジェクトの「ビルド」と呼びます。必要

に応じて、ファイルごとに異なる言語ツール向けのプロパティを呼び出す事ができます。このような場合でも、ビル

ドプロセスが全ての言語ツールの動作を統合します。 
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図1-13 MPLAB® X IDEのプロパティ マネージャ 

ソースファイルは、アセンブラまたはコンパイラの規則に従って書かれたテキストファイルです。アセンブラとコン

パイラは、これらのソースファイルを複数の中間的なマシンコード モジュールに変換します。この際、関数とデー

タを参照するためにプレースホルダも生成されます。

リンカはこれらのプレースホルダを解決し、全てのモジュールから実行可能なマシンコード ファイルを生成します。

リンカはデバッグファイルも生成します。MPLAB X IDEは、このデバッグファイルに基づいて、実行用マシンコー

ドを元のソースファイルに関連付けます。

コードの作成にはテキストエディタを使います。このエディタはテキストの構造を認識し、命令ニーモニック、C言

語の構造体、コメント等の各種エレメントを色分け表示します。エディタは、ソースコードの作成に必要な一般的

機能を備えています。コード作成後、エディタは他のツールと連携してデバッガ内でのコードの実行状態を表示し

ます。エディタでブレークポイント (コードの実行を一時停止する位置)を設定してプログラムを実行し、変数名の

上にマウスポインタを置くと変数値を表示できます。変数名をソーステキスト ウィンドウからウォッチ ウィンドウ

にドラッグ&ドロップすると、各ブレークポイントで停止した時またはコード実行中に変数値の変化を観察できます。 

1.4 言語ツール

「言語ツール」とは、クロスアセンブラやクロスコンパイラ等のプログラムを指します。Visual BasicやCコンパイ

ラのように、PC上で動作する言語ツールが一般的によく知られています。

組み込みシステムでは「クロスアセンブラ」または「クロスコンパイラ」を言語ツールとして使います。これらのツ

ールもPC上で動作しますが、そのPCではなく別のマイクロプロセッサ(またはMCU)上で動作するコードを生成しま

す。

これらの言語ツールはデバッグファイルも生成します。MPLAB X IDEは、デバッグファイルを使ってマシン語命令

とメモリ領域をソースコードに関連付けます。この関連付けにより、MPLAB X IDEエディタによるブレークポイン

トの設定とウォッチ ウィンドウによる変数の表示が可能となり、ソースコードをシングルステップ実行してアプリ

ケーションの動作を観察できるようになります。

組み込みシステムの言語ツールは、コードサイズが非常に重要視されるという点でも、一般的なコンパイラと異なり

ます。これは、コードサイズを小さくできればMCUのメモリサイズを小さくでき、それだけコストを削減できるか

らです。このため、ターゲット デバイスを熟知してコードを最適化するテクニックが求められます。

一般的なPC用プログラムの場合、ある程度複雑なプログラムになると、そのサイズは数MBに達します。これに対し、

単純な組み込みシステムのプログラムであれば、1 KB以下に収める事ができます。比較的複雑な機能を実行する中

規模の組み込みシステムになると、32Kまたは64Kのメモリサイズが必要になる場合もあります。組み込みシステム

の中には、大規模なテーブル、ユーザテキスト メッセージ、データのロギングに何MBものストレージを使うものも

あります。
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図1-14 コンパイラによるソースコードからマシンコードへの変換 

 
 
1.5 デバッグ 

統合開発環境(IDE)では、コードの動作をテストするためにデバッガを使います。デバッガには、MCUの動作をPC上

でシミュレートするソフトウェア プログラム (シミュレータ)と、実際のアプリケーション内でプログラムの動作を

解析できるハードウェア デバイス (ハードウェア デバッガ)があります。 

IDEとデバッグ 

通常、プロジェクトの設計サイクルが最終段階に近づくと、デバッグは緊急の課題になります。製品化の最終ステッ

プではアプリケーションを当初の設計通りに機能させる必要がありますが、多くの場合この段階が製品の完成に遅れ

を生じる最大の要因となります。このような製品開発において、統合開発環境が極めて重要な役割を果たします。コ

ードの「微調整」、リコンパイル、ダウンロード、テストは全てそれなりに時間を要します。全て同じ環境内のツー

ルを使う事で、サイクル時間を短縮できます。致命的なバグを全て取り除く必要がある最終ステップでは、組み込み

エンジニアの腕が試されます。適切なツールはエンジニアを支援して開発期間を短縮します。MPLAB X IDEでは、

各種ツールを共通のインターフェイスで使えるため、ソフトウェア シミュレータから低コストのインサーキット デ
バッガへ、さらには強力なインサーキット エミュレータへとツールをアップグレードする際にも習熟が容易です。 
 

ソフトウェア デバッガ 

MPLAB X IDEはシミュレータを内蔵しているため、ハードウェアを追加しなくても、PC上でプログラムをテストで

きます。シミュレータはソフトウェア デバッガとも呼ばれ、その機能はハードウェア デバッガとほぼ同じです。こ

のためシミュレータの使い方を習得すれば、ハードウェア デバッガも容易に使えます。シミュレータはPCのCPUを

使ってMCUの動作をシミュレートするため、通常は実際のMCUよりも低速で動作します。 

ハードウェア デバッガ 

MPLAB X IDEで使えるハードウェアには、プログラマとハードウェア デバッガの2種類があります。プログラマは、

PC上で作成したマシンコードをMCUの内部メモリに書き込みます。これにより、アプリケーションに組み込んだ

MCU上でプログラムを実行できるようになります。 

しかし、最初からコードが期待通りに機能する事はきわめて稀です。そこで実際のアプリケーションでプログラムの

動作をよく観察して、期待通りの動作が得られるようにソースコードを修正する必要があります。このプロセスをデ

バッグと呼びます。既に説明した通り、シミュレータはPC上でコードの動作をテストできますが、MCUにプログラ

ムを書き込んで実際のアプリケーションで動作させると、シミュレータでは見つからなかった問題が多数発生します。

プログラマだけでコードを変更してMCUにプログラミングし直し、ターゲットにプラグインして再テストできます

が、コードが複雑な場合、長い時間と労力を要するサイクルになる可能性があります。また、ハードウェア内の問題

を正確に理解する事は困難です。 

このような場合、ハードウェア デバッガが有効です。ハードウェア デバッガには、特殊なデバッグ用回路を内蔵し

たMCUを使うインサーキット エミュレータとインサーキット デバッガがあります。ハードウェア デバッガは、こ

の特殊な回路を使う事によりシミュレータと同様にコード内の任意ステップでの変数の観察や、シングルステップ実

行を可能にします。 
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1.6 デバイスのプログラミング 
アプリケーションのデバッグが終わって、開発環境で完全に動作する事を確認できたら、今度は実際のデバイス上で

動作をテストする必要があります。デバイスのプログラミングにはインサーキット エミュレータ、インサーキット 
デバッガ、開発用プログラマ、デバイス プログラマを使えます。MPLAB X IDをプログラマ機能向けに設定して、デ

バイスにプログラムを書き込む事ができます。これにより、アプリケーションを完成品とほぼ同じ状態で観察できる

ようになります。エンジニアリング プロトタイプ プログラマを使うと、プロトタイプを素早く作成して評価できま

す。アプリケーションによっては、デバイスをプリント基板にはんだ実装後でもプログラミングできます。In-Circuit 
Serial Programming™ (ICSP™)プログラミング機能を使うと、製造時にファームウェアを書き込み、さらに後から書

き直す事もできます。インサーキット デバッグをサポートしているデバイスなら、完成品をインサーキット デバッ

ガに接続して製造後の品質検査とファームウェアの改良開発が可能です。 

量産時のプログラミングには量産プログラマとMPLAB IPEを使います。MPLAB IPEはMPLAB X IDEと共にインスト

ールされます。 

 
1.7 MPLAB X IDEの構成要素 

MPLAB X IDEは以下の要素で構成されています。 

• プログラマ用テキストエディタ: このエディタはデバッガ用のウィンドウとしても機能します。 
• プロジェクト マネージャ (プロジェクト ウィンドウとして表示): IDEと言語ツール間の統合と通信を提供します。 
• 各種アセンブラ/リンカ パッケージ: ターゲット デバイスのファームウェア開発に使います。 
• デバッガエンジン: ブレークポイント、シングルステップ実行、ウォッチ ウィンドウ等、デバッガが備えるべき

全ての機能を提供します。デバッガは、ソフトウェアおよびハードウェア デバッグツールと連携して機能します。 
• ソフトウェア シミュレータ: 全てのPIC/dsPICデバイス、多くのAVR/SAMデバイスに対応します。シミュレー

タの実行ファイルは、デバイス別に用意しています。MPLAB X IDEは、それらのファイルの中から、ターゲッ
ト デバイスに適合するファイルを選択します。 

以下のMPLAB X IDE用オプション コンポーネントもご利用またはご購入頂けます。 

コンパイラ言語ツール 

Microchip社のMPLAB XC Cコンパイラは、MCU向けに完全に統合および最適化したコードを提供します。コミュニ

ティベース コンパイラ、サードパーティ コンパイラをMPLAB X IDEのプロジェクト マネージャから起動してコー

ドをコンパイルする事もできます。コンパイルしたコードは自動的にターゲット デバッガに読み込まれ、テストと

検証が可能です。 

プログラミング環境/フレームワーク 

MPLAB Code Configurator (MCC)は、無償のグラフィカルなプログラミング環境です。MCCで設計を行うと、シー

ムレスで分かりやすいC言語コードが生成され、プロジェクトに挿入できます。[Tools] > [Plugins] > [Available 
Plugins]を選択すると、MCCプラグインをMPLAB X IDEにインストールできます。 

MPLAB® Harmonyは、移植可能な周辺モジュール ライブラリをベースに構築されたシステムサービス、デバイスド

ライバ、その他ライブラリのフレームワークであり、組み込みPIC32アプリケーションの開発に使える柔軟性、移植

性、一貫性のあるソフトウェア「構成要素」を提供します。MPLAB Harmony Configurator (MHC)は、MPLAB 
Harmony向けの便利なハードウェア設定ユーティリティであり、[Tools] > [Plugins] > [Available Plugins]からプラグ

インとして入手できます。 

プログラマ 

MPLAB ICD 4インサーキット デバッガ等の量産プログラマを使うと、量産環境でターゲット デバイスにコードをプ

ログラミングできます。プログラマとMPLAB X IDEまたはMPLAB IPEを組み合わせて使う事で、コードとデータだ

けでなく、ターゲットMCUまたはDSCの各種動作モードを設定するコンフィグレーション ビットのプログラミング

も制御できます。 

インサーキット デバッガ/エミュレータ 

インサーキット デバッガおよびエミュレータを使うと、ターゲット デバイス上でアプリケーション コードをデバッ
グできます。これらのツールは、一部のデバイスが内蔵する特殊なリソースを使って、アプリケーションに実装済み
のターゲットMCUにコードをダウンロードし、ブレークポイントの設定、コードのシングルステップ実行、レジス
タと変数の監視を可能とします。エミュレータでは、その他トレース等のデバッグ機能も利用できます。 

プラグインツール 
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MPLAB X IDEに機能を追加するために、各種プラグインを利用できます。例えばMPLAB Data Visualizerを使うと、

アプリケーションの出力をリアルタイムでグラフィカルに表示する事ができます。 
 
 
1.8 MPLAB X IDEヘルプ 

MPLAB X IDEは、NetBeansプラットフォームをベースにしています。従って、多くのNetBeans機能をMPLAB X 
IDEの機能として利用できます。NetBeansヘルプトピックの詳細は、以下を参照してください。 

https://docs.oracle.com/cd/E50453_01/doc.80/e50452/toc.htm 

ヘルプ 

MPLAB X IDEの挙動を完全に理解するには、全てのヘルプファイルを参照してください。ヘルプを開くには[Help] > 
[Help Contents]を選択します。この操作により全ヘルプファイルが1つに結合されます。そのため開くのに少し時間

がかかります。 

ツールのヘルプ 

[Help] > [Tool Help Contents]で選択したツールの個別のヘルプファイルを参照する事もできます。個別のヘルプファ

イルを開く事で、素早く範囲を絞って内容を検索できます。 

開発者ヘルプ 

Microchip Developer Helpは先進機能のヒントを探すのに便利です。

http://microchipdeveloper.com/ 

Developer Helpでトピックを検索するには[How do I?]の横のボックスにテキストを入力します。 

図1-15 Microchip Developer Help 

 
1.9 その他のMPLAB X IDE関連文書 

ヘルプ以外の文書、ビデオとフォーラムへのリンク、Wikiは[Start Page]から利用できます。 

https://docs.oracle.com/cd/E50453_01/doc.80/e50452/toc.htm
http://microchipdeveloper.com/
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図1-16 MPLAB X IDEの[Start Page] 

 
 
1.10 Microchip社ウェブサイト 

Microchip社は以下のウェブサイトで開発ツールのオンライン サポートを提供しています。

http://www.microchip.com/development-tools/ 

 
 

1.11 Microchip社オンラインストア 
MPLAB X IDE v3.xx以降、開発ツール ソフトウェア/ハードウェア製品を入手するにはMicrochip社のオンラインスト

アにIDE経由でアクセスします。 

• [MPLAB X Store]タブ – [Start Page]タブの隣がこのタブです。このタブは各種製品へのリンクを提供します。 
• [Help] > [MPLAB X Store] – [Help]メニューの下に[MPLAB X Store]タブを開くリンクがあります。 
• [MPLAB X Store]ツールバー アイコン – [MPLAB X IDE]ツールバー上のアイコンで[MPLAB X Store]タブが開き

ます。 
 
 
1.12 プログラミング センター 

Microchip社プログラミング センターを使うと、デバイスへのコードの書き込みまたはプログラミング済み製品の無

償サンプル請求が可能です。以下のアイコンをクリックするとmicrochipDIRECTのサイトが開きます。 

ストアのアイコン 

http://www.microchip.com/development-tools/
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プログラミング センターのアイコン 

 
 

1.13 MPLAB X IDEの更新 
MPLAB X IDEはユーザの皆様にお使い頂くだけでなく、Microchip社内でも新機能を採用した新型MCUの開発に使

っています。MPLAB X IDEの新機能の多くは、お客様からのご要望とMicrochip社内での使用経験を基に開発して

います。新設計のMCUのリリースが続く限り、MPLAB X IDEも進化し続けます。 

新しいデバイスのサポートと新機能を追加するために、MPLAB X IDEのバージョンはほぼ数ヶ月に1回のペースで

更新されます。 

開発プロジェクトの途中でMPLAB X IDEの新バージョンがリリースされた場合、よほどの理由(例: 現在の作業を阻

害しているバグの修正)がない限り、その時点での新バージョンへの更新は推奨しません。新しいプロジェクトの

開始時に更新する事を推奨します。 

新バージョンへの更新のたびに、MPLAB X IDEソフトウェアに新機能が追加されるため、マニュアル等の印刷文書

の更新はオンラインヘルプよりも遅れます。このため、MPLAB X IDEで疑問が生じた場合、オンラインヘルプが最

良の参照資料です。 

MPLAB X IDEと関連要素の変更通知サービスをご希望のお客様は、以下のmyMICROCHIP Personalized 
Notification Serviceで開発ツールのセクションにご登録ください。 

http://www.microchip.com/pcn 
 
 
1.14 IDE外での作業手順 

MPLAB X IDEは、組み込みシステム向けアプリケーションの書き込み、デバッグ、リリースを支援するように設計

されています。しかし、IDE外でコード開発が必要な場合があります。 

MPLAB X IDE外でコードをビルドする方法は、以下を参照してください。

http://microchipdeveloper.com/mplabx:work-outside 

http://www.microchip.com/pcn
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2. 使用前の準備 
MPLAB X IDEを使うには以下の作業を行います。 

• readme/リリースノートでのインストール要件の確認 
• MPLAB X IDE(とJRE)のインストール 
• ハードウェア ツール用USBドライバのインストール 
• ターゲットへの接続 
• 言語ツール (アセンブリ、コンパイラ)のインストール 
• IDEの起動 
• Microchip社オンラインストアでの購入 

さらに、IDEの複数インスタンスの起動方法、複数バージョンの起動方法、起動パラメータの使い方を学習します。 
 
 
2.1 インストール要件の確認 

インストール要件とインストールに関する問題は「Readme for MPLAB X IDE」に記載されています。このHTMLフ
ァイルへは、デスクトップ上の[Learn & Discover] > [Getting Started] > [Users Guide & Release Notes]からアクセス

できます。 
 
 
2.2 JREとMPLAB X IDEのインストール 

MPLAB X IDE (NetBeansプラットフォーム ベース)をインストールする際、Java Runtime Environment (JRE) 8もイ

ンストールされます。このJREはMPLAB X IDE専用であり、他の用途ではPCに登録されていません。 

Windows XPの場合、JRE 7をインストールする必要があります。MPLAB X IDEインストーラはシステムでJRE 7を
検索します。見つからなかった場合、推奨ダウンロードサイトを表示します。 

Mac OS XにおけるJRE 8のサポートは10.8 (Mountain Lion)から始まりました。従って、MPLAB X IDEにはMac OS 
X 10.8以上が必要です。 

 
 
2.3 ハードウェア ツール用USBデバイスドライバのインストール 

MPLAB X IDEインストーラは、サポートされているハードウェア ツールのUSBデバイスドライバのプリインストー

ラを含んでいます。MPLAB X IDEをインストールした後でハードウェア ツールをPCに接続すると、オペレーティン

グ システム(OS)がドライバとツールを関連付けます。しかし、一部のOSとツールでは正しい関連付けに追加ステッ

プが必要です。 

macOS®またはLinux®用USBドライバのインストール 

MPLAB X IDEをMacまたはLinux PCにインストールする場合、追加ステップは不要です。 

Windows®用USBドライバのインストール 

MPLAB X IDEをWindows PCにインストールする場合、以下の手順を実行します。 

Note:  MPLAB IDE v8用のUSBハードウェア ツール ドライバは、MPLAB X IDE用とは異なります。

下表に、手順が必要なツールと不要なツールを示します。 

手順が必要なツール 不要なツール 

MPLAB REAL ICEインサーキット エミュレータ PICkit 2またはPICkit 3インサーキット デバッガ 

MPLAB ICD 3、MPLAB ICD 4、 
MPLAB PICkit 4インサーキット デバッガ その他のMPLABスタータキット 

MPLAB PM3デバイス プログラマ 
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(続き) 
手順が必要なツール 不要なツール 

PIC32スタータキット 
 

以下のセクションに記載する手順を実行し、インストール方法を決定します。 
 

2.3.1 MPLAB X IDEをインストールする前に 
既存のWinUSBドライバのWindowsのバージョンがIDEプリインストーラのバージョンより古いと、システムドラ

イバは新しいものに置き換えられます。既存のWinUSBドライバを残しておきたい場合、MPLAB X IDEのインス

トール前にファイル名を変えておきます。 

WinUSBドライバファイルは以下の場所に保存されています。 

32ビットWindowsの場合: 

C:\Windows\system32\WinUSB.dll (32ビット)  
C:\Windows\system32\drivers\WinUSB.sys (64ビット)  

64ビットWindowsの場合: 
C:\Windows\SysWOW64\WinUSB.dll (32ビット) 
C:\Windows\system32\WinUSB.dll (64ビット) 
C:\Windows\system32\drivers\WinUSB.sys (64ビット) 

2.3.2 MPLAB IDE v8.xxがシステムにインストールされていない場合 
特別な操作は必要ありません。MPLAB X IDEのインストール時にUSBドライバもインストールされます。PCのUSB
ポートにツールを接続すると、[新しいハードウェアが見つかりました]というバルーン メッセージが表示されます。

その後、ドライバが自動的にインストールされます。またはウィザードに従い[自動的にドライバを選択する]ように

設定します。しかし、どちらの手順も失敗した(プリインストールされたドライバとツールを関連付けられなかった)
場合、手動でインストール/関連付けを行う必要があります。その手順とドライバの保存場所は2.3.3.4「ドライバの

手動切り換えが必要な場合」を参照してください。 
 

2.3.3 MPLAB IDE v8.xxがインストール済みの場合 
コンピュータにMPLAB IDE v8.xx以前のバージョンがインストール済みの場合、MPLAB Device Driver Switcherを実

行してMPLAB IDE v8ドライバからMPLAB X IDEドライバに切り換える必要があります。 

ツールに関連付けられているドライバの判定は以下の手順で行います。 

1. ツール ハードウェアをPCのUSBコネクタに接続します。 
2. PCの[デバイス マネージャ]ウィンドウを開きます。 

2.1. MPLAB IDE v8.xxの場合、ドライバは[Custom USB Device] > [Microchip Custom USB Device]に
保存されています。 

2.2. MPLAB X IDEの場合、ドライバは[Microchip Tools] > [Microchip WinUSB Device]に保存されています。 
3. MPLAB IDE v8.xxドライバをSwitcherでMPLAB X IDEドライバに切り換えます。 

MPLAB X IDEのドライバに切り換えるには、以下を参照してください。 

1. 手動切り換え(Windows XP 64の場合) 
2. 管理者モードの使用(Windows 7または8の場合) 
3. ツール用USBデバイスドライバの切り換え 

Switcherがドライバの切り換えに失敗した場合、以下を参照してください。 

1. ドライバの手動インストールが必要な場合 
2. ツールの通信問題 

2.3.3.1 手動切り換え(Windows XP 64の場合) 
Note:  Microsoft Windows XP Professional SP3のサポートは終了しました。ただし、サポート外ですがほとんどの

場合MPLAB X IDEは動作します。 
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64ビット版Windows XPを使っている場合、MPLAB Device Driver Switcherで自動的にドライバを切り換える事はで

きません。この場合、手動で切り換える必要があります。2.3.3.4「ドライバの手動切り換えが必要な場合」を参照

してください。 

2.3.3.2 管理者モードの使用(Windows 7または8の場合) 
MPLAB Device Driver Switcherを実行するには、管理者モードでログインする必要があります。 

Switcherユーティリティを管理者として実行するには、実行ファイルを右クリックして[管理者として実行]を選択し

ます。実行ファイルは以下の場所に保存されています。 
• 32ビット版の場合: C:\Program Files\Microchip\MPLABX\vx.xx\Switcher\32Bit\MPDDSwitch.exe 
• 64ビット版の場合: C:\Program 

Files(x86)\Microchip\MPLABX\vx.xx\Switcher\64Bit\MPDDSwitch64.exe 

ドライバの切り換えにはSwitcher GUIユーティリティを推奨します。このユーティリティがうまく動作しない場合の

み、コマンドライン アプリケーションを使います。 

コマンドライン アプリケーション(mchpdds32.exeまたはmchpdds64.exe)を管理者として実行するには、コマンド 
プロンプトを管理者モードで起動します。[スタート] > [全てのプログラム] > [アクセサリ] > [コマンド プロンプト]を
右クリックして [管理者として実行 ]を選択します。管理者用コマンドプロンプト画面が開きます。ここで、

ReadMe32.txtまたはReadMe64.txtファイルに記載されているコマンドを入力してドライバを切り換えます。 

2.3.3.3 ハードウェア ツール用USBドライバの切り換え 
MPLAB Device Driver Switcherは、MPLAB IDE v8ドライバとMPLAB X IDEドライバを切り換えるためのGUIアプリ

ケーションです。デスクトップのアイコンをクリックすると、Switcherユーティリティが起動します。 

図2-1 MPLAB Driver Switcherのアイコン 

図2-2 Swithcerユーティリティ 

 
Switcherの操作 

USBドライバの切り換えは以下の手順で行います。 

1. [Tool Group and Action]の下で、ドライバを切り換えツールをクリックして選択します。  
Note:  Switcher実行時にツールを接続しておかないと、そのツールに対応したドライバのインストールと切

り換えができません。 
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2. ラジオボタンで[MPLAB 8]または[MPLAB X]を選択します。 
3. [Apply Changes]ボタンをクリックします。切り換えの進捗状況がテキスト ウィンドウに表示されます。

切り換えには少し時間がかかります。 
4. 切り換えが完了したら、[デバイス マネージャ]ウィンドウでドライバ名を確認します。MPLAB X IEの場合、

ドライバは[Microchip Tools] > [Microchip WinUSB Device]で確認できます。MPLAB IDE v8.xxの場合、ドライ

バは[Custom USB Device] > [Microchip Custom USB Device]で確認できます。 

Switcherのトラブルシュート 

1. GUIによるドライバの切り換えに失敗した場合、[Advanced]ボタンをクリックしてドライバファイルへのパス

を確認した上でSwitcherを再度実行します。 
2. それでもGUIからドライバを切り換えられない場合、手動で切り換えます。その手順とドライバの保存場所は、

2.3.3.4「ドライバの手動切り換えが必要な場合」を参照してください。 

Switcher実行ファイルの保存場所 

Switcher実行ファイルは、MPLAB X IDEインストール フォルダ、Switcherサブフォルダの以下の場所に保存されて

います(既定値)。 

• 32ビット版の場合: C:\Program Files\Microchip\MPLABX\vx.xx\Switcher 
• 64ビット版の場合: C:\Program Files (x86)\Microchip\MPLABX\vx.xx\Switcher 

vx.xxはMPLAB X IDEのバージョンです。 

2.3.3.4 ドライバの手動切り換えが必要な場合 
USBドライバの手動切り換えまたは関連付けが必要な場合、以下の手順を実行します。 

1. [コントロール パネル]の[デバイス マネージャ]を開きます。[Microchip Tools]でツールを探します。見つから

ない場合、[その他のデバイス]の下の[不明なデバイス]で探します。 
2. ツール名または[不明なデバイス]を右クリックして、[ドライバ ソフトウェアの更新]を選択します。 
3. [ドライバ ソフトウェアの更新]ダイアログで[コンピュータを参照してドライバ ソフトウェアを検索します]を

選択します。 
Note:  [ドライバ ソフトウェアの最新版を自動検索します]は選択しないでください。Windowsの既定値ドラ

イバがツールに関連付けられてしまい、ツールが機能しなくなる場合があります。誤って選択した場合、元に

戻るかダイアログを終了し、上の手順を再度実行して正しいドライバに切り換えます。 
4. デバイスドライバの正しい保存場所を参照します。 

MPLAB X IDEの場合、デバイスドライバの既定値での保存場所は以下の通りです。 

C:\Program 
Files\Microchip\MPLABX\vx.xx\Switcher\32Bit\ winusb\x86\MCHPWinUSBDevice.inf 

または 

C:\Program Files 
(x86)\Microchip\MPLABX\vx.xx\Switcher\64Bit\ winusb\amd64\MCHPWinUSBDevice.inf 

vx.xxはMPLAB IDEMPLAB X IDEのバージョンです。 
5. Windowsのセキュリティ ダイアログが表示された場合、[このドライバ ソフトウェアをインストールします]

を選択し、選択したドライバに切り換えます。 

2.3.3.5 ツールの通信問題 
1. ドッキング ステーションまたはハブを介してツールを接続するとうまく行かない場合があります。その場合

PCのUSBポートに直接ツールを接続します。 
2. デバイスドライバを手動で切り換える場合、「32Bit」または「64Bit」フォルダ内のINFファイルを指定する

必要があります。詳細は2.3.3.4「ドライバの手動切り換えが必要な場合」を参照してください。 
 
2.4 ターゲットとハードウェア ツールの接続 

インサーキット デバッガやエミュレータを使う場合、以下を参照してそれらのツールをターゲットに接続します。 

• 開発ツールの設計アドバイザリ 
• ヘッダの仕様書(ヘッダを使う場合) 
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• ツールのマニュアル 

プログラマ専用機の場合、プログラマのマニュアルを参照してください。 

Microchip社のデモボード、評価用キット、リファレンス デザインをターゲットとして使う場合、セットアップに関

する情報は、それらに付属する文書を参照してください。 
 
 
2.5 言語ツールのインストール 

MPLAB X IDEをインストールする際に、言語ツールのMPASMツールチェーンも一緒にインストールされます。 

さらに、MPLAB X IDEでは以下のCコンパイラ ツールチェーン (コンパイラ、アセンブラ、リンカ等)を使えます。

コンパイラ ツールチェーンを選ぶ際は、設計に使うデバイスがサポートされているか注意します。 

• MPLAB XC Cコンパイラ 
• AVRおよびArm Cコンパイラ 
• AVRASM2 - Atmel Studioと一緒にインストールされる 

MPLAB XCコンパイラは、FreeとPRO(機能制限なし、コード最適化使用可能)のライセンスがあります。これらの

コンパイラのインストールとライセンス取得の方法は『MPLAB® XC Cコンパイラのインストールとライセンス認証』

(DS50002059)を参照してください。MPLAB X IDEは、インストール済みコンパイラのライセンス取得とネットワー

ク ライセンスの取得/返却機能を備えています。[Tools] > [Licenses]で行います。 

AVRとArm GNU Cコンパイラ(GCC)は無償です。インストーラの画面に従ってインストールします。 

Note:  これらのコンパイラは、MPLAB X IDEがアクセスできる場所にインストールする必要があります(例: MPLAB 
XC Cコンパイラの場合はC:\Program Files\Microchip)。そうでない場合、MPLAB X IDEでその場所を指定します(4.7
「言語ツールのパスの指定」参照)。 

 
 
2.6 MPLAB IDEの起動とデスクトップの表示 

[MPLAB X IDE]アイコンをダブルクリックするとプログラムが起動します。 

図2-3MPLAB X IDEのアイコン 

MPLAB X IDEは、NetBeansプラットフォームに基づいて構築されています。NetBeans IDEを使い慣れていれば、

MPLAB X IDEデスクトップはすぐに使えます。しかし、以下のタブはMPLAB X IDE特有のものです。 

• [Start Page] 
• [MPLAB X Store] 

[Start Page]は、各種のリンクを収めた3つのタブで構成されています。起動時に[Start Page]を表示したくない場合、

各タブの下部の[Show on Startup]のチェックを外します。 

https://www.microchip.com/mplab/compilers
https://www.microchip.com/mplab/compilers
https://www.microchip.com/mplab/avr-support/avr-and-arm-toolchains-c-compilers
https://www.microchip.com/mplab/avr-support/avr-and-arm-toolchains-c-compilers
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図2-4 MPLAB X IDEのデスクトップ 

 
 
2.7 [MPLAB X Store]での購入 

[MPLAB X Store]タブをクリックするとMicrochip社オンラインストアからツールを購入できます。このタブでは

MPLAB X IDEに関する最新の商品を紹介します。各種カテゴリを参照して他の商品を見つける事もできます。 

このタブは[Help]メニューまたはツールバー アイコンから直接アクセスする事もできます。 

図2-5 MPLAB X Store 

追加の機能が予定されています。[Start Page]の[My MPLAB IDE]からmicrochipDIRECTへのログインが可能になる予

定です。その場合、 

• ソフトウェアに関するアラート(HPAの失効等)を確認できます。 
• mySoftwareアカウントにアクセスできます。mySoftwareアカウントでは各種ライセンスを登録およびダウンロ

ードし、HPAを更新できます。 
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2.8 複数インスタンスのIDEを起動する方法 
MPLAB X IDEの各インスタンスでハードウェア ツール(MPLAB PICkit 4等)を使うには、事前に設定が必要です。 
ハードウェア ツールの準備が完了したら、IDEのインスタンスをIDEと同じフォルダから起動します。 

 
2.8.1 複数インスタンスを使うためのハードウェア ツールの設定方法 

既定値ではIDEのインスタンスを最大5つ使えます。それ以上のインスタンスを使う場合、「mchpdefport」ファイ

ルを手動で編集する必要があります。 

「mchpdefport」ファイルの使い方とフォーマット 

「mchpdefport」ファイルは、IDEとローレベルUSBライブラリ(DLL、so、dylibファイル)にツールのホットプラグに

必要な情報を提供します。このファイルのフォーマットを以下に示します。 

1行目はIDEを実行するホスト名を示します。 

以降の行は、ローレベルのライブラリがハイレベルのIDEと通信するポートまたはソケットの番号を表します。IDE
の各インスタンスは、別々のポートまたはソケットに割り当てられます。IDEのインスタンス間の通信はユーザから

は見えません。 

MPLAB X IDEのインスタンスが5つまでの場合、このファイルを編集する必要はありません。6つ以上のインスタン

スを使う場合、このファイルを編集してポートまたはソケットの数を追加します。 

「mchpdefport」ファイルの位置 

IDEの既定値インストールでは、「mchpdefport」ファイルはオペレーティング システムに応じて以下の場所に保存

されています。 
 

OS 場所 

Windows (64ビット) C:\Windows\system32 
と 

C:\Windows\SysWOW64 

Note:  両方の「mchpdefport」を編集する必要があります。 

Note:  64ビットシステムで32ビットエディタを使ってC:\Windows\system32の
「mchpdefport」を編集すると、実際にはSysWOW64の「mchpdefport」を編集しています。

system32のファイルを編集するには64ビットエディタを使う必要があります。 

Windows (32ビット) C:\Windows\system32 

Linux /etc/.mplab_ide 

Mac (OS X) /etc/.mplab_ide 

 
2.8.2 IDEのインスタンスの呼び出し方 

MPLAB X IDEでは、各インスタンスが独自のユーザフォルダを持つ必要があります。従って、あるインスタンスに

対するプリファレンスの設定またはプラグインの追加は、他のインスタンスには反映されません。 

複数のインスタンスを使い分けるには、[–-userdir]オプションでフォルダを指定してIDEを起動します。 

Windows 

[–-userdir]オプションを使ってショートカットを作成します。例: Windows 7: 

1. デスクトップで右クリックし、[新規作成] > [ショートカット]を選択します。 
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$ /opt/microchip/mplabx/vx.xx/mplab_platform/bin/mplab_ide --userdir ~/.anydir1 & 
$ /opt/microchip/mplabx/vx.xx/mplab_platform/bin/mplab_ide --userdir ~/.anydir2 & 

$/bin/sh /Applications/microchip/mplabx/vx.xx/mplab_ide.app/Contents/ 
Resources/mplab_platform/bin/mplab_ide --userdir "${HOME}/Library/ 
Application Support/mplab_ide/dev/anydir" 

 
$/bin/sh /Applications/microchip/mplabx/vx.xx/mplab_ide.app/Contents/ 
Resources/mplab_platform/bin/mplab_ide --userdir anydir 

C:\Program Files (x86)\Microchip\MPLABX\v3.00 

 
 

2. [参照]をクリックして、インストールされているMPLAB X IDEの実行ファイルを指定します(以下は既定値)。 
C:\Program Files (x86)\Microchip\MPLABX\vx.xx\mplab_platform\ bin\mplab_ide.exe 
(vx.xxはMPLAB X IDEのバージョン) 

3. 行の末尾にユーザフォルダの場所を入力します。このタイプのMPLAB X IDE情報の場合、既定値の場所の下

にユーザフォルダを置く事ができます。 
--userdir “C:\Users\MyFiles\AppData\Roaming\.mplab_ide\ dev\anydir” 
または、任意の場所に置いてもかまいません。 
--userdir anydir 

4. [OK]をクリックします。 

Linux 

インストールしたバージョンを、パラメータを指定せず起動(デスクトップ アイコンをクリック)した場合、ユーザフ

ォルダとして「$ (HOME)/.mplab_ide」を使います。ユーザフォルダを変更するには、シェルスクリプト

「$InstallationDir/mplab_platform/bin/ mplab_ide」に引数「--userid anydir」を渡して実行しま

す。以下は、MPLAB X IDEのインスタンスを2つ実行する場合の例です。 

vx.xxはMPLAB X IDEのバージョン 

ユーザIDを埋め込んだデスクトップ アイコンを作成する事もできます。 

Mac OS 

シェルウィンドウを開き、以下のコマンド行を入力して、インストールされているMPLAB X IDEを別のユーザフォ

ルダで実行します。このタイプのMPLAB X IDE情報の場合、既定値の場所の下にユーザフォルダを置く事ができま

す。 

または、任意の場所に置いてもかまいません。 
 

 

2.9 複数バージョンのIDEを使う方法 
MPLAB X IDE v3.00がリリースされる前は、異なるバージョンのMPLAB X IDEをインストールする場合、異なるフ

ォルダにインストールする必要がありました。MPLAB X IDE v3.00からは、これは既定値で行われます。例を以下に

示します。 

複数のバージョンを同時に起動および実行できます。各バージョンは独自のユーザフォルダを持ちます。 

任意のバージョンのMPLAB X IDEとMPLAB IDE (v8以前)を同一PC上で実行できます。しかし、「USBデバイスド

ライバ (ハードウェア ツール用)のインストール」に記載したUSBハードウェア ドライバの制約に留意する必要があ

ります。 

 
2.10 起動パラメータによる起動 

コマンドライン オプションの多くはNetBeansプラットフォーム

からのものです。以下を参照してください。

http://wiki.netbeans.org/FaqStartupParameters 

さらに、--helpオプションを使うと、MPLAB® X IDEオプションのリストを参照できます。例えば64ビット

Windows® 7システムの場合: 

http://wiki.netbeans.org/FaqStartupParameters
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>C:\Program Files (x86)\Microchip\MPLABX\vx.xx\mplab_platform\bin\mplab_ide --help 
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3. チュートリアル 
チュートリアルでは、例を示しながらMPLAB X IDEの使い方を説明します。 

サンプル プロジェクトではポテンショメータの値を4つのLEDに表示します。このプロジェクトをMPLAB X IDEでダ

ウンロードして開くと、プロジェクト プロパティの設定/変更方法とプロジェクトの実行方法が説明されます。ブレ

ークポイントの設定、コードのステップ実行、変数値の表示、レジスタおよびメモリ値の表示/変更等のデバッグ機

能が示されます。 
 
 
3.1 ソフトウェアのインストールとセットアップ 

以下のソフトウェアをダウンロードしてインストールします。インストールの詳細は第2章「使用前の準備」を参照

してください。 

• MPLAB X IDEをインストールします。http://www.microchip.com/mplabxで無償IDEをダウンロードします。 
• MPLAB XC8 Cコンパイラをインストールします。http://www.microchip.com/xcで無償MPLAB XCコンパイラを

ダウンロードします。 

MPLAB X IDEを起動します。IDEウィンドウの[Tools] > [Options] > [Embedded] > [Build Tools]でコンパイラが表示

されている事を確認します。表示されていない場合、[Add]ボタンをクリックし、コンパイラがインストールされた

場所を手動で探します。 

 
 

3.2 ハードウェアの接続 
Curiosity多ピン(HPC)開発ボード(DM164136)とPIC16F18875を使います。詳細は以下の製品ページを参照してくだ

さい。 

• DM164136 
• PIC16F18875 

評価用ボードとPCをUSBケーブルで接続します。ドライバが自動的にインストールされます。 

http://www.microchip.com/mplabx
http://www.microchip.com/xc
https://www.microchip.com/developmenttools/ProductDetails/PartNO/DM164136
https://www.microchip.com/wwwproducts/en/PIC16F18875
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3.3 サンプルコードのダウンロード 

[MPLAB Xpress Code Examples]を開

きます。以下のように選択します。 

• [Tags]の下で「#Getting Started」にチェックを入れます。 
• [Board]の下で「Curiosity HPC Board」にチェックを入れます。 
• [Title]の下で「CuriosityHPC-Basics」をクリックします。 

 

「CuriosityHPC-Basics」ページに、ボードとデバイスの情報へのリンクが表示されています。[Download]をクリッ

クしてサンプル プロジェクトをダウンロードします。ファイルを解凍します。 
 

ヒント:  Users>UserName>MPLABXProjectsフォルダにダウンロードします。 
 
 
 

 
 
3.4 MPLAB X IDEでサンプル プロジェクトを開く 

MPLAB X IDEで[Open Project]アイコン をクリックします。リストをスクロールして「CuriosityHPC-Basics」
プロジェクトを選択し、[Open Project]をクリックします。 

https://mplabxpress.microchip.com/mplabcloud/example
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[Projects]および[Files]ウィンドウの表示 

[Projects]ウィンドウには、ファイルがカテゴリごとにグループ分けされたプロジェクト ツリーが表示されます。 
カテゴリの詳細は8.1「[Projects]ウィンドウの表示」を参照してください。 

[Files]ウィンドウをクリックすると、プロジェクト ファイルのファイル マネージャ画面が表示されます。8.2
「[Files]ウィンドウの表示」を参照してください。 

どちらのウィンドウでもファイル名をダブルクリックすると、そのファイルの内容が[Editor]ウィンドウに表示されま

す。タブを閉じるには、[x]をクリックします。 

[Projects]ウィンドウ内でプロジェクト名を右クリックすると、コンテクスト メニューが開きます。この操作は、プ

ロジェクトのサブフォルダとFilesやClasses等のツリーでも同様です。 

図3-1 [Projects]および[Files]ウィンドウの表示 

[Dashboard]および[Navigator]ウィンドウの表示 

[Dashboard]ウィンドウはプロジェクトの詳細を表示します。詳細は12.6「[Dashboard]ウィンドウ」を参照してく

ださい。 

[Navigator]ウィンドウは選択中のファイルをコンパクトに表示し、ファイル各部への移動を簡単にします。 
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図3-2 プロジェクトを開いている時の[Dashboard]ウィンドウ 

 
 
3.5 プロジェクト プロパティの設定 

[Projects]ウィンドウでプロジェクト名を右クリックすると、ドロップダウン メニューが表示されます。[Properties]

を選択します。[Project Properties]ウィンドウを確認します。[OK]をクリックすると、変更が保存されます。 

Categories このプロジェクトは無償版(free)コンパイラを使うように設定されています。ライセン

ス版を使っている場合、「pro」を選択できます。 

Device ボード上のデバイスと一致しているか確認します。 

Packs 下図で選択されているパックバージョンはMPLAB X IDE v5.20用です。 

Hardware [Starter Kits (PKOB)](内蔵デバッガ)として「Curiosity」を選択します。 

Compiler Toolchain チュートリアルのプロジェクトはMPLAB XC8 v1.37で作成しました。図のように最

新バージョンのコンパイラに変更するか、以下からプロジェクトで使用したバージ

ョンをダウンロードします。 
Downloads Archive 

https://www.microchip.com/development-tools/pic-and-dspic-downloads-archive
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図3-3 [Project Properties]ウィンドウ 

 
 
3.6 コードの実行 

[Run Project]アイコン をクリックすると、プログラムが実行されます。実行の進捗状況は[Output]ウィンドウ

に表示されます(下図参照)。[Hold in Reset]ボタン を使うと、デバイスリセットと実行をトグルできます。 

図3-4 [Output]ウィンドウ - コード実行 

ボード上のポテンショメータを回すと、値に従ってLEDが点灯します。 
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3.7 コードのデバッグ 

本チュートリアルで使うコードの動作はテスト済みです。しかし、実際にアプリケーションを開発する際にはコード

をデバッグする必要があります。 

[Debug Project]アイコン をクリックすると、デバッグ セッションが開始します。デバッグの進捗状況は

[Output]ウィンドウに表示されます。 
 

コードの実行を一時停止する 
 

 
Pause 

コードの実行を再開する 
 

 
Continue 

コードの実行を終了する 
 

 
Finish Debugger Session 

 
C/C++コード プロジェクトのデバッグに関する詳細は以下のNetBeansヘルプも参照してください。 

Debugging C/C++ Projects Tutorial 

図3-5 [Output]ウィンドウ - デバッグモードでのコードの実行 

 
 

3.8 ブレークポイントの設定 
コードをデバッグする際に、コードの特定位置で実行を一時停止して変数値を調べる事ができると便利です。そのた

めにはブレークポイントを使います。 

ブレークポイントの詳細は以下のNetBeansヘルプも参照してください。 

https://netbeans.org/kb/docs/cnd/debugging.html%23starting
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Debugging C/C++ Projects Tutorial>Creating Breakpoints 
 

3.8.1 ブレークポイントの設定 

コード実行中であれば、[Finish Debugger Session]アイコン をクリックして実行を停止します。 

[Projects]ウィンドウの[Source Files]でファイルmain.cをダブルクリックすると、このファイルが[Editor]ウィンドウ

で開きます。下図に示す行の左側の余白をクリックし、この行にブレークポイントを設定します。 

図3-6 コードのブレークポイントの設定 

 
3.8.2 ブレークポイントでの一時停止 

[Debug Project]アイコン をクリックすると、コードを再び実行されます。コード実行はブレークポイント

の位置で一時停止します。pot_value変数の上にマウスカーソルを置くと、現在値が表示されます。 

https://netbeans.org/kb/docs/cnd/debugging.html%23breakpoints
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図3-7 ブレークポイントで一時停止したコード実行 

 
3.8.3 トラブルシュート 

エディタでコード行の横に電球アイコン (警告)が表示される場合、インクルード ファイルのパス設定が必要です。

以下を参照してください。 

Set The Include Directory Path 

Note:  MPLAB XC8 v2.xxではAVR MCUとPIC MCUをサポートしているため、コンパイラのインストール フォルダ

構造が変更されました。 
 
 
3.9 コードのステップ実行 

Step Intoを使うと、ブレークポイントで停止した状態からコードをステップ実行できます。ステップ実行すると、変

数値の変化を調べたり、プログラムフローが正しいかどうかを判断できます。 

Step Over – コードを1行実行します。その行が関数コールだった場合、呼び出した関数全体を

実行して停止します。 
 

Step Into – コードを1行実行します。その行が関数コールだった場合、呼び出した関数の先頭の

命令文を実行して停止します。 
 

Step Out – コードを1行実行します。その行が関数コールだった場合、実行後に呼び出し元の制

御に戻ります。 
 

Run to Cursor – コードをカーソル位置まで実行して停止します。 
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図3-8 ステップ実行中のコード 

 
 
3.10 変数値の表示 

変数値の変化は [Variables]ウィンドウで観察できます。このウィンドウを開くには [Window] > [Debugging] > 
[Variables]を選択します。このウィンドウの詳細は4.17「ローカル変数値の変化の観察」を参照してください。 

[Debug Project]アイコン をクリックします。コードが実行され、ブレークポイントで停止します。

pot_valueの情報が[Variables]ウィンドウに表示されます。 

図3-9 [Variables]ウィンドウ - 1番目のブレークポイントでの停止 

ボード上のポテンショメータを回して値を変化させます。[Continue]アイコン をクリックします。コードが実

行され、再びブレークポイントで停止します。[Variables]ウィンドウを表示し、値が変化した事を確認します(図中

の赤字)。 

図3-10 [Variables]ウィンドウ - 2番目のブレークポイントでの停止 
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#include "mcc_generated_files/mcc.h" 
uint16_t pot_value; 
/* Main application 
*/ 

void main(void) 

while (1) 
{ 

// Add your application code 
pot_value = ADCC_GetSingleConversion(POT); 

 
 

 

3.11 シンボル値の変化の観察 
グローバル シンボルまたはSFRの値の変化を[Watches]ウィンドウで観察します。これらの値がプログラム実行中に

予測通りに変化するか確認する事でコードのデバッグに役立てます。 
 

3.11.1 コードの編集 

[Finish Debugger Session]アイコン をクリックします。 

現在pot_valueはローカルシンボルです。これをグローバル シンボルにするためには、main()の前に宣言します。 
 

ローカル変数宣言を解除するためuint16_tを削除します。 
 

 
この行にブレークポイントを作り、再び[Debug Project]アイコン をクリックします。コード実行はこの行

で停止します。 
 

3.11.2 新規ウォッチの作成 
ウォッチの新規作成方法 

1. [Debug] > [New Watch]を選択すると、[New Watch]ダイアログが開きます。 
2. ウォッチ式(この例では「pot_value」)を入力し、[OK]をクリックします。デスクトップに[Watches]ウィン

ドウが開き、指定したシンボルが表示されます。 

図3-11 [New Watch]シンボル 

 
3.11.3 [Watches]ウィンドウでの値の変化の表示 

[Debug Project]アイコン をクリックします。コードが実行され、ブレークポイントで停止します。[Watches]
ウィンドウにpot_valueの情報が表示されます。 
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図3-12 [Watches]ウィンドウ - 1番目のブレークポイントでの停止 

ボード上のポテンショメータを回して値を変化させます。[Continue]アイコン をクリックします。コードが実

行され、再びブレークポイントで停止します。[Variables]ウィンドウを表示し、値が変化した事を確認します。 

図3-13 [Watches]ウィンドウ - 2番目のブレークポイントでの停止 

このウィンドウの詳細は12.19「[Watches]ウィンドウ」を参照してください。 
 
 
3.12 I/Oレジスタの表示 

[I/O View]ウィンドウは、アクティブなプロジェクトに関連付けられたデバイスのI/Oメモリマップをグラフィカルに

表示します。このデバッグツールはデバッグ時にレジスタが格納している値を表示するため、周辺モジュールの設定

を確認できます。再コンパイルしないでレジスタの値を変更する事もできます。 

[Window] > [Debugging] > [IO View]を選択して[I/O View]ウィンドウを開きます。ウィンドウの[Peripheral](上部)で
[Analog-to-Digital Converter]をクリックします。このモジュールに関連付けられているレジスタが[Register](下部)に
表示されます。 
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図3-14 [IO View]ウィンドウ 

ADCを使ってポテンショメータの信号をLED用のデジタル信号に変換するため、ポテンショメータを回すと一部の

値が変わります。ポテンショメータを回してから[Continue]アイコン をクリックします。 

これらをクリックして直接レジスタの値を変更する事もできます。 
 

このウィンドウの詳細は、以下のセクションを参照してください。 

• 5.20「プロジェクト レジスタの表示([I/O View])」 
• 12.8「[I/O View]ウィンドウ」 

 
 
3.13 デバイスメモリ (コンフィグレーション ビットを含む)の表示 

MPLAB X IDEは柔軟で見やすい[Memory]ウィンドウを備えています。このウィンドウは、各種デバイスメモリに合

わせて、表示を柔軟にカスタマイズできます。[Window] > [Target Memory Views]を選択すると、デバイス固有のメ

モリウィンドウの一覧が表示されます。 

例えばフラッシュメモリを表示するには 

1. [Window] > [Target Memory Views] > [Program Memory]を選択します。 
2. [Program Memory]ウィンドウが開き、直前の一時停止位置が表示されます。 
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図3-15 ブレークポイントで停止時の[Memory]ウィンドウの内容 

[Memory]ウィンドウのオプションを設定するには、[Memory]ウィンドウ内で右クリックし、各種オプション(表示オ

プション、メモリの書き込み、テーブルのインポート/エクスポート、ファイルへの出力等)を含むコンテクスト メニ

ューを開きます。メニュー内容はウィンドウによって異なります。12.「MPLAB X IDEのウィンドウとダイアログ」

を参照してください。 

[Flash Memory]ウィンドウは、下の方法で更新できます。 

1. コード実行を停止(デバッガ セッションを終了)します。 

2. [Read Device Memory]アイコン をクリックします。 

 
3.14 デバイスのプログラミング 

コードをデバッグしたら、ターゲット デバイスにプログラミングします。 

まず、[Project Properties]ウィンドウでプログラミング オプションを確認します。本チュートリアルではオプション

を変更する必要はありません。 
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最後に、[Make and Program]アイコン をクリックしてデバイスをプログラミングします。 

Note:  MPLAB X IDEは、全てのプログラミング機能を備えている訳ではありません。その他のプログラミング機能

のサポートについては、MPLAB X IDEと一緒にインストールされるMPLAB IPEを参照してください。 
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4. 基本作業 
MPLAB® X IDEにおけるプロジェクトの作業手順は以下の通りです。 

表4-1 基本作業手順 
 

 

 
準備 

1. 使用前の準備として、MPLAB X IDEをインストールし、ハードウェア ツールを設定し(USBドライバ

をインストールしてターゲットを正しく接続し)、言語ツールをインストールします。 
2. MPLAB X IDEを起動します。 

 

 
プロジェクトの

作成とビルド 

1. [New Project]ウィザードを使ってプロジェクトを新規作成します(新規プロジェクトの作成)。次に、

デスクトップ ペインで変更を確認します(プロジェクト作成後のデスクトップ ペイン)。 
2. [Project Properties]ウィンドウを開き([Project Properties]ウィンドウを開く)、プロジェクトを確認ま

たは編集し(プロジェクト プロパティの表示と変更)、デバッガ/プログラマ、言語ツールのオプション

を設定します(デバッガ/プログラマツール オプションを設定または変更する方法、言語ツールオプシ

ョンを設定または変更する方法)。 
3. [Tools Options]ダイアログで、言語ツールのパスと、その他のツールオプションを設定します(言語ツ

ールのパスの指定、その他のツールオプションの設定)。 
4. ファイルを新規作成してプロジェクトに追加します(ファイルの新規作成)。または、既存のファイル

をプロジェクトに追加します(既存ファイルのプロジェクトへの追加)。追加したファイルは[File]ウィ

ンドウに表示され、エディタを使ってアプリケーション コードを入力または編集できます。 
5. エディタのその他の機能は「エディタの使い方」を参照してください。 
6. ライブラリとオブジェクト ファイルを追加、設定します(ライブラリやオブジェクト ファイルの追加

と設定)。 
7. 各ファイルまたはフォルダ全体のプロパティ (ビルドに含めるかどうか)を設定します(ファイルおよ

びフォルダ プロパティの設定)。 
8. プロジェクトのビルドプロパティを設定します(ビルドプロパティの設定)。プロジェクトのコンフィ

グレーション タイプ、ビルド前後のステップ、ユーザIDとしてのチェックサムの使用、ビルド完了

時の代替HEXファイルのロードに関するビルドプロパティを設定します。 
9. プロジェクトをビルドします(プロジェクトのビルド)。 

 

 
コードの実行 

1. コードを実行します(コードの実行)。 
2. デバッグ セッションでコードをデバッグします(コードのデバッグ)。 

 

 
コードの 
デバッグ 

1. ブレークポイントによりプログラム実行を制御します(ブレークポイントによるプログラム実行の制

御)。ブレークポイントは、エディタ内で行を選択して設定するか、[Breakpoint]ウィンドウを使って

設定します。 
2. プログラム実行時にコードをステップ実行します(コードのステップ実行)。 
3. [Watches]および[Variables]ウィンドウでシンボルと変数の値の変化を観察します(シンボル値の変化の

観察)。 
4. デバイスメモリを表示または変更します(デバイスメモリの表示と変更)。メモリタイプはデバイスに

よって異なります。「[Configuration Bits]ウィンドウでのコンフィグレーション値の設定」」も参照

してください。 
 

 
デバイスのプログ

ラミング 

1. ツールバーのボタンを使ってデバイスをプログラミングします(デバイスのプログラミング)。 

 
4.1 新規プロジェクトの作成 

プロジェクトには複数のソースファイルと、これらのソースファイルをコンパイルしてリンクし、生成されたプログ

ラムを実行する方法に関する情報が含まれます。IDEは、makefileとメタデータ ファイルを保存するプロジェクト フ
ォルダにプロジェクト情報を保存します。このプロジェクト フォルダにソースフォルダを置く必要はありませんが、

プロジェクトの移植性という点では推奨します。 

IDEでは常にプロジェクト内で作業を行います。プログラムが1つのソースファイルに格納されている場合も同様で

す。IDEがプロジェクトをビルドできるように、各プロジェクトは固有のmakefileを持つ必要があります。プロジェ

クトのmakefileはIDEで生成できますが、IDE外で作成したmakefileを使う事もできます。 

IDEが生成したmakefileを含むプロジェクトはManaged Projects(管理プロジェクト)と呼び、いくつかの種類があり

ます。MPLAB X IDEで[New Project]ウィザードを使ってプロジェクトを作成する際に、利用可能なプロジェクト タ
イプから選択できます。 
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IDE外で作成したmakefileを使うプロジェクトはUser Makefile Projects(ユーザMakefileプロジェクト)と呼びます。

このタイプのmakefileの作成に関する情報は「MPLAB® X IDE外部でのMakefileの作成」を参照してください。 

プロジェクトはIDEの[Projects]ウィンドウで操作します(12.15「[Projects]ウィンドウ」)。 

コンフィグレーション タイプを変更する事でスタンドアロン (アプリケーション) プロジェクトをライブラリ プロジ

ェクトに変更できます。詳細は4.10.1「プロジェクト コンフィグレーション タイプの変更」を参照してください。 
 

4.1.1 MPLAB X IDE v5新プロジェクト フォーマット 
v5.00以降の新プロジェクト フォーマットでは、バージョン別にデバイス情報を格納するパックをサポートしていま

す。パックは以下に保存されています。 

<MPLAB X IDE install directory>\v5.xx\packs 

プロジェクトの管理 

v5.00以降で作成または更新されたプロジェクトは、v4.xxに対して下位互換ではありません。 

v5.00以前に作成されたプロジェクトを開くと、現行バージョンにアップグレードされる事を通知するメッセージが

表示されます。 

• [Yes]を選択するとプロジェクトは現行バージョンにアップグレードされ、以前のバージョンで開く事はできな

くなります。 
• [No]を選択すると、プロジェクトに対する変更をv5.00以降に保存する事はできません。変更はv4.xxで行う必要

があります。 

プロジェクトをv5.xxに更新後v4.xxに戻す場合、MPLAB X IDEの[Tools] > [Plugins] > [Available Plugins] > [Save As 
v4.xx Project]からプラグインをインストールします。プラグイン インストール後は、[Tools] > [Embedded] > [Save 
as MPLAB X v4.xx Project]を選択して古いバージョンでプロジェクトを保存できます。 

デバイスパックについて 

v4.20以前のバージョンでは、サポートデバイス(*.PIC)ファイルはそれぞれのMPLAB X IDEバージョンに組み込まれ

ていました。そのバージョンでサポートされているデバイスを更新する事はできず、次のMPLAB X IDEバージョン

まで待つ必要がありました。 

v5.00以降のバージョンでは、デバイスファイルはバージョン管理されたデバイスファミリ パックにグループ化され

ています。各MPLAB X IDEバージョンにはデバイスパックが付属していますが、このデバイスパックをアップデー

トして新しいデバイス、新しいデバイス機能サポート、デバイスバグ修正サポートを含める事ができます。 

デバイスパックの詳細は以下を参照してください。 

5.1「デバイスパックを使う方法」 
 

4.1.2 [New Project]ウィザードの起動 
プロジェクトはいくつかの方法で新規作成できます。 

 
 

 

[File] > [New Project]を選択する(または<Ctrl>+<Shift>+<N>) 

 

 

[New Project]アイコン([File]ツールバー上) 

 

 

[Start Page]で、[Learn & Discover]または[My MPLAB X IDE]
タブを開き、[Projects] > [Create New]を選択する 
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4.1.3 Step 1: Choose Project 
プロジェクト カテゴリを選択します。ほとんどの場合、以下を含む[Microchip Embedded]のプロジェクト タイプを

選択します。 
以下のオプションを使ってプロジェクト カテゴリを選択できます。 
 

• Standalone Project – 新しいプロジェクト(C言語またはアセンブリコード)を作成します。本セクションでは、

このプロジェクト タイプを解説します。 
• Existing MPLAB IDE v8 Project – 既存のMPLAB IDE v8用プロジェクトをMPLAB X IDE用に変換します。詳細は

5.3「MPLAB IDE v8プロジェクトのインポート」を参照してください。 
• Prebuilt (Hex, Loadable Image) Project – 既存のプロジェクト イメージをMPLAB X IDEにロードします。詳細は

5.4「ビルド済みのプロジェクト」を参照してください。 
• User Makefile Project – 外部makeファイルを使うプロジェクトを作成します。詳細は6.6「ユーザMakefileプロ

ジェクトの作成」を参照してください。 
• Library Project – 実行用HEXファイルではなくライブラリをビルドする新しいプロジェクト(C言語またはアセン

ブリコード)を作成します。詳細は5.7「ライブラリ プロジェクト」を参照してください。 
• Import START MPLAB Project / Import Atmel Studio Project - これらのAtmelプロジェクトをインポートします。

詳細は5.8「Atmel Studio 7またはAtmel STARTプロジェクトのインポート」を参照してください。 
 
その他に以下を選択できます。 

 
• 5.9「その他の組み込みプロジェクト」– 他社製プロジェクト 
• 5.10「サンプル プロジェクト」– 各種デバイスファミリ向けの既製のプロジェクトやプロジェクト テンプレー

トを選ぶ事ができます。 

項目を選択したら、[Next>]をクリックして次のダイアログへ進みます。 

図4-1 プロジェクト ウィザード – プロジェクトの選択 

 
4.1.4 Step 2: Select Device 

アプリケーションで使う予定のデバイスを[Device]ドロップダウン リストから選択します。選択肢を絞り込むために、

最初にデバイスファミリを選択します。 

LFデバイスの場合、デバイスにFタイプより低い電圧(通常は5.0 Vの代わりに3.3 V)を供給する必要があります。過電

圧でデバイスを損傷する可能性がある場合、警告が表示されます。 

[Next>]をクリックします。 
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図4-2 プロジェクト ウィザード – デバイスの選択 

 
4.1.5 Step 3: Select Header 

プロジェクト デバイスのヘッダを選択します。利用可能なヘッダがない場合、MPLAB X IDEはこのステッ

プを表示しません。利用可能なヘッダがある場合、以下のヘルプトピックを参照してください。 

• プロセッサ拡張パックとデバッグヘッダ 
• エミュレーション拡張パックとエミュレーション ヘッダ 

完了したら、[Next>]をクリックします。 

Note:  [Project Properties]ウィンドウで後からヘッダを選択する事もできます。 
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図4-3 プロジェクト ウィザード – ヘッダの選択 

 
4.1.6 Step 4: Select Tool 

デバッグツールを選択します。 

ツール名の左横の丸い色付きマークの詳細は4.1.6.1「プロジェクト ツールサポート」を参照してください。 

ハードウェア ツール接続時、ツール名の下にシリアル番号(SN)が表示されます。これにより、同じハードウェ

ア ツールを複数接続しても個別のツールを識別できます。 

ツールを選択して[Next>]をクリックします。 

図4-4 プロジェクト ウィザード – ツールの選択 
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4.1.6.1 プロジェクト ツールサポート 
プロジェクト デバイスのプロジェクト ツールサポートは、ツール名の左側の丸いマーク(信号灯)の色で識別できます。 

 

マーク 色 サポート 
 

 緑 完全サポート(実装と完全なテスト済み) 
 

 黄 ベータ版サポート(実装済み、ただし完全なテストは未完) 
 

 赤 未サポート 
 

色を識別できない場合、マウスカーソルをマークの上に置くと、サポートに関する情報を表示できます。 
 

デバッガまたはプログラマとして使えるハードウェア ツールの場合、ツール名の横に2つの信号灯が表示されます。

左側の信号灯はデバッグサポート、右側の信号灯はプログラマ サポートを意味します。 

ハードウェア ツール接続時も、ツール名の下にシリアル番号(SN)が表示されます。これにより、同じハードウェア 
ツールを複数接続していても個別のツールを識別できます。 

お使いのサードパーティ製ハードウェア ツールがここに表示されない場合、そのツールが適切にインストールされ

ているかどうか確認します。詳細は6.8「サードパーティ製ハードウェア ツール」を参照してください。 
 

4.1.7 Step 5: Select Plugin Board 
MPLAB REAL ICEインサーキット エミュレータのプラグインボードを選択します。このエミュレータをデバッグツ

ールとして選択していない場合、MPLAB X IDEはこのステップを表示しません。 

プラグインボードとはエミュレータのドライバボード スロットに挿入する基板で、デバッグ機能を追加できます。 

表4-2 エミュレータ プラグインボード 
 

Supported Plugin Board ボードの説明 

None 標準通信ドライバボード 

None 高速通信ドライバボード 

JTAG Driver Board JTAGアダプタボード 

Power Monitor Board 電源モニタボード (ロジック プローブ コネクタにも挿入する必要があります) 
 

ツールを選択してから[Next>]をクリックします。 



MPLAB X IDEユーザガイド 
基本作業 

ユーザガイド DS-50002027E_JP - p. 55 © 2019 Microchip Technology 
 

 

 

 
 

図4-5 プロジェクト ウィザード – プラグインボードの選択 

 
4.1.8 Step 6: Select Compiler 

言語ツール(Cコンパイラまたはアセンブラ)を選択します。選択可能な言語ツールは以下のように表示されます。 

ツール略称(ツールバージョン) [ツール実行パス] 

ツール名の左横の丸い色付きマーク(信号灯)の詳細は4.1.6.1「プロジェクト ツールサポート」を参照してください。 

ここに必要な言語ツールが表示されない場合、またはサポートツールが1つも表示されない場合、ツールがインスト

ール済みであるかどうか確認します。2.5「言語ツールのインストール」を参照してください。 

Note:  AVR GNUおよびArm GNUツールチェーンの場合、MPLAB X IDEが検索可能な場所にコンパイラをインスト

ールします(例： Windowsの場合、C:\Program Files (x86)\Microchip)。または、パスを入力する必要があ

ります。4.7「言語ツールのパスの指定」を参照してください。 

ツールは[Build Tools]の下に表示されるが、サポートが表示されない場合、そのプロジェクト デバイスはツールまた

はツールバージョンによってサポートされていない可能性があります。そのデバイスをサポートする他の言語ツール

を選ぶかインストールする必要があります。または、[Download Latest］でMPLAB XCコンパイラの最新バージョン

をダウンロードしてインストールする事もできます。ただし、このバージョンがそのデバイスをサポートしている必

要があります。 

ツールを選択して[Next>]をクリックします。 
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図4-6 プロジェクト ウィザード – コンパイラ(またはその他の言語ツール)の選択 

 
4.1.8.1 サポートされている言語ツール 

下表に、言語ツールに対する現行およびレガシーMPLAB X IDEサポートを示します。現行の言語ツールは新規デバ

イスをサポートします。レガシーツールは新規デバイスをサポートしません。 

表4-3 Microchip社製言語ツール – 現行 
 

ツールチェーン 正式

名 
サポートするデバイス 

XC8 MPLAB XC8 C Compiler for PIC MCUs 8ビットPIC® MCU 
 MPLAB XC8 C Compiler for AVR MCUs 8ビットAVR® MCU 

XC16 MPLAB XC16 C Compiler 16ビットPIC MCU、dsPIC® DSC 

XC32 MPLAB XC32 C/C++ Compiler for PIC32M MCUs 32ビットPIC32M MCU 
 MPLAB XC32 C/C++ Compiler for PIC32C/SAM MCUs 32ビットPIC32C/SAM MCU 

Arm® GNU Arm GNU C Compiler 32ビットArm MCU 

AVR GNU AVR GNU C Compiler 8/32ビットAVR MCU 

MPASM MPASM Assembler, MPLINK Object Linker and Utilities 8ビットPIC MCU 
 

表4-4 Microchip社製言語ツール – レガシー 
 

ツールチェーン 正式名 

8ビットPIC MCU向け言語ツール 

C18* MPLAB C Compiler for PIC18 MCUs 

HI-TECH PICC HI-TECH C Compiler for PIC10/12/16 MCUs 

HI-TECH PICC18 HI-TECH C Compiler for PIC18 MCUs 

16ビットPIC MCU、dsPIC DSC向け言語ツール 

ASM30** MPLAB Assembler, Object Linker and Utilities for PIC24 MCUs and dsPIC DSCs 
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(続き) 
ツールチェーン 正式名 

C30 PIC24 MCUおよびdsPIC DSC向けMPLAB Cコンパイラ 

C24 MPLAB C Compiler for PIC24 MCUs (C30のサブセット) 

dsPIC MPLAB C Compiler for dsPIC DSCs (C30のサブセット) 

HI-TECH DSPICC HI-TECH C Compiler for PIC24 MCUs and dsPIC DSCs 

32ビットPIC MCU向け言語ツール 

C32 MPLAB C Compiler for PIC32 MCUs 

HI-TECH PICC32 HI-TECH C Compiler for PIC32 MCUs 

* ほとんどのコンパイラには、アセンブラ、リンカ、ユーティリティが付属しています。しかし、MPLAB C18は
MPASMツールチェーンでサポートされています。 
** MPLAB X IDEのv1.30以降には付属していません。16ビットコンパイラに付属するアセンブラをお使いくださ

い。 
 

各言語ツールの詳細はそれぞれの文書を参照してください。 

サードパーティ製言語ツールチェーン (CCS等 )については、 [Start Page]の「Release Notes and Support 
Documentaion」より[Readme for Third Party Tools.htm]ファイルを参照してください。 

4.1.8.2 最新MPLAB XCコンパイラのダウンロード 
[Download Latest]リンクをクリックすると、MPLAB XC Cコンパイラの最新バージョンをダウンロードできます。

OSによっては、コンパイラのインストールとコンパイラ選択ツリーの更新も行います。 

[Download Latest]リンクはStep 6.[Select Compiler]、[Compiler Toolchains] > [XCn] (n = 8、16、32)の下の[New 
Project]ウィザードにも表示されます。 

Note:  インターネットに接続していない場合、このリンクは表示されません。 

プロジェクトが作成されると、このリンクは[Project Properties]ウィンドウに表示されます。 

図4-7 [Download Latest] 

[Download Latest]リンクをクリックすると、以下の手順が実行されます。 
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1. メッセージ ダイアログが開き、実行内容を表示します。この時点ではダウンロードとインストールをキャン

セルする事ができます。 
2. 最新コンパイラが既にインストールされている場合、メッセージ ダイアログにより続行するか確認します。 
3. コンパイラ インストーラの保存先を選択します。 
4. ダウンロード中は、ダウンロードの残り量を示す進捗ウィンドウが表示されます。 
5. WindowsおよびMac OS: インストーラのダウンロードが完了したらコンパイラのインストールが始まります。

コンパイラがインストールされたら、MPLAB X IDEはそのコンパイラを選択ツリーへ追加します。追加でき

ない場合、MPLAB X IDEにコンパイラを手動で追加する必要がある旨の通知が表示されます(4.7「言語ツール

のパスの指定」)。 
6. Linux: ダウンロードしたコンパイラを手動でインストールする必要があります。追加されると、MPLAB X 

IDEが認識するはずです。認識しない場合、MPLAB X IDEにコンパイラを手動で追加する必要があります(4.7
「言語ツールのパスの指定」)。 

 
4.1.9 Step 7: Select Project Name and Folder 

プロジェクトの名前と保存場所、その他のプロジェクト設定を選択します。 

プロジェクト名を入力します。拡張子として.X が使われます。[Project Folder]テキストボックスを参照してくださ

い。フォルダの場所を参照します。プロジェクト フォルダを新規作成する事もできます。既定値では、プロジェク

トは以下のパスに保存されます。 

• Windows 7以降 – C:\Users\UserName\MPLABXProjects 
• Linux – /home/UserName/MPLABXProjects 
• Mac – /Users/UserName/MPLABXProjects 

表4-5 その他の機能 
 

Set as main project このプロジェクトをメイン プロジェクトに指定します。 

Use project location as 
project folder 

プロジェクトの保存場所と同じフォルダ内にプロジェクトを作成します。 
これは、MPLAB IDE v8プロジェクトをインポートする際、MPLAB X IDEのプロジェ

クトを同じフォルダにする場合(ビルドも同様にする場合)に便利です。 

MPLAB IDE v8が.mcpファイルを使ってプロジェクト情報を保存するのに対し、

MPLAB X IDEはフォルダを使います。従って、MPLAB IDE v8プロジェクト(.mcpフ
ァイル)とフォルダを共有させる事ができるMPLAB X IDEプロジェクトは1つだけで

す。 
Encoding プロジェクトのエンコードを選択します。既定値の文字セットはISO-8859-1 (Latin 1)

です。この選択によって、コード構文の色分け設定が決まります。色分けは[Tools] > 
[Options] (macOSでは[MPLAB X IDE] > [Preferences])を選択し、[Fonts and Colors]
ボタンをクリックして、[Syntax]タブより編集できます。 

 
[Finish]をクリックすると、プロジェクトの新規作成が完了します。 

Note:  コンフィグレーション タイプを変更する事でスタンドアロン (アプリケーション) プロジェクトをライブラリ 
プロジェクトに変更できます。詳細は4.10.1「プロジェクト コンフィグレーション タイプの変更」を参照してくだ

さい。 
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図4-8 プロジェクト ウィザード – プロジェクト名と保存先フォルダの選択 

 
 
4.2 プロジェクト作成後のデスクトップ画面 

MPLAB X IDEのデスクトップは、4つのペインに分割されます。プロジェクトの作成が完了すると、これらのペイン

にいくつかのウィンドウが表示されます。 

デスクトップ ペイン 

• [File]ペイン – ファイルに関する情報を表示します。 
– [Projects]ウィンドウは、ファイルがカテゴリごとにグループ分けされたプロジェクト ツリーを表示します。 
– [Files]ウィンドウは、コンピュータ上のフォルダ構成に従って、プロジェクト ファイルを表示します。 
– [Classes]ウィンドウは、コード内の全てのクラスと、それらの関数、変数、定数を表示します。その宣言

部分を見るには、項目をダブルクリックします。 
• [Navigator]ペイン – [File]ペイン内の項目に関する情報を表示します。 

– [Dashboard]ウィンドウは、選択されているプロジェクトに関する情報を表示します。 
– [Navigator]ウィンドウは、選択されているプロジェクト ファイル内のシンボルと変数に関する情報を表示

します。 
• [Editor]ペイン – プロジェクト ファイルの内容を表示して編集します。ここには[Start Page]と[MPLAB X Store]

も表示されます。 
• [Task]ペイン – アプリケーションのビルド、デバッグ、実行からのタスク出力を表示します。 
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図4-9 MPLAB X IDEのデスクトップ - ペイン 

デスクトップ ウィンドウ 

ペインはIDEインターフェイスの各セクションを説明するために便利ですが、ウィンドウはペイン間で移動できます。

そのため、ペインが必ずしもウィンドウの内容を表しているとは限りません。従って、ほとんどの文書はウィンドウ

のみを説明しています。 

デスクトップでのウィンドウ間の移動は以下のように行います。 

• ウィンドウをクリックしてフォーカスします。 
• 1つのウィンドウで<Ctrl>を押しながら<Tab>を押すと、開いている他のウィンドウにフォーカスを変更できま

す。ポップアップ リストからウィンドウを選択します。 

図4-10 ウィンドウ フォーカスの切り換え 

 
 
4.3 [Project Properties]ウィンドウを開く 

プロジェクト作成後は、[Project Properties]ウィンドウでプロパティを表示、編集できます。このウィンドウは以下

のいずれかの方法で開く事ができます。 
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1. [File]ペインの[Projects]ウィンドウ内でプロジェクト名を右クリックし、[Properties]を選択します。 
 

2. [File]ペインの[Projects]ウィンドウ内でプロジェクト名を左クリックし、メニューから[File] > [Project Properties]
を選択します。 

 

3. [Projects]ウィンドウ内でプロジェクト名をクリックし、[Set Project Configuration]ドロップダウン メニューをク

リックして[Customize]を選択します。 

 
4. [Dashboard]ウィンドウで[Project Properties]アイコンをクリックします。 

 

 
 
4.4 プロジェクト プロパティの表示と変更 

開いたダイアログで、[Conf: [default]]カテゴリをクリックすると、プロジェクト コンフィグレーション (デバイス、

デバッガ/プログラマツール、言語ツール等)が表示されます。 
 

Categories 作成後のプロジェクト コンフィグレーションは[default]として設定されています。[Manage 
Configurations]ボタンをクリックすると、各種コンフィグレーションを作成できます。6.4「複

数コンフィグレーションの使い方」を参照してください。 
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Device シミュレートするデバイス、またはボード上のデバイスです。 
デバイス変更時(特に別のファミリのデバイスに変更する場合)はパック、ハードウェア ツール、

コンパイラを更新する必要があるため、注意が必要です。 

Packs 選択したデバイスのデバイスファミリ パック(DFP)バージョンです。MPLAB X IDEの最新バー

ジョンには、DFPの最新バージョンが付属します。しかし、別のバージョンに変更する事もでき

ます。5.1「デバイスパックを使う方法」参照 
Hardware Tool サポートされているハードウェア デバッグツール(またはシミュレータ)を選択します。4.1.6.1

「プロジェクト ツールサポート」参照 

Compiler 
Toolchain 

サポートされている言語ツール(通常はコンパイラ)を選択します。4.1.6.1「プロジェクト ツール

サポート」参照 
MPLAB XC Cコンパイラの最新バージョンは、[Download Latest]リンクをクリックすると入手で

きます。 
4.1.8.2「最新MPLAB XCコンパイラのダウンロード」参照 

 

図4-11 [Project Properties]ウィンドウ - 既定値コンフィグレーション 

 
 
4.5 デバッガ/プログラマツール オプションを設定または変更する方法 

[Project Properties]ウィンドウでは、ツールのオプションも設定します。 

ハードウェア ツールまたはシミュレータ(Conf: [default]の下)をクリックして、関連するオプション メニューを表示

させます。これらのオプションの意味は、各ツールの文書を参照してください。 
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図4-12 サンプルツールの設定ページ 

 
 
4.6 言語ツールオプションを設定または変更する方法 

[Project Properties]ウィンドウの言語ツールをクリックして、設定オプションを表示させます。これらのオプション

の意味は、言語ツールの文書を参照してください。 
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図4-13 言語ツールの設定ページ 

IDEオプションとコマンドライン オプション 

IDEに入力するオプションは、コマンドラインで入力するオプションとフォーマットが異なる場合があります。

[Option Description]タブのオプション名をクリックするとオプションの詳細が表示されます。また、オプションデー

タを入力または選択してから、[Generated Command Line]タブをクリックして内容を表示させ、オプションで生成

されたコマンドライン コードが正しい事を確認します。 

グローバル オプション 

グローバル オプションを設定すると、言語ツールスイート内の全ての言語ツールに適用されます。また、[User 
Comments]タブを使うと特定のオプションを選択した理由を入力できます。 

 
 
4.7 言語ツールのパスの指定 

MPLAB X IDEで利用できる言語ツールとそれらのパスを表示/変更するには、以下の手順に従います。 

• macOSの場合: メイン メニューバーから 
[MPLAB X IDE] > [Preferences] > [Embedded] > [Build Tools]を選択してビルドツールにアクセスする 

• その他のOSの場合: 
[Tools] > [Options] > [Embedded] > [Build Tools]を選択してビルドツールにアクセスする 

ウィンドウには、インストールされている全てのツールチェーンが自動的に表示されます。12.16.3「[Build Options]
タブ」を参照してください。 
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図4-14 言語ツール (コンパイラ)のパス 

 
4.7.1 ツールチェーンの追加または変更 

[Toolchain]欄にインストール済みのツールが表示されない場合、以下を試します。 

• [Scan for Build Tools]ボタン – 環境パスをスキャンし、PCにインストールされている言語ツールの一覧を表示

します。 
• [Add]ボタン – ツールの実行ファイルを保存したフォルダ (ベースフォルダ)へのパスを入力する事により、手動

でリストにツールを追加します。一般的に実行ファイルは、ツールをインストールしたフォルダ内の「bin」サ

ブフォルダに保存されています。 

同じコンパイラの複数のバージョンをインストールしている場合、リストからいずれか1つのバージョンを選択します。

ツールのパスを変更するには、新しいパスを手入力するか、[...]ボタンをクリックして選択します。 

4.7.2 ツールチェーンの削除 
既存のツールチェーンを削除するには、以下の手順に従います。 

1. リストからツールチェーンをクリックして選択します。 
2. [Remove]ボタンをクリックします。 

この操作では、コンパイラはPCからアンインストールされません。MPLAB X IDEがこのコンパイラを認識しなくな

るだけです。ツールチェーンを再び追加する方法は、4.7.1「ツールチェーンの追加または変更」を参照してください。 

コンパイラをPCからアンインストールする場合、上のようにMPLAB X IDE内のコンパイラの参照を最初に削除しま

す。その後、コンパイラをアンインストールします。コンパイラを先にアンインストールし、MPLAB X IDEを起動

した場合、ツールチェーン パスが赤で表示されます。このアンインストール済みコンパイラへの参照を削除するに

は、既述の手順で行います。 
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C:\Program Files (x86)\Microchip\xc16\vx.xx\bin 

 
 

4.7.3 ツールチェーン パス 
MPLAB X IDEは、既定値のインストールパスとPATH環境変数でツールチェーンを検索します。Windows 64ビット

OSにおけるMPLAB XC16の既定値パスの例を以下に示します。 

コンパイラをインストールする際、インストール先を選択できます。以下のどちらかを行う事ができます。 

• 既定値の場所にインストールする 

または 

• 別の場所にインストールし、この場所をPATHに追加する 

既定値以外の場所にインストールする場合、その場所をPATHに追加する必要があります。 

PATHに新規の場所を追加しない場合、MPLAB X IDEでコンパイラの場所を指定できます([Tools] > [Options]で[Build 
Tools]タブを開き、[Embedded]ボタンをクリック)。 

最後に、インストール場所をPATH変数に手動で追加できます。 

MPLAB X IDEがツールチェーンを認識しているにもかかわらずパスが見つからない場合、そのパスは赤の文字で表

示されます。 
 
 
4.8 その他のツールオプションの設定 

ビルド用パス以外の組み込みオプションも設定できます。[Options]ウィンドウの[Embedded]カテゴリでタブを選択

できます。12.16「[Tools] > [Options]ウィンドウ、[Embedded]」を参照してください。 
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4.9 プロジェクトへのファイルの追加 

プロジェクトを新規作成したら、アプリケーションを作成するためにプロジェクトにファイルを追加します。コード

を書くためにファイルを新規作成するか、既存のファイルをインポートまたは参照できます。エディタを使うと、言

語ツール固有の色分けやその他の機能を使ってファイルの内容を作成または更新できます。 

ファイルリンクの順序 

リンク処理の順序は、プロジェクトにファイルを追加した順序で決まります。MPLAB IDE v8からプロジェクトをイ

ンポートする場合、その順序は.mcpファイルで決まります。プロジェクトに新規に追加したファイルが最後にリン

クされます。ファイルを削除した後で再度追加した場合、そのファイルはリンクリストの末尾に移動します。 

ライブラリとオブジェクト ファイルのリンク 

リンカが使うライブラリとオブジェクト ファイルは参照できます。 

ビルドからのファイルの除外 

ファイルまたはフォルダレベルのオプションを設定する事で、ビルドからファイルを除外できます。 
 

4.9.1 [New File]ウィザードの起動 
ファイルを新規作成してプロジェクトにコードを追加するには、[New File]ウィザードを使います。このウィザード

はいくつかの方法で起動できます。 
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[File] > [New File](または<Ctrl>+<N>) 

 

 

[New File]アイコン([File]ツールバー上) 

 

 

[Projects]/[Files]ウィンドウ内のプロジェクト フォルダ(例: [Source Files])を右クリックし、 
[New] > [Other]を選択する 

 

4.9.2 ファイルの新規作成 
[New File]ウィザードの手順に従ってファイルを新規作成します。 

Step 1. Choose File Type 

[Microchip Embedded]を展開して、その中のファイルカテゴリを選択します。次にファイルタイプを選択します。

[Next>]をクリックします。 

図4-15 ファイル ウィザード – カテゴリとタイプの選択 

Step 2. Name and Location 

ファイルに名前を付け、そのファイルをプロジェクト フォルダに保存します。[Finish]をクリックします。 
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図4-16 ファイル ウィザード – 関連付けるプロジェクトの選択 

ファイルと同名の[Editor]タブが表示されます。このタブでファイルを編集します。ファイル内のテキストは、構文

に基づいて色分け表示されます(色分けはファイルタイプによって異なります)。 

 
 

4.9.3 既存ファイルのプロジェクトへの追加 
以下のどちらかの方法により、既存ファイルをプロジェクトに追加できます。 
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• [Project/File]ウィンドウ内のプロジェクトを右クリックし、[Add Existing Item]を選択します。追加後はそのファ

イルをフォルダにドラッグ&ドロップできます。 
• [Project/File]ウィンドウ内のフォルダ(例: [Source Files])を右クリックし、[Add Existing Item]を選択します。 

 

4.9.3.1 プロジェクト フォルダ内のファイルの追加 
メイン プロジェクト フォルダ内のファイルを追加する際は、追加方法を以下から選択できます。 

• Auto – MPLAB X IDEがファイルのパスの指定方法を自動的に選択します。 
• Relative – ファイルのパスをプロジェクト フォルダに対して相対的に指定します(最も移植性に優れます)。 
• Absolute – ファイルのパスを絶対パスで指定します。 
• Copy – 指定したファイルをプロジェクト フォルダにコピーします。 

パスモードを選択すると、MPLAB X IDEがこの設定を記憶します。変更する場合、 
12.16.2「[Project Options]タブ」の[File Path Mode]を参照してください。 

ファイルは[Projects]ウィンドウに表示されます。ファイルと同名の[Editor]タブも表示されます。 
 

4.9.3.2 プロジェクト フォルダ外のファイルの追加 
プロジェクト フォルダ以外の場所に保存されているソースファイルは、「Relative」として追加(パスを保存)します。

これにより、外部ファイル用フォルダ(_ext)が作成され、プロジェクトはビルド時にそのファイルを見つける事がで

きるようになります。 
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//TODOやファイル コンテクスト メニュー等のナビゲーション機能を使えるようにするために、ファイルの保存場所を

プロジェクト内で指定しておく必要があります。このために、以下を行います。 

1. [Projects]ウィンドウ内のプロジェクト名の上で右クリックして、[Properties]を選択します。 
2. [Categories]の下で[General]をクリックします。 
3. [Source Folders]の横の[Add]をクリックします。 
4. プロジェクトに追加した外部ファイルのパスを表示させ、[Select]ボタンをクリックします。 
5. [Apply]または[OK]をクリックして、プロジェクトをリビルドします。 

MPLAB IDE v8プロジェクトをインポートした場合、ソースファイルはプロジェクト フォルダ内に保存されません。

自動的にファイルをインポートするには、[File] > [Import] > [MPLAB IDE v8 Project]を使います。 

図4-17 外部ファイルパスの指定 

 
4.9.4 ファイル内のコードの編集 

コードの編集には、NetBeansエディタを使います。エディタの詳細はNetBeansヘルプトピックを参照してください。 

https://netbeans.org/features/java/editor.html 

このエディタに関するMPLAB X IDE関連の情報も参照してください。 

7.「エディタ」 
 

4.9.5 ライブラリやオブジェクト ファイルの追加と設定 
リンカが使うライブラリ ファイルは以下の場所より参照できます。 

• [Projects]ウィンドウの「Libraries」フォルダ 
• [Project Properties]ウィンドウ 

言語ツールのライブラリアンを使えば、その他のライブラリ ファイルも設定できます。 

4.9.5.1 「Libraries」フォルダ 
[Projects]タブで「Libraries」フォルダを右クリックすると、以下の項目が表示されます。 

https://netbeans.org/features/java/editor.html
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• [Add Library Project] 
プロジェクトに必要なライブラリを出力として生成するプロジェクトを作成します(依存性の確立)。詳細は

NetBeansヘルプトピックを参照してください。 

https://netbeans.org/kb/73/java/project-setup.html#projects-dependencies. 
• [Add Library/Object File] 

既存のライブラリ ファイルまたはプリビルド (オブジェクト) ファイルをプロジェクトに追加します。 
• [Properties] 

その他の設定を行う[Project Properties]ウィンドウを開きます。 

4.9.5.2 [Project Properties]ウィンドウ: [Libraries]カテゴリ 
[Project Properties]ウィンドウを開き、[Libraries]カテゴリをクリックします。[Projects]ウィンドウの[Libraries]フォ

ルダに追加した全てのファイルが表示されます。ウィンドウ右側のボタンを使って、さらにファイルを追加したり、

表示されているファイルを管理したりする事ができます。 

ライブラリリスト内のファイルの順序でリンクの順序が決まります。これは、プロジェクト内のライブラリが相互参

照している場合、重要です。セカンダリ ライブラリのオブジェクトを参照するライブラリは、リンク順のリスト内

でより上位に位置している必要があります。リンク順が正しくない場合、リンク処理中に「undefined reference to」
エラーが発生する場合があります。リンク処理の順序の詳細は言語ツールの文書を参照してください。 

図4-18 ライブラリ/オブジェクト ファイルの管理とリンク順の設定 

4.9.5.3 [Project Properties]ウィンドウ: ライブラリアン カテゴリ 
[Project Properties]ウィンドウを開き、使う言語ツールのカテゴリの下のライブラリアン/アーカイバをクリックしま

す。ライブラリアンの実行ファイル名は、言語ツールのマニュアルで調べます。 

左側のペイン内でリンカ名をクリックします。次に右側のペイン内で、[Option categories]で[Libraries]を選択します。

このリストからライブラリのオプションを選択します。 

https://netbeans.org/kb/73/java/project-setup.html%23projects-dependencies
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図4-19 ライブラリアンのライブラリ オプションの設定 

 
4.9.6 ファイルおよびフォルダ プロパティの設定 

[File Properties]ダイアログを使うと、プロジェクト ファイルを、プロジェクト内の他のファイルとは異なる方法で

ビルドできます。このダイアログは、 [File]ペインの [Projects]ウィンドウ内でファイル名を右クリックし、

[Properties]を選択すると開きます。[Exclude from build]にチェックを入れると、このファイルをプロジェクトのビル

ドから除外できます。[Override build options]にチェックボックスを入れると、プロジェクト コンフィグレーション

内のビルドオプションよりもここで選択したオプションを優先させる事ができます。[Override build options]にチェ

ックを入れてから[Apply]をクリックすると、選択したオプションが[Categories]の下に表示されます。 
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図4-20 ファイル プロパティ 

(仮想)フォルダ全体は、[File]ウィンドウの[Projects]タブ内でフォルダ名を右クリックし、[Properties]を選択する事

でビルドプロセスから除外できます。フォルダまたは個々のファイルを選択してビルドから除外します。上位のフ

ォルダを選択すると、そのフォルダの内容全体が選択されます。ファイルまたは他のフォルダは自由に選択を解除

できます。 
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図4-21 フォルダ プロパティ 

 
 
4.10 ビルドプロパティの設定 

プロジェクトをビルドする前に、必要に応じて[Project Properties]ウィンドウの[Building]カテゴリでビルドプロパテ

ィを設定できます。 
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図4-22 ビルドプロパティ - makeオプション 

 
4.10.1 プロジェクト コンフィグレーション タイプの変更 

MPLAB X IDE v2.15では、[New Project]ウィザードでスタンドアロンまたはライブラリ プロジェクトを作成する場合、

「application」と「library」のどちらかのコンフィグレーション タイプのプロジェクトが作成されます。これは、以

下のセクションで示す事項に注意した上で、既存のプロジェクトのコンフィグレーション タイプを必要に応じて切

り換える事ができる事を意味しています。 

プリビルドおよびユーザMakefileプロジェクトは、この機能によって影響されません(これらは一度作成すると別のタ

イプのプロジェクトには変更できません)。 

スタンドアロン プロジェクトからライブラリ プロジェクトへの切り換え 

プロジェクト コンフィグレーション タイプを「application」から「library」に切り換える場合、ユーザがmain()を
削除する必要があります。コンフィグレーション タイプが「library」になると、「application」プロジェクト内の全

てのロード可能ファイルはビルド/リンクされません。ロード可能ファイルの詳細は、5.5「ロード可能なプロジェク

ト、ファイル、シンボル」を参照してください。 

ツールチェーン(XC8)がライブラリをサポートしていない場合、コンボボックスは無効になりコンフィグレーション

を「library」に切り換える事はできません。 

ライブラリ プロジェクトからスタンドアロン プロジェクトへの切り換え 

プロジェクト コンフィグレーション タイプを「library」から「application」に切り換える場合、ユーザがmain()を
追加する必要があります。 

 
4.10.2 ビルド前後でのスクリプト/マクロ実行 

ビルドプロセスの先頭または末尾に実行するコマンドを入力します。これらのコマンドをnbproject/Makefile-
$CONF.mkファイルに挿入すると、ビルドプロセスをカスタマイズできます。呼び出すスクリプトまたはプログラム

内でプロジェクト関連のアイテム(画像名等)を参照する必要がある場合、マクロを使います。 

マクロを直接入力するか、[Insert Macro]をクリックして編集ボックス内の現在の位置にマクロ名をコピーします。

コマンドは、カレントフォルダをMPLAB X IDEプロジェクト フォルダに設定して、makeプロセスで実行されます。

プロジェクト フォルダは、nbprojectフォルダを含むプロジェクトとして定義されます。 
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Batch Code Example 

@echo off 
if "%1" == "true" goto debug 
:production 
@echo We are in production 
goto end 
:debug 
@echo We are in debug 
:end 

 
 

表4-6 マクロ 
 

名前* 機能 

Device 現在選択中のプロジェクト コンフィグレーションのデバイス 

ProjectDir PC上のプロジェクト ファイルの位置 

ConfName 現在選択中のプロジェクト コンフィグレーションの名前 

ImagePath ビルドイメージへのパス 

ImageDir ビルドイメージを含むフォルダ 

ImageName ビルドイメージの名前 

IsDebug デバッグ実行は「true」、それ以外は「false」 

* コンパイラによっては、その他のマクロも選択できる場合があります。 
 

例: デバッグ中にのみプロセスを実行する 

以下に示すウィンドウ上で、IsDebugマクロをクリックして選択し、次に[Insert Macro]をクリックしてスクリプト

に挿入します。 

図4-23 ビルドプロパティ - プリ/ポストビルド 

実行するスクリプトで、$1 (LinuxまたはMac OS)または%1 (Windows)の値にチェックを入れます。 

 

Bashのサンプルコード 

#!/bin/bash 
echo is $1 
if [ "$1" == "true" ]; then 
echo We are in debug 
else 
echo We are in production 
fi 
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:0801f800361e0000361e000057 
:020000040000fa 
:10020800361e0000361e0000361e0000361e000096 

:10022800361E0000361E0000361E0000361E000076 
:10023800361E0000361E0000361E0000361E000066 
:10024800361E0000361E0000361E0000361E000056 

:bbaaaarrdd...ddcc 

hexmate myfile.hex -omyfile.hex 

 
 

4.10.3 ユーザIDメモリへの非保護チェックサムの挿入 
チェックボックスをクリックすると、ビルドで生成されるチェックサムをユーザIDとして使います(デバイスがサポ

ートしている(灰色でない)場合)。 

PIC32ファミリのデバイスでは、チェックサムはユーザIDによって異なります。従って、PIC32デバイスはこの機能

をサポートしていません。 
 

4.10.4 HEXファイルの正規化 
行アドレスが昇順であり、データが1サイズ(16バイト)にバッファリングされている場合、可能であればHEXファイ

ルは正規化されます。 

例えば、myfile.hexファイルの行(レコード)とMPLAB XC16 Cコンパイラ/リンカの出力を以下に示します。 

このファイルを正規化した場合、ファイルのデータは以下のようになります。 

 

フォーマットは以下の通りです。 
 

これは以下を意味します。 
 

: 開始レコード 

bb バイトカウント 

aaaa アドレス 

rr レコードタイプ 

dd データ 

CC チェックサム 
 

MPLAB X IDEでは、Hexmateと呼ぶアプリケーションを使ってIntel HEXファイルを正規化します。[Normalize hex 
file]オプションにチェックを入れると、ビルド後に以下が呼び出されます。 

基本的に、HexmateはHEXファイル全体を解凍しHEXファイルで指定したアドレスにデータを配列します。次に、

結果のメモリイメージを新規HEXファイルに圧縮し直します。結果ファイルでは全データは昇順であり、かつ連続

しています。アドレスに隙間がある場合、出力ファイルにも隙間ができます(未使用アドレスは埋め込まれません)。 

Hexmateの使い方の詳細はインストールしたMPLAB XC8 Cコンパイラのdocsフォルダにある『MPLAB XC8 C 
Compiler User’s Guide』(DS50002053)を参照してください。HexmateはMPLAB XC8の文書に記載されていますが、

どのコンパイラと組み合わせても使えます。 

正規化されたHEXファイルは、レコードバイトのばらつきが最小化されているため、シリアル接続でのブートロー

ダ等のプログラミング コードとして便利です。 
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4.11 プロジェクトのビルド 
MPLAB X IDEでは、実行またはデバッグの前にプロジェクトをビルドしておく必要はありません。ビルドは、実行

とデバッグの一部として処理されます。しかし、開発の初期段階または既存プロジェクトの大幅変更時には、プロジ

ェクトを実行またはデバッグする前に、プロジェクトのビルドを確認する場合もあります。 

プロジェクトのビルド方法 

• [Projects]ウィンドウのプロジェクト名を右クリックして[Build]を選択するか、[Clean and Build]を選択して中

間ファイルを削除してからビルドする 
• ツールバーの[Build Project]または[Clean and Build Project]アイコンをクリックする 

ビルドの進捗状況は[Output]ウィンドウに表示されます。 

ビルドには以下の機能があります。 

表4-7 ツールバーボタンのビルドオプション 
 

ボタンアイコン 機能 概要 
 Build Project プロジェクト内の全ファイルに対してmakeを実行します。 
 Build for Debugging プロジェクト内の全ファイルに対してmakeを実行し、ビルドされたイメ

ージにデバッグ実行ファイルを追加します。 

Build with PRO 
Comparison 

MPLAB XC CコンパイラをFreeモードで使っている場合、PROモードで

もビルドして出力を比較する事ができます。5.25「MPLAB XCコンパイ

ラのFreeライセンスとPROライセンスの比較」を参照してください。 
 Clean and Build 前回のビルドファイルを削除してから、プロジェクト内の全ファイルに

対してmakeを実行します。 
 Clean and Build for 

Debugging 
前回のビルドファイルを削除してから、プロジェクト内の全ファイルに

対してmakeを実行します。ビルドされたイメージにデバッグ実行ファイ

ルを追加します。 
Clean and Build 
with PRO 
Comparison 

前回のビルドファイルを削除してから、PRO Comparisonでビルドしま

す。 

 
[Output]ウィンドウへのエラーの表示方法 

1. [Output]ウィンドウを右クリックして[Filter]を選択します。 
2. [Filter]ダイアログの[Match Case]にチェックを入れて「: error」と入力します。ビルドを停止させたエラーだ

けが[Output]ウィンドウに表示されます。 
3. フィルタのON/OFFは<Ctrl>+<G>でトグルします。 

エラーに関する詳細は言語ツールのマニュアルを参照してください。 

チェックサム情報の表示方法 

[Dashboard]ウィンドウ(5.19「ダッシュボードの表示」参照)を開き、ビルド後のチェックサムを確認します。 
 
4.12 コードの実行 

コードのビルドに成功すれば、アプリケーションを実行できます。 

コード実行時の動作 

[Run Project]ツールバーアイコン をクリックすると以下の動作が実行されます。 

• make処理がビルドを必要と判断した場合、ビルドを実行します。 
• インサーキット デバッガ/エミュレータまたはプログラマを使う場合、ターゲット デバイスには自動的にイ

メージ (デバッグ実行ファイルは含まず)がプログラミングされ、次いでデバイスが実行に向けてリリースさ

れます。この場合、ブレークポイント等のデバッグ機能は有効になりません。 
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Note:  プログラミング後にデバイスをリセット状態に保持するには、「Run Project」ではなく[Hold in Reset]
 アイコンをクリックします。 

• シミュレータの場合、アプリケーションは一切のデバッグ機能を使わずコードを実行します。 

コード実行の進捗状況が[Output]ウィンドウに表示されます。 

アプリケーション コードの実行 

1. [Projects]ウィンドウでプロジェクトを選択するか、そのプロジェクトをメイン プロジェクトに指定します

(右クリックして[Set as Main Project]を選択)。 
2. 以下のどちらかの方法でプログラムを実行します。 

– [Run Program]アイコン をクリックする 

– [Make and Program Device]アイコン をクリックする 

コード実行の進捗状況が[Output]ウィンドウに表示されます。 
 

4.12.1 実行に関する注意事項 
プログラムを実行する場合、MPLAB X IDEは実行時(RunまたはDebug)のみハードウェア ツールに接続する事に注

意してください。従って、MPLAB X IDEの設定は、実行時にのみツールに反映します。停止中に変更された設定は、

実行が再開した時にのみ更新されます。 

MPLAB IDE v8のように常時ハードウェア ツールに接続するには、[Tools] > [Options] (macOSでは[MPLAB X IDE] > 
[Preferences])を選択し、[Embedded]ボタンをクリックし、[Generic Settings]タブで[Maintain active connection to 
hardware tool]にチェックを入れます。4.20「デバイスのプログラミング」も参照してください。 

 
 

4.13 コードのデバッグ 
コードが正常に動作しない場合、デバッグが必要です。 

デバッグ時の動作 

[Debug Project]ツールバー アイコン をクリックすると以下の動作が実行されます。 

• make処理がビルドを必要と判断した場合、ビルドを実行します。 
• インサーキット デバッガ/エミュレータを使う場合、ターゲット デバイスまたはヘッダは自動的にイメー

ジ (デバッグ実行ファイルを含む)がプログラミングされ、デバッグ セッションが始まります。 
• シミュレータの場合、即座にデバッグ セッションが始まります。 

デバッグの進捗状況は[Output]ウィンドウに表示されます。アプリケーション コードのデバッグ 

アプリケーション コードをデバッグする方法 

1. [Projects]ウィンドウでプロジェクトを選択するか、そのプロジェクトをメイン プロジェクトに指定します

(右クリックして[Set as Main Project]を選択)。 

2. [Debug Project]アイコン または[Step Into]アイコンをクリックして、デバッグを始めます。 

アプリケーション コードの実行を一時停止する方法 

[Pause]アイコン をクリックすると、プログラムの実行が一時停止します。 

コードの実行を再開する方法 
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#ifdef DEBUG 
fprintf(stderr,"This is a debugging message\n"); 
#endif 

 
[Continue]アイコン をクリックすると、プログラムの実行が再開します。 

コードの実行を終了する方法 

[Finish Debugger Session]アイコン をクリックすると、プログラムの実行が終了します。 

デバッガを起動する方法 

コードがデバッグ用にビルドされたもので、単にデバッグツールを起動するだけならば、[Debug Project]アイコン

横の下矢印をクリックして、[Launch Debugger]を選択します。 

表4-8 [Debug]アイコン 
 

アイコン 機能 関連メニュー項目 
 

 

 
Debug Project 

Debug>Debug Project 

 

 

 
Step Into 

Debug>Step Into 

 

 

 
Pause 

Debug>Pause 

 

 

 
Continue 

Debug>Continue 

 

 

 
Finish Debug Session 

Debug>Finish Debugger Session 

 
4.13.1 デバッグ用マクロの生成 

MPLAB X IDEは、Microchip社製言語ツール向けのデバッグ用マクロを生成します。Microchip社製コンパイラおよび

アセンブラに渡されるマクロを下表に示します。 

表4-9 Microchip社製ツールのデバッグ用マクロ 
 

マクロ名 関連ツール 機能 

    DEBUG 全て デバッグ用のビルドである事を示します。 

    MPLAB_REAL_ICE   
    MPLAB_ICD3   

    MPLAB_PK3   

XC8 使用中のハードウェア デバッグツールを示します。 
フォーマットは MPLAB_xxx  (xxxはハードウェア ツールの

指定子)です。 

    MPLAB_PICKIT2     

    MPLAB_DEBUGGER_REAL_ICE 
    MPLAB_DEBUGGER_ICD3 

    MPLAB_DEBUGGER_PK3 

XC16, XC32, 
MPASM 

使用中のハードウェア デバッグツールを示します。 
フォーマットは MPLAB_DEBUGGER_xxx (xxxはハードウェ

ア ツールの指定子)です。 

    MPLAB_DEBUGGER_PICKIT2   

    MPLAB_DEBUGGER_PIC32MXSK XC32 使用中のスタータキットを示します。 
 

これらのマクロはユーザコード内で使えます。例: 
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4.13.2 デバッグに関する注意事項 
コードをデバッグする場合、以下の事項に注意します。 

• デバッグ機能(ウォッチ ウィンドウやメモリ ウィンドウでの変数値の表示等)の多くは、デバッグ セッション 
(デバッグモード)内でのみ使えます。 

• MPLAB X IDEは常時ハードウェア ツールに接続しています。実行時のみ接続するには、[Tools] > [Options] 
(macOSでは[MPLAB X IDE] > [Preferences])を選択し、[Embedded]ボタンをクリックし、[Generic Settings]
タブで[Maintain active connection to hardware tool]のチェックを外します。 
チェックを外すと、MPLAB X IDEで行った設定は実行時にのみツールに反映されます。停止中に変更された設

定は、実行が再開した時にのみ更新されます。 
• アプリケーションによっては、個別に実行するためにデバッグステップの分割が必要になる場合があります。

それには、[Debug] > [Discrete Debugger Operation]による手順を使います。 
• デバッグ中はコンパイラの最適化を無効にするか、コンパイラで利用可能な場合は「debug」最適化を使います。

[Project Properties]ウィンドウの[Categories]で実行可能な言語ツールを選択します。次に、[Options categories]
から[Optimizations]を選択し、最低レベルを選択します。「0」があれば、これを選択します。 

 
 
4.14 ブレークポイントによるプログラム実行の制御 

コードをデバッグする際に、コードの特定位置で実行を一時停止して、変数の値を調べる事ができると便利です。そ

のためにブレークポイントを使います。 

ブレークポイントの詳細はNetBeansヘルプトピックを参照してください。

https://netbeans.org/kb/docs/cnd/debugging.html#breakpoints  

図4-24 [Breakpoints]ウィンドウ内のブレークポイント 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

関連リンク 
12.2 「[Breakpoints]ウィンドウ」 
12.3 「[New Breakpoint]ダイアログ」 

 
4.14.1 単純な行ブレークポイントのセット/クリア 

以下のいずれかの方法により、コード行にブレークポイントをセット/クリアできます。 

• ソースエディタで左側の余白をクリックする(下図参照) 
• 行をクリックしてから<Ctrl>+<F8>を押す 
• [Debug] > [Toggle Line Breakpoint]を選択する 

https://netbeans.org/kb/docs/cnd/debugging.html%23breakpoints
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図4-25 クリックしてブレークポイントを有効/無効にする 

 
4.14.2 [New Breakpoint]ダイアログによるブレークポイントの設定 

[New Breakpoint]ダイアログを開くには以下の手順を実行します。 

1. [Breakpoints]ウィンドウの左上にある[Create New Breakpoint]アイコン をクリックします。 
2. [Debug] > [New Breakpoint]を選択します。ブレークポイントのタイプを選択し、オプションを設定します。 

表4-10 ブレークポイントのタイプ 
選択肢 説明 
Line [Editor]ウィンドウのコード行でブレーク 
Data データ(RAM)メモリ内のアドレスの読み書きでブレーク(SFRおよびシンボル位置も含む) 
Address プログラム (フラッシュ) メモリ内のアドレスを実行時にブレーク 
Event リセット、スリープ/ウェイクアップ、ウォッチドッグ タイマ タイムアウト等、特定のイベントでブレ

ーク 
Function 特定の関数へのエントリ時にブレーク 

  
各ブレークポイント タイプに利用可能なオプションは12.3「[New Breakpoint]ダイアログ」を参照してください。 

 
4.14.3 [Breakpoints]ウィンドウによるブレークポイントのセット/クリア 

[Breakpoints]ウィンドウを使ってブレークポイントを表示し、トグルするには以下の手順を実行します。 

1. チェックボックスを使ってブレークポイントをトグルします。 
2. [Window] > [Debugging] > [Breakpoints]を選択します。 

 
4.14.4 ブレークポイント シーケンスの設定(一部デバイスのみ) 

ブレークポイント シーケンスは複数のブレークポイントのリストです。プログラムの実行は各ブレークポイントで

停止せず、最後のブレークポイントの実行後に停止します。ブレークポイント シーケンスは、特定の命令に至るま

でに複数の実行パスが存在する場合、その中の1つのパスの動作だけを調べる時に便利です。 

ブレークポイント シーケンスの作成方法 

1. 既存のブレークポイントを右クリックするか、複数の既存ブレークポイントを<Shift>+クリックで選択して右

クリックします。 
2. コンテクスト メニューから[Complex Breakpoint]へ進み、[Add a New Sequence]を選択します。 
3. ダイアログ ボックスにシーケンス名を入力し、[OK]をクリッします。 
4. 新しく作成したシーケンスの下に、最初に選択したブレークポイントが表示されます。 
5. 別の既存ブレークポイントをシーケンスに追加するには、そのブレークポイントを右クリックし、[Complex 

Breakpoint] > [Add to Name]を選択します(Nameはシーケンス名)。 
6. シーケンスに既存ではない新しいブレークポイントを追加するには、シーケンスを右クリックし、コンテクス

ト メニューから[New Breakpoint]を選択します。 
シーケンスの並び順を選択する方法 

1. 全ての項目が表示されるように、シーケンスを展開します。 
2. 項目を右クリックして、[Complex Breakpoints] > [Move Up]または[Complex Breakpoints] > [Move Down]を選

択します。ブレークポイントのシーケンス実行順はボトムアップです。つまり、シーケンスの最後のブレー

クポイントが最初に発生します。 

シーケンスまたはブレークポイントの無効化/削除方法 

• 項目を右クリックして「Disable」を選択すると、その項目は一時的に無効になります。 
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• 項目を右クリックして「Delete」を選択すると、その項目は完全に削除されます。 

図4-26 ブレークポイント シーケンスの例 

 
4.14.5 ブレークポイント タプルの設定(一部デバイスのみ) 

MPLAB X IDEでは、「タプル」はAND演算されるブレークポイントのリストを意味します。ブレークポイントの

AND演算は、複数箇所で変更される変数が特定の箇所で変更された時にだけブレークさせたい場合に便利です。 

AND演算は2点のみ可能です。1つはプログラムメモリ ブレークポイント、もう1つはデータメモリ ブレークポイン

トである事が必要です。両方のブレークポイントが同時に発生した時にのみ、プログラムが一時停止します。 

ブレークポイント タプルの作成方法 

1. [Breakpoints]ウィンドウの左上の[Create New Breakpoint]アイコン をクリックします。[New Breakpoint]
ダイアログが開きます。 

2. アドレス ブレークポイントを作成します。[OK]をクリックして、作成したブレークポイントを[Breakpoints]
ウィンドウに追加します。 

3. 上の1と2を繰り返して、データ ブレークポイントを作成します。 
4. いずれかのブレークポイントを右クリックし、[Complex Breakpoint] > [Add to New Tuple]を選択します。 
5. ダイアログ ボックスにタプル名を入力し、[OK]をクリックします。 
6. 新しく作成したタプルの下に、そのブレークポイントが表示されます。 
7. もう1つのブレークポイントを右クリックし、[Complex Breakpoint] > [Move to Name]を選択します(Nameは

タプル名)。 

タプルまたはブレークポイントを削除するには、以下のどちらかの操作を行います。 

• 項目を右クリックし、[Disable]を選択すると、その項目は一時的に無効になります。 
• 項目を右クリックし、[Delete]を選択すると、その項目は完全に削除されます。 

図4-27 ブレークポイント タプルの例 

 
4.14.6 ブレークポイント アドレスの表示 

デバッグ セッションの前と実行中にブレークポイントのアドレスを表示するには、以下の手順を実行します。 

1. [Tools] > [Options]を選択し、[Embedded]ボタンをクリックし、[Generic Settings]タブで[On mouseover 
source lines in editor, evaluate break point status]を選択します。 

2. 行ブレークポイントを設定します。 
3. [Debug Project]アイコンをクリックしてコードをデバッグします。 
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4. ブレークポイント アイコンとソースコード先頭の間にカーソルを置き、ステップ1の操作を実行してマウスオ

ーバーで確認します。 

単一のブレークポイント アドレス 

多くの場合、単一のアドレスが表示されます。プログラム/実行メモリウィンドウ([Window] > [Target Memory 
Views])を開くと、その位置でのメモリアドレスと命令が表示されます。 

図4-28 ブレークポイント アドレスの表示 

複数のブレークポイント アドレス 

場合によっては、複数のブレークポイント位置が表示される事があります。理由としては、コンパイラの最適化レ

ベル指定(-Os)が高く設定されている場合が考えられます。MPLAB X IDE v5.20以前は最初のアドレスのみ表示され

ていました。現在は全てのアドレスが表示されます。 

プログラム/実行メモリウィンドウ([Window] > [Target Memory Views])を開くと、その位置での各メモリアドレスと

命令が表示されます。設定したブレークポイントがBrokenブレークポイントあるいは設定できない場合、メモリウ

ィンドウ内で次または他の位置を選択できます。その場合でも対応関係にあればコード内では同じ行番号に表示され

ます。 

図4-29 複数ブレークポイント アドレスの表示 

 
4.14.7 ハードウェア ブレークポイントの使い方 

コードの行で一時停止する場合、以下のどちらかを実行します。 

• ソフトウェア ブレークポイントからハードウェア ブレークポイントへ切り換える 
• ハードウェア ブレークポイントを設定する 

デバッグを実行すると、同じコード行で停止する事に注意が必要です。[Debug]を再実行してプログラム実行を継

続するか、シングルステップ実行でブレークポイント行のコードを実行します。 
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4.14.8 デュアル パーティション デバイスとブレークポイント 
デバッグの性質上、デュアル パーティション デバイスの場合、デバッガが停止したのがアクティブ パーティショ
ンであれば、そのアクティブ パーティション内にブレークポイントを設定する必要があります。従って、パーティ
ション1で開始したら、ブレークポイントをパーティション2に設定する事はできません。切り換え点まで実行し、
パーティション2に切り換えてから、パーティション2でのブレークポイントを設定する必要があります。 

 
4.14.9 ブレークポイント用の機能 

ブレークポイントから次のブレークポイントまでの実行時間を計測するにはストップウォッチを使います(5.15「ス
トップウォッチの使用」参照)。 

ブレークポイント リソースを確認するには[Dashboard]ウィンドウ(5.19「ダッシュボードの表示」参照)を開きます。
ブレークポイントの利用可能数と使用数、ソフトウェア ブレークポイントがサポートされているかを確認できます。 

 
4.14.10 コンパイラの最適化とブレークポイント 

コンパイラの最適化によって、プログラムの実行方法が変わる場合があります。そのような場合、ブレークポイント
のメモリアドレス マッピングに影響し、複数アドレスが生成される可能性があります。ブレークポイント関連の問
題を避けるため、デバッグ時は最低レベルの最適化を使う事を推奨します。 

図4-30 最低レベルの最適化例 

 
4.14.11 ブレークポイントのリソース使用量 

ハードウェア デバッガ(例: インサーキット デバッグツール)では、使えるブレークポイント数に制限があります。利
用可能なブレークポイントの数はデバイスによって異なります。利用可能なブレークポイントの数と、既に使用中の
ブレークポイントの数は、[Dashboard]ウィンドウ(5.19「ダッシュボードの表示」)で調確認できます。 

以下のMPLAB X IDE機能は、ブレークポイントを必要とします。 
 

 

 
Step Over 

 

 
Step Out 
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Run to Cursor 

 

 
Reset to Main 

 

利用可能なブレークポイントが残っていない時にこれらの機能を使おうとすると、ダイアログが開いて全てのリソー

スが使用中である事を知らせます。 
 

4.14.12 ブレークポイント情報 
デバッグ セッション中と終了後に、ツールヒントとアイコンによってブレークポイント情報が表示されます。 

• ビルドなしにデバッグ セッションから出た場合、ブレークポイントを設定しようとすると、マウス ツールチッ

プが青色アイコンで表示されデバッグ情報がない事を示します。 
• ビルドありでデバッグ セッションから出た場合、行の最適化によりブレークポイント設定ができない場合もあ

ります。 
• デバッグ セッション中の場合 - ブレークポイント設定が可能か不可能かがツールチップに表示されます。 

ツールチップは非表示にする事もできます([TOOLS] > [OPTIONS]、[Embedded]、[Generic Settings])。 
 

4.14.13 Brokenブレークポイント アイコン 

ブレークポイント アイコンが破れた状態( )で表示される場合があります。 

• ビルドなしにデバッグセッションから出た場合、ブレークポイントを設定しようとすると、マウス ツールチッ

プに破れたアイコンが表示されデバッグ情報はない事を示します。 
• デバッグ セッション中にパス、ファイル、フォルダの命名制約が原因でソースファイルが見つからない事があ

ります(「パス/ファイル/フォルダ名の制約」参照)。 
 
 
4.15 コードのステップ実行 

[Debug]メニューと[Debug]ツールバーのステップ実行機能を使うと、コードの先頭またはブレークポイントでの停止

状態からコードをステップ実行できます。これにより、変数値の変化を観察したり、プログラムフローが正しいかど

うかを判断できます。 

コードのステップ実行は、以下の方法で行えます。 
 

 

 
Step Over – プログラムのソースを1行実行します。その行が関数コールである場合、呼び出した関数全体

を実行した後に停止します。 
 

 
Step Into – プログラムのソースを1行実行します。その行が関数コールである場合、呼び出した関数の先

頭の命令文を実行した後に停止します。 
 

 
Step Out – プログラムのソースを1行実行します。その行が関数コールの場合、実行後に呼び出し元に戻

ります。 
 

 
Run to Cursor – プロジェクトをカーソル位置まで実行して、停止します。 

 
[Editor]ウィンドウ以外に、[Disassembly]ウィンドウ(5.16「 [Disassembly]ウィンドウの表示」)と、[Memory]ウィン

ドウ内のプログラムメモリでも、コードをシングルステップ実行できます。 
 
 
4.16 シンボル値の変化の観察 

選択したシンボルの値の変化を[Watches]ウィンドウで観察します。これらの値がプログラム実行中に予測通りに変

化するか確認する事により、コードのデバッグに役立てる事ができます。 

以下のシンボルを[Watches]ウィンドウに追加できます。 



MPLAB X IDEユーザガイド 
基本作業 

ユーザガイド DS-50002027E_JP - p. 88 © 2019 Microchip Technology 
 

 

 

 
 

• グローバル シンボル – ビルド後に表示されます。 
• SFR – 特殊機能レジスタ (デバイスによって異なります) 
• 絶対アドレス 

一般的に、値の変化を観察するにはデバッグを一時停止する必要があります。しかし、ツールによっては実行時の更
新が可能です(プログラム実行中に値の変化を観察できます)。この機能が使えるかどうかは、ツールのマニュアルを
参照してください。 

PIC32 MCU以外のデバイスでは、ランタイム ウォッチに使うシンボルはデバイスメモリに適合したサイズである必
要があります。つまり、8ビットデバイスを使用する場合、8ビットのシンボルを使う必要があります。 

C言語エニュメレート タイプでは、enumラベル (テキスト)と整数値のどちらかをウィンドウで入力できます。ラベ
ルは、大文字と小文字を区別する事に注意します。 

図4-31 [Watches]ウィンドウ – プログラムの一時停止 

[Watches]ウィンドウは以下の方法で開きます。 
• [Window] > [Debugging] > [Watches]を選択して、[Watches]ウィンドウを開きます。 
• ウィンドウが既に開いている場合、[Output]ウィンドウ内の[Watches]タブをクリックします。 

新規ウォッチを直接作成する方法 
以下のいずれかの方法により、シンボルを[Watches]ウィンドウに直接追加できます。 

• [Name]列をダブルクリックして、グローバル シンボル、SFR、絶対アドレス(0x300)を入力します。 
• [Editor]ウィンドウのグローバル シンボルまたはSFRを右クリックして、[New Watch]を選択します。 
• [Editor]ウィンドウ内でグローバル シンボルまたはSFRを選択し、これを「Watches」ウィンドウにドラッグ&

ドロップします。 

[New Watches]ダイアログを使って新規ウォッチを作成する方法 
以下のどちらかの方法により、シンボルまたはSFRを[Watches]ウィンドウに追加できます。 

• [Watches]ウィンドウ内で右クリックして[New Watch]を選択するか、[Debug] > [New Watch]を選択します。
ラジオボタンで、[Global Symbols]または[SFRs]のどちらをリストに表示するのかを選択します。リスト
内でいずれかの名前をクリックし、[OK]をクリックします。 

• [Editor]ウィンドウ内でシンボルまたはSFR名を選択し、右クリックで開いたメニューから[New Watch]を選
択すると、その名前がウィンドウに表示されます。[OK]をクリックします。 

ランタイム ウォッチの新規作成方法 
ランタイム ウォッチを[Watches]ウィンドウに追加する前に、クロックを以下のように設定する必要があります。 

1. プロジェクト名の上で右クリックして[Properties]を選択します。 
2. デバッグツールの名前(REAL ICE等)をクリックし、オプション カテゴリ[Clock]を選択します。 
3. 命令実行速度を設定します。 

グローバル シンボルまたはSFRをランタイム ウォッチとして追加する方法は、上の「[New Watches]ダイアログを

使って新規ウォッチを作成する方法」と基本的に同じですが、「New Watch」ではなく「New Runtime Watch」を

選択する必要があります。 

PIC32 MCU以外のデバイスでは、ランタイム ウォッチに使うシンボルはデバイスメモリに適合したサイズである必
要があります。つまり、8ビットデバイスを使う場合、8ビットのシンボルを使う必要があります。 

シンボル値の変化を表示する方法 

1. プログラムをデバッグ実行し、一時停止します。 
2. [Watches]タブをクリックしてアクティブにします。 
3. シンボルをウォッチする場合、コードをデバッグ実行し、一時停止して値の変化を観察します。 

シンボルをランタイム ウォッチする場合、コードをデバッグ実行すると、プログラムを実行しなが

ら値の変化を観察できます。 
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シンボル (グローバル シンボル、SFR、配列、レジスタのビットフィールド等)の値を表示するには、デバッグ セッ

ションを実行している必要があります。 

Note:  この方法でマクロの値を表示する事はできません。デバッグ中はエディタ内でマクロを右クリックし、

[Macro Expansion]ウィンドウを使います。 

ウォッチシンボルの基数を変更する方法 

シンボルの行で右クリックし、[Display Value As]を選択します。 

その他の作業の方法 

詳細は12.19「[Watches]ウィンドウ」を参照してください。 
 
4.17 ローカル変数値の変化の観察 

ローカル変数の値の変化を[Variables]ウィンドウで観察します。これらの値がプログラム実行中に予測通りに変化す

るか確認する事により、コードのデバッグに役立てる事ができます。 

一般的に、値の変化を観察するにはデバッグを一時停止する必要があります。しかしツールによっては、実行中に値

の変化を観察できます。この機能が使えるかどうかは、ツールのマニュアルを参照してください。 

図4-32 [Variables]ウィンドウ – プログラムの一時停止 

[Variables]ウィンドウを開く方法 

• [Window] > [Debugging] > [Variables]を選択して[Variables]ウィンドウを開きます。 
• [Variables]ウィンドウが既に開いている場合、[Output]ウィンドウ内の[Variables]タブをクリックします。 

変数の変化を観察する方法 

1. プログラムをデバッグ実行し、一時停止します。 
2. [Variables]タブをクリックしてウィンドウを開くと、ローカル変数値が表示されます。 

変数の基数を変更する方法 

変数の行で右クリックし、[Display Value As]を選択します。 
 
4.18 デバイスメモリの表示と変更 

MPLAB X IDEは柔軟で簡潔な[Memory]ウィンドウを備えています。このウィンドウには、デバッグ中に各種タイプ

のデバイスメモリの内容を表示できます。このウィンドウ内の値を更新するには、デバッグを一時停止する必要があ

ります。 

デバイスメモリの表示 

1. ペイン内のウィンドウをクリックしてペインをアクティブにします。[Memory]ウィンドウはこのペイン内に

開きます。 
2. [Window] > [Target Memory Views]を選択します。選択肢を下表に示します。一部のデバイスでは使えないメ

モリタイプもあります。 
表4-11 メモリ画面 – 8/16ビットデバイス 

 

タイプ 説明 

Program Memory デバイス上の全てのプログラムメモリ(ROM) 

File Registers デバイス上の全てのファイルレジスタ(RAM) 
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(続き) 
タイプ 説明 

SFR 全ての特殊機能レジスタ(SFR) 

Peripherals 周辺モジュールごとの全てのSFR 

Configuration Bits 全てのコンフィグレーション レジスタ 

EE Data Memory デバイス上の全てのEEデータメモリ 

User OTP Memory ユーザOTPメモリ 

User ID Memory ユーザIDメモリ 
 

表4-12 メモリ画面 – 32ビットデバイス 
 

タイプ 説明 

Execution Memory デバイス上の全てのフラッシュメモリ 

Data Memory デバイス上の全てのRAM 

Peripherals 全ての特殊機能レジスタ(SFR) 

Configuration Bits 全てのコンフィグレーション レジスタ 

CPU Memory 全てのCPUメモリ 

User ID Memory ユーザIDメモリ 

3. [Memory]ウィンドウでは、[Memory]ドロップダウン ボックスからメモリを選択して画面を変更できます。 
メモリ画面のフォーマットは[Format]ドロップダウン ボックスからも変更できます。フォーマットの選択肢は

メモリタイプとデバイスによって異なります。 
図4-33 メモリとメモリ フォーマットの選択 

4. デバッグを一時停止すると、選択したメモリの内容が[Memory]ウィンドウに表示されます。 
5. ウィンドウを閉じるには、そのウィンドウのタブの[x]をクリックします。 

図4-34 [Memory]ウィンドウの内容 
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デバイスメモリの変更 
メモリの値を変更するにはコードをデバッグする必要があります。コード実行中はメモリを変更できません。 
Note:  変更したデータは、デバッグにのみ反映されます。アプリケーション コードは変更されません。 
メモリの値を変更するには以下の情報を使います。 
 

• 列をクリックしてデータを選択または入力すると、[Memory]ウィンドウ内の値を変更できます。ウィンドウに
よっては、変更されたデータを赤いテキストで表示します。 

• [Fill Memory]機能は、ほとんどの[Memory]ウィンドウのコンテクスト(右クリック) メニューに表示されます。 
• プログラムメモリの場合、変更を表示するにはリビルドする必要があります。変更したデータをデバイスに書

き込んでデバッガを起動するには、[Debug] > [Discrete Debugger Operation]を選択します。 

コンテクスト メニューを使った[Memory]ウィンドウのオプション設定 

[Memory]ウィンドウ内で右クリックすると、各種オプション(表示オプション、メモリの書き込み、テーブルのイン

ポート/エクスポート、ファイルへの出力等)を含むコンテクスト メニューが開きます。メニューの内容はウィンドウ

によって異なります。詳細は12.「MPLAB X IDEのウィンドウとダイアログ」を参照してください。 

[Memory]ウィンドウの更新 
プログラムメモリ、EEPROM、ユーザIDメモリ、コンフィグレーション ビットを表示する[Memory]ウィンドウは、
以下の方法で更新できます。 

1. デバッグ中の場合、プログラムを一時停止します。ただし、ツールとデバイスがデバッグ読み出し(以下参照)
をサポートしている場合、一時停止の必要はありません。 

2. [Read Device Memory]アイコン をクリックします。 

デバッグ読み出し 
ほとんどのデバイスでは、デバイスメモリの読み出し前にプログラムを一時停止する(デバッガ セッションを終了す
る)必要があります。しかし、中にはデバッグモード中の読み出し(デバッグ読み出し)が可能なデバイスもあります。
この機能を使えるかどうかは、デバッグ中に[Read Device Memory]アイコンが灰色表示になるか否かによって判別
できます。 

現在、MPLAB REAL ICEインサーキット エミュレータとMPLAB ICD 3がデバッグ読み出しに対応しています。 

デバッグ読み出しは、ターゲットのオシレータ速度で実行されるため、ターゲットが非常に低速で動作している場合、
読み出されるまでに長時間を要する可能性があります。デバッグ セッションを終了してから読み出しを実行する事
で、強制的に高速のICSP読み出しを使う事もできます。デバッグ セッション中以外は必ずICSP読み出しが実行され
るためです。 

 
4.19 [Configuration Bits]ウィンドウでのコンフィグレーション値の設定 

[Window] > [Target Memory Views]から[Configuration Bits]を選択すると、[Configuration Bits]ウィンドウが開きます。メ

モリウィンドウの使い方は4.18「デバイスメモリの表示と変更」を参照してください。 

[Configuration Bits]ウィンドウは、コンフィグレーション ビットの設定作業に便利です。ただし、量産ではコンフィ
グレーション ビットをコードで設定する必要があります。 

 
4.19.1 [Configuration Bits]ウィンドウの使い方 

デバッグ セッションで[Configuration Bits]ウィンドウを使うと、コンフィグレーション ビットを一時的に変更でき
ます(4.18 「デバイスメモリの表示と変更」参照)。設定が決まったら、以下のセクションで説明する方法で保存でき
ます。 

コンフィグレーション ビットを編集できるのはデバッグ セッション中のみです。リビルドすると[Configuration Bits]
ウィンドウによる変更は全て失われます。 

各種デバイスのコンフィグレーション ビットの設定に関するまとめは、14.「コンフィグレーション設定のまとめ」

に記載しています。 

Note:  AVRまたはSAMデバイスの場合、このウィンドウに赤字が表示されると、何らかの対応が必要です。マウス
カーソルをその上に置くと、指示がポップアップ表示されます。 

コンフィグレーション設定の編集 

他のメモリウィンドウではデバッグモードにする必要がありますが、このウィンドウでは常時値を編集できます。た

だし、リビルドすると[Configuration Bits]ウィンドウによる変更は全て失われます。 
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編集可能なフィールドの既定値は、[Configuration Bits]ウィンドウの最初の画面が表示される時と[Reset to Defaults]
メニューを操作する時に表示されます。コンフィグレーション ビットがソースコードで表現される場合、全ての編

集可能なフィールドの値は、ソースコードで割り当てられた値に初期化されます。これは、ビルド完了後とロード

成功後に行われます。 

コンフィグレーション ウィンドウで既定値を変更すると、その変更はターゲット デバイスに書き込まれるまで永続

的ではなく一時的な変更である旨のメッセージが表示されます。 

図4-35 保留中の変更 

値は以下のように変更できます。 

• 選択ボックスの値: 選択ボックスの値は[Option]または[Setting]列に表示されます。フィールドの列の値をクリッ

クし、リストから選択して変更します。 
• 手動入力値: 手動入力値は[Option]または[Setting]列に表示されます。[Option]列のテキストは、選択可能なレン

ジ(例: [User range: 0x0 - 0x3F]がある事を示します。[Setting]列のテキストは、値を入力する必要がある事(例: 
[Enter Hexadecimal value])を表示します。 

編集したいフィールドの[Option]または[Setting]列のテキストをクリックすると、対応する[Value]列が編集可能

になります。入力値は絶対値に対して検証されるため、編集したフィールドの値が適用される実際の位置を考

慮する必要はありません。入力値を「0」パディングして実際のマスク位置に近似しようとすると、フィルタが

かけられ可能な範囲で絶対値に修正されます。 

[Generate Source Code to Output] 

[Configuration Bits]ウィンドウの下のボタン[Generate Source Code to Output]をクリックします(以下の最初の図)。
[Output]ウィンドウにコンフィグレーション ビットの設定が生成され、コードにコピーできるようになります(以下

の2番目の図)。 

図4-36 [Configuration Bits]ウィンドウ - [Generate Source Code to Output] 
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図4-37 [Output]ウィンドウ - 生成されたソースコード 

[Insert Source Code in Editor] 

[Insert Source Code In Editor]は、[Configuration Bits]ウィンドウのコンテクスト メニューまたはサイドバーの

[Clipboard]アイコンから選択できます(下の最初の図)。エディタ内でメイン プロジェクトを表示または作成し、コン

フィグレーション ビットの設定先にカーソルを置いて、アイコンをクリックします(下の2番目の図)。 

図4-38 [Configuration Bits]ウィンドウ - [Insert Source Code in Editor] 
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図4-39 [Editor]ウィンドウ - 生成されたソースコード 

[Program Device for Debugging] 

IDEツールバー アイコン[Program device for debugging]をクリックすると、[Configuration Bits]ウィンドウの現在値

がデバイスにプログラミングされます。4.20「デバイスのプログラミング」を参照してください。 
 

4.19.2 アセンブリ プロジェクトでのコンフィグレーション ビットの設定 
MPLAB XCのアセンブリ プロジェクトでも[Configuration Bits]ウィンドウを使えます。(MPASMまたはMPLAB 
ASM30のプロジェクトでは使えません。) 簡単なC言語ファイルをプロジェクトに追加して、生成した#pragma 
configマクロを含めます。 
そうすれば、アセンブリconfigワードを手入力する必要はありません。 

アセンブリconfigワードと#pragma configの間に違いはありません。両方とも1プログラムワードを書き込み、

結果としてプログラムサイズも同じです。ただし、#pragma config構文の方が柔軟で、検証、フォーマット、コ

メント機能が優れています。 

 
4.20 デバイスのプログラミング 

コードのデバッグ後は、そのコードをターゲット デバイスにプログラミングします。 

プロジェクトのプログラミング プロパティの設定 

[Project Properties]ウィンドウでプログラミング オプションを設定します。 

1. [Projects]ウィンドウでプロジェクト名を右クリックして[Properties]を選択します。 
2. [Categories]でプログラミングに使うハードウェア ツール(例: PM3)を選択します。 
3. [Option categories]で[Memories to Program]の設定を確認します。 

[Preserve Memory]オプションを使う場合、コード保護が有効でない事を確認します。プログラマが書き込み

に必要なデータを読み出し、デバイスのバルク消去を実行し、デバイスを再プログラミングして、保護する領

域にデータを再度書き込む事で、コードは保護されます。 
4. [Option categories]で[Program Options]の設定を確認します。 
5. ハードウェア ツールによって、プログラミングのオプション カテゴリが異なります。各オプション カテゴリ

を確認しプロジェクトに対して設定が正しい事を確かめます。 
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6. DMCI、モータ制御アプリケーション等と一緒にRTDMを使う場合、[Loading]カテゴリの[Load symbols when 
programming or building for production (slows process)]チェックボックスにチェックを入れる必要があります。 

プログラミング オプションの詳細は、ハードウェア ツールの文書を参照してください。 

必要なプログラミング オプションを設定したら、デバイスをプログラミングできます。 

プログラミングの実行 

デバッグ済みコードでターゲット デバイスをプログラミングするには、ツールバーの[Make and Program Device 
Project]ボタンをクリックします。 

表4-9に、その他のプログラミング関連の機能を示しています。各アイコンの先頭の機能は、ボタンをクリックする

だけで起動します。その他の機能を選択するにはボタンアイコン横の下矢印をクリックします。 

表4-13 プログラミング関連機能のツールバーボタン 
 

ボタン 
アイコン 

機能 説明 

 

 
Make and Program Device (必要に応じて)プロジェクトがビルドされ、デバイスがプログラミングさ

れます。プログラミングが完了すると、即座にプログラムの実行が始ま

ります。 

Program Device for Debugging デバイスがデバッグイメージに基づいてプログラミングされます。 
プログラミングが完了すると、即座にプログラムの実行が始まります。 

Program Device for Production デバイスが量産イメージに基づいてプログラミングされます。 
プログラミングが完了すると、即座にプログラムの実行が始まります。 

Programmer to Go PICkit 3 PICkit 3のProgrammer to Go機能を使います。 
 

 
Read Device Memory ターゲット デバイスのメモリの内容をMPLAB X IDEに転送します。 

Read Device Memory to File ターゲット デバイスのメモリの内容を指定したファイルに転送します。 
 Read EE/Flash Data Memory 

to a File 
ターゲット データメモリの内容を指定したファイルに転送します。 

 

 
Hold In Reset デバイスのリセットと実行をトグルします。 

 
MPLAB統合量産環境を使ったプログラミング 

MPLAB X IDEは、全てのプログラミング機能を備えている訳ではありません。その他のプログラミング機能のサポ

ートについては、MPLAB X IDEに付属してインストールされるMPLAB IPEを参照してください。 
 

 

 

 
 

MPLAB IPEのデスクトップ アイコン 
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5. 追加作業 
以下は、MPLAB X IDEにおける追加作業の要約です。 

表5-1 追加作業の実行 
 

 

 
プロジェクト関連 

1. プロジェクトでデバイスパックを使う方法を学ぶ(デバイスパックを使う方法) 
2. MPLAB X IDEプロジェクトの開き方を選択する(MPLAB X IDEプロジェクトを開く) 
3. MPLAB X IDEにMPLAB IDE v8プロジェクトをインポートする(MPLAB IDE v8プロジェクトのインポ

ート) 
4. [Prebuilt Projects]インポート ウィザードを使ってビルド済みのイメージ(HEX、ELF、COF)を開く(ビ

ルド済みのプロジェクト) 
5. ロード可能なプロジェクト、ファイル、シンボルを使ってプロジェクトのHEXファイルを結合また

は置換する(ロード可能なプロジェクト、ファイル、シンボル)(一般的なアプリケーションでは、ロ

ード可能なプロジェクトとファイル: ブートローダのように、ロード可能なプロジェクト/ファイル

を使ってブートローダとアプリケーション コードを結合しています。) 
6. ライブラリ プロジェクトを作成し、その出力をライブラリとしてビルドする(ライブラリ プロジェク

ト) 
7. [Import Atmel Studio 7]または[Atmel START Project]ウィザードを使って、StudioまたはStartプ

ロジェクトを開く(Atmel Studio 7またはAtmel STARTプロジェクトのインポート) 
8. その他の組み込みプロジェクトまたはサンプル プロジェクトからプロジェクトを作成する(その他の

組み込みプロジェクト、サンプル プロジェクト) 
9. Microchip社コンパイラがサポートしているファイルタイプだけでなく他のタイプのファイルを使

う(他のタイプのファイルの使い方)プロジェクトで使う既定値のファイル テンプレートを変更す

るためにコード テンプレートを変更または作成する(コード テンプレートの変更または作成) 
10. プロジェクトで使うハードウェアまたは言語ツールを切り換える(ハードウェア ツールまたは言語ツ

ールの切り換え) 
11. プロジェクト フォルダとエンコードを変更する(プロジェクト フォルダとエンコードの変更) 

 

 

 
コードのデバッグ 

1. ストップウォッチを使ってブレークポイント間のタイミングを調べる(ストップウォッチの使用) 
2. ウィンドウに逆アセンブルコードを表示する([Disassembly]ウィンドウの表示) 
3. 関数コールをたどるため、コールスタックまたはコールグラフを表示する(コールスタックの表示、コ

ールグラフの表示) 
4. ダッシュボード画面にブレークポイント リソース、チェックサム、メモリ使用率等のプロジェク

ト情報を表示する(ダッシュボードの表示) 
5. 設計およびデバッグ中にプロジェクトのレジスタを表示する(プロジェクト レジスタの表示([I/O 

View])) 
 
 

 
コードの管理 

1. リファクタリングおよびプロファイリング ツールを使ってコードを改善する(コードの改善*) 
2. 内蔵のローカルファイル履歴機能を使ってソースコードを管理する(ローカルファイル履歴によるソ

ースコードの管理) 
またはリビジョン管理システムを使ってソースコードを管理する(リビジョン管理システムによるソ

ースコードの管理) 
3. チームサーバと問題追跡システムを使って、コード開発とエラー追跡を連携する(コード開発とエ

ラー追跡の連携*) 
4. アプリケーションに適した最適化作業を決定するためにMPLAB XCコンパイラのFreeライセンスと

PROライセンスを比較するMPLAB XCコンパイラのFreeライセンスとPROライセンスの比較) 
 

 

 
機能の追加 

1. コード開発を支援するためにプラグインツールを追加する(プラグインツールの追加) 

* この機能については、[Start Page]の[My MPLAB X IDE]タブを開き、[Extend MPLAB]セクションの[Selecting Simple or Full-
Featured Menus]トピックを参照してください。 

 
5.1 デバイスパックを使う方法 

MPLAB X IDEがデバイスをシミュレートまたはエミュレートするには、デバイス固有の情報が必要です。この情報

はデバイスファイル(.PIC)に保存されておりデバイスの電力要件、プログラミング方式、アーキテクチャ等のデータ

を含んでいます。 

MPLAB X IDE v5.00以降のデバイスファイルは、バージョン管理されたデバイスファミリ パック(DFP)にまとめられ

ています。MPLAB X IDEはデバイスパックと一緒にインストールされますが、デバイスパックをアップグレードし

て新しいデバイス、新しいデバイス機能、デバイスバグ修正のサポートを追加する事ができます。 



MPLAB X IDEユーザガイド 
追加作業 

ユーザガイド DS-50002027E_JP - p. 97 © 2019 Microchip Technology 
 

 

 

 
 

例えば、Windowsコンピュータ上でPIC16F19197のデバイスファイルを収めたDFPのパスは以下の通りです。 

C:\Program Files (x86)\Microchip\MPLABX\v5.00\packs\Microchip\PIC16F1xxxx_DFP 
\1.0.38\edc\PIC16F19197.PIC 
 

• インストール場所: C:\Program Files (x86)\Microchip\MPLABX 
• バージョン: \v5.00 
• パック保存フォルダ: \packs 
• デバイスファミリ パック: \Microchip\PIC16F1xxxx_DFP 
• パックバージョン: \1.0.38 
• デバイスファイル保存フォルダ: \edc 
• デバイスファイル: \PIC16F19197.PIC 

詳細は以下のヘルプを参照してください。 

Device Packs in Projects 

Device Pack Frequently Asked Questions 
 

5.1.1 MPLAB X IDEインストール中のパックのインストール 
MPLAB X IDEをインストールする際は、インストールするMicrochip社デバイスサポートを選択できます([Choose 
Microchip device support you want installed])。これにより、選択したデバイス アーキテクチャのパックがインスト

ールされます。必要なものだけをインストールする事でディスク容量が節約でき、インストール時間も短くて済み

ます。 

これは、分散インストーラ(distributed installer)とも呼ばれます。 
 

MPLAB X IDEのインストールに関する情報はMPLAB X IDE Readmeに記載しています。 
 

5.1.2 MPLAB X IDEインストール後のパックのインストール 
[Tools] > [Packs]を選択すると、MPLAB Pack Manager経由でインストール可能なバージョン別パックリストが開き

ます。 
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初めて開くと、最新IDEリリースと互換のパックのみ表示されます。IDEリリースボタンをクリックするとフィルタ

機能が無効になり、全バージョンのパックが表示されます。下図はリストの例です。 
 

 

 
フィルタがかけられたパックリスト 

 

 
全バージョンのパックを表示 

 
図5-1 MPLAB Pack Manager 

 
5.1.3 インストールしたパックの切り換え 

MPLAB X IDEで開いたプロジェクトの場合、[Projects]ウィンドウでプロジェクト名を右クリックし、[Properties]を
選択して[Project Properties]ウィンドウを開きます。[Packs]リストに、プロジェクト デバイスに使えるパックが表示

されます。 

灰色で表示されたパックは、使用中のMPLAB X IDEバージョンには含まれていません。パックのインストール方法

は5.1.2「MPLAB X IDEインストール後のパックのインストール」を参照してください。フィルタをOFFにして全バ

ージョンを表示し、目的のバージョンをインストールします。 

Note:  [Project Properties]でデバイスパックがインストールされていないデバイスに切り換えた場合、デバイスパッ

クのインストールを促される事はありません。MPLAB Pack Managerを使って、自分でインストールする必要があ

ります。 
 

5.1.4 ウェブ上のパック 
以下のウェブサイトでパックバージョンの検索とダウンロードが行えます。
https://packs.download.microchip.com/ 

https://packs.download.microchip.com/
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パック名をクリックすると、サポートしているデバイス、パックバージョン履歴等の情報が表示されます。 

図5-2 Microchip社のパックリポジトリ 

 
 
5.2 MPLAB X IDEプロジェクトを開く 

既存のプロジェクト(作成したプロジェクトまたはダウンロードしたサンプル)がある場合、いくつかの方法でこのプ

ロジェクトを開く事ができます。 

IDEメニューから開く 

[File] > [Open Project]または[File] > [Open Recent Project]を選択します。 

アイコンで開く 

[Open Project]アイコンをクリックします。 
 

プロジェクト フォルダをドラッグ&ドロップして開く 

ファイル マネージャ ウィンドウでプロジェクト フォルダを選択します。そのフォルダを[Editor]ペインにドラッグ

&ドロップします(4.2「プロジェクト作成後のデスクトップ画面」参照)。プロジェクトが[Projects]ウィンドウ内に表

示されます。 

図5-3 フォルダのドラッグ&ドロップ 
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図5-4 プロジェクトが開いた状態 

プロジェクトが保存されているフォルダをドラッグ&ドロップして開く 

プロジェクトが保存されているフォルダを開くには、ファイル マネージャ ウィンドウでフォルダを選択します。こ

のフォルダを[Editor]ペインにドラッグ&ドロップします(前のステップ参照)。[File]ペインのタブにフォルダ名の付

いたウィンドウが開きます。このウィンドウには、フォルダと関連プロジェクトが表示されます。このフォルダでプ

ロジェクトを開くには、プロジェクト名を右クリックし、[Open Project of Folder]を選択します。プロジェクトが

[Projects]ウィンドウ内に表示されます。 

図5-5 プロジェクトが保存されているフォルダが開いた状態 

 
 
5.3 MPLAB IDE v8プロジェクトのインポート 

[New Project]ウィザードを使うと、MPLAB IDE v8プロジェクトをMPLAB X IDEプロジェクトにインポートできます。

以下にその際の注意事項を示します。 

MPLAB IDE v8のワークスペースの設定は転送されません。 

MPLAB IDE v8のワークスペースに保存されている設定(ツール設定等)は、新しいMPLAB X IDEプロジェクトに転送

されません。ワークスペースに保存されている情報については、MPLAB IDE v8ヘルプ([MPLAB IDE Reference] > 
[Operational Reference] > [Saved Information])を参照してください。 

プロジェクトの設定(コンパイラ、リンカ、アセンブラの設定等)は、新しいMPLAB X IDEプロジェクトに転送されま

す。 

MPLAB IDE v8プロジェクトのファイルが変更される可能性 

インポートするMPLAB IDE v8プロジェクトが、「MPLAB C Compiler for PIC24 MCUs and dsPIC DSCs」(MPLAB 
C30とも呼ぶ)とCOFFデバッグファイル フォーマットを使っている場合、以下のように変換されます。 

• MPLAB X IDEプロジェクトがCOFFライブラリを使わない場合、デバッグファイル  フォーマットは

ELF/DWARFに変換されます。MPLAB X IDEプロジェクトがCOFFライブラリを使う場合、フォーマットは

COFFのままとなります。 
• MPLAB IDE v8はファイル拡張子の大文字/小文字(.cと.C等)を区別しませんが、MPLAB X IDEはこれらを区別

し、.cをCのコードファイル、.CをC++のコードファイルに関連付けます。従って、.C拡張子を持つCコード

を含むMPLAB IDE v8プロジェクトをインポートすると、MPLAB X IDEはその.Cファイルを.cにリネームし、

コンパイラの誤動作を防ぎます。 

MPLAB IDE v8プロジェクトのビルドが変更される可能性 

MPLAB X IDEにインポートしたMPLAB IDE v8プロジェクトは元のプロジェクトと同じようにはビルドされません。 

• プロジェクトコードに     FILE  , assert(),     TIME  ,または     DATE  を使わないでくださ

い。ビルド(とチェックサム)が変わってしまいます。 
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• 論理サブフォルダを使うMPLAB IDE v8プロジェクトのチェックサムは、MPLAB X IDEにインポートされると

変わってしまいます。同じチェックサムでビルドするには、論理サブフォルダ内のファイルをメイン論理フォ

ルダ (ソースファイル、ヘッダファイル等)に移動してから、MPLAB X IDEにインポートします。 

ソースファイル内の論理サブフォルダを削除する方法: 

• ソースファイルの下のファイルにドラッグする 
• フォルダを選択して<Delete>を押す 
• または、フォルダを右クリックして[Remove from Project]を選択すると、フォルダがプロジェクトから削除さ

れます。ただしPCからフォルダが削除される事はありません。 

図5-6 ファイルの移動とサブフォルダの削除 

 
5.3.1 [Import MPLAB IDE v8 Project]ウィザードを開く 

このウィザードは以下2通りの方法で開きます。 

[Import Legacy Project]ウィザードを使う方法 

[Import Legacy Project]ウィザードは以下の方法で開きます。 

• [Start Page]で[Learn & Discover]または[My MPLAB X IDE]タブをクリックし、[Projects]セクションで[Import 
Legacy]を選択します。 

• [File] > [Import] > [MPLAB IDE v8 Project]を選択します。 

[New Project]ウィザードを使う方法 

[New Project]ウィザードは以下の方法で開きます。 

• [Start Page]で、[Learn & Discover]または[My MPLAB X IDE]タブを開き、[Projects]セクションで[Create 
New]を選択します。 

• [File] > [New Project]を選択します(または<Ctrl>+<Shift>+<N>)。 

• ツールバーで[New Project]アイコン をクリックします。 

[New Project]ウィザードが起動し、プロジェクトの新規作成を支援します。 

Step 1.Choose Project: [Microchip Embedded]カテゴリを選択し、プロジェクト タイプ[Existing MPLAB IDE v8 
Project]からプロジェクトを選択します。[Next>]をクリックします。 
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5.3.2 [Import MPLAB IDE v8 Project]ウィザードの使用 
以下の手順でMPLAB IDE v8プロジェクトをインポートします。ステップの番号は[Import Legacy Project]オプション

に従っています(5.3.1「[Import MPLAB IDE v8 Project]ウィザードを開く」参照) 

[Next>]をクリックすると次のステップに進みます。 

Step 1. Locate MPLAB IDE v8 Project *.mcp File: レガシー プロジェクトを選択します。 

Step 2. Select Device: アプリケーションで使う予定のデバイスを[Device]ドロップダウン リストから選択します。

デバイスファミリを選択すると選択肢を絞り込めます。 

Step 3. Select Header: このステップは、選択したデバイスでヘッダが利用可能である場合に表示されます。デバッ

グ用にヘッダが必要かどうか、デバイスがデバッグ回路を内蔵しているかどうかは、以下の文書で確認します。次に

ヘッダを使うかどうかを選択します。 

• 『Processor Extension Pak and Debug Header Specification』 
• 『エミュレーション拡張パック(EEP)およびエミュレーション ヘッダ ユーザガイド』 

Step 4. Select Tool: アプリケーションの開発に使う開発ツールをリストから選択します。デバイスのサポートを判

定する方法は4.1.6.1「プロジェクト ツールサポート」を参照してください。 

Step 5. Select Plugin Board: プラグインボードを使う場合、ここで選択します。 

Step 6. Select Compiler: アプリケーションの開発に使う言語ツール (コンパイラ)をリストから選択します。デバイ

スのサポートを判定する方法は4.1.6.1「プロジェクト ツールサポート」を参照してください。 

Step 7. Select Project Name and Folder: 両方のプロジェクトの保守性を保つために、既定値の名前とフォルダは

変更しない事を推奨します。下図の例を参照してください。 

File Locations: 

新規プロジェクトは、ソースファイルをプロジェクト フォルダにコピーしません。その代わりに、v8フォルダ内の

ファイル保存場所を参照します。 

独立したMPLAB X IDEプロジェクトを作成するには、プロジェクトを新規作成して、MPLAB IDE v8のソースファイ

ルを、そのプロジェクトにコピーする必要があります。 

Main Project: 

インポート時にこのプロジェクトをメイン プロジェクトとするために、チェックを入れます。 

Project Location: 

MPLAB X IDEプロジェクトの保存場所はMPLAB IDE v8プロジェクト フォルダ内ではないため、チェックを外しま

す。 

File Formatting: 

MPLAB IDE v8からプロジェクトをインポートする際に使う文字エンコードの既定値は「ISO-8859-1」です。 

インポート元のプロジェクトで実際に使っているエンコードを選択する必要があります。例えば、MPLAB IDE v8の
フォーマットが「950 (ANSI/OEM – Traditional Chinese Big5)」である場合、ドロップダウン リストから「Big5」を

選択します。 

Step 8. Summary: [Finish]をクリックする前に、設定した内容を確認します。不適切な設定が見つかった場合、

[Back]ボタンを使って以前のステップに戻って修正します。 

レガシー プロジェクトが[Project]ウィンドウ内に開きます。 
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図5-7 Step 7のダイアログ例 

 

5.4 ビルド済みのプロジェクト 
[Import Image File]ウィザードを使って、ビルド済みのロード可能イメージ(HEX、ELF、COFファイル)からプロジェ

クトを作成します。 

Note:  デバイスにプリビルト イメージをプログラミングする場合、makeは実行しませんが[Make and Program 
Device]アイコンをクリックします。 

このウィザードを開くには、[Start Page]を使う方法と[New Project]を使う方法があります。 

[Import Prebuilt Project]を使う方法 

[Import Image File]ウィザードは、以下の方法で開きます。 

• [Start Page]で[Learn & Discover]または[My MPLAB X IDE]タブをクリックし、[Projects]セクションで[Import 
Prebuilt]へのリンクを選択します。 

• [File] > [Import] > [Hex/ELF (Prebuilt) File]を選択します。 

[New Project]ウィザードを使う方法 

[New Project]ウィザードを開く方法は、4.1.2「[New Project]ウィザードの起動」を参照してください。[New Project]
ウィザードが起動し、プロジェクトの新規作成を支援します。 

• Step 1. Choose Project: [Microchip Embedded]カテゴリを選択し、プロジェクト  タイプ [Prebuilt (Hex, 
Loadable Image) Project]からプロジェクトを選択します。[Next>]をクリックします。 

• 「Import Image File」ウィザードが開きます。 

[Import Image File]ウィザード 
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以下の手順により、イメージファイルをインポートします。ステップ番号は[Import Prebuilt Project]オプションに従

っています。 

[Next>]をクリックすると次のステップに進みます。 

Step 1. Import Image File: イメージファイルの名前と保存場所を選択します。ダイアログで場所を選択できます。 

Step 2. Select Device: アプリケーションで使う予定のデバイスを[Device]ドロップダウン リストから選択します。

デバイスファミリを選択すると選択肢を絞り込めます。 

Step 3. Select Header: このステップは、選択したデバイスでヘッダが利用可能である場合に表示されます。デバッ

グ用にヘッダが必要かどうか、デバイスがデバッグ回路を内蔵しているかどうかは、以下の文書で確認します。次に

ヘッダを使うかどうかを選択します。 
• 『Processor Extension Pak and Debug Header Specification』 
• 『エミュレーション拡張パック(EEP)およびエミュレーション ヘッダ ユーザガイド』 

Step 4. Select Tool: アプリケーションの開発に使う開発ツールをリストから選択します。使うデバイスのサポート

を判定する方法は4.1.6.1「プロジェクト ツールサポート」を参照してください。 

Step 5. Select Project Name and Folder: 新規プロジェクトの名前と保存場所を選択します。ダイアログで保存場

所を選択できます。完了したら、[Finish]をクリックします。 

作成したプロジェクトが[Projects]ウィンドウ内に表示されます。 

プロジェクトをHEXファイルとしてエクスポートする方法は12.15「[Projects]ウィンドウ - [Project]メニュー」を参

照してください。 
 
5.5 ロード可能なプロジェクト、ファイル、シンボル 

複数のプロジェクトの結合、複数のHEXファイルの結合、プロジェクトとHEXファイルの結合、プロジェクトHEX
ファイルの置換には、ロード可能なプロジェクトおよびファイルを使います。Hexmateアプリケーションを使って、

プロジェクトまたはロードしたHEXファイルを1つのファイルにマージします。このアプリケーションの使い方の詳

細は、インストールしたMPLAB XC8 Cコンパイラのdocsフォルダにある『MPLAB XC8 C Compiler User’s Guide』
(DS50002053)を参照してください。9.5 「エラー」のセクション[HEXMATE Conflict Report Address Error]も参照し

てください。 

RTDM (Real Time Data Monitoring)とDMCI (Data Monitoring and Control Interface)を使う場合(モータ制御アプリケ

ーション等)のように、量産ビルドまたはプログラミング中にデバッグシンボルをロードするには、ロード可能なシ

ンボルを使います。 

ロード可能なプロジェクトまたはファイルは、ブートローダとアプリケーションを結合したコードを作成する場合に

便利です。5.6「ロード可能なプロジェクトとファイル: ブートローダ」を参照してください。 

以下に、現在のプロジェクトとロード可能なプロジェクトおよびファイルの組み合わせを示します。 

表5-2 ロード可能プロジェクト/ファイルの組み合わせ 
 

現在のプロジェクト ロード可能プロジェクト/ファイル 注意 

スタンドアロン、 
既存のMPLAB IDE v8 
ライブラリ 

スタンドアロン なし 

HEXファイル なし 

ELF/COFファイル デバッグできますがビルドはできません。 
エラーが[Output]ウィンドウに表示されます。 

ビルド済み(HEX) HEXファイル 重複しているメモリ領域は自動ではチェック

しません。デバッグできますがビルドはでき

ません。 

[Build]ボタンは無効になります。 

 ELF/COFファイル 

ビルド済み(COF/ELF) HEXファイル 

 ELF/COFファイル  

 
以下にオプションを示します。 
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表5-3 ロード可能プロジェクト/ファイルのオプション 
 

ロード可能 
プロジェクトの

追加 

現在のプロジェクトに既存のプロジェクトをロードします。 
現在のプロジェクトをビルドする際に、全てのプロジェクトがビルドされHEXファイルが1つに

結合されます。デバッグファイルも全てが結合されます(ELFまたはCOF)。 

ロード可能 
ファイルの追加 

現在のプロジェクトに既存のHEXファイルをロードします。 
現在のプロジェクトをビルドする際に、ロードしたHEXファイルとその他のHEXファイルが1つ
のファイルに結合されます。 

Note: HEXファイルをロードしたプロジェクトはデバッグできません。デバッグが必要な場合、

ロード可能プロジェクトを使います。 

代替ファイルの

追加 
代替HEXファイルをロードします。 
このオプションを使うとビルド後の処理を設定できます。この処理では、プロジェクトのHEXフ
ァイルを別の場所にコピーまたは移動し、HEXMATE等のツールを使ってファイルを別のHEXフ
ァイルとマージし、IDEにロードする事ができます。 

 
5.5.1 [Projects]ウィンドウ – [Loadables]フォルダによる設定 

[Projects]ウィンドウの[Loadables]フォルダを右クリックして、以下のオプションを選択します(下図参照)。 

• Add Loadable Project – 既存のプロジェクトを選択して、現在のプロジェクトに追加します。さらにプロジェク

トを追加するには手順を繰り返します。 
• Add Loadable Files – 既存のHEXファイルを選択して、現在のプロジェクトに追加します。さらにHEXファイル

を追加するには手順を繰り返します。 
• Properties – ロードのために[Project Properties]ウィンドウを開きます。5.5.2「[Project Properties]ウィンドウ – 

[Loading]カテゴリによる設定」を参照してください。 

全てのプロジェクトをビルドしてHEXファイルを1つに結合するには、現在のプロジェクトをビルドします。デバッ

グファイルも全て結合されます。 

図5-8 [Projects]ウィンドウ – [Loadables]フォルダ 

 
5.5.2 [Project Properties]ウィンドウ – [Loading]カテゴリによる設定 

[Project Properties]ウィンドウを開き([File] > [Project Properties])、[Loading]カテゴリをクリックします。 

• 現在のプロジェクトを他のプロジェクトと結合する方法 
• 現在のプロジェクトHEXファイルを他のHEXファイルと結合する方法 
• 代替HEXファイルをロードする方法 
• プログラミング/ビルド中にデバッグシンボルをロードする方法 
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図5-9 [Project Properties]ウィンドウ – [Loading]カテゴリ 

現在のプロジェクトを他のプロジェクトと結合する方法 

1. [Add Loadable Project]をクリックします。[Add Loadable Project]ダイアログが開きます。 
2. プロジェクトを選択します。 
3. [Configurations]からこのプロジェクトで使うビルド コンフィグレーションを選択します。このプロジェクト

に他のコンフィグレーションを追加していなければ、ここには[default]しか表示されません。 
4. [Store path as]から、ロード可能プロジェクトへのパス情報の保存方法を選択します。以下から選択します。 

4.1. Auto – ロード可能プロジェクトへのパスを相対パスと絶対パスのどちらにするかを、その保存場所

に基づいてMPLAB IDEが決定できるようにします。 
メイン プロジェクトのフォルダにロード可能プロジェクトが含まれている場合、参照は相対パスに

なります。それ以外の場合、参照は絶対パスになります。 
4.2. Relative – ロード可能プロジェクトを(メイン プロジェクトへの)相対パスで参照します。これは、パ

スを追加する際に推奨する方法です。 
4.3. Absolute – ロード可能プロジェクトを絶対パスで参照します。 

このモードが便利な場合もありますが、プロジェクトを別のシステムに移動する場合、しばしばパス

の修正が必要です。 
5. [Add]をクリックしてダイアログを閉じます。 
6. 現在のプロジェクトのビルドにこのプロジェクトを含める場合、[Project Properties]ウィンドウで[Include]に

チェックを入れます。 
7. 複数のプロジェクトを追加した場合、ここに表示される順序が、現在のプロジェクトのHEXファイルにこれら

のHEXファイルが追加される順序を決定します。追加の順序を変更するには、[Up]と[Down]ボタンを使いま

す。 
8. [Apply]または[OK]をクリックして変更を確定します。 

次に現在のプロジェクトをビルドする際は、ここに表示されたプロジェクトも([Include]がチェックされていれば)ビ
ルドされ、それらのHEXファイルが現在のプロジェクトのHEXファイルと結合されて、1つの出力HEXファイルが生

成されます。デバッグファイルも全て結合されます。 
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図5-10 [Add Loadable Project]ダイアログ 

現在のプロジェクトHEXファイルを他のHEXファイルと結合する方法 

1. [Add Loadable File]をクリックします。[Add Loadable File]ダイアログが開きます。 
2. HEXファイルを選択します。 
3. [Store path as]から、ロード可能ファイルへのパス情報の保存方法を選択します。以下の方法から選択します。 

3.1. Auto – ロード可能ファイルへのパスを相対パスと絶対パスのどちらにするかを、その保存場所に基

づいてMPLAB IDEが決定できるようにします。 
メイン プロジェクトのフォルダにロード可能ファイルが含まれている場合、参照は相対パスになり

ます。それ以外の場合、参照は絶対パスになります。 
3.2. Relative – ロード可能ファイルを(メイン プロジェクトへの)相対パスで参照します。これは、パスを

追加する際に推奨する方法です。 
3.3. Absolute – ロード可能ファイルを絶対パスで参照します。 

このモードが便利な場合もありますが、プロジェクトを別のシステムに移動する場合、しばしばパス

の修正が必要です。 
4. [Add]をクリックしてダイアログを閉じます。 
5. [Project Properties]ウィンドウで、複数のファイルを追加した場合、ここに表示される順序が、現在のプロジ

ェクトのHEXファイルにこれらのHEXファイルが追加される順序を決定します。追加の順序を変更するには、

[Up]と[Down]ボタンを使います。 
6. [Apply]または[OK]をクリックして変更を確定します。 

次に現在のプロジェクトをビルドする際は、ここに表示されたHEXファイルが現在のプロジェクトのHEXファイル

(CurrentProject.X.Production.hex)と結合されて、1つの出力HEXファイルが生成されます。このファイル

(CurrentProject.X.unified.hex)は、同じフォルダ内に現在のプロジェクトHEXファイルとして生成されます。 

代替HEXファイルをロードする方法 

1. [Load this .hex file instead of ...]にチェックを入れます。 
2. [...]ボタンをクリックして、[Add Loadable File]ダイアログを開きます。このダイアログを使ったHEXファイル

の追加の詳細は、前のトピックを参照してください。 
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次に現在のプロジェクトをビルドする際、その完了時に代替HEXファイルがロードされます。 

プログラミング/ビルド中にデバッグシンボルをロードする方法 

RTDMとDMCIを使う場合(モータ制御アプリケーション等)、[Load symbols when programming or building for 
production (slows process)]にチェックを入れると、プログラミング中にデバッグシンボルをロードする事ができま

す。それ以外の場合、チェックは外したまま(既定値)にしてプログラミングとビルドの速度を向上させます。 

図5-11 ロード可能ファイルの追加 

 
5.5.3 ロード可能プロジェクト/ファイルの推奨使用法 

ロード可能プロジェクト/ファイルは、以下の方法で使う事を推奨します。 

1. デバイスのコンフィグレーション ビットの設定と初期化を行うプロジェクトをメイン プロジェクトとして選

択します(右クリックして[Set as Main Project]を選択)。メイン プロジェクトと競合するため、ロード可能プ

ロジェクト/ファイルにデバイス コンフィグレーション設定を持たせる事はできません。 
2. 他のプロジェクトを、ロード可能プロジェクト/ファイルとしてメイン プロジェクトに追加します。ロードす

るプロジェクトに複数のプロジェクト コンフィグレーションが設定されている場合、ロードする際にそれら

を全て指定します。 

ロード可能プロジェクト/ファイルを含むプロジェクトをメイン プロジェクトに指定しておく事で、どのロード可能

プロジェクト/ファイルに変更が生じても、ビルドを実行する際にその変更が確実に反映されるようにします。 
 
5.6 ロード可能プロジェクトおよびファイル: ブートローダ 

ブートローダとアプリケーションのコードを結合する方法 

1. アプリケーション用とブートローダ用にそれぞれ1つずつプロジェクトを作成します。 
2. ブートローダのプロジェクトまたはHEXファイルをアプリケーション プロジェクトにロードします。この方

法は5.5.1「[Projects]ウィンドウ – [Loadables]フォルダによる設定」または5.5.2「[Project Properties]ウィン

ドウ – [Loading]カテゴリによる設定」を参照してください。 

次にアプリケーション プロジェクトをビルドすると、ブートローダとアプリケーションのHEXファイルが結合され

たものが生成されます。デバッグファイルも全て結合されます。 
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ビルドのエラーは5.5.3「ロード可能プロジェクト/ファイルの推奨使用法」または以下のセクションを参照してくだ

さい。 

PIC18 MCU (MPLAB C18)向けMPLAB Cコンパイラ 
このコンパイラはアプリケーションの起動コード(c018x.o)を生成します。リセットベクタ (アドレス0)で始まるこ
の起動コードはソフトウェア スタックの初期化、必要に応じてidataセクションの初期化、main()へのジャンプを含
みます。この起動コードがアプリケーション内に残っていると、ブートローダ コードリセットと競合が生じ、デー
タ競合に関するリンカエラー メッセージが表示されます。 

解決策の1つは、0以外のアドレスで始まるように起動コードを編集する事です。 

MPLAB XC8 – PIC18 MCUの例 

以下のMicrochip社ウェビナーでは、PIC18 MCU向けにブートローダとアプリケーション コードを組み合わせる方法

を、MPLAB XC8とMPLAB X IDEを使って詳しく説明しています。 
Linking PIC18 Bootloaders and Applications 

MPLAB XC16ブートローダの例 

サンプル ブートローダについては、『MPLAB XC16 Cコンパイラ ユーザガイド』(DS50002071)またはヘルプファ

イルを参照してください。 

MPLAB XC32ブートローダの例 

Microchip社ウェブサイトで『PIC32 Bootloader Application Note』(DS01388)を参照してください。 
 
 
5.7 ライブラリ プロジェクト 

HEXファイルではなくライブラリ ファイル(コンパイラによって*.libまたは*.a)を生成するプロジェクトを作成します

(赤字部分参照)。このプロジェクトはmain()関数を持たないため、単独で実行する事はできません。作成したライブ

ラリは、main()関数を持つ別のプロジェクトで使います。 

図5-12 ライブラリ プロジェクトの例 

[New Project]ウィザードの開き方は4.1.2「[New Project]ウィザードの起動」を参照してください。 

[New Project]ウィザードが起動し、プロジェクトの新規作成を支援します。[Next]をクリックすると次のステップに

進みます。 

Step 1. Choose Project: 「Microchip Embedded」カテゴリを選択し、プロジェクト タイプ「Library Project」から
プロジェクトを選択します。 

Step 2. Select Device: アプリケーションで使う予定のデバイスを[Device]ドロップダウン リストから選択します。
選択肢を絞り込むために、最初にデバイスファミリを選択します。 

Step 3. Select Header: このステップは、選択したデバイスでヘッダが利用可能である場合に表示されます。デバッ
グ用にヘッダが必要かどうか、または、使うデバイスがデバッグ回路を内蔵しているかどうかは、以下のどちらかの
文書で確認できます。 

• プロセッサ拡張パックとデバッグヘッダ 
• エミュレーション拡張パックとエミュレーション ヘッダ 

Step 4. Select Tool: アプリケーションの開発に使う開発ツールをリストから選択します。使うデバイスのサポート
を判定する方法は4.1.6.1「プロジェクト ツールサポート」を参照してください。 

Step 5. Select Compiler: アプリケーションの開発に使う言語ツール (コンパイラ)をリストから選択します。使うデ
バイスのサポートを判定する方法は4.1.6.1「プロジェクト ツールサポート」を参照してください。 

https://www.microchip.com/webinars.microchip.com/WebinarDetails.aspx?dDocName=en558478
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Step 6. Select Project Name and Folder: 新規プロジェクトの名前と保存場所を選択します。ダイアログを使って

保存場所を選択できます。完了したら、[Finish]をクリックします。 

作成したプロジェクトが[Projects]ウィンドウ内に表示されます。 

必要に応じてライブラリ プロジェクトをスタンドアロン (アプリケーション) プロジェクトに変更できます。詳細は

4.10.1「プロジェクト コンフィグレーション タイプの変更」を参照してください。 
 
 
5.8 Atmel Studio 7またはAtmel STARTプロジェクトのインポート 

[New Project]または[Import]ウィザードを使って、MPLAB X IDE用のAtmel Studio 7プロジェクトまたはAtmel 
STARTエクスポート ファイルをインポートします。 

ウィザードは以下の2通りの方法で開きます。 

[Import Project]ウィザードを使う方法 

[Import Atmel Studio]または[START Project]ウィザードを開くには、以下のどちらかを選択します。 

• File>Import>Atmel Studio Project 

• File>Import>START MPLAB Project 

[New Project]ウィザードを使う方法 

[New Project]ウィザードは、以下の方法で開きます。 

• [Start Page]で、[Learn & Discover]または[My MPLAB X IDE]タブをクリックし、[Projects]セクションで

[Create New]へのリンクを選択します。 
• [File] > [New Project](または<Ctrl>+<Shift>+<N>)を選択します。 
• ツールバーで[New Project]アイコンをクリックします。 

[New Project]ウィザードが起動し、プロジェクトの新規作成を支援します。 

Step 1.Choose Project: [Microchip Embedded]カテゴリを選択し、プロジェクト タイプから[Import Atmel Studio 
Project]または[Import Atmel START MPLAB Project]を選択します。[Next]をクリックします。 

 
5.8.1 [Import Atmel Project] - Locate Project File 

Step 1または2.Locate Atmel StudioまたはSTART Project File 

要求したファイルを選択します。例えばWindows 7 OSの場合、プロジェクト ファイルは以下の場所に保存されています。 

C:\Users\Admin\Documents\Atmel Studio\7.0\ 

Atmel Studioの場合、*.cprojまたは*.cppprojがプロジェクト ファイルです。Atmel STARTの場合、*.atzipがプロ

ジェクト ファイルです。 



MPLAB X IDEユーザガイド 
追加作業 

ユーザガイド DS-50002027E_JP - p. 111 © 2019 Microchip Technology 
 

 

 

 
 

図5-13 [Import Atmel Studio Project] 

 
5.8.2 [Import Atmel Project] - Select Device 

Step 2または3. Select Device 

このウィンドウにはインポートしたプロジェクトのデバイス情報が表示されます。 
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図5-14 [Import Atmel Project] - Select Device 

 
5.8.3 [Import Atmel Project] - Select Tool 

Step 3または4. Select Tool 

このウィンドウには、MPLAB X IDEで使えるAtmelプロジェクトのデバッグツールが表示されます。リストから別の

ツールを選択する事はできますが、プロジェクトが正しく動作する事を確認するため、インポートが完了するまで元

のプロジェクト ツールから変えないでおきましょう。後から別のツールを選択できます。 

デバイスに対するツールのサポートレベルが、ツール名の横のマークで色分け表示されます。この表示の詳細は「基

本作業」の「新規プロジェクトの作成」を参照してください。 
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図5-15 [Import Atmel Project] - Select Tool 

 
5.8.4 [Import Atmel Project] - Select Compiler 

Step 4または5. Select Compiler 

このウィンドウには、MPLAB X IDEで使えるAtmelプロジェクトのコンパイラが表示されます。リストから別のコン

パイラを選択する事はできますが、プロジェクトが正しく動作する事を確認するため、インポートが完了するまで元

のプロジェクト コンパイラから変えないでおきましょう。後から別のコンパイラを選択できます。 

デバイスに対するツールのサポートレベルが、ツール名の横のマークで色分け表示されます。 

互換性のあるコンパイラが表示されない場合、[Cancel]をクリックして「基本作業」の「新規プロジェクトの作成」

に記載されている手順を実行します。 
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図5-16 [Import Atmel Project] - Select Compiler 

 
5.8.5 [Import Atmel Project] - Select Device Support 

Step 5または6. Select Device Support 

MPLAB X IDE v5.00以降は、バージョン管理されたデバイスパックでサポートされています。デバイスパック バー

ジョンがMPLAB X IDEでサポートされていない場合: 

1. [Override Default Device Support]にチェックを入れ、ヘルプアイコン(?)をクリックして表示される指示に従

ってパックサポートをダウンロードします。パックをダウンロードすると、Atmel Studioにインストールされ

ます(下図参照)。 
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図5-17 [Import Atmel Project] - Select Device Support 

図5-18 デバイスパックのインストール 

 
2. [Override Default Device Support]にチェックを入れると、Atmel Studioパックフォルダ内で正しいバージョン

を検索できます。例: 

C:\Program Files (x86)\Atmel\Studio\7.0\packs\atmel\ATmega_DFP\1.2.209 

3. [Override Default Device Support]のチェックを外すと、プロジェクト内で最新のMPLAB X IDEデバイスパッ

ク バージョンを使う事ができます。例えば、MPLAB X IDEプロジェクト パックは以下に保存されています。 
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C:\Program Files (x86)\Microchip\MPLABX\v5.xx\packs\Atmel\ATmega_DFP 

 
5.8.6 [Import Atmel Project] - Select Project Name and Folder 

Step 6または7. Select Project Name and Folder 

両方のプロジェクトの保守性を保つため、既定値の名前とフォルダは変更しない事を推奨します。 

Project Files Location: 

Atmel Startの場合、ソースファイルはMPLAB X IDEプロジェクトにコピーされます。 

Atmel Studioの場合、新規プロジェクトはソースファイルをプロジェクト フォルダにコピーしません。その代わりに、

Atmelプロジェクト フォルダ内のファイル保存場所を参照します。 

独立したMPLAB X IDEプロジェクトを作成するには、新規プロジェクトを作成してソースファイルをそのプロジェ

クトにコピーする必要があります。 

Main Project: 

[Set as main project]にチェックを入れて、このプロジェクトをインポート時のメイン プロジェクトに設定します。 

Project Location: 

Atmel Studioでは、[Use project location as the project folder]にチェックを入れずに、MPLAB X IDEプロジェクトと

Atmelプロジェクトを一緒に保存する事を推奨します。WindowsでAtmelプロジェクトパスが長くなる場合(下図の警

告参照)、MPLAB X IDEにインポートする前にプロジェクトのパスを変更します。 

File Formatting/Encoding: 

インポート元のプロジェクトで実際に使っているエンコードを選択する必要があります。例えばフォーマットが

「950 (ANSI/OEM – Traditional Chinese Big5)」である場合、ドロップダウン リストから[Big5]を選択します。 

Path Length (Window OS): 

プロジェクトへのパスが長過ぎる場合、ビルド中の問題を避けるために短くする必要があります。 

図5-19 [Import Atmel Project] – Select Project Name and Folder 
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5.8.7 [Import Atmel Project] - Summary 
Step 7または8. Summary 

[Finish]をクリックする前に、設定した内容を確認します。不適切な設定が見つかった場合、[Back]ボタンを使って

以前のステップに戻って修正します。 

プロジェクト インポート中は、[Output]ウィンドウに警告等が表示されないか確認します。プロジェクトのビルドに

失敗する場合、変更を加える必要があるでしょう。 

図5-20 [Import Atmel Project] – Summary 

作成したプロジェクトが[Projects]ウィンドウ内に表示されます。 

Note:  元のAtmelプロジェクトのソースファイルはリンクされます。コピーはされません。従って、Atmelまたは

MPLAB X IDEプロジェクトでソースファイルに変更が加えられた場合、両方で通知されます。 
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図5-21 [Import Atmel Project] – [Projects]ウィンドウ 

 
 
5.9 その他の組み込みプロジェクト 

MPLAB X IDEでは、他の組み込みプロジェクトを選択して、そこからプロジェクトを作成できます。 

1. [File] > [New Project]を選択します。 
2. [Categories]の下の[Other Embedded]をクリックし、使用可能な組み込みプロジェクトのリストから選択しま

す。 
3. MPLAB X IDEプロジェクトの作成を継続します。 

この機能は既存のファイルをMPLAB X IDEプロジェクトにインポートします。他の組み込みプロジェクト設定の変

換やコード変換には未対応です。 

MPLAB X IDEの使い方の詳細は以下を参照してください。 

• チュートリアル 
• 基本作業 

使用可能なコンパイラの詳細は以下を参照してください。 

https://www.microchip.com/mplab/compilers 

 
 

5.10 サンプル プロジェクト 
サンプル プロジェクトを作成すると、Microchip社のデバイス、ツール、MPLAB X IDEの習得に役立ちます。 

1. [File] > [New Project]を選択します。 
2. [Categories]の下の[Samples]>[Microchip Embedded]をクリックし、使用可能な組み込みプロジェクト (デモボ

ードのライトを点滅させるもの)またはテンプレート プロジェクトのリストから選択します。詳細は説明を参

照してください。 

デモボードの製品番号は以下の通りです。 

• Explorer16デモボード: DM240001 
• PICDEM 2 Plus: DM163022-1 

https://www.microchip.com/mplab/compilers


MPLAB X IDEユーザガイド 
追加作業 

ユーザガイド DS-50002027E_JP - p. 119 © 2019 Microchip Technology 
 

 

 

 
 

 

5.11 他のタイプのファイルの使い方 
[File] > [New File]を選択すると、多くのタイプのファイルが提示されます。ここまでは、Microchip社のコンパイラ 
ファイルの使い方を説明してきました。しかし、使うプロジェクト言語ツールや特定のファイルを作成する必要性に

応じて、他のタイプのファイルを選択する事もできます。 

表5-4 ファイルタイプ 
 

カテゴリ ファイルタイプ 

Microchip 
Embedded 

MPLAB X IDEがサポートする言語ツール用のファイルです。利用可能なファイルタイプは、コンパ

イラ フォルダを選択すると表示されます。 

C 汎用Cファイル 

C++ 汎用C++ファイル 

Assembler 汎用アセンブリ ファイル 

Shell Scripts シェルスクリプト ファイル: Bash、C、Korn等 

Makefile Makefileファイル 

XML XMLファイル 

Other HTML、JavaScript等の他のタイプのファイル 
一覧に必要なファイルタイプが表示されない場合、[Empty File]を選択し、次のウィンドウで、拡張

子と共にファイルに名前を付けます。 
 
 
5.12 コード テンプレートの変更または作成 

プロジェクトに追加するファイルを作成(4.9.2「ファイルの新規作成」参照)する際に、新規ファイル用のテンプレ

ートを使います。このテンプレートを編集するには、[Tools] > [Templates]から[Open in Editor]を選択します。この

ダイアログの[Add]または[Duplicate]ボタンを使って、テンプレートを新規作成する事もできます。 

[New Folder]ボタンを使うと、テンプレートを保存する新しいフォルダを作成できます。MPLAB X IDEは

「Microchip Embedded」、「Shell Scripts」、「Makefiles」、「Other」以外の全てのフォルダを無視するため、

ファイルまたはフォルダは、これらのフォルダの下に作成する必要がある事に注意してください。 
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// <editor-fold defaultstate="collapsed" desc="${comment}"> 
${selection}${cursor}// </editor-fold> 

 
 

図5-22 テンプレート マネージャ 

テンプレート オプションは、[Tools] > [Options] (macOSでは[MPLAB X IDE] > [Preferences])を選択し、[Editor]ボ
タンをクリックし、[Code Templates]タブで設定できます(以下参照)。 

「fcom」オプションは、Cコード用のコメント オプションです。[Editor]ウィンドウに「fcom」と入力して<Tab>キ
ーを押すと、以下のテキストが挿入されます。 

このオプションを使うと、上のテキストで囲まれたコードセクションを非表示(折り畳み)/表示(展開)できます。 

[Code Template]タブで「fcom」を選択すると、[Expanded Text]セクションに「${comment}」が表示されます。 
このテキストの上にマウスカーソルを置くと、テキスト全体が表示されます。 
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図5-23 テンプレート オプション 

 
 
5.13 ハードウェア ツールまたは言語ツールの切り換え 

現在接続しているものと異なるデバッグツールを選択しているプロジェクトを実行またはデバッグしようとした場

合、そのプロジェクトに使う別のハードウェア ツールを選択できるダイアログが表示されます。 
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図5-24 [Switch Hardware Tool]ダイアログ 

複数のハードウェア ツールを接続しておき、[Project Properties]ウィンドウでそれらのツールを切り換える事もでき

ます(4.3「[Project Properties]ウィンドウを開く」参照)。 

複数バージョンのコンパイラ ツールチェーン(言語ツール)を切り換える場合も、[Project Properties]ウィンドウを使

います。 
 
 
5.14 プロジェクト フォルダとエンコードの変更 

プロジェクトを作成した際、プロジェクト フォルダとエンコードを指定しました。プロジェクト作成後は、[Project 
Properties]ウィンドウの[General]カテゴリを使ってプロジェクト フォルダを追加または無視し、プロジェクト エン

コードを変更できます。 
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図5-25 [Project Properties]ウィンドウ – [General]カテゴリ 

[Project Location] 

現在のプロジェクトの保存場所を表示します。プロジェクトの保存場所の変更は8.9「プロジェクトの移動、コピー、

リネーム」を参照してください。 

[Source Folders] 

プロジェクト ファイルを探す際にMPLAB X IDEが検索するフォルダを追加します。 

Note:  プロジェクト フォルダの外にファイルを追加するとプロジェクトの移植性が損なわれる場合があります。 

[Ignored Folders Pattern] 

指定した正規表現パターンに従ってプロジェクト フォルダ内のフォルダを無視します。 

例: フォルダsrc5を除外する 

プロジェクトからsrc5フォルダとその中身を除外するには、[Ignored Folders Pattern]テキストボックスに以下の正

規表現を入力します。 

^(src5|nbproject|build|test)$ 

[Projects]ウィンドウを表示してsrc5フォルダが表示されていない事を確認します。[Files]ウィンドウを表示し、こ

のフォルダが存在しているが除外されている事を確認します。 
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図5-26 プロジェクトからのフォルダの除外 

プロジェクトがビルドされたら、[Output]ウィンドウの[Build]タブにsrc5フォルダまたはscr5.cファイルが表示さ

れていない事を確認します。 

[Macro] 

指定したソースファイルにリンクするために、[Add Existing Items]選択ダイアログで使うソースファイルへのパスを

入力します。 

例: MPLAB Harmonyファイル 

MPLAB Harmonyソースファイルへのパスを選択します。 
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図5-27 [Macro]用のパスの入力 

[Projects]ウィンドウで[Source Files]フォルダを右クリックし、[Add Existing Items]のオプションの1つを選択します。

このダイアログにはマクロからファイルを選択するオプションがあります。[Relative to Macro]の上にマウスカーソ

ルを置くと、マクロ値が表示されます。 

図5-28 マクロからファイルを選択する事を選択する 

[Encoding] 

プロジェクト エンコードを変更します。ここではコード構文の色分けを指定します。 
これは、[Tools] > [Options] (macOSでは[MPLAB X IDE] > [Preferences])、[Fonts and Colors]ボタン、[Syntax]タ
ブで編集できます。 
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5.15 ストップウォッチの使用 
ストップウォッチを使うと、2つのブレークポイント間の時間を調べる事ができます。 

ストップウォッチの使い方 

1. ストップウォッチを開始するブレークポイントを追加します。 
2. ストップウォッチを停止するブレークポイントを追加します。 
3. [Window] > [Debugging] > [Stopwatch]を選択し、ウィンドウの左にある[Properties]アイコンをクリックし、

開始および停止ブレークポイントを選択します。 
4. 再度プログラムをデバッグすると、ストップウォッチの結果が表示されます。 

図5-29 ストップウォッチの設定 

図5-30 [Stopwatch]ウィンドウの内容 

 

[Stopwatch]ウィンドウの左側には以下のアイコンが表示されます。 

表5-5 ストップウォッチ アイコン 
 

アイコン アイコンテキスト 説明 
 

 
Properties ストップウォッチのプロパティを設定します。現在のブレークポイ

ントまたはトリガの1つを始点、もう1つを終点として選択します。 
 

 
Reset Stopwatch on Run 実行時にストップウォッチの時間を0にリセットします。 

 

 
Clear History [Stopwatch]ウィンドウをクリアします。 
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(続き) 
アイコン アイコンテキスト 説明 

 

 
Clear 
Stopwatch 

(シミュレータのみ)デバイスリセット後にストップウォッチをリセットします。 

 
 

5.16 [Disassembly]ウィンドウの表示 
このウィンドウは逆アセンブルコードを表示します。このウィンドウは、[Window] > [Debugging] > [Output] > 
[Disassembly Listing File]と選択して開きます。ウィンドウの内容を表示するには、デバッグ セッションで一時停止

する必要があります([Debug] > [Debug Project])。 

この情報は、リンカが生成したリスティング ファイルにも含まれている場合があります。このファイルは[File] > 
[Open File]を選択し、 
ProjectName.lstファイルを選択して開きます。 

逆アセンブル ファイル全体を素早く表示するには、[Disassembly]ウィンドウで右クリックして「Disassembly 
Listing File」を選択します。 

Note:  [Disassembly]ウィンドウは各命令を逆アセンブルします。しかし、命令に関連したバンク切り換えの履歴は

保持していません。従って、ウィンドウに表示されるSFR名はBank 0用です。 

図5-31 変数をマウスオーバーした[Disassembly]ウィンドウ 

表5-6 [Disassembly]ウィンドウのコンテクスト メニュー 
 

メニュー項目 説明 

Step Instruction、Step Over、Run to Cursor 4.15「コードのステップ実行」を参照してください。 

Cut、Copy、Paste ウィンドウ内で選択したテキストの切り取り、コピー、貼

り付け 
Select in Projects [Projects]ウィンドウを開いて、選択した内容を保存してい

る文書を選択します。 
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(続き) 
メニュー項目 説明 

Disassembly Listing File 逆アセンブル リスティング ファイルの内容を表示します。 
 
 

5.17 コールスタックの表示 
16/32ビットデバイスでは、[Call Stack]ウィンドウを使って、実行中のCコード内のCALLとGOTOを表示できます。

このウィンドウはアセンブリコードには対応していません。コールスタックを使う場合、コード最適化はOFFにし

ておく事を推奨します。 

[Call Stack]ウィンドウは、関数とその引数を、実行中のプログラムで呼び出された順番に一覧表示します。 

コールスタックの表示方法 

1. プログラムをデバッグ実行し、一時停止します。 
2. [Window] > [Debugging] > [Call Stack]を選択して[Call Stack]ウィンドウを開きます。12.4「[Call Stack]

ウィンドウ」も参照してください。コールスタックの詳細は、以下のNetBeansビデオをご覧ください。 

https://www.youtube.com/watch?v=iS8OOUPmTUc 
 
 
5.18 コールグラフの表示 

[Call Graph]ウィンドウは、選択した関数からコールされている関数、または、選択した関数をコールしている関

数をツリー構造で表示します。 

コールグラフの表示方法 

• 選択(強調表示)した関数を右クリックし、ドロップダウン メニューから[Show Call Graph]を選択します。 

図5-32 main関数のコールグラフ 

https://www.youtube.com/watch?v=iS8OOUPmTUc
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5.19 ダッシュボードの表示 
[Window] > [Dashboard]を選択すると、プロジェクト情報を表示できます。 

図5-33 ダッシュボードの表示 

ダッシュボードは、以下のどちらかのプロジェクトを表示します。 

• メイン プロジェクトが未選択の場合、[Projects]ウィンドウ内でアクティブなプロジェクト([Projects]ウィンド

ウ内でいずれかのプロジェクトをクリックすると、そのプロジェクトがアクティブになります) 
• メイン プロジェクト([Projects]ウィンドウでいずれかのプロジェクトを右クリックし、[Set as Main Project]を

選択します) 
• 他のプロジェクトは、アクティブ/非アクティブに関係なく表示されません。 

 
5.19.1 ダッシュボードのグループ 

[Dashboard]ウィンドウのプロジェクト情報はグループごとに表示されています。 

表5-7 ダッシュボードのグループ(続き) 
 

グループ 定義と説明 
 

 
Project Name 

• アクティブ/メイン プロジェクトの名前 
• プロジェクト タイプ (アプリケーションまたはライブラリ)とプロジェクト コンフィグレーシ

ョン(既定値またはユーザ定義) 
 

 
Device 

• プロジェクト デバイス 
• 実行またはデバッグ実行中に生成された全てのステータスフラグ 
• デバイスのメモリに読み込んだ内容のチェックサム

チェックサムを表示するにはビルドする必要があり

ます。6.14「チェックサム」を参照してください。 
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(続き) 
グループ 定義と説明 

 

 
Packs 

バージョン管理されたデバイス情報を保存するパック -.PICファイルやその他のファイル (デバイス

によって異なります) 

 

 
Compiler 
Toolchain 

• プロジェクト ツールチェーン名(例: XC8)、(ツールのバージョン番号)、[実行ファイルへのパ

ス] 
• イメージタイプ(量産またはデバッグ)、ツールチェーンのライセンスタイプに対応する最適化

レベル 
最適化の詳細は言語ツールの文書を参照してください。 

• コンパイラ ライセンス*の情報: 
– license type: ワークステーションまたはネットワーク 
– license mode: FREE, STD, PRO 
– license seats: 利用できるシートの総数 
– licenses available: 利用できるライセンスの数 
– HPA – HPAが終了するまでの日数 
– Expire – ライセンスが失効するまでの日数 
– Press for status – [Output]ウィンドウにステータスを表示します。 

* コンパイラ ライセンスを表示するにはMPLAB XC8 v1.34, MPLAB XC16 v1.25, MPLAB XC32 
v1.40のいずれかを入手する必要があります。 

コンパイラ ライセンスの詳細は以下を参照してください。 

https://www.microchip.com/mplab/compilers 
 

 
Memory 

• Usage Symbols disabled.のメッセージが出ている場合、メッセージをクリックして有効にしま

す。 
[Project Properties]ウィンドウの[Loading]カテゴリで、[Load symbols when programming or 
building for production (slows process)]にチェックを入れます。 

• メモリのタイプ(DataまたはProject)とデバイスでの利用可能容量 
• 使用済みメモリは残りのメモリ容量の目安になります。 

コンパイラはプログラム空間の使用率、コンフィグレーション ビット、ID位置、EEPROM(デ
バイスに内蔵されている場合)の詳細を記載したメモリ概要を出力します。 

これらのメモリ空間の合計は、ワードサイズで考えると[Dashboard]の[Program Used]と一致

します。メモリ容量が比較的少ないデバイスでは、マップファイルを確認する必要がありま

す。 
 

 
Debug Tool 

ハードウェア デバッグツール 
• デバッグツールの名前とシリアル番号 
• デバッグツールの接続(既定値ではツールの接続は常時アクティブです)変更するには、[Tools] 

> [Options] (macOSでは[MPLAB X IDE] > [Preferences])を選択し、[Embedded]ボタンをクリ

ックし、[Generic Settings]タブを開いて、[Maintain active connection to hardware tool]に移

動します。 
• [Refresh Debug Tool Status]ボタンをクリックすると、ハードウェア デバッグツールのファ

ームウェア バージョンと現在の電圧レベルが表示されます。 

シミュレータ 

• デバッグツールの名前(例: シミュレータ) 
• シミュレートする周辺モジュールをクリックしてサポートされている周辺モジュールを表示し

ます。 

https://www.microchip.com/mplab/compilers
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(続き) 
グループ 定義と説明 

 
 

Debug 
Resources 

ハードウェア ブレークポイント 
現在使用中のブレークポイント数とプロジェクト デバイス向けに使用可能なブレークポイン

ト数を示します。 

ソフトウェア ブレークポイント 
 プロジェクト デバイスでソフトウェア ブレークポイントがサポートされているかどうかを示

します。 
 デバッグツール アクセサリ 
 このプロジェクトで使っているデバッグツール アクセサリ (デバッグヘッダ等)の種類を示し

ます。 
 

5.19.2 [Dashboard]アイコン 
[Dashboard]ウィンドウの左側のアイコンで、下表の各種機能にアクセスできます。 

表5-8 サイドバーのアイコン 
 

アイコン 機能 
 

 
プロジェクト プロパティ: 
[Project Properties]ウィンドウを表示します。 

 

 
デバッグツールのステータス表示を更新する: 
クリックすると、ハードウェア デバッグツールの詳細を表示します。 

 

 ソフトウェア ブレークポイントをトグル(有効化/無効化)する: 
クリックするたびにソフトウェア ブレークポイント

の有効/無効が切り換わります。この機能の状態はア

イコンに表示されています。 
• 中心が赤: 無効 
• 中心が緑: 有効 
• 中心が黒: サポートしていない – 使用中のデバイスまたはツールで利用できるブレークポイント

数を超えている場合 
 

 
デバイス データシートを開く: 
Microchip社のウェブサイトからデバイスのデータシートを開きます。 

https://www.microchip.com/ 

ローカルに保存したデータシートを開くか、ブラウザを開いてMicrochip社ウェブサイトでデータシー

トを検索できます。 
 

 
コンパイラのヘルプ: 
クリックすると、コンパイラ インストール フォルダの「docs」フォルダ内の文書の主索引(利用できる

場合)が開きます。 

 
5.20 プロジェクト レジスタの表示([I/O View]) 

[I/O View]ウィンドウ([Window] > [Debugging] > [IO View])で、現在のプロジェクトのターゲット デバイスのレジス

タ概要を表示する事ができます。このウィンドウは設計時にクイック リファレンスとして機能し、プロジェクトが

デバッグモードの時はレジスタ値を表示できます。 

[I/O View]は上下ペインに分割され、上のペインには周辺モジュール、下のペインには選択した周辺モジュールのレ

ジスタが表示されます。 

• 上のペインは、名前付きの編集値を持つレジスタをコンボで表示できます(例: Configコンボ)。 
• 下のペインは、編集用のカスタムビット制御のあるレジスタワードと変更された色付きビットを表示します。

このウィンドウの詳細は12.8「[I/O View]ウィンドウ」を参照してください。 
デバッグ一時停止中の編集 

https://www.microchip.com/
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デバッグモードを一時停止すると、ウィンドウ内で値を編集できます。 

図5-34 デバッグ一時停止中の[I/O View] 

ビットをクリックすると値がトグルします。レジスタ内の各ビットは別の列に表示されます。セットされたビットは

既定値で暗い色になりますが、クリアされたビットは色がなくなります(既定値は白)。 

値フィールドをクリックし新しい値を書き込む事で、任意の値を変更できます。 

一部の値とビットは読み出し専用のため変更できません。ビットによっては書き込み専用です。詳細は各デバイスの

文書を参照してください。ビットまたは値がセットされるとデバイスから直ちに読み戻され、[I/O View]にはデバイ

スからの実際の値が表示されます。新しい値をセットしても[I/O View]が更新されない場合、そのレジスタは書き込

み専用またはアクセス不可である可能性があります。 

色の変更 

前回の表示以降にレジスタが変更された場合、値とビットは赤で表示されます。前回以降にビットがセットされた場

合、赤の塗りつぶしで表示されます。クリアされた場合、赤の枠線で表示されます。この機能はツールバーでトグル

できます。 
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図5-35 [I/O View] - 変更されたビット表示のトグル 

 
 
5.21 コードの改善 

リファクタリングおよび/またはプロファイリングを使ってコードを改善します。 

コードのリファクタリングは、コードの機能を変更せずにコードを単純化します。現在、Cコードでは以下を行えま

す。 

• 複数ファイルを通して、関数の使用箇所を検出する 
• 複数ファイルを通して、関数とパラメータの名前変更する 

詳細は7.6「Cコードのリファクタリング」を参照してください。 

コードのプロファイリングは、プログラム実行中にCPU使用率、メモリ使用率、スレッド使用率を常時監視するもの

です。プロファイリング ツールは、Cプロジェクト実行時に常時動作します。 

NetBeans IDEメニューの機能(MPLAB X IDEでは通常使わないまたは表示されない機能)は、 
[Tools] > [Plugins] > [Installed] > [MPLAB Hidden Menu Filter]を選択し、その項目を選択して[Deactivate]をクリック

すると表示できます。 
 
 
5.22 ローカルファイル履歴によるソースコードの管理 

MPLAB X IDEは、NetBeansプラットフォームの特長であるローカルファイル履歴機能を内蔵しています。この機能

は、ローカル プロジェクトおよびファイル向けの、従来のバージョン管理システムのようなバージョン管理機能で

す。これにはローカルDIFFおよびファイル復元ツールが含まれます。 

ファイルのローカル履歴を表示させるには、以下のどちらかを行います。 

• [Editor]ウィンドウで[History]ボタンをクリックする 
• [Project]または[File]ウィンドウでファイルを右クリックし、[History] > [Show History]を選択する 

そのファイルの全変更履歴が表示されます。 
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図5-36 [Editor]ウィンドウ内のローカル履歴 

表5-9 ローカル履歴のコンテクスト メニュー 
 

メニュー項目 概要 

Revert from 
History 

前のバージョンに戻します。[Revert to]ダイアログが開き、そのファイルの全変更履歴が表示

されます。いずれかのバージョンを選択し、[OK]をクリックすると、そのバージョンが復元

されます。 
Delete from 
History 

変更した項目を履歴から削除します。 
履歴から削除した項目を元に戻すには、[Project]または[File]ウィンドウでファイルを右クリッ

クし、[History] > [Revert Deleted]を選択します。 

Show only rows 
where 

[Date]列の下で右クリックして日付フィルタ(Date == またはDate < >)を選択します。 
[Message]列の下で右クリックしてメッセージ フィルタ(Message == またはMessage < 
>)を選択します。 

 
 
5.23 リビジョン管理システムによるソースコードの管理 

多数のファイルを含む複雑なアプリケーションをチームで開発する場合、ソースコードの変更管理が必要です。

MPLAB X IDEはソースファイルのバージョン管理機能を備えています。さらに、外部のリビジョン (ソースまたはバ

ージョン)管理プログラムもサポートしています。 

各種のリビジョン管理システム(RCS)をMPLAB IX DEと組み合わせて使う事ができます。一度設定すると、リビジ

ョン管理操作はコンテクスト メニューからアクセスできます。 

現在サポートしているソース/バージョン管理システムはGit、Subversion、Mercurialです。その他のシステムはプラ

グイン(例: CVS)を介してサポートできる場合があります。 

MPLAB X IDEプロジェクト用のリビジョン管理システムを使う際の注意事項は以下の通りです。 

1. 全てのプロジェクト ファイルを同プロジェクト内に保存するようにします。プロジェクト外のファイルもレ

ポジトリに含め、そのプロジェクトを検索できるようにします。 
2. MPLAB X IDEでは当該プロジェクトのファイルのみコミットします。不要なファイルを含めると、プロジェ

クトが他のマシンでコンパイルされなくなる可能性があるため、これは重要です。「プロジェクト ファイル

の保存」を参照してください。 
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3. [Merge Conflicts Resolver]ウィンドウを使ってチェックインする際の競合を解消しました。「リビジョン管理

されたファイルの競合の解消」を参照してください。 
4. 読み出し専用ファイルは、「読み出し専用ファイルを使ったプロジェクトのビルド」に従って確認します。ソ

ース/バージョン管理の設定方法 

1. [Team]メニューからバージョン管理プログラムのサブメニューを選択し、そのバージョン管理プログラムを設

定します(下図参照)。 
2. [Tools] > [Options] (macOSでは[MPLAB X IDE] > [Preferences])を選択して、[Team]を選択し、[Versioning]タ

ブでバージョン管理オプションを設定します。 
3. [Window] > [Versioning]を選択して[Version Control]ウィンドウを開きます。 

図5-37 バージョン管理のオプション 

Gitの使い方 

Gitの詳細は以下のリンクをご覧ください。 

• Gitウェブサイト: http://git-scm.com 
• Wikipedia: Git: https://en.wikipedia.org/wiki/Git 
• Gitチュートリアル: https://git-scm.com/docs/gittutorial 
• NetBeans IDEでのGitサポートの使用: https://netbeans.org/kb/docs/ide/git.html 

Subversionの使い方 

Subversionの詳細は以下のリンクをご覧ください。 

• Apache™ Subversion®ウェブサイト: http://subversion.apache.org/ 
• Wikipedia: Apache™ Subversion®: http://en.wikipedia.org/wiki/Apache_Subversion 
• Subversion®によるバージョン管理: http://svnbook.red-bean.com/ 

http://git-scm.com/
https://en.wikipedia.org/wiki/Git
https://git-scm.com/docs/gittutorial
https://netbeans.org/kb/docs/ide/git.html
http://subversion.apache.org/
http://en.wikipedia.org/wiki/Apache_Subversion
http://svnbook.red-bean.com/
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• NetBeans IDEでのSubversionサポートの使用: https://netbeans.org/kb/docs/ide/subversion.html 

Mercurialの使い方 

Mercurialの詳細は以下のリンクをご覧ください。 

• Mercurialウェブサイト: http://mercurial.selenic.com/ 
• Wikipedia: Mercurial: http://en.wikipedia.org/wiki/Mercurial 
• Hginit: Mercurial tutorial: http://hginit.com/ 
• NetBeans IDEでのMercurialサポートの使用: https://netbeans.org/kb/docs/ide/mercurial.html 

CVSの使い方 

MPALB X IDEでCVSを使うには、CVSプラグインをインストールする必要があります。5.26「プラグインツールの

追加」を参照してください。 
• CVS - Concurrent Versions System: http://www.nongnu.org/cvs/ 
• Wikipedia: Concurrent Versions System: http://en.wikipedia.org/wiki/Concurrent_Versions_System 
• Source Forge: What is CVS?: http://sourceforge.net/apps/trac/sourceforge/wiki/CVS 
• NetBeans IDEでのCVSサポートの使用: https://netbeans.org/kb/docs/ide/cvs.html 

その他のリビジョン管理システムの使い方 

その他のリビジョン管理システムはプラグインとして追加できます。5.26「プラグインツールの追加」を参照してく

ださい。 
 

5.23.1 プロジェクト ファイルの保存 
リポジトリに保存する必要があるプロジェクト ファイル 

下表に、プロジェクト ファイルをバージョン管理リポジトリにコミットする必要があるかどうかを示します。 

表5-10 リポジトリに保存するプロジェクト ファイル 
 

フォルダまたはファイル コミットの要否 

プロジェクト フォルダ 

Makefile 
 

 

ソースファイル 
 

 

buildフォルダ 
 

 

distフォルダ 
 

 

nbprojectフォルダ 

configurations.xml 
 

 

project.properties 
 

 

project.xml 
 

 

Makefile-* 
 

 

Package-* 
 

 

privateフォルダ 
 

 

https://netbeans.org/kb/docs/ide/subversion.html
http://mercurial.selenic.com/
http://en.wikipedia.org/wiki/Mercurial
http://hginit.com/
https://netbeans.org/kb/docs/ide/mercurial.html
http://www.nongnu.org/cvs/
http://en.wikipedia.org/wiki/Concurrent_Versions_System
http://sourceforge.net/apps/trac/sourceforge/wiki/CVS
https://netbeans.org/kb/docs/ide/cvs.html
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(続き) 
フォルダまたはファイル コミットの要否 

緑のチェック: プロジェクトのイメージを生成する必要があります。 
赤のX印: これらのフォルダ/ファイルは再生成されるため保存する必要はありません。 

 

プロジェクトの構成の詳細は「[Files]ウィンドウの表示」を参照してください。 
 

5.23.2 リビジョン管理されたファイルの競合の解消 
チェックインしようとするファイルと、リビジョン システムのリポジトリ内の他の人が変更した同じファイルとの

間に競合が発生する場合があります。 

これらの問題の解消方法は以下の例を参照してください。 

例: configurations.xmlの競合 

configurations.xmlファイルの競合の解消方法 

1. 競合は以下によって通知されます。 
1.1. 警告ダイアログ 
1.2. [Output]ウィンドウ 

2. [Projects]ウィンドウの[Files]タブをクリックし、nbprojectフォルダを展開します。 
configurations.xmlという名前のファイルを見つけます(競合を示す赤いフォントで表示)。 

3. configurations.xmlファイルを右クリックして[RCS] > [Resolve Conflicts]を選択します(RCSは使用中の

リビジョン管理システムの名前)。これにより[Merge Conflicts Resolver]ウィンドウが開きます。 
4. [Merge Conflicts Resolver]ウィンドウを使って競合を解消します。 
5. エラーが解決したらプロジェクトを閉じます。右クリックのコンテクスト メニューが動作しない場合、[File] 

> [Close Project]を使ってプロジェクトを閉じます。 
6. 再度プロジェクトを開きます。競合は解消済みのはずです。 

 
5.23.3 読み出し専用ファイルを使ったプロジェクトのビルド 

ファイルがリポジトリにチェックイン済みであり、一部のファイルが読み出し専用のプロジェクトをビルドするには

以下の手順で行います。 

1. 最小限のファイルをソース管理にコミットします(5.23.1「プロジェクト ファイルの保存」参照)。 
2. ファイルnbproject/configurations.xmlとnbproject/project.xmlを書き込み可能にします。 

 
5.24 コード開発とエラー追跡の連携 

MPLAB X IDEは、チームサーバによるグループ間で連携したコード開発をサポートします。[Team]メニューを使う

と、アカウントへのログイン、プロジェクトの作成またはロード、プロジェクトの共有、リソースの取得、チャット 
メッセージの送信、コンタクトリストの表示が可能です。問題追跡システムを使うとバグ追跡で連携できます。 

サポートするメニュー項目は以下の通りです。 

• [Window] > [Services] – [Services]ウィンドウは実行時リソースへのメイン エントリポイントです。IDEに登録

されているサーバ、データベース、Webサービス等の重要な実行時リソースの論理ビューを表示します。詳細

は[Help] > [Help Contents]で[Services]ウィンドウを検索してください。 
• [Team] > [Find Task] – [Find Tasks]ウィンドウ内で、プロジェクト タスクと評価基準を選択し、[Search]をク

リックします。 
• [Team] > [Report Task] – [Report a New Task]ウィンドウ内で新しいプロジェクト タスクを選択し、問題の詳細

を記述し、[Submit]をクリックします。 

チーム プロジェクトと問題追跡の詳細は以下のNetBeansヘルプトピックを参照してください。
https://netbeans.org/kb/docs/ide/team-servers.html 
これらツールの詳細は以下を参照してください。 

• Git – http://git-scm.com 
• Mercurial – http://mercurial.selenic.com/ 
• Subversion – http://subversion.apache.org/ 

https://netbeans.org/kb/docs/ide/team-servers.html
http://git-scm.com/
http://mercurial.selenic.com/
http://subversion.apache.org/
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5.25 MPLAB XCコンパイラのFreeライセンスとPROライセンスの比較 
Microchip社ウェブサイトからMPLAB XC Cコンパイラをダウンロードすると、コンパイラはPROライセンスとし

て60日間実行され、その後Freeライセンスになります。最適化機能を継続して使う場合はPROライセンスを購入

できます。 

図5-38 各ライセンスの最適化レベル 

PROライセンスを購入すべきかどうか判断するには、MPLAB X IDEでアプリケーションの比較ツールを実行します。

ビルドアイコンのオプション プルダウン メニューから[Build with PRO comparison]または[Clean and Build with PRO 
comparison]を選択します。以下に出力例を示します。 

Note:  コードが大き過ぎてFreeモードでビルドできない場合、この比較は機能しません。しかし、MPLAB XC8コン

パイラの場合は--MAXIPICオプションを使って試行できます。 

これらのオプションは選択された最適化レベルでプロジェクトをビルドしますが、機能しないPROビルドも作成して

2つの結果を比較します。元のビルドは出力データとして表示されます。PROビルド部分は削除されます。 

図5-39 PROの比較 

 
 
5.26 プラグインツールの追加 

DMCI等MPLAB X IDEのプラグインツールは、IDEのプラグイン マネージャまたはEmbedded Code Sourceウェブサ

イトから追加できます。 

インストールしたプラグインの表示 
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MPLAB X IDEには多数のプラグインがインストールされています。灰色表示でない項目は無効にするまたはアンイ

ンストールする事ができますが、[Category]に(Optional)と表示されていない場合は推奨しません。 

インストールされているプラグインを表示するには、[Tools] > [Plugins]を選択し、[Installed]タブをクリックします。 

図5-40 インストールされているMicrochip社製プラグインツール 

プラグイン マネージャからのプラグインの追加 

利用可能なプラグインを表示およびインストールする方法 

1. MPLAB X IDEで[Tools] > [Plugins]を選択し、[Available Plugins]タブをクリックします。 
2. チェックボックスにチェックを入れてプラグインを選択し、[Install]をクリックします(下図参照)。 
3. 画面の指示に従って、プラグインをダウンロードおよびインストールします。 

Note:  プラグインによっては、インストールされる機能が他のプラグイン内のモジュールに依存するものが

あります。そのような場合、プラグイン マネージャは警告を表示します。 
4. インストール後、プラグインは[Installed]タブに表示されます。このプラグインに対して無効にする、再度有

効にする、アンインストールする、のいずれかの操作を実行できます。 
5. [Tools] > [Embedded]を選択して、追加したツールを確認します。追加したツールが表示されない場合、

MPLAB X IDEを一度終了してから再起動すると表示される場合があります。 

[Help]ボタンをクリックすると、プラグインのインストールに関するヘルプを表示できます。 
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図5-41 利用可能なMIicrochip社製プラグインツール 

組み込みコード集からのプラグインの追加 

利用可能なプラグインを表示、ダウンロード、インストールする方法 

1. 以下のEmbedded Code Sourceウェブサイトを開きます。

http://www.embeddedcodesource.com/codedeveloper/microchip-technology 
2. プラグインを選択し、ウェブページの指示に従ってローカルフォルダにダウンロードします。 
3. ダウンロードしたZIPファイルを解凍して.nbmファイルを取り出します。 
4. MPLAB X IDEで[Tools] > [Plugins]を選択し、[Downloaded]タブをクリックします。 
5. [Add Plugins]をクリックします。.nbmファイルを検索、選択して開きます。 

http://www.embeddedcodesource.com/codedeveloper/microchip-technology
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図5-42 ダウンロード済みMicrochip社製プラグインツール 

6. プラグイン名の隣のチェックボックスがチェックされている事を確認し、[Install]をクリックしてプラグイン

をインストールします。 
図5-43 ダウンロード済みMicrochip社製プラグインツールのインストール 

7. 画面の指示に従って、プラグインをダウンロードおよびインストールします。 
Note:  プラグインによっては、インストールされる機能が他のプラグイン内のモジュールに依存するものが

あります。そのような場合、プラグイン マネージャは警告を表示します。 
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8. インストール後、プラグインは[Installed]タブに表示されるます。このプラグインに対して無効にする、再度

有効にする、アンインストールする、のいずれかの操作を実行できます。 
9. [Tools] > [Embedded]を選択して、追加したツールを確認します。追加したツールが表示されない場合、

MPLAB X IDEを一度終了してから再起動すると表示される場合があります。 

プラグインの更新 

使用中のプラグインに更新版が存在するかどうかを判断する方法 

1. MPLAB X IDEで[Tools] > [Plugins]を選択し、[Updates]タブをクリックします。 
2. [Check for Updates]をクリックします。 
3. 更新版が表示される場合、プラグイン名がチェックされている事を確認し、[Update]をクリックします。 
4. 画面の指示に従って、プラグインを更新します。 

MPLAB X IDEの新バージョンをインストールしても、インストール済みのプラグインは更新されません。プラグイ

ンは、そのリリースに付けられたバージョンのインターフェイスでテストされています。全てのプラグインがバー

ジョン間で移行可能とは限らず、そのまま流用される事はありません。これはNetBeansに対してもあてはまります。

従って、新しいバージョンのMPLAB X IDEをインストールした場合、プラグインの再インストールが必要な場合が

あります。 

更新センターの設定 

[Plugins]ウィンドウに利用可能なプラグインを表示させるには、更新センターを設定する必要があります。MPLAB 
X IDEには2つのMicrochip更新センターがあらかじめ設定されています。 

• lhttp://ww1.microchip.com/downloads/mplab/X/plugins/updates.xml 
• http://ww1.microchip.com/downloads/mplab/X/thirdpartyplugins/updates.xml  

プラグイン マネージャで別の更新センターを設定する方法 

1. [Tools] > [Plugins]を選択し、[Settings]タブをクリックします。 
2. [Add]ボタンをクリックして、[Update Center Customizer]ダイアログを開きます。 
3. 更新センターの名前を入力します。 
4. 更新センターのURLを入力します。 
5. [OK]をクリックします。 

図5-44 Microchip更新センターの設定 

http://ww1.microchip.com/downloads/mplab/X/plugins/updates.xml
http://ww1.microchip.com/downloads/mplab/X/thirdpartyplugins/updates.xml
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インストール済みプラグインの設定 

MPLAB X IDEにプラグインをインストールすると、設定が必要な場合があります。プラグイン設定オプションは、

[Tools] > [Options]の[Plugins]に表示されます。「[Tools Options]ウィンドウ、[Plugins]」を参照してください。 

プラグインコードの保存場所 

プラグインコードはMPLAB X IDEのユーザ コンフィグレーション データと一緒に保存されています。8.7「ユーザ 
コンフィグレーション データの表示」を参照してください。 
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default_options="-J-Dnb.FileChooser.useShellFolders=false -J-Dcrownking.stream.verbosity=very- 
quiet -J-Xms256m -J-Xmx512m -J-XX:PermSize=128m -J-XX:MaxPermSize=384m -J-XX: 
+UseConcMarkSweepGC -J-XX:+CMSClassUnloadingEnabled" 

 
 

 

6. 高度な作業とコンセプト 
本章ではより高度な作業の方法と便利なコンセプトを説明します。 

表6-1 高度な作業とコンセプトの内容 
 

 

 
高速化 

1. MPLAB X IDEの高速化(IDEの動作が遅い場合) 
2. ビルド時間の短縮(MPLAB X IDEで並列makeを使う) 

 

 

 
プロジェクト

関連作業 

1. 複数プロジェクトの使い方(複雑なアプリケーション開発時) 
2. 複数コンフィグレーションの使い方(同じプロジェクトコードで複数プロジェクト プロ

パティを選択可能にする) 
3. デュアルコア プロジェクトの作成(dsPIC33CHデュアルコア デバイスを使う場合) 
4. ユーザMakefileプロジェクトの作成(MPLAB X IDEで外部makefilesを使う場合) 
5. ソースファイル フォルダにリンクしたリソースの使用(プロジェクト ソースベースまた

はライブラリ バージョンの変更(MPLAB Harmony)) 
6. サードパーティ製ツールの使い方(MPLAB X IDEプロジェクト内) 
7. コードカバレッジの使用(実行されたコードの割合をテスト) 
8. ログデータ(実行とデバッグの問題を記録する) 
9. MPLAB X IDEプロジェクトのパッケージ化(プロジェクト内のファイルを圧縮) 
10. ターゲットとのハードウェア ツールの接続により、デバッグ機能が決まる場合がありま

す。「ハードウェア ツールの接続とデバッグ」を参照してください。 
 

 

 
コンセプト 

1. チェックサムの定義 
2. コンフィグレーションの種類 

 
 
6.1 MPLAB X IDEの高速化 

MPLAB X IDEの動作が遅い場合、以下を検討します。 

PCヒープの増加 

mplab_ide.confファイルを編集すると、MPLAB X IDEに割り当てられているメモリ容量を変更できます。このファ

イルは編集前にバックアップしておく事を推奨します。このファイルを編集すると、変更内容はMPLAB X IDEを次

回起動した時に有効になります。 

• Windows 64ビット - C:\Program Files (x86)\Microchip\MPLABX\vx.xx\mplab_platform\etc 
• Windows 32ビット - C:\Program Files\Microchip\MPLABX\vx.xx\mplab_platform\etc 
• Linux - /opt/microchip/mplabx/vx.xx/mplab_platform/etc 
• macOS - /Applications/microchip/mplabx/vx.xx/Contents/Resources/mplab_platform/etc 

vx.xxはMPLAB X IDEのバージョン番号です。

以下の行は既定値を収めています。 

太字の部分は以下の通りです。 

-Xms256m: JVMが256 MB以上のヒープを割り当てる事を意味します。 

-Xmx512m: JVMが512 MB以下のヒープを割り当てる事を意味します。 
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-XX:PermSize=128m: JVMが、ヒープに収まらないデータの追加に必要な空間として128 MBを割り当てる事を意

味します。 

-XX:MaxPermSize=384m: JVMが、ヒープに収まらないデータの追加に必要な空間として384 MB未満を割り当てる

事を意味します。 

以下のエラーが発生しない限り、PermSizeまたはMaxPermSizeを変更する必要はありません。 
java.lang.OutOfMemoryError: PermGen space. 

最も重要な部分は-Xmx512mです。この値はMPLAB X IDEが使うヒープ量の最大値を指定しています。一見、大きな

ヒープ量を設定した方が良いように見えるかもしれません。しかし、MPLAB X IDEにメモリを使う事は他のアプリ

ケーションとシステム機能に使うメモリが少なくなる事を意味しています。 

メモリモニタを有効にすると、IDEが使うメモリの量を監視できます。ツールバー領域の空いた所を右クリックして

[Memory]を選択します。または、[View] > [Toolbars] > [Memory]を選択します。 

mplab_ide.confの値を変えない限り、上限値は512 MBです。-Xmx512mの設定は128 MB刻みで変更する事を推

奨します。大容量のメモリを使える場合、128 MBを超える刻みで増やす事もできます。しかし、システムの他の部

分のために十分なメモリが残っている事を確認してください。 

[Change Debug]ウィンドウの使用 

デバッグツールを使うとMPLAB X IDEが遅くなる場合、以下を試します。 

• 必要なウィンドウのみを表示させます。MPLAB X IDEデバッガは、デバッグツールの使用中、開いているウィ

ンドウを全て監視するためです。 
• デバッグのステップ実行中の[Stack]ウィンドウの更新頻度を低くします。[Tools] > [Options] (macOSでは

[MPLAB X IDE] > [Preferences])ウィンドウの[Embedded]ボタンをクリックし、[Generic Settings]タブの

[Disable auto refresh for call stack view during debug sessions] と [On mouse over structure and array 
expressions, evaluate integral members only]にチェックを入れます。 

 
6.2 ビルド時間の短縮 

PCによっては、並列make(12.16.2「[Project Options]タブ参照)を使ってプロジェクトのビルド時間を短縮できる場

合があります。並列makeをサポートしていない言語ツールもあります。 

オペレーティング システム(OS)の変更を検討する方法もあります。OSによっては、より高速にファイルをアクセス

できます。MPLAB X IDEはWindows, Linux, Mac OSをサポートしているため、その中でどれが適しているかを検討

します。 
 
6.3 複数プロジェクトの使い方 

MPLAB X IDEでは、複数のプロジェクトを使って作業できます。 

MPLAB X IDEで複数のプロジェクトを開いて[Projects]ウィンドウに表示できます。このウィンドウの詳細は本

書の12.15「[Projects]ウィンドウ」を参照してください。 

図6-1 [Projects]ウィンドウに表示した複数のプロジェクト 
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複数プロジェクトを開く 

MPLAB X IDEではプロジェクトを新規作成する([File] > [New Project])または複数のプロジェクトを開く([File] > 
[Open Project])事ができます。または、以下のようにショートカットで--openディレクティブを使えます。 

 
次に、複数のショートカットを作成して、様々な場所から複数のプロジェクトを開く事ができます。 

プロジェクト タイプの定義 

以下で説明するように、各プロジェクトはアクティブ(または開発のフォーカス)にする事ができます。ただし、メイ

ンプロジェクトは常に1つだけです。 

メイン プロジェクト 

プロジェクト名を右クリックして[Set as Main Project]を選択すると、プロジェクトをメイン プロジェクトとして選

択できます。メイン プロジェクトの名前は太字で表示されます。この場合、全てのツールバー機能が1つのメイン 
プロジェクトで実行されます。 

アクティブなプロジェクト 
メイン プロジェクトを設定せずに作業する事もできます。アクティブなプロジェクトとは、メイン プロジェクトが

ない時にフォーカスされるプロジェクトです。 

[Projects]ウィンドウ内でいずれかのプロジェクトをクリックすると、そのプロジェクトがアクティブになります。

その場合IDEは、作業中のプロジェクトをコンテクストで判断します。すなわち、あるファイルにフォーカスするよ

うにエディタを設定すると、そのファイルを含むプロジェクトがアクティブ プロジェクトになります。アクティブ 
プロジェクトは、全ての操作([Debug Project]アイコンのクリック等)を受けます。 

プロジェクト コードの開発 

プロジェクトのコードの開発とデバッグの方法 

1. [Projects]ウィンドウ内のプロジェクトをクリックして[Debug] > [Debug Project]を選択し、プロジェクトのデ

バッグを開始します。 
2. 複数のデバッグ セッションを同時に実行する場合、[Sessions]ウィンドウを開くと([Window] > [Debugging] > 

[Sessions])現在実行中のデバッグ セッション間で切り換える事ができます。 

デバッグ セッションを切り換えると[Watches]ウィンドウ、変数、メモリ表示が現在選択しているデバッグ中のプロ

ジェクトのものに切り換わります。ステータスビットも現在のプロジェクトのものに切り換わります。ダッシュボ

ードは、デバッグ プロジェクトまたは[Project]ウィンドウ内のプロジェクトのいずれであれ、最後に選択したプロ

ジェクトの内容を表示します。これは設計仕様に基づいた動作です。 

[Tools] > [Options] (macOSでは[MPLAB X IDE] > [Preferences])、[Embedded]ボタン、[Generic Settings]タブでオ

プション[Maintain active connection to hardware tool]を選択しておくと、セッション/プロジェクト切り換え時に再

接続が行われます。これは設計仕様に基づいた動作です。 

複数プロジェクトのグループ化 

複数プロジェクトを使うもう1つの方法はグループ化です。[File] > [Project Group]を選択し、[Create New Group]ダ
イアログ ボックスでプロジェクト グループを選択するか新規に作成します。 

 
6.4 複数コンフィグレーションの使い方 

MPLAB X IDEでは、同一プロジェクトで複数のビルド コンフィグレーションを使えます。これは、複数のプラット

フォームでコンパイル可能なコード(Microchip社のアプリケーション ライブラリ デモプロジェクト等)にとって便利

です。 

新規プロジェクトを作成すると、「default」という名前のコンフィグレーションが作成されます。追加コンフィグ

レーションは、以下のセクションの手順に従って作成します。 
 

6.4.1 [Manage Configurations]ダイアログ 
ユーザ コンフィグレーションの作成は、以下のどちらかの手順で始めます。 

"C:\Program Files 
(x86)\Microchip\MPLABX\v3.15\mplab_platform\bin\ mplab_ide.exe" --
open "C:\MPLAB_X_Projects\MyProject1" 
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• ツールバーのドロップダウン メニューから[Customize]を選択して、[Project Properties]ウィンドウを開く 

• プロジェクト名を右クリックして[Properties]を選択し、[Project Properties]ダイアログを開く 

[Project Properties]ウィンドウで[Manage Configurations]をクリックして、[Configurations]ダイアログを開きます。

このウィンドウでは、既存コンフィグレーションの名前を変更するか、新規コンフィグレーションを追加するか、既

存コンフィグレーションを複製できます。名前にスペースがある場合は全てアンダースコアに置き換えられます。 

1つのプロジェクトに対して複数のコンフィグレーションを作成した場合、[Manage Configurations]ボタンまたは

ドロップダウン メニューを使って、いずれか1つのコンフィグレーションをアクティブにします。 

図6-2 [Project Properties] – [Configurations]ダイアログ 

 
6.4.2 新規コンフィグレーションの追加 

プロジェクトに新規コンフィグレーションを追加する方法 

1. [Project Properties]ウィンドウで[Manage Configurations]をクリックします。 
2. [Configurations]ダイアログで、プロジェクト コンフィグレーションを選択して[New]をクリックします。 
3. [New Configuration Name]ダイアログに名前を入力します(例: 「My Test」(下図参照)。[OK]をクリックしてダ

イアログを閉じます。名前にスペースは使えないため、[Configurations]ではこの名前は「My_Test」に変更さ

れます。 
4. [OK]をクリックして[Project Properties]ウィンドウに戻ります。以上で、「Debug」コンフィグレーション

(Conf: My_Test)が表示されるはずです。 
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図6-3 新規コンフィグレーションの作成 

新規コンフィグレーションを追加した場合、複数の項目を[Project Properties]ウィンドウで割り当てる必要がありま

す(下図参照)。 

1. デバイス – ハードウェア ツールとコンパイラのサポートを確認するため、これを最初に選択する必要があり

ます。 
2. ハードウェア ツール 
3. コンパイラ ツールチェーン 



MPLAB X IDEユーザガイド 
高度な作業とコンセプト 

ユーザガイド DS-50002027E_JP - p. 149 © 2019 Microchip Technology 
 

 

 

 
 

図6-4 新規コンフィグレーション 

 
6.4.3 複製したコンフィグレーションの追加 

既存コンフィグレーションの複製を追加し、これを編集して使う事ができます。 

複製コンフィグレーションを作成する理由の1つは、デバッグ用コンフィグレーションを作成するためです。MPLAB 
X IDEはMicrochip社製ツールと組み合わせて使うデバッグ用マクロ(4.13「コードのデバッグ」の[Debug Macros 
Generated]参照)を提供しています。しかし、専用のコンフィグレーションを作成する事で、ユーザ独自のデバッグ

用マクロを使えるようになります。またはサードパーティのツールで同じデバッグ機能を使えるようになります。 

デバッグ コンフィグレーションの設定方法 

1. [Project Properties]ウィンドウで[Manage Configurations]をクリックします。 
2. [Configuration]ダイアログで、プロジェクト コンフィグレーションを選択して[Duplicate]をクリックします。 
3. [Rename]をクリックし、[New Configuration Name]ダイアログで名前(例: 「My Debug」)を入力します(下図

参照)。[OK]をクリックしてダイアログを閉じます。名前にスペースは使えないため、[Configurations]ではこ

の名前は[My_Debug]に変更されます。 
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図6-5 デバッグ コンフィグレーションの作成 

4. [OK]をクリックして[Project Properties]ウィンドウに戻ります。以上で、デバッグ コンフィグレーション

(Conf: My_Debug)が表示されるはずです(下図参照)。 
図6-6 デバッグ コンフィグレーション 

デバッグと同様に、コード内のマクロを使って他のコンフィグレーションに切り換えるには、6.4.6「コンフィグレ

ーション マクロ」を参照してください。 
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6.4.4 コンフィグレーション内のファイル管理 
プロジェクト ファイルは、作成したコンフィグレーションに個別に、またはグループとして割り当てる事で管理で

きます。 

[Projects]ウィンドウ 

ツールバーの[Set Project Configuration]ドロップダウン ボックスからコンフィグレーションを選択します。次に、1
つまたは複数のファイルを選択して(<Shift>+クリックまたは<Ctrl>+クリック)右クリックすると、コンテクスト メ
ニューが表示されます。[Exclude file(s) from current configuration]を選択します。1つまたは複数のファイルを再び

含めるには、コンテクスト メニューの[Include file(s) from current configuration]を選択します。 

[Project Properties]ウィンドウ 

多くのファイルに適用するコンフィグレーションを設定する場合、[Projects]ウィンドウでプロジェクト名を右クリ

ックして[Project Properties]ウィンドウを開きます。[File Inclusion/Exclusion]カテゴリを選択します。

[Configurations]ドロップダウンボックスからコンフィグレーションを選択し、このコンフィグレーションに含める

または除外するファイルを指定します。 

図6-7 [Project Properties] – [Configurations] 

 
6.4.5 コンフィグレーション名 

一部の特殊文字はコンフィグレーション名に使えません。これは、ソースコード内のコンフィグレーション名を定義

マクロ（「コンフィグレーション マクロ」）として使うためです。 

ハイフン(-)、アンパサンド(&)等の特殊文字は自動的にアンダースコア(_)に置換されます。 
 

6.4.6 コンフィグレーション マクロ 
新規または複製コンフィグレーションを追加する場合、独自のコンフィグレーション関連マクロを作成するか、コー

ド内の#ifdef文または他の文の自動生成マクロを使えます。これらはMPLAB XC Cコンパイラのプリプロセッサ マク

ロです。 

ユーザ定義マクロ 

独自のプリプロセッサ マクロの定義方法 
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// If My_Debug configuration is active 
#ifdef DebugConfig 
fprintf(stderr,"This is a debugging message\n"); 
#endif 

int main(int argc, char** argv) 
{ 
printf(CFG_NAME); 
return{EXIT_SUCCESS}; 
} 

 
 

1. [Project Properties]ウィンドウで、プロジェクト コンフィグレーションをクリックしてアクティブにします。

そのコンフィグレーションの下で、ツールチェーン内のコンパイラをクリックします。 
2. [Preprocessing and messages]オプション カテゴリで、マクロを定義できるオプションを選択し、関連するテ

キストボックスをクリックします。 
3. ポップアップ ダイアログでマクロ名を入力し、[OK]をクリックします。以上で、このマクロはアクティブ コ

ンフィグレーションに関連付けられました。 
マクロには、コンフィグレーションと同じ名前 (例 : 6.4.3「複製コンフィグレーションの追加」の

「My_Debug」)か、任意の名前(例: 「DebugConfig」)を付ける事ができます。 

マクロ名(および以下で説明する文字列)は大文字と小文字を区別します。 

以上で、プロセッサマクロは以下のコンディショナル テキスト内で使えるようになりました。 
 

さらに、コンフィグレーション名と一致する文字列値をマクロに割り当てると、通常のコードで使えます。 

 
CFG_NAMEマクロは常にアクティブ コンフィグレーションの名前を保持します。 
自動生成マクロ 
新規または複製コンフィグレーションを作成すると(例: My_Test)、関連するマクロ(例: XPRJ_My_Test)も作成され

ます。マクロには、コンフィグレーション名(「My_Test」)と一致する文字列値が含まれます。 

前のセクションのように#ifdef文用のマクロか、以下のようにコンパイル時にマクロの値を使う事ができます。 

CFG_NAMEマクロは自動的にアクティブ コンフィグレーションの名前を保持します。 
 
 
6.5 デュアルコア プロジェクトの作成 

デュアルコア デバイス(例: dsPIC33CH DSC)には独立した動作が可能なマスタコアとスレーブコアがあり、アプリ

ケーション開発時はプログラミングとデバッグを別々に行えます。両方のプロセッサ (マスタとスレーブ) サブシス

テムにはそれぞれ専用の割り込みコントローラ、クロック ジェネレータ、ICD、ポートロジック、I/O MUX、PPSを
備えています。デュアルコア デバイスはシングルダイ上に別々の2つのdsPIC® DSCがあるのと同じです。 

デュアルコア デバイスには、プロジェクトの様々な作成および使用方法に対応するいくつかの動作モードがありま

す。 

マスタのみのプログラミングとデバッグ 

#ifdef DebugConfig 
#define CFG_NAME “My_Debug”; 
// other defines 
#endif 
#ifdef DefaultConfig 
#define CFG_NAME “My_Default”; 
// other defines 
#endif 
: 
int main(int argc, char** argv) 
{ 
printf(CFG_NAME); 
return{EXIT_SUCCESS}; 
} 
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// FS1ICD 
#pragma config S1ICS = PGD2 // ICD Communication Channel Select bits 

// (Communicate on PGEC2 and PGED2) 
#pragma config S1DEBUG = ON // Background Debug (Enabled) 
: 

 
 

デュアルコア デバイスは、既定値ではマスタのみのモードです。MSI(マスタスレーブ インターフェイス)では、

MSI1マスタ制御レジスタ(MSI1CON)のスレーブ イネーブルビット(SLVEN)が「0」にセットされています。 

このデバイスモード用のプロジェクトは、他のMicrochip社製デバイスのプロジェクトと同じです。詳細は「新規プ

ロジェクトの作成」を参照してください。 

スレーブのみのプログラミング 

スレーブ プロジェクトを独立して動作させる場合、スレーブ用のポートを割り当てる必要があります。従って、コ

ンフィグレーション ビットの設定(スレーブに割り当てるポート等)でマスタをプログラミングするマスタ プロジェ

クト(例: MasterStub)が必要です。詳細は「[Configuration Bits]ウィンドウでのコンフィグレーション ビットの設定」

を参照してください。 

図6-8 マスタ コンフィグレーション ビット 

スレーブのみのプログラミング モードには2つのプロジェクトが必要です。 

1. 「Create a New Project」に従ってMasterStubを作成し、スレーブを有効にします(SLVEN = 「1」)。コンフ

ィグレーション ビットは前述のようにセットします。 
2. 「Create a New Project」に従ってSlaveOnlyプロジェクトを作成します。ただし、デバイスは「S1」バージ

ョンを使います(例 dsPIC33CH128MP508S1)。 

最初にMasterStubをプログラミングし、次にSlaveOnlyをプログラミングします。 

スレーブのみのデバッグ 

前のセクションで作成したSlaveOnlyプロジェクトをデバッグするには、コンフィグレーションの設定でバックグラウ

ンド デバッグ(S1DEBUG)を有効にします。 

マスタおよびスレーブのプログラミングとデバッグ 

このモードでは、マスタ プロジェクトがスレーブ プロジェクトにリンクされます。つまり、スレーブコードはマス

タ内に存在し、マスタはこのコードをスレーブに転送する必要があります。 

1. 「スレーブのみのプログラミング」で説明した通り、マスタおよびスレーブ プロジェクトを作成します。 
2. [Projects]ウィンドウで、マスタ プロジェクトに「Slaves」という名前のフォルダがあります。このフォルダ

を右クリックして[Add Slave Project]をクリックします。次に、ダイアログでスレーブ プロジェクトを選択し

て[Add]をクリックします。 
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図6-9 [Add Slave Project]ダイアログ 

3. マスタ プロジェクトを右クリックして[Properties]を選択し、[Project Properties]ウィンドウを開きます。

[Slaves]カテゴリをクリックし、[Build]チェックボックスにチェックを入れます。[Apply]をクリックします。 
図6-10 マスタおよびスレーブ プロジェクト 
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#include "Slav.h" 
//The function to transfer the code from slave to master and start the slave is below. 
_program_slave(1,0,Slav); 
_start_slave(); 

 
 

4. マスタコードに以下を追加します。 

5. マスタをビルドしてプログラミングする事により、マスタおよびスレーブのプロジェクトがビルドされ、マス

タおよびスレーブのコアがプログラミングされます。 
 
6.6 ユーザMakefileプロジェクトの作成 

外部makefileを使うプロジェクトを作成します。これは、プロジェクトがMPLAB X IDEの外にビルドされているが、

MPLAB X IDEを使ってデバッグを実行する場合に便利です。 

makefileプロジェクトを作成するには、[New Project]ウィザードを使います。 
 

6.6.1 [New Project] - ユーザMakefile 
[New Project]ウィザードを開く方法については4.1.2「[New Project]ウィザードの起動」を参照してください。 
[New Project]ウィザードが起動し、プロジェクトの新規作成を支援します。 
Step 1. Choose Project: [Microchip Embedded]カテゴリを選択し、プロジェクト タイプ[User Makefile Project]から

プロジェクトを選択します。 

Step 2. Select Device: プロジェクトで使うデバイスを[Device]ドロップダウン リストから選択します。選択肢を絞

り込むために、最初にデバイスファミリを選択します。 

Step 3. Select Header: このステップは、選択したデバイスでヘッダが利用可能である場合に表示されます。デバッ

グ用にヘッダが必要かどうか、デバイスがデバッグ回路を内蔵しているかどうかは、以下のどちらかの文書で確認し

ます。確認後にヘッダを使うかどうかを選択します。 
• 『Processor Extension Pak and Debug Header Specification』 
• 『エミュレーション拡張パック(EEP)およびエミュレーション ヘッダ ユーザガイド』 

Step 4. Select Tool: アプリケーション開発に使うツールをリストから選択します。 
選択したデバイスに対するツールのサポートレベルが、ツール名の横のマークで色分け表示されます。緑は完全サポ

ート、黄はベータサポート、赤は未サポートを意味します。 

Step 5. プラグインボードの選択: このステップは、選択したデバイスでプラグインボードが利用可能である場合に

表示されます。[Supported Plugin Board]のドロップダウン リストで利用可能なプラグインボードを調べます。 

Step 6. Select Project Name and Folder: 新規プロジェクトの名前と保存場所を選択します。表1を参照してくださ

い。 

Step 7. Create User Makefile Project: データを入力してmakefileプロジェクトを設定します(表2参照)。このウィン

ドウでの一般的なデータ入力の方法は以下の通りです。 
• パスにはスラッシュ「/」を推奨します。代わりにバックスラッシュ「\」も使えますが、エスケープする必要が

あるかもしれません「\\」。 
• パスとファイル名にスペースを使わない事を推奨します。しかし、このウィンドウでパスおよびファイル名を

入力する際にどうしてもスペースを使わなくてはいけない場合、エスケープ スペース (スペースの前にバックス

ラッシュ)を使います。スペースはGNU Makeにおける区切り文字であるため、スペースを使うと問題が生じる

事が分かっています。 

Step 8. Finish: 作成したプロジェクトが[Projects]ウィンドウ内に表示されます。 

プロジェクト作成後、[Project Properties]ウィンドウの[Makefile]カテゴリでMakefileプロジェクトの設定を変更しま

す。プロジェクトをHEXファイルとしてエクスポートする方法は12.15「[Projects]ウィンドウ – [Project]メニュー」

を参照してください。 
表6-2 表1: [Select Project Name and Folder]の設定項目 

 

項目 説明 

Project Name プロジェクトの名前を指定します。 

Project Location プロジェクトの保存場所を入力または参照します。 
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(続き) 
項目 説明 

Project Folder プロジェクト名とプロジェクトの保存場所に基づいて、プロジェクト フォルダの保存場所

を表示します。 
プロジェクト フォルダと作業フォルダの関係は6.6.2「ユーザMakefileプロジェクト フォル

ダおよび作業フォルダ」を参照してください。 
Set as main project 作成されるプロジェクトをメイン プロジェクトに設定します。既定値でチェックが入って

います。 
Overwrite existing 
project 

このチェックボックスは、プロジェクト名が既に使われている場合にアクティブになりま

す。 

Also delete sources このチェックボックスは、プロジェクトが既に存在し、ソースコードが含まれている場合に

アクティブになります。 
Use project location 
as project folder 

プロジェクトの保存場所と同じフォルダ内にプロジェクトを作成します。 
これは、MPLAB IDE v8プロジェクトをインポートする際、MPLAB X IDEのプロジェクト

を同じフォルダにする場合(ビルドも同様にする場合)に便利です。 

MPLAB IDE v8が.mcpファイルを使ってプロジェクト情報を保存するのに対し、MPLAB 
X IDEはフォルダを使います。従って、MPLAB IDE v8プロジェクト(.mcpファイル)とフ

ォルダを共有させる事ができるMPLAB X IDEプロジェクトは1つだけです。 
Encoding 既定値でISO-8859-1に設定されます。通常これを変更する必要はありません。 

 

表6-3 表2: [Create User Makefile Project]の設定項目 
 

項目 説明 

Working 
Directory 

外部プロジェクトの保存場所を指定します。これは各種コマンド (ビルド、デバッグビルド、ク

リーン)が実行される既定値の保存場所です。 
プロジェクト フォルダと作業フォルダの関係は6.6.2「ユーザMakefileプロジェクト フォルダお

よび作業フォルダ」を参照してください。 

このフォルダはユーザに代わってフォーマットの問題を処理するため、[Browse...]クリック時の

フォルダを参照する事を推奨します。 
Build command MPLAB X IDE(アイコンまたはメニュー)でビルドまたは[Run]コマンドが要求された場合、代わり

にこのコマンドに従ってビルドを実行します。 
ビルドパス*: Windowsの場合、引用符を使います。LinuxまたはMac OSの場合、スペースはエス

ケープする必要があります。 
Debug build 
command 

MPLAB X IDE(アイコンまたはメニュー)で[Debug]コマンドが要求された場合、代わりにこのコマ

ンドに従ってデバッグビルドを実行します。 
デバッグビルド パス*: Windowsの場合、引用符を使います。LinuxまたはMac OSの場合、スペー

スはエスケープする必要があります。 
以下も参照してください。 
http://microchipdeveloper.com/mplabx:work-outside-compile-for-debug 

Clean 
command 

MPLAB X IDE(アイコンまたはメニュー)で[Clean]コマンドが要求された場合、代わりにこのコマ

ンドに従ってクリーンを実行します。 
クリーンパス*: Windowsの場合、引用符を使います。LinuxまたはMac OSの場合、スペースはエ

スケープする必要があります。 
Image name 量産イメージファイル(HEX)のパスと名前を入力します。イメージパス*: スペースは全てエスケ

ープする必要があります。 

Debug image 
name 

デバッグイメージ ファイル(ELFまたはCOF)のパスと名前を入力します。デバッグイメージ パス

*: スペースは全てエスケープする必要があります。 

User Include 
Paths 

ユーザ インクルード ファイルを入力または参照します。インクルードパスはダイアログ(図6-11)
で管理します。 
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#include <xc.h> 
int main(void) 
{ while(1) { 

 

(続き) 
項目 説明 

User Macros マクロを追加または「解析および追加」します。 
[Edit]: マクロ名を入力します。またはマクロを含むファイルを参照します。マクロはダイアログ

(図6-12)で管理します。 

[Parse]: マクロを自動的に解析します(MPLAB XCコンパイラのみ)。ダイアログの指示に従いま

す。完了後、表示されている現在のマクロを選択して置換するか、現在のマクロの一覧に付け加

えます。このダイアログの使用例は6.6.3「Makefileプロジェクトの例」を参照してください。 
 

図6-11 [Select Include Paths]ダイアログ 

図6-12 [macrosName]ダイアログ 

 
 

6.6.2 ユーザMakefileプロジェクト フォルダおよび作業フォルダ 
プロジェクト フォルダはMakefileとnbproject/Makefilesを保存しています。MPLAB X IDEはプロジェクト フ
ォルダでmakefileを実行します。次に作業フォルダに移動し、「Build command」または「Debug build command」
を実行します。これによりGNU Makeが実行され、「Build command」として指定した処理が実行されます。 

プロジェクト フォルダは、絶対パスで保存場所を定義する場合、作業フォルダに対してどこにでも配置できます。

しかし、この方法を使うとプロジェクトの移植性が損なわれます。プロジェクトを移植しやすくするには、作業フォ

ルダはプロジェクト フォルダに対して相対パス(例: プロジェクト フォルダの1レベル下)で指定します。 
 

6.6.3 Makefileプロジェクトの例 
この例では、MPLAB X IDEでユーザmakefileプロジェクトを作成する方法を示します。このmakefileプロジェクトは、

バッチファイルとIDE外で作成したユーザコード上のmakeのどちらかを実行します。このユーザコードは、1つのフ

ァイル(t.c)から成ります。このファイルに記述されているシンプルなコードを以下に示します。 

例: t.cのコード 
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C:\Users\MCHP\MPLABXProjects\makestuff\myOwnCodeWithItsOwnMakefile 

::assumes xc32-gcc and xc32-bin2hex are on the path 
rem @echo off 
set COMPILER=xc32-gcc 
set BIN2HEX=xc32-bin2hex 
set PROCESSOR=32MX360F512L 
if "%1" == "production" goto production 
if "%1" == "clean" goto clean 
:debug 
%COMPILER% -mprocessor=%PROCESSOR% -g -D_DEBUG -o t_debug.elf t.c 
goto end 
:production 
%COMPILER% -mprocessor=%PROCESSOR% -o t_production.elf t.c 
%BIN2HEX% t_production.elf 
goto end 
:clean 
del /F *.elf 
del /F *.hex 
goto end 
:end 

 
 

 

 
本コードは、量産向けにはt_production.hexにリンクし、デバッグ向けにはt_debug.elfにリンクします。 

この例では、t.c、バッチファイル(makeme.bat)、ユーザmakefile (Makefile)は以下のフォルダ(Windowsの場合)
に保存されていると仮定します。 

使用中のPC上でこの例を再現する場合、MCHPをユーザのUserNameで置き換えます。 

• [User Makefile Project] – バッチファイルからコードを作成 
• [User Makefile Project] – ユーザMakefileからコードを作成 
• [User Makefile Project] – 完了 
• [User Makefile Project] – マクロの解析 

6.6.3.1 [User Makefile Project] – バッチファイルからコードを作成 
コードをコンパイルするため、バッチファイル(makeme.bat)の引数としてproduction、debug、cleanのいずれ

かを使います。productionの場合、t_production.hexがビルドされます。debugの場合、t_debug.elfがビ

ルドされます。cleanの場合、.elfおよび.hexファイルが消去されます。 

例: makeme.bat 
 

MPLAB X IDEでユーザmakefileプロジェクトを作成するには、6.6.1「[New Project] - ユーザMakefile」の手順を実行

します。 

1. Choose Project: [Microchip Embedded]、[User Makefile Project]を選択します。 
2. Select Device: デバイスとしてPIC32MX360F512Lを選択します。 
3. Select Header: このデバイスに利用できるヘッダはありません。 
4. Select Tool: SNでハードウェア ツールまたは[Simulator]を選択します。この例では「Simulator」を使います。 
5. Select Plugin Board: この例ではヘッダを使いません。 
6. Select Project Name and Folder: この例では「Project Folder」は 

myOwnCodeWithItsOwnMakefileと同じフォルダに作成します。従って、「Project Location」は

C:\Users\MCHP\MPLABXProjects\makestuffとし、「Project Name」はMPLABXProjectTとします。 

} 
return 0; 
} 



MPLAB X IDEユーザガイド 
高度な作業とコンセプト 

ユーザガイド DS-50002027E_JP - p. 159 © 2019 Microchip Technology 
 

 

 

 
 

図6-13 [User Makefile Project] – プロジェクト名とフォルダの選択 

7. Create User Makefile Project: 情報を入力してmakefileプロジェクトを設定します。 
作業フォルダでは、各種コマンド (バッチファイルのビルド、デバッグビルド、クリーン)が実行されます。 
このフォルダは絶対パスとして設定できます。 

C:\Users\MCHP\MPLABXProjects\makestuff\myOwnCodeWithItsOwnMakefile. 

しかし、この方法を使うとMPLAB X IDEプロジェクトの移植性が損なわれます。従って作業フォルダ、イメ

ージ名、デバッグイメージ名はMPLAB X IDEプロジェクト フォルダからの相対パスで入力します。 

[Finish]をクリックするとプロジェクトが作成されます。 
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# Assumes xc32gcc and xc32bin2hex are on the path 
COMPILER=xc32gcc 
BIN2HEX=xc32bin2hex 
PROCESSOR=32MX795F512L 
production: t_production.hex 
debug: t_debug.elf 
t_debug.elf: t.c 
$(COMPILER) mprocessor=$(PROCESSOR) -g -D_DEBUG -o t_debug.elf 
t.c 
t_production.hex: t_production.elf 
$(BIN2HEX) t_production.elf 
t_production.elf: t.c 
$(COMPILER) mprocessor=$(PROCESSOR) o t_production.elf t.c 
clean: 
del /F *.hex 
del /F *.elf 

 
 

図6-14 [User Makefile Project] – バッチファイルからコードを作成 

6.6.3.2 [User Makefile Project] – ユーザMakefileからコードを作成 
コードをコンパイルするため、ユーザmakefile (Makefile)は引数としてproduction、debug、cleanのいずれ

かを使います。productionの場合、t_production.hexがビルドされます。debugの場合、t_debug.elfがビ

ルドされます。cleanの場合、.elfと.hexファイルが消去されます。 

例: ユーザMakefileのコード 
 

MPLAB X IDEでユーザmakefileプロジェクトを作成するには、「[User Makefile Project] – バッチファイルからコー

ドを作成」の手順1～6を実行します。Step 7は下図に従って設定します。 
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作業フォルダでは、各種コマンド (ユーザMakefileのビルド、デバッグビルド、クリーン)が実行されます。作業フ

ォルダ、イメージ名、デバッグイメージ名はMPLAB X IDEプロジェクト フォルダからの相対パスで入力します。 

MPLAB X IDEはビルド、デバッグビルド、クリーンにGNU Makeを使います。「ユーザMakefileプロジェクト フ
ォルダおよび作業フォルダ」に従って、MPLAB X IDEがプロジェクト フォルダ内でMakefileを実行すると、作業

フォルダがカレントフォルダになります。作業フォルダ内でmakeはmakefileを検索し、ユーザ定義のMakefileを
見つけます。このMakefileはビルド、デバッグビルド、クリーンの方法を定義します。 

Note:  「Build command」等のコマンドを定義するもう1つの方法は、-fオプションを使ってユーザmakefileを指

定する事です(例: make -f Makefile production)。[Finish]をクリックするとプロジェクトが作成されます。 
図6-15 [User Makefile Project] – ユーザMakefileからコードを作成 

6.6.3.3 [User Makefile Project] – 完了 
プロジェクト作成後、[Projects]ウィンドウに以下が表示されます。プロジェクト名を右クリックしてプロジェクト

をビルドできます。 
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#include <xc.h> 
void main(void) 
{ return; 
} 

 
 

図6-16 [User Makefile Project] – プロジェクト ツリー 

設定を変更する場合、プロジェクト名を右クリックして[Properties]を選択します。 

図6-17 [User Makefile Project] – [Project Properties]ダイアログ 

この例では、ビルドの結果 (t_production.hex)とデバッグビルドの結果 (t_debug.elf)は作業フォルダ

myOwnCodeWithItsOwnMakefileに保存されています。MPLAB X IDEではMPLABXProjectTプロジェクト フォル

ダのみが表示されるため、ビルド後のIDEの[Projects]ウィンドウでは変化が見られません。 

6.6.3.4 [User Makefile Project] – マクロの解析 
MPLAB XC Cコンパイラのマクロを解析し、makefileプロジェクトに追加できます。これを行うには、引数を指定し

てコマンドラインでコンパイラを呼び出し、出力全体を[Parse macros]ダイアログの最初のパネルにコピーする必要

があります。 

コマンドラインでコンパイラを実行するにはCファイルが必要です。この例では、以下のコードをファイル

xcmain.cに貼り付けます。 
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xc32-gcc -dM -E xcmain.c > macros32.txt 

xc16-gcc -dM -E xcmain.c > macros16.txt 
xc8 --pre -v --chip=8BitMCU xcmain.c > macros8.txt 

 
 

コンピュータがMPLAB XCコンパイラへのパスを認識している事を確認します。その後、コマンドラインで以下のコ

マンドを実行します。 

MPLAB XC32++ではなくMPLAB XC32 Cコンパイラを使うため、xc32-gccが実行ファイルです。オプション-dMは、

前処理の最後に有効なマクロ定義のリストだけを出力するようプリプロセッサに指示します。オプション-Eは、前

処理後に実行を停止させます。リダイレクト(>)文字は、出力をファイルmacros.txtに書き込みます。 

その他のMPLAB XC Cコンパイラでは以下を使えます。 
 

8BitMCUは使用中の8ビットデバイスに置き換えます。macros8.txtファイルに対しては、マクロをファイル内の

他のテキストから分離するための編集も必要です。 

[Parse macros]ダイアログは以下の手順で開きます。 

1. プロジェクト名の上で右クリックして[Properties]を選択します。 
2. [Categories]の下で[Makefile]を選択します。 
3. [Set User Makefile properties]の下で[User Macros]に移動し、[Parse]ボタンをクリックします。マクロの解析

は以下の手順で行います。 

1. macros.txtの内容をコピーしてダイアログの左パネルに貼り付けます。 
2. 使用中のMPLAB XC Cコンパイラにチェックを入れる(この場合は「xc32」)。 
3. [Parse]ボタンをクリックします。 

[User Macros]テキストボックスの現在の内容を置換するには[Replace]、追加するには[Append]、変更しない場合は

[Cancel]ボタンをクリックします。 

図6-18 [Parse Macros]ダイアログ 
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6.7 ソースファイル フォルダにリンクしたリソースの使用 
マクロを使ってソースベース(またはライブラリ バージョン)をポイントし、別のソースベースに移動するように切り

換えられます。これは、MPLAB Harmonyアプリケーションで特に便利です。 

MPLAB X IDEでプロジェクトを開き、[File] > [Project Properties]を選択します。[General]カテゴリをクリックし、

[Macro]の横の[Browse]をクリックします。ソースベースを保存しているフォルダを見つけて開きます。[OK]をクリ

ックします。プロジェクトでは、このソースベースのファイルを「Relative to Macro」として開きます。 

別のソースベースに切り換えるには、その新しいソースベースを保存しているフォルダを[Macro]で参照して選択し

ます。新しいソースベースと一致する古いソースベースのファイルは全て、新しいソースベースを参照するように

なります。 
 
 
6.8 サードパーティ製ハードウェア ツールの使い方 

サードパーティ製ハードウェア ツールを使う場合、以下の要件があります。 

• 必要なUSBドライバを入手してインストールします。USBドライバとインストール説明書は、通常サードパーテ

ィから入手できます。 
• このツールのMPLAB X IDEプラグインをインストールします。詳細は5.26「プラグインツールの追加」を参照し

てください。 

インストールが完了すると、[Project Properties]ウィンドウにハードウェア ツールが表示され選択できるようになり

ます(4.4「プロジェクト プロパティの表示と変更」参照)。 
 
 
6.9 コードカバレッジの使用 

コードカバレッジは、コードのどの部分が実行されているかを表示します。コードカバレッジの出力を表示するには、

コードカバレッジをサポートしているMPLAB XC CコンパイラをMPLAB X IDEで使う必要があります。コードカバ

レッジは以下のバージョン以降でサポートしています。 

• MPLAB X IDE v5.25 
• MPLAB XC8 v2.10 
• MPLAB XC16 v1.40 
• MPLAB XC32 v2.30 

MPLAB X IDEでは、コンパイラ カテゴリの下の[Project Properties]ウィンドウでコードカバレッジを有効にできます。

有効にしたら、テストコードを完全に実行して停止/一時停止します。[Window] > [Debugging] > [Code Coverage]を
選択し、コード全体に対して実行されたコードの割合を[Code Coverage]タブウィンドウで確認します。 

MPLAB Code Coverageアドオン ライセンス(SW006026- COV)を購入すると、コードカバレッジの詳細を表示でき

ます。このライセンスを購入すると、コンパイラのフルコード カバレッジ機能がアクティベートされ、以下が表示

されます。 

• コードカバレッジを表示したテキスト 
• [Code Coverage]タブウィンドウでの詳細レポート 
 

詳細は以下を参照してください。 

http://www.microchip.com/mplab/codecoverage 

 
 

6.10 ログファイル 
ログファイルは、プログラム実行状況の把握と問題の解決に役立ちます。 

MPLAB X IDEに問題やエラーが発生して技術サポートに問い合わせる場合、2つのログファイル(MPLAB X IDEのロ

グファイルとNetBeansプラットフォームのログファイル)のデータが必要です。その他の補足情報も必要です。 

http://www.microchip.com/mplab/codecoverage
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図6-19 データロギング 

 
6.10.1 MPLAB® X IDEのログファイル 

MPLAB X IDEのログファイル機能は、Java Loggerクラスに基づいてデータを生成します。 

ログファイルの設定方法 

1. [Tools] > [Options] (macOSでは[MPLAB X IDE] > [Preferences])を選択して[Embedded]ボタンをクリックし、

[Diagnostics]タブを選択します。 
2. ドロップダウン ボックスからログレベルを選択します。 

Note:  ログレベルが高いほど収集データは増えますが、アプリケーション実行速度は低下します。 
3. ログファイルを保存する場所(パス)を選択します。 

データを記録する方法 

1. ログレベル「Finest」を設定します。 
2. ログファイルの名前と保存場所を書き留めます。 
3. 問題やエラーが発生するまでステップを繰り返します。 
4. 生成されたログファイルとその他必要な情報を技術サポートに送信します。 
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6.10.2 NetBeansプラットフォームのログファイル 
NetBeansのログファイルは、NetBeansプラットフォームの実行に関する情報を記録します。 

データを記録する方法

1. [View] > [IDE log]を選択して[Output]ウィンドウにログファイルを開きます。

2. [Output]ウィンドウを右クリックして[Clear]を選択します。

3. 問題やエラーが発生するまでステップを繰り返します。

4. ウィンドウを右クリックし、[Save As]を選択してテキストをファイルに保存します。

5. ファイルとその他必要な情報を技術サポートに送信します。

6.10.3 その他のサポート情報 
ログは有益ですが、技術サポートでは問題の解決にあたりその他の情報も必要です。例えば以下のような情報です。

• ログファイルに対応する、実際に実行したステップ

• デバッグツールおよび言語ツールの種類とバージョン等、ツールの詳細

• その他のMPLAB X IDEプロジェクト データ

6.10.4 ログ収集に関する注意事項 
ログ収集時は以下に注意します。

• ログファイルはできるだけ短く、焦点を絞ります。つまり、エラーが発生するまで延々とコードを実行して長

時間記録せず、エラー発生から記録するようにします。

• ハードウェア ツールの場合、USB通信の問題を判別するには循環ログが有益です。

6.11 MPLAB X IDEプロジェクトのパッケージ化 
プロジェクトを右クリックして[Package]を選択すると、プロジェクトをzipファイル(.zip)にパッケージ化できます。

MPLAB X IDEはファイルをZIPに圧縮できますが、解凍する事はできません。従って、プロジェクトの解凍には別の

プログラムが必要です。

この機能は、プロジェクトをパッケージする際にプロジェクト ファイルを解析し、パッケージに含めるべきプロジ

ェクト ファイルのフォルダを決定します。すなわち、プロジェクト フォルダと、その相対パスを使うフォルダ内の

ファイルだけをパッケージに含めます。

パッケージにはソースファイル、makefile、「nbproject」フォルダが含まれます。 

ヘッダファイルは、プロジェクトに追加していない限り含まれません。従って、ユーザ作成のヘッダファイルが必要

な場合、解凍済みのプロジェクトはビルドできません。

6.12 ハードウェア ツールの接続とデバッグ 
ハードウェア デバッグツールとターゲット間の接続によって、利用可能なデバッグ機能とデバイス関連のデバッグ

機能が決まります。

ハードウェア ツールとターゲットの接続 - PIC MCU

表6-4 ハードウェア ツールとターゲットの接続 - PIC MCU

接続 ハードウェアのサポート(1) デバッグのサポート
(2,3,4) 

トレースのサポート(1) サポート速度

標準(ICSP)通信 Real ICE, ICD4, ICD3: モジ

ュラケーブル(6ピンRJ-11) 
Snap, PK4, PK3: 
リボンケーブル(6ピンSIL)

Basic, 
Advanced 

Real ICE: ネイティブ 
トレース

15 MIPS以下 

PIC32: デバイス

依存
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(続き) 
接続 ハードウェアのサポート(1) デバッグのサポート

(2,3,4) 
トレースのサポート(1) サポート速度

高速(LVDS)通信 Real ICE: パフォーマ

ンス パック

(AC244002) 

Basic, 
Advanced 

Real ICE: ネイティブ 
トレース

Real ICE: SPIトレース 

15 MIPS超 

PIC32: デバイス

依存

Real ICE: パフォーマン

ス パック + アイソレー

タ ユニット(AC244005)

Basic, 
Advanced 

なし 15 MIPS超 

PIC32: デバイス

依存

JTAG Real ICE: JTAGアダプタ

(AC244007) 

SJL 

Basic なし PIC32: デバイス

依存

ロジックポート Real ICE: ロジックポート 
プローブ(4ピン) 

N/A Real ICE: I/Oポートト

レース

デバイス依存

Real ICE: トレース インタ

ーフェイス キット

(AC244006) 

N/A Real ICE: 命令トレース

(PIC32 MCU、一部のエ

ミュレーション ヘッダ)

デバイス依存

標準(ICSP)通信 + 
ロジックポート

Real ICE: 電力モニ

タ(AC244008)
Basic なし 15 MIPS以下 

PIC32: デバイス

依存

1. ツール略語については最後の表を参照してください。

2. サポートはデバイス依存です。デバイスによっては使えないデバッグ機能があります。

3. 基本的なデバイスサポート(Basic): Run、Halt、Reset、Step Into、Step Over、ソフトウェア/ハードウェア

ブレークポイント

4. 高度なデバイスサポート(Advanced): データキャプチャ、ランタイム ウォッチ等

表6-5 ハードウェア ツールとターゲットの接続 - AVR MCU 

接続 ハードウェア

サポート(1,2)

デバイスのサポート
(3) 

デバッグのサポート(4,5,6) トレースの

サポート

サポート速度

JTAG AI、PK4 全AVR MCU Basic なし 32 kHz～7.5 MHz 

aWire AI AVR 32ビットMCU Basic なし 7.5 kbit/s～7 Mbit/s 

PDI 2線インター

フェイス

Al、PK4 AVR XMEGA® MCU Basic なし 32 kHz～7.5 MHz 

debugWIRE Al, PK4 AVR 8ビットMCU Basic なし 4 kbit/s～0.5 Mbit/s 

UPDI Al, PK4 AVR 8ビットMCU Basics なし 最大750 kbit/s 

SPI AI, PK4 AVR 8ビットMCU プログラミングのみ N/A 8 kHz～5 MHz 

TPI AI, PK4 tinyAVR 8ビット
MCU 

プログラミングのみ N/A デバイス依存
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(続き) 
接続 ハードウェア サポート

(1,2) 
デバイスのサポート
(3) 

デバッグのサポート
(4,5,6) 

トレースのサポート サポート速度

1. ツールの略語については表6-7を参照してください。

2. ICD4とPK4にはAC102015デバッガ アダプタボードが必要です。

3. デバイスサポートは現在進行中であり、現時点で利用できない場合があります。

4. サポートはデバイス依存です。デバイスによっては使えないデバッグ機能があります。

5. 基本的なデバイスサポート(Basic): Run、Halt、ソフトウェア/ハードウェア ブレークポイント

6. プログラミングのみ: この接続ではデバッグできません。

表6-6 ハードウェア ツールとターゲットの接続 - SAM MCU

接続 ハードウェア サポート
(1,2) 

デバイスのサポート
(3) 

デバッグのサポート
(4,5,6) 

トレースのサポート サポート速度

JTAG ICD4 SAM MCU Basic なし 32 kHz～7.5 MHz 

SWD ICD4 SAM MCU Basic, Advanced ITM - 3 MB/s 32 kHz～10 MHz 

1. ツールの略語については表6-7を参照してください。

2. ICD4とPK4にはAC102015デバッガ アダプタボードが必要です。

3. デバイスサポートは現在進行中であり、現時点で利用できない場合があります。

4. サポートはデバイス依存です。デバイスによっては使えないデバッグ機能があります。

5. 基本的なデバッグサポート(Basic): Run、Halt、ソフトウェア/ハードウェア ブレークポイント

6. 高度なデバッグサポート(Advanced): Basicへの追加機能、デバイス依存

表6-7 ツールの略語

略語 ツール名

Snap MPLAB Snapインサーキット デバッガ/量産プログラマ 

PK4 MPLAB PICkit 4インサーキット デバッガ/量産プログラマ 

PK3 PICkit 3インサーキット デバッガ/開発用プログラマ 

ICD4 MPLAB ICD 4インサーキット デバッガ/量産プログラマ 

ICD3 MPLAB ICD 3インサーキット デバッガ/量産プログラマ 

RI MPLAB REAL ICEインサーキット エミュレータ/量産プログラマ 

AI Atmel-ICEインサーキット デバッガ/プログラマ 

SJL SEGGER J-Linkデバッグプローブ (サードパーティ) 

デバイス依存デバッグ機能の詳細は以下を参照してください。

<MPLAB X IDE install>docs/FeatureSupport/HWToolDebugFeatures.html 

6.13 IDEスクリプトの使用 
MPLAB X IDEにはIDEの挙動をプログラミングにより制御できるスクリプト機能があります。Microchip社のMPUプ

ロジェクトで使えるように開発すると、MCUプロジェクトでも使えます。

スクリプトについて

スクリプトはJythonで書かれています。スクリプトはAPIへアクセスでき、以下が可能です。

• デバッグ セッションの状態(実行、停止等)を制御
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• デバッグ中にデバイスメモリへアクセス 
• 停止を発生させるかどうかを決定する関数へのコールバックを使ってブレークポイントを設定(これにより、条

件付きブレークポイントを実装可能) 
• [Projects]ウィンドウに操作を配置(クリックするとスクリプトのメソッドを実行) 
• デバッグイベントのフックを提供(特定のイベントが発生したら関数を呼び出す) 

スクリプトの使い方 

スクリプト機能へは以下の手順でアクセスします。 

1. スクリプトを使うプロジェクトを閉じます。 
2. autoload.pyという名前のファイルを作成します。APIを説明する自己文書化autoload.pyは、<MPLAB X 

IDE Install folder>\docs\example_codeに保存されています。 
3. このファイルをプロジェクト フォルダにコピーします。必要に応じてファイルを編集します。 
4. プロジェクトを再度開くと、プロジェクトツリーに「Script Files」フォルダが表示されます。ファイル

autoload.pyはこのフォルダにあります。 
5. 必要に応じて「Tests」のスクリプトを実行します。 

図6-20 プロジェクト内の未編集autoload.py 

 
 
6.14 チェックサム 

チェックサムとは、アプリケーション コードと、MCUまたはDSCの設定から得られる16進数です。チェックサム生

成方法の詳細はデバイスのプログラミング仕様を参照してください。 

チェックサムはプロジェクトのビルド時に生成されます。生成されたチェックサムは[Dashboard]ウィンドウに表示

されます(5.19「ダッシュボードの表示」)。 
 

チェックサムはビルドエラーの検出に役立ちます。例として、あるプロジェクトをあるコンピュータでビルドした場

合について考えます。同じプロジェクトを別のコンピュータにコピーしてビルドした時に、チェックサムが同じであ

ればプロジェクトが正常にコピーされた事を意味します。チェックサムが異なれば、コピーに失敗した事を意味しま

す。 
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チェックサムをエラー検出に使う場合、プロジェクト コードを開発する際以下に注意する必要があります。コンパ

イラマクロの  TIME  と  DATE  を使ってはいけません。ファイルパスを変更する場合、マクロの  FILE  と
assert()を使ってはいけません。 

デバイスによって、チェックサムをユーザIDとして使う場合があります。 
4.10.3「ユーザIDメモリへの非保護チェックサムの挿入」 

 
 
6.15 コンフィグレーション 

「コンフィグレーション」という用語は様々な文脈で使われます。下表にそれらの用語と定義を示します。 

表6-8 コンフィグレーションの文脈 
 

用語 定義 

コンフィグレーション ビット 
コンフィグレーション ヒューズ 

コンフィグレーション ワード 

コンフィグレーション バイト 

コンフィグレーション レジスタ 

これらの用語は全て、デバイスを設定するために使うデバイスメモリの物

理領域を指します。利用可能なコンフィグレーションは、デバイスのデー

タシートを参照してください。 

[Configuration Bits]ウィンドウ プロジェクトで設定したデバイスで利用可能なコンフィグレーションを表

示するウィンドウです。このウィンドウの詳細は、4.19「 [Configuration 
Bits]ウィンドウでのコンフィグレーション値の設定」を参照してくださ

い。 

プロジェクト コンフィグレーション プロジェクトのビルド設定です。プロジェクト作成後、コンフィグレーシ

ョン名は「[default]」となっています。この名前は変更できます。また、1
つのプロジェクトに対して複数のコンフィグレーションを作成できます。

詳細は6.4「複数コンフィグレーションの使い方」を参照してください。 

このデータはconfigurations.xmlファイルに保存されます。 
プロジェクト コンフィグレーシ

ョン タイプ 
特定タイプのプロジェクト向けの設定です。プロジェクト コンフィグレー

ション タイプは、「アプリケーション」として設定したスタンドアロン 
プロジェクトと「ライブラリ」として設定したライブラリ プロジェクトに

のみ適用されます。詳細は4.10.1「プロジェクト コンフィグレーション タ
イプの変更」を参照してください。 

ユーザ コンフィグレーション データ ユーザが作成したMPLAB X IDEのコンフィグレーションです。8.7「ユー

ザ コンフィグレーション データの表示」を参照してください。 
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7. エディタ 

MPLAB X IDEはNetbeansプラットフォームをベースとしているため、コードの編集にはNetBeansプラットフォーム

のエディタを使います。 

NetBeansソースエディタの詳細は以下を参照してください。

https://docs.oracle.com/cd/E50453_01/doc.80/e50452/working_nbeans.htm#A1151635  

エディタに関するCコンパイラ情報は、以下のNetBeansヘルプトピックでご覧ください。

https://netbeans.org/kb/docs/cnd/navigating-editing.html 

 
 

7.1 エディタの使い方 
エディタを使うには、[File] > [New File]を使ってファイルを作成します。または[File] > [Open File]を使って既存のフ

ァイルを開きます。以下のセクションでは、その他の操作と機能について説明します。 

デスクトップの制御 

エディタに関連するデスクトップ項目には以下のようなものがあります。 

• [File]メニュー – [Editor]ウィンドウでファイルを開きます(10.1.1「[File]メニュー」参照)。 
• [Edit]メニュー – 編集コマンドにアクセスします(10.1.2「[Edit]メニュー」)。 
• エディタ ツールバー – こちらも編集コマンドにアクセスします。各ファイルのエディタ ウィンドウの上にあり

ます(10.2.10「エディタ用ツールバー」参照)。 
• ウィンドウ内で右クリックして開くコンテクスト メニュー – その他のコマンドを利用できます。 

表示の制御 

下表に基本的な表示の制御機能を示します。その他のフォーマット設定機能については7.2「エディタのオプション」

を参照してください。 
 

操作 説明 

ソースエディタのウィ

ンドウを最大化する 
以下のいずれかを行います。 

• ソースエディタのファイルのタブをダブルクリックする 
• ソースエディタのウィンドウを選択し、<Shift>+<Esc>を押す 
• [Window] > [Configure Window] > [Maximize]を選択する 

最大化したソースエデ

ィタを元のサイズに戻

す 

以下のいずれかを行います。 
• ソースエディタのファイルのタブをダブルクリックする 
• <Shift>+<Esc>を押す 
• [Window] > [Configure Window] > [Restore]を選択する 

行番号を表示する [View] > [Show Line Numbers]を選択する 

2つのファイルを同時に

表示する 
1. 2つ以上のファイルを開く 
2. 1つのファイルのタブをクリックし、ファイルを配置するウィンドウの側面にド

ラッグする 
ウィンドウの配置場所を示す赤いプレビュー ボックスが表示された状態でマウ

スボタンを放すと、エディタ ウィンドウがそこに配置されます。 
タブをドラッグする場所によって、ウィンドウは水平または垂直に分割できま

す。 

1つのファイルの表示画

面を分割する 
1. ソースエディタのファイルのタブを右クリックし、[Clone]を選択する 
2. コピーしたファイルのタブをクリックし、コピーしたファイルを配置するウィ

ンドウの部分にドラッグする 

https://docs.oracle.com/cd/E50453_01/doc.80/e50452/working_nbeans.htm%23A1151635
https://netbeans.org/kb/docs/cnd/navigating-editing.html
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(続き) 
操作 説明 

開いているファイル間を

移動する 
1. <Ctrl>を押す 
2. <Ctrl>を押したままで<Tab>を押すと、選択ボックスが表示される 
3. 移動するファイルを選択する 

コードを自動的にフォー

マットする 
ソースエディタ内で右クリックし、[Format]を選択する 
テキストを選択している場合、そのテキストのみがフォーマットされます。テキスト

を選択していない場合、そのファイル全体がフォーマットされます。 
 

基本的なエディタ機能 

下表に、頻繁に使われるエディタ機能をまとめます。 
 

エディタ機能 参考文献 

Unicodeのサポート 既定値ではISO-8859-1文字エンコードを使います。これを変更するには以下を

行います。 
[Projects]ウィンドウでプロジェクト名を右クリックして[Properties]を選択する 
左側の[Categories]の下の列で[General]を選択する 
ページ下部の[Encoding]を変更する 

構文に基づくコードの色分け [Tools] > [Options] (macOSでは[MPLAB X IDE] > [Preferences])、[Fonts and 
Colors]ボタン、[Syntax]タブ 
色分けは、プロジェクト作成時のエンコード設定で決まります。 

コード入力中のエラー表示 以下のNetbeansヘルプトピックを参照してください。

https://netbeans.org/kb/docs/java/editor-codereference.html#coloring 

シンボル、エラー等の色付きマ

ーカによる識別 
[Tools] > [Options] (macOSでは[MPLAB X IDE] > [Preferences])、[Fonts and 
Colors]ボタン、[Annotations]タブ 

候補とヒントを表示する

スマートコード補完 
[Tools] > [Options] (macOSでは[MPLAB X IDE] > [Preferences])、[Editor]ボタ

ン、[Code Completion]タブ 

デバッグモードでシンボルにカ

ーソルを合わせて値を表示する 
デバッグ停止時にシンボルの上にマウスカーソルを置くと値が表示されます。 
Note:  この方法でマクロの値を表示する事はできません。デバッグ中にエディ

タ内のマクロを右クリックして(macOSでは<Cmd>+<Alt>+<Click>)、[Macro 
Expansion]ウィンドウを使います。 

アセンブリとCコードの折り畳み

および展開表示 
7.5「コード折り畳み」を参照してください。 

関数(例: delay(x))を右クリッ

クして、その関数が使われてい

る箇所を検索する。検索を関数

内のみに制限する事もできます

(例: ローカル変数iの検索)。 

以下のNetBeansヘルプトピックを参照してください。

http://wiki.netbeans.org/Find_Usages_in_Compiled_Dependencies 

関数(例: delay(x))を右

クリックして、コールグ

ラフを表示する 
コールグラフの横のボタンを使

って順番の入れ換え等を行う 

「コールグラフの表示」を参照してください。 

ソースコード内でキーワード(例: 
//TODO)を使ってコメントを作

成し、それらの要処理事項をス

キャンして[Action Items]ウィン

ドウに自動的に追加する 

以下のNetBeansヘルプトピックを参照してください。

https://netbeans.org/features/ide/index.html 

[Options]ウィンドウに関しては、[Team]: [Action Items]を参照してください。 

https://netbeans.org/kb/docs/java/editor-codereference.html%23coloring
http://wiki.netbeans.org/Find_Usages_in_Compiled_Dependencies
https://netbeans.org/features/ide/index.html
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(続き) 
エディタ機能 参考文献 

バージョン管理システムがなくてもローカル

ファイル履歴機能を使って以前のバージョン

を復元する 

5.22「ローカルファイル履歴によるソースコードの管理」 

[Go to File]、[Go to Type]、[Go to Symbol]、
[Go to Header]、[Go to Declaration]等を使っ

て、素早く移動する 

「[Navigate]メニュー」を参照してください。 

リファクタリング オプション(関数と変数の

名前変更、全関数の検索等)を使ってコード

の構造を改良する 

7.6「Cコードのリファクタリング」を参照してください。 

 

エディタのトラブルシュート 

エディタ内でハイライトされたコードのエラーは、コンパイラのマニュアルを参照してください。エラーのハイラ

イト表示に関する詳細は、NetBeansヘルプトピックを参照してください。 

https://netbeans.org/kb/docs/java/editor-codereference.html#coloring  

個々のエラーは9.5「エラー」に記載しています。 

 
 

7.2 エディタのオプション 
エディタ オプションの設定方法 

1. [Tools] > [Options] (macOSでは[MPLAB X IDE] > [Preferences])を選択して[Options]ダイアログを開きます。 
2. [Editor]ボタンをクリックします。タブをクリックしてエディタ機能

を設定します。下表に各タブとそのオプションを示します。 

表7-1 [General]タブ 
 

項目 説明 

Code Folding コード折り畳みを有効にする場合にチェックを入れます。また折り畳むコードの種類を選

択します。コード折り畳みの詳細は7.5「コード折り畳み」を参照してください。 
以下のNetBeansヘルプトピックも参照してください。 

https://netbeans.org/kb/docs/java/editor-codereference.html 

Camel Case 
Behavior 

キャメルケース ナビゲーションを有効にする場合にチェックを入れます。 

 
表7-2 [Formatting]タブ 

 

項目 説明 

Language フォーマット設定を適用するプログラミング言語を選択します。 

Category カテゴリを選択します。現在は[Tabs and Indents]のみです。 

Expand Tabs to Spaces タブをスペースに変換する場合、チェックを入れます。 

Number of Spaces per Indent インデント1段をスペース何文字にするか入力します。 

Tab Size タブのサイズを入力します。 

Right Margin 右余白のサイズを入力します。 

https://netbeans.org/kb/docs/java/editor-codereference.html%23coloring
https://netbeans.org/kb/docs/java/editor-codereference.html
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表7-3 [Code Completion]タブ 
 

項目 説明 

Language コード補完機能を適用するプログラミング言語を選択します。 

Completion options コード補完機能を有効にする場合、チェックを入れます。コード補完の詳細は以下の

NetBeansヘルプトピックを参照してください。 
https://netbeans.org/kb/docs/java/editor-codereference.html 

 
表7-4 [Code Templates]タブ 

 

項目 説明 

Language テンプレートを適用するプログラミング言語を選択します。 

Templates 上で指定した言語に対するテンプレート情報を入力します。 
Abbreviation: エディタに入力する省略形を入力します。 

Expanded Text: 上の省略形と[Expand template on]で選択したキーを入力すると、ここで指定す

るテキストに展開します。 

Description: テンプレート項目に説明を追加します(任意)。コード テンプレートの詳細は以下

のNetBeansヘルプトピックを参照してください。 

https://netbeans.org/kb/docs/java/editor-codereference.html 

Expand 
template on 

省略形を展開するトリガとなるキーを選択します。 

 
表7-5 [Hints]タブ 

 

項目 説明 

Language ヒントを適用するプログラミング言語を選択します。 

[Hint]ウィンドウ [Hint]ウィンドウでは、エラー、警告等どれをどのように表示するかを指定します。 
ヒントの使い方は以下のNetBeansヘルプトピックを参照してください。 

https://netbeans.org/kb/docs/java/editor-codereference.html 

 
表7-6 [Macros]タブ 

 

項目 説明 

Macros エディタマクロを作成、編集、削除します。 
マクロを新規作成するには、[New]ボタンをクリックしてマクロ名を入力します。その後、リストでそ

のマクロを選択し、マクロコード エディタでコードを引用符で囲んで入力します。 

マクロのキーボード ショートカットを設定するには、リストからマクロを選択し、[Set Shortcut]ボタ

ンをクリックし、ダイアログ ボックスにショートカットを入力します。このショートカットを使って

マクロを実行します。 

マクロを削除するには、リストからマクロを選択して[Remove]ボタンをクリックします。 

マクロコードを変更するには、リストからマクロを選択してエディタでコードを編集します。 
Macro 
Code 

上のマクロ名をクリックして、マクロコードを引用符で囲んで入力します。マクロのキーワードの一

覧は、以下のURLを参照してください。 

http://wiki.netbeans.org/FaqEditorMacros 

Note:  通常、エディタでゼロから入力するよりも、操作を記録してマクロとして追加する方が簡単で

す。マクロの記録には、[Edit] > [Start/Stop Macro Recording]を使います。 

https://netbeans.org/kb/docs/java/editor-codereference.html
https://netbeans.org/kb/docs/java/editor-codereference.html
https://netbeans.org/kb/docs/java/editor-codereference.html
http://wiki.netbeans.org/FaqEditorMacros
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7.3 コードのハイパーリンク 
コードのハイパーリンクを使うと、リンク内容の関連情報に移動できます。 

Cコードのハイパーリンク 

ハイパーリンク ナビゲーションを使うと、関数、変数、定数のいずれかの呼び出しからその宣言にジャンプできます。 

以下のどちらかの方法により、ハイパーリンクを使えます。 
• <Ctrl> (Windows, Linux)または<Command> (Mac)を押しながら関数、変数、定数のいずれかの上にマウスカー

ソルを置きます。その要素に関する情報とハイパーリンクが表示されます。ハイパーリンクをクリックすると

宣言にジャンプします。<Alt>+<左矢印>を押すと、呼び出し元に戻ります。 
• マウスカーソルを識別子の上に置き、<Ctrl>+<B>または<Command>+<B>を押すと、エディタは宣言にジャン

プします。<Alt>+<左矢印>を押すと、呼び出し元に戻ります。 

<Alt>+<左矢印>または<Alt>+<右矢印>を押すと、カーソル位置の履歴で後方または前方に移動します。 

ASMコードのハイパーリンク 

アセンブリ ソースファイルに含まれているヘッダファイルを参照するには、#include文で参照されているファイル名

の上にマウスカーソルを置き<Ctrl> (Windows, Linux)または<Command> (Mac)を押します。マウスをクリックする

と、エディタのファイルタブ内にインクルード ファイルが開きます。 
 
7.4 エディタの赤の感嘆符 

ソースエディタは、ソースコード中の構文およびセマンティック エラー(例: セミコロンの欠落、未解決の識別子)を
ハイライト表示します。エラーは赤の下線で表示されます。また、エラーを含む各行の隣のエディタ ウィンドウ左

側の余白に赤の感嘆符「グリフ」 が表示されます。グリフの上にマウスカーソルを置くとエラーメッセージが表

示されます。 

Note:  エディタに表示されるエラーが全て本当のエラーとは限りません。認識できないシンボルである可能性もあ

ります。コードをビルドしてみてビルドに成功するかどうか確かめます。詳細はセクション「未認識のシンボルによ

るエラー」を参照してください。 

エラー条件とその他のマーク表示 

エラーは、以下のいずれかを実行した場合に発生する可能性があります。 

• 新規のコードを入力した 
• 既存のコードを編集した 
• 既存のファイルをプロジェクトに追加した 
• 別の場所にファイルを移動した 
• プロジェクトのプロパティまたはソースファイルを変更した 

ファイル内にエラーがある場合、エディタ ウィンドウ右側のエラーストライプに赤のマークが表示されます。エラ

ーストライプは、現在表示されている行だけではなくファイル全体を表しています。エラーストライプのマークをダ

ブルクリックすると、マークが表す行にジャンプします。 

未認識のシンボルによるエラー 

コンパイラのプリパーサまたはパーサによって認識されないシンボルは、エラーとして表示されていても実際にはエ

ラーではない(コードはビルドされる)場合があります。従って、このタイプのエラーが疑われる場合、プロジェクト

のビルドを試みます。 

例としては9.5「エラー」で以下を参照してください。 

• For 8-bit code, #asm and #endasm cause red bangs in the Editor window. 
• For 16-bit code, MPLAB XC16 packed attribute statement causes red bangs in the Editor window. 

 
7.5 コード折り畳み 

コードの一部を折り畳んで非表示にする事で、コードを読みやすくします。選択したオプションに応じて、Cまた

はアセンブリコードの一部を折り畳み(非表示)または展開(表示)できます。 
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コード折り畳みは既定値で有効になっています。ほとんどのCまたはアセンブリコードでは、折り畳む事ができるコ

ード部分はコード左の[-]および[+]アイコンで示されています。 

コード折り畳みの有効化と設定 

コード折り畳みは以下の手順で有効化および設定します。 

1. [Tools] > [Options] (macOSでは[MPLAB X IDE] > [Preferences])を選択して[Options]ダイアログを開きます。 
2. [Editor]ボタンをクリックします。 
3. [General]タブをクリックし、[Use code folding]にチェックを入れます。 
4. その下で折り畳むセクションを指定します。折り畳みを実行するコードタイプが表示されない場合、カスタム

の折り畳み機能を設定できます。 

コード折り畳み/展開 

エディタで、メソッドの隣の[-]アイコンをクリックすると、コードは折り畳まれます。折り畳まれたメソッドの隣の

[+]アイコンをクリックすると、コードは展開されます。折り畳まれたコードは省略記号の箱で表されます。省略記

号の箱の上にカーソルを置くと、IDEは折り畳まれたメソッドを表示します。 

図7-1 展開されたコード 
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// <editor-fold defaultstate="collapsed" desc="user-description"> 
C code block to fold 
// </editor-fold> 

; <editor-fold defaultstate="collapsed" desc="user-description"> 
ASM code block to fold 
; </editor-fold> 

 
 

図7-2 折り畳まれたコード 

コード折り畳み – インライン アセンブリとMPLAB C18 C 

_asmおよび_endasmディレクティブを使っている場合、コード折り畳みはMPLAB C18のインライン アセンブリコ

ードに対して機能しません。その回避策は、コードブロックをコード/ファイルの末尾付近に配置する事です。 

コード折り畳みのカスタマイズ – C 

Cコードをカスタム設定で折り畳む方法は以下の通りです。 

• 折り畳むコードの前後に以下のコメントを入力します。 

または 

• fcomと入力して<Tab>キーを押すと、自動的に上のコメントが挿入されます。コ

メントが入力されたら、自分のコード向けにカスタマイズできます。 

defaultstate 「collapsed」または「expanded」のどちらかを指定します。 

desc 折り畳むコードブロックの説明を入力します。折り畳んでも、参考のためにこの説明だけは表

示されたままになります。 
 

上の「コード折り畳み/展開」に、カスタムコード折り畳み例を示しています。 

詳細は以下のNetBeansヘルプトピックを参照してください。

https://ui.netbeans.org/docs/ui/code_folding/cf_uispec.html 

コード折り畳みのカスタマイズ – ASM 

アセンブリコードをカスタム設定で折り畳む方法は以下の通りです。 

• MPASMアセンブラまたはMPLAB XC16アセンブラのコードの場合、以下のコメントをコードの前後に入力します。 

https://ui.netbeans.org/docs/ui/code_folding/cf_uispec.html
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// <editor-fold defaultstate="collapsed" desc="user-description"> 
ASM code block to fold 
// </editor-fold> 

Undo - IDEは、リファクタリングの影響を受けた全てのファイル内の全ての変更を元に戻します。 

 
 

• MPLAB XC32アセンブラのコードの場合、以下のコメントをコードの前後に入力します。 

または 

• MPASMアセンブラまたはMPLAB XC16アセンブラのコードの場合、fcom;と入力して<Tab>キーを押すと、自

動的に上のコメントが挿入されます。 
• MPLAB XC32アセンブラのコードの場合、fcom//と入力して<Tab>キーを押すと、自動的に上のコメントが挿

入されます。 

アセンブリコードは、Cコードと同じように折り畳まれます。コード折り畳みの例は、上のCコードの例を参照して

ください。 

カスタマイズしたコード折り畳み/展開 

コードブロックを展開または折り畳むには、[View]メニューを選択するか、[Editor]ウィンドウを右クリックして、以

下を選択します。 

1. [Code Folds] > [Collapse Fold] - コードブロックを非表示(折り畳み) 
2. [Code Folds] > [Expand Fold] - コードブロックを表示(展開) 
3. [Code Folds] > [Collapse All] - 折り畳み設定したコードブロックの全てを非表示 
4. [Code Folds] > [Expand All] - 折り畳み設定したコードブロックの全てを表示 

上の「コード折り畳み/展開」に、カスタムコード折り畳み例を示しています。 
 
7.6 Cコードのリファクタリング 

リファクタリングは、プログラムの挙動を一切変更する事なくコードを再構成します。リファクタリングによりコー

ドが読みやすくなり、内容の理解と編集が容易になります。式をリファクタリングした場合、同じ結果が得られる必

要があるのと同様に、リファクタリング後のプログラムも元のプログラムと機能的に等価である事が必要です。 

一般的に、以下を目的としてコードをリファクタリングします。 

• コードの編集や機能の追加を容易にする 
• コードを単純化して理解しやすくする 
• 不要な繰り返しを取り除く 
• コードを他の用途またはより一般的な用途で使えるようにする 
• コードの性能を改善する 

IDEのリファクタリング機能は、ユーザが加えようとしている変更を評価してコードを再構成し、その変更によって

アプリケーションのどの部分が影響を受けるのかを示します。これにより、必要な全ての箇所でコードを変更してコ

ードを単純化できます。例えば、クラス名を変更する場合、IDEはコード内でその名前が使われている箇所を全て検

出し、その名前が使われている箇所を全て変更するようユーザに提示します。 

[Refactor]メニュー 

IDEのリファクタリング機能は、ユーザがある箇所でコードの構造を変更した時に、その変更を反映してコード全体

を更新します。 

リファクタリング機能は、[Refactor]メニュー(10.1.6「[Refactor]メニュー」参照)から利用できます。 

リファクタリングした変更の取り消し/やり直し 

[Refactor]メニュー内のコマンドを使って適用した変更は、[Undo/Redo]ツールバー メニューのボタンで取り消す(ま
たはやり直す)事ができます。 
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(#error This line shown only when there is an error.) 

 

 
リファクタリングを実行した後に、その影響を受けたファイルのいずれかを変更した場合、リファクタリングの

[Undo/Redo]は利用できなくなります。 

関数の使用箇所の検索 

[Find Usages]コマンドを使うと、プロジェクトのソースコード内で特定の関数が使われている全ての箇所を検出で

きます。 

プロジェクト内で関数が使われている箇所を検出する方法 

1. [Navigator]ウィンドウまたは[Source Editor]ウィンドウ内で関数を右クリックし、[Find Usages]を選択します 
(<Alt>+<F7> (macOSでは<Ctrl>+<F7>)を押す)。 

2. [Find Usages]コマンドは、指定された関数を呼び出しているコード行を表示します。[Find Usages]ダイアロ

グ ボックス内で[Find]をクリックすると、 
[Usages]ウィンドウに、その関数が見つかったファイルの名前と、そのファイル内で関数が使われているコー

ド行が表示されます。 

見つかった関数使用行のいずれかを選択して、その位置へジャンプする方法 

• [Usages]ウィンドウの左ペイン内で、上向きまたは下向き矢印ボタンを使って、関数使用行を選択します。 
• コードの1行をダブルクリックしてファイルを開くと、カーソルはそのコード行を指します。 

その他のIDE検索機能 

以下のIDEツールにより、プロジェクト内で特定テキストが使われている全ての箇所を検索できます。 

• テキストの検索と置換: エディタで開いたソースファイル内で、特定テキストを検索するには、[Edit] > [Find]を
選択して[Find]ダイアログ ボックスを開くか、[Edit] > [Replace]を選択して[Replace]ダイアログ ボックスを開

きます。これらのコマンドは、文字列がCコードエレメントであるかどうかに関係なく、一致する文字列を全て

検索します。 
• プロジェクト内の検索: [Find]コマンドと同様に、[Find in Projects]コマンドも、関数名かどうかに関係なく、一

致する文字列を検索します。[Edit] > [Find in Projects]を選択して[Find in Projects]ダイアログ ボックスを開き、

検索文字列を入力します。 

[Navigator]ウィンドウ内で関数をダブルクリックすると、ソースファイル内でその関数が宣言されている箇所を検索

できます。その関数が別のソースファイル内で宣言されている場合、関数を右クリックしてコンテクスト メニュー

から[Navigate] > [Go To Declaration]を選択します。 

関数またはパラメータの名前変更 

関数またはパラメータの名前を変更し、プロジェクト全体を通してその関数またはパラメータへの参照を更新するに

は、以下の手順を実行します。 

1. ソースエディタ内で関数またはパラメータを右クリックし、コンテクスト  メニューから [Refactor] > 
[Rename]を選択します。 

2. [Rename]ダイアログ ボックスに新しい名前を入力します。 
3. 必要に応じて[Preview]をクリックします。すると、[Refactoring]ウィンドウ内の[Source Editor]の下段に、変

更対象のコード行が表示されます。チェックを外すとその行は変更されません。 
4. [Do Refactoring]をクリックして、変更を適用します。 

関数またはパラメータにカーソルを合わせて<Ctrl>+<R>を押して新しい名前を入力すると、直接簡単に名前を変更

できます。名前の変更作業を終了するには[Escape]を押します。 

Cコードの移動、コピー、安全な削除 

これらの機能はC++コード専用です。10.1.6「[Refactor]メニュー」を参照してください。 
 
7.7 C/C++コードのエラー ディレクティブ 

コードで#errorディレクティブを使う場合、以下のように文をカッコで囲む事を推奨します。 
 

Redo - IDEは、影響を受けた全てのファイル内のリファクタリングした変更を繰り返します。 
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囲まれていない場合、構文パーサはCコンパイラと同じ方法で#errorディレクティブを扱い、そのトラックで停止

します。従って、エディタではこれを示すため、そのディレクティブ直後のテキストが灰色表示されます。 
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8. プロジェクト ファイルおよびフォルダ 
MPLAB X IDEでは通常、[File]ペイン内にプロジェクト ファイルとフォルダを操作するためのウィンドウ([Projects]、
[Files]、[Favorites]、[Classes])を表示します。 

本章で以下のプロジェクト ファイルおよびフォルダ関連トピックを確認する事を推奨します。 

• パス/ファイル/フォルダ名の制約 
• パス/ファイル/フォルダ プロジェクトに関する推奨事項 
• ユーザ コンフィグレーション データの表示 
• MPLAB IDE v8プロジェクトのインポート – 相対パス 
• プロジェクトの移動、コピー、リネーム 
• プロジェクトの削除 

 
 
8.1 [Projects]ウィンドウの表示 

[Projects]ウィンドウは、いわばプロジェクトの正面入口です。このウィンドウは重要なプロジェクト内容を表示し

ます。このウィンドウの詳細は12.15「[Projects]ウィンドウ」を参照してください。 

プロジェクトには少なくともソースファイルを追加する必要があります。MPLAB X IDEは、各種の既定値ファイル 
(ヘッダファイル、リンカスクリプト)を自動的に見つけます。ユーザはライブラリ ファイル、プリコンパイル済みオ

ブジェクト ファイル、編集済みのヘッダおよびリンカスクリプト ファイルを追加できます。ビルドに含めないファ

イルは「Important Files」の下に保存できます。 

図8-1 [Projects]ウィンドウ – 単純なCコード プロジェクト 

表8-1 [Projects]ウィンドウのフォルダ定義 
 

仮想フォルダ 保存するファイル 

Header Files ヘッダファイル(.h、.inc) 

Important Files その他の重要ファイル(makefile等)や 
データシートPDF等の文書ファイルをここに含める事ができます。 

Linker Files リンカファイル(.ld、.gld、.lkr) 

Source Files ソースファイル(.c、.cpp、.asm) 

Libraries ライブラリ ファイル(.a、.lib) 

Loadables プリコンパイル済みオブジェクト ファイル(.o) 
 

NetBeansヘルプトピックも参照してください。 [Help] > [Help Contents]を選択し、 [Search]タブに「Projects 
Window C or C++」と入力します。リストで最初に表示される[Projects]ウィンドウを見つけます。 
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8.2 [Files]ウィンドウの表示 
[Files]ウィンドウには、[Projects]ウィンドウに表示されないファイルとフォルダを含め、フォルダベースでプロジェク

トの内容を全て表示できます。 

図8-2 [Files]ウィンドウ – シンプルなCコード プロジェクト 

表8-2 [Files]ウィンドウのフォルダ定義 
 

フォルダ 概要 

MyProject MakefileファイルとCコードまたはアセンブリのアプリケーション ファイルを保存するプロ

ジェクト フォルダです。Makefileは、プロジェクトのマスタmakefileです。このファイルは

プロジェクト作成時に生成され、それ以降は一切変更されません(再生成されません)。GNU
のmakeに詳しければ、このファイルを編集してもかまいません。しかし、MPLAB X IDEで
は、Makefile自体を編集する代わりに、プリビルド/makeステップとポストビルド/makeステ

ップを追加する方法を使えます。 
build(1) 中間生成ファイルを保存するフォルダです。プロジェクト コンフィグレーション、使い方、

保存場所に応じたサブフォルダにファイルを保存しています。 
このフォルダは以下のファイルを保存しています。 

• 実行ファイル(.o) 
• 依存関係ファイル(.o.d) 
• HI-TECH®の中間生成ファイル(.p1) 
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(続き) 
フォルダ 概要 

dist(1) 出力ファイルを保存するフォルダです。プロジェクト コンフィグレーション、使い方、保存

場所に応じたサブフォルダにファイルを保存しています。 
このフォルダは以下のファイルを保存しています。 

• 実行ファイル(.hex) 
• ELFまたはCOFオブジェクト ファイル(.elf、.cof) 
• ライブラリ ファイル(.a、.lib) 

nbproject makefileとメタデータ ファイルを保存するフォルダです。以下のファイルを保存していま

す。 
• プライベート フォルダは、プロジェクトのユーザおよびコンピュータ固有の設定を保存

しています。 
• プロジェクトのmakefile 
• コンフィグレーション別のmakefile 
• project.xml: IDEが生成したメタデータ ファイル 
• configurations.xml: メタデータ ファイル 

default, MyConfig(2) プロジェクト コンフィグレーションを保存するフォルダです。ユーザがコンフィグレーショ

ンを一切作成しなかった場合、全てのコードは「default」フォルダに保存されます。 

production, debug(2) 量産バージョンとデバッグ バージョンのフォルダです。 

_ext(2) 外部プロジェクトのファイルを保存するフォルダです。プロジェクト フォルダの外部にある

ファイルを参照する場合、そのファイルがこのフォルダに表示されます。 

1. これらのフォルダをソース管理に含める必要はありません。これらのフォルダはビルドによって作成され

ます。5.23「リビジョン管理システムによるソースコードの管理」も参照してください。 
2. これらの項目は上図には示していません。 

 

NetBeansヘルプトピックも参照してください。[Help] > [Help Contents]を選択し、[Search]タブに「Files Window C 
and C++」と入力します。リストで最初に表示される[Files]ウィンドウを見つけます。 

 
 
8.3 [Classes]ウィンドウの表示 

CまたはC++コードの場合、[Classes]ウィンドウ([Window] > [Classes])で全てのクラス(関数)と各クラスのメンバお

よびフィールドを確認できます。 

NetBeansヘルプトピックも参照してください。[Help] > [Help Contents]を選択し、[Search]タブに「Using the 
Classes Window」と入力します。 
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図8-3 [Classes]ウィンドウ – シンプルなCコード プロジェクト 

 
8.4 [Favorites]ウィンドウの表示 

[Favorites]ウィンドウ([Window] > [Favorites])を使うと、プロジェクトの内外にかかわらず、コンピュータまたはネ

ットワーク上の任意のファイルまたはフォルダにアクセスできます。 

[Favorites]ウィンドウを初めて開いた時には、コンピュータのホームフォルダのみが含まれています。 

• ファイルまたはフォルダを追加するには、[Favorites]ウィンドウ内で右クリックして[Add to Favorites]を選択し

ます。 
• ファイルを追加するには、[Projects]ウィンドウ内でファイル名を右クリックして[Tools] > [Add to Favorites]を

選択します。 

図8-4 [Favorites]ウィンドウの表示例 

NetBeansヘルプトピックも参照してください。 [Help] > [Help Contents]を選択し、 [Search]タブに「Favorites 
Window」と入力します。 

 
8.5 パス/ファイル/フォルダ名の制約 

パス/ファイル/フォルダ名には以下のASCII文字のみ使えます。 

• A～Z 
• a～z 
• 0～9 
• アンダースコア: _ 
• ダッシュ: - 
• ピリオド: . 

Windows 

Windowsの最大パス長は260文字です。Microsoft社による説明は以下のURLをご覧ください。 

https://msdn.microsoft.com/en-us/library/windows/desktop/aa365247(v=vs.85).aspx 

https://msdn.microsoft.com/en-us/library/windows/desktop/aa365247(v=vs.85).aspx
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C:\MyProjects\mplab8project 

C:\MyProjects\mplab8project\mplab8project.X 

 
 

Windowsは、ユーザが長過ぎるパスを作成する事を妨げようとしますが、特定のアプリケーション、カット&ペース

ト等で、260文字を超えるパスを指定する事は可能です。しかし、プロジェクトのソースファイルが長過ぎるパスを

使っている場合、プロジェクトは正常にビルドされません。 

また、Windowsはコマンドを8191文字に制限しています。詳細は以下を参照してください。 

セクション「Command line too long (Windows)」 

 
クロス プラットフォーム オペレーティング システム 

MPLAB X IDEを複数のプラットフォーム(Windows、Mac、Linux)で使う場合、以下の点に注意します。 

• 相対パスにはフォワード スラッシュ「/」を使う必要があります。バックスラッシュ「\」は、Windowsプラット

フォーム以外では使えません。例: 
#include headers/myheader.h. 

• Linuxは大文字と小文字を区別します。従ってgenerictypedefs.hとGenericTypeDefs.hは区別されます。 
 
 
8.6 パス/ファイル/フォルダ プロジェクトに関する推奨事項 

プロジェクトに既存のファイルまたはフォルダを追加する場合、8.5「パス/ファイル/フォルダ名の制約」に記載し

た制約に注意してください。特にパスの長さには注意してください。Windowsには既知の制限(パス260文字、コマ

ンド8191文字)がありますが、パスが非常に長いと他のシステムで問題が発生する可能性があります。ビルドに失敗

する場合、パスを短くするか、ファイルまたはフォルダをプロジェクト フォルダに移動してみます。 

移植性を最大限に考慮したプロジェクトにするには、ファイルまたはフォルダのインポート時に相対パスを使います。 

関連リンク 
4.9.3「既存ファイルのプロジェクトへの追加」 
6.11「MPLAB X IDEプロジェクトのパッケージ化」 
8.5「パス/ファイル/フォルダ名の制約」 

 
8.7 ユーザ コンフィグレーション データの表示 

MPLAB X IDEのユーザフォルダ(userdir)は、ユーザ コンフィグレーション データ(例: ウィンドウ構成、エディタ設

定、メニューとツールバーのカスタマイズ、各種モジュールの設定(既知のコンパイラ一覧等))を保存しています。 

プラグインをインストールする場合([Tools] > [Plugins])、プラグイン情報(コード)は、MPLAB Xインストール フォル

ダではなく、ユーザフォルダに保存されます。この保存場所は、[Tools] > [Plugins] > [Settings] > [Advanced]の下で

[Plugin Install Location]ドロップダウン メニューから[Force install into shared directories]を選択して変更できます。 

ユーザフォルダの保存場所を調べるには、[Help] > [About]を選択しUserdirの次のパスを見つけます。この情報は

MPLAB X IDEが作成および管理します。 
 
8.8 MPLAB IDE v8プロジェクトのインポート – 相対パス 

MPLAB IDE v8プロジェクトは以下のパスに保存されています。 
 

MPLAB IDE v8プロジェクトをMPLAB X IDEにインポートした場合、以下のファイルが作成されます。 
 

既定値では、MPLAB X IDEにインポートしたプロジェクトは、両方のプロジェクトの保守性を維持するために、

MPLAB IDE v8プロジェクトの下に置かれます。これに対し、MPLAB X IDEのプロジェクト フォルダはどこに置い

てもかまいません。また、プロジェクト名はmplab8project.Xに設定されますが、変更してもかまいません。MPLAB 
X IDEのプロジェクト名は.Xで終わるという規則がありますが、あくまで便宜的なものです。 

新規プロジェクトは、ソースファイルをプロジェクト フォルダにコピーしません。その代わりに、v8フォルダ内の

ファイル保存場所を参照します。独立したMPLAB X IDEプロジェクトを作成するには、新規プロジェクトを作成し

て、MPLAB IDE v8のソースファイルを、そのプロジェクトにコピーする必要があります。 
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詳細は5.3「MPLAB IDE v8プロジェクトのインポート」を参照してください。 
 
 
8.9 プロジェクトの移動、コピー、リネーム 

プロジェクトを作成した後で、変更する必要がある事に気付く場合があります。プロジェクトを右クリックすると開

くコンテクスト メニューを使うと、MPLAB X IDE内でプロジェクトを移動、コピー、リネームできます。プロジェ

クトを削除する事もできます。詳細は12.15「[Projects]ウィンドウ」 - [Project]メニューを参照してください。 

外部ツールを使う事もできます。プロジェクト ファイルの構造は、MPLAB X IDEを使わなくても問題ないようにな

っています。 
 
 
8.10 プロジェクトの削除 

MPLAB X IDEでプロジェクトを削除する方法 

1. [Projects]ウィンドウでプロジェクト名を右クリックして[Delete]を選択します。 
2. [Delete Project]ダイアログでは以下を削除できます。 

2.1. コンピュータに保存されているプロジェクト ファイル - 一部のソースファイルは削除されません。 
2.2. プロジェクト ファイルと全ソースファイル (チェックボックス経由)プロジェクトは削除され、

MPLAB X IDEからは見えなくなります。 

Note:  MPLAB X IDEは終了時に、プロジェクトに割り当てられた全てのリソースを解放する訳ではありません。

MPLAB X IDEはJava上で動作しているため、リソースの解放は即座には行われません。Javaでは、ガーベジ コレク

ション(GC)を呼び出すタイミングをJREに決定させるのが最善の方法です。しかし、メモリツールバーを有効にして

クリックする事で、GCを強制的に実行する事もできます。 
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9. トラブルシュート 
本章には、MPLAB X IDEの使用中に問題やエラーが発生した場合の対処に役立つ情報を記載しています。ここに記

載した方法で対処できなかった場合はMicrochip社までお問い合わせください。連絡先は本書の「サポート」に記載

しています。 
 
9.1 USBドライバのインストールに関する問題 

正しいUSBドライバのインストール方法は2.3「USBデバイスドライバ (ハードウェア ツール用)のインストール」を

参照してください。 
問題が生じた場合の対処方法は2.3.3.5「ツールの通信の問題」を参照してください。 

 

9.2 オペレーティング システムに関する問題 
オペレーティング システムが異なると、パス、ファイル、フォルダの命名に関する問題も異なります。詳細は以下

を参照してください。 
8.5「パス/ファイル/フォルダ名の制約」 

 
9.3 NetBeansプラットフォームに関する問題 

NetBeansプラットフォームのリリース バージョンによっては、MPLAB X IDEの使用に際して問題が生じる可能性

があります。詳細は以下のNetBeansウェブサイトをご覧ください。 

http://www.netbeans.org 
http://netbeans.org/community/releases/index.html 

以下はMPLAB X IDEで既知の問題です。 

• 前景色として[Inherited]を選択すると、カテゴリのテキストがエディタ内で見えなくなる 
• デバッグ用のインジケータが表示されない 
• 識別子を解決できない 
• コードを素早くステップ実行すると、[Watches]ウィンドウでSFRが選択解除される 
• 9.3.5「サブメニューに移動するとメニューが消える事がある」 

 
9.3.1 前景色として[Inherited]を選択すると、カテゴリのテキストがエディタで見えなくなる 

フィールドの前景色([Foreground])が[Inherited]の場合、ポップアップ完了ウィンドウ (ヒント)内のテキストが見えな

くなります。ポップアップ完了ウィンドウには、未選択のエントリが白の背景に白のテキストとして表示されます。

一覧を下にスクロールすると、エントリごとに青の背景に白のテキストで表示されます。それ以外の機能は正常に働

いているように見えます。 

この問題はNetbeans Bugzillaの[Fonts & Colors]の問題として登録されています。

https://netbeans.org/bugzilla/show_bug.cgi?id=249766 
[Options] > [Fonts & Colors]。[Syntax]タブの任意のカテゴリで前景色として[Inherited]を選択すると、エディタ内で

テキストが見えなくなります。プリファレンスxmlファイル「org-netbeans-modules-editor-settings- 
CustomFontsColors-tokenColorings.xml」を見ると、問題のあるカテゴリ(例: 「Field」、「Identifier」)の前景の属性

に有効な色へのリンクが存在しない事が分かります。 

回避策: 

1. [Tools] > [Options]、[Fonts & Colors]ボタン、[Syntax]タブを選択します。 
2. [Language]に[C]を選択します。 
3. [Category]で[Field]をクリックします。 
4. [Foreground]に[Inherited]が選択されている事を確認します。リストから任意の色を選択します。 
5. [OK]をクリックします。 

 
9.3.2 デバッグ用のインジケータが表示されない 

デバッグ実行中のようですが、一時停止矢印または線の強調表示がなく、ブレークポイントが破損して表示されます

(ガーターのアイコンが壊れている)。これはファイルパスが正しく設定されていない時に発生します。8.5「パス/フ
ァイル/フォルダ名の制約」を参照してください。 

http://www.netbeans.org/
http://netbeans.org/community/releases/index.html
https://netbeans.org/bugzilla/show_bug.cgi?id=249766
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例: 
 
 
 
 
 
 
 
 
 
 
 
 
以下も参照してください。

https://netbeans.org/bugzilla/show_bug.cgi?id=256329 

void main(void) 
{ EEPROM_DATA 
edata; 
edata.data [0] = 0xAA; // this is ok 
edata.signature2 = 0xDD; // unresolved ident. 

 

// unresolved ident. 

struct dados { 
unsigned char signature1; 
unsigned char signature2; 

}; 
typedef union { 

unsigned char data [2]; 
struct dados; 

} EEPROM_DATA; 

<install path>ld.exe: cannot find file.o 

 
 

9.3.3 識別子を解決できない 
ライブパーサが名前のない構造にネストされた構造の未解決識別子を表示します。これは、NetBeansネイティブ

CNDが匿名フィールド宣言をサポートしていないためです。これはフィールドの識別子を指定する事で回避できま

す。ただし、コードでは使用するたびにそのフィールド名を指定する必要があります。 

 

9.3.4 コードを素早くステップ実行すると、[Watches]ウィンドウでSFRが選択解除される 
ステップ実行すると、カーソルがソースで更新され、[Watches]ウィンドウからフォーカスが削除されます。その後、

Netbeansは[Watches]ウィンドウ全体を再描画し、ハイライトを削除します。 
 

9.3.5 サブメニューに移動するとメニューが消える 
WindowsでMPLAB X IDEメニューを選択してサブメニューを選択すると、メニューが消える事があります。この問

題を解決するには、MPLAB X IDEを再起動します。 
 
 
9.4 MPLAB X IDEに関する問題 

下表にMPLAB X IDEの問題を示します。この表で問題の解決策が見つからない場合、プロジェクトのデバッグおよ

びコンパイルツール関連文書も参照してください。 

• MPLAB IDE v8プロジェクトのインポート – 設定 
• MPLAB IDE v8プロジェクトのインポート – 変更されたリンカスクリプト 
• MPLAB C18 Cコンパイラと構造 
• プロジェクトがエンプティである/プロジェクト ファイルが灰色表示されている 
• エディタ内のコードが#error文の後に灰色表示されている 
• インターネット接続が安定していないため、最新のツールチェーンをダウンロードできない 

 
9.4.1 MPLAB IDE v8プロジェクトのインポート – 設定 

MPLAB IDE v8のワークスペースに保存されている設定(ツール設定等)は、新しいMPLAB X IDEプロジェクトに転送

されません。ワークスペースに保存されている情報の内容については、MPLAB IDE v8ヘルプ([MPLAB IDE 
Reference] > [Operational Reference] > [Saved Information])を参照してください。 

 
9.4.2 MPLAB IDE v8プロジェクトのインポート – 変更されたリンカスクリプト 

MPLAB IDE v8プロジェクトのリンカスクリプトを変更してオブジェクト ファイルをインクルードするようにしてい

た場合、MPLAB X IDEにインポートすると、リンカはそのファイルを見つける事ができません。MPLAB IDE v8と
MPLAB X IDEではビルドパスが異なるからです。 

従って、以下のようなエラーが表示されます。 
 

https://netbeans.org/bugzilla/show_bug.cgi?id=256329
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/* Global-namespace object initialization - MPLAB v8*/ 
.init : 
{ 
KEEP (crti.o(.init)) 
: 
} >kseg0_program_mem 

/* Global-namespace object initialization - MPLAB X*/ 
.init : 
{ 
KEEP (*crti.o(.init)) 
: 
} >kseg0_program_mem 

int attribute ((address(0x9D001000))) myfunction (void) {} 

 
 

MPLAB IDE v8では、ビルド関連のファイルが全て1つのフォルダに保存されるのに対し、MPLAB X IDEではビルド

ファイルが別々のサブフォルダに保存されるためです。 

既存のリンカスクリプトにワイルドカードを使えば、MPLAB X IDEでも動作させる事ができます。例えば、 
 

から以下に変更します。 
 

これとは別に、Cコードに関数を配置できるアドレス属性を使う方法もあります。 
 

これによって、既定値のリンカスクリプトを変更する事なく、アドレスに関数を配置できます。 
 

9.4.3 MPLAB C18 Cコンパイラと構造 
RAMメモリ内の構造のポインタ値は、[Watches]ウィンドウ内では正しく表示されません。これは、コンパイラが完

全なデバッグ情報を保存しないためです。この問題の回避策は、MPLAB XC8 Cコンパイラを代わりに使う事です。 
 

9.4.4 プロジェクトがエンプティである/プロジェクト ファイルが灰色表示されている 
破損したプロジェクトをロード、かつダイアログの質問の答えを間違えた場合、[Projects]ウィンドウが灰色表示さ

れ、「ソースファイルがないためプロジェクトをビルドできない」というメッセージが表示されます。 

図9-1 プロジェクト エンプティエラー 

この問題は、破損したプロジェクトをMPLAB X IDEにロードした場合に発生します。Cソースファイルをヘッダファ

イルに関連付けられるかどうか尋ねるダイアログが表示されます。この時点で[No](既定値)をクリックする事で、こ

の問題を回避できます。 

図9-2 新ヘッダ拡張子エラー 

しかし、[Yes]をクリックするとソースファイルがヘッダファイルとして認識されてしまい、プロジェクトは空のよ

うに見えます。プロジェクトを修復するため、以下のどちらかの方法が使えます。 

• MPLAB X IDEを終了します。 
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• [Help] > [About]ダイアログで指定されているMPLAB X IDEのユーザフォルダに移動し、MPLAB X IDEの使用中

のバージョンのフォルダを削除します。例えば、フォルダv3.05を
C:\Users\UserName\AppData\Roaming\mplab_ide\dev\v3.05から削除します。 

• MPLAB X IDEを再起動します。 
または 
• [Tools] > [Options]を選択し、[Embedded]ボタンをクリックし、[Other]タブを開きます。 
• ヘッダファイルの関連付けから「c」を削除します。 
• ソースファイルの関連付けに「c」を追加します。 
• [OK]をクリックします。 

 
9.4.5 エディタ内のコードが#error文の後に灰色表示されている 

7.7「C/C++コードのエラー ディレクティブ」を参照してください。 
 

9.4.6 インターネット接続が安定していないため、最新のツールチェーンをダウンロードできない 
インターネット接続が不安定であると判断されたため、以下のリンクで説明している機能を利用できません。 

4.1.8.2「最新MPLAB XCコンパイラのダウンロード」 
 
 
9.5 エラー 

IDEは様々な形でエラーを示しますが、多くの場合ウィンドウ内のアイコンまたは[Output]ウィンドウ内のメッセー

ジとしてエラーを表示します。アイコンにカーソルを合わせると、問題の内容を示すメッセージが表示されます。

テキスト メッセージについては、オンラインヘルプで該当するエラーを検索してください。 

IDEとエディタの一般的なエラーと解決方法を以下のセクションに示します。 

• Command line too long (Windows) 
• Couldn’t reserve space for Cygwin™ heap (Windows 7または8) 
• Destination Path Too Long/The filename or extension is too long (Windows) 
• The project ProjectName is empty 
• For 8-bit code, #asm and #endasm cause red bangs in the Editor window 
• For 16-bit code, MPLAB XC16 packed attribute statement causes red bangs in the Editor window 
• Hexmate Conflict Report Address Error 
• Programming Errors 
• Programmer to Go Not Supported 
• Mouseover shows “Not Recognized” in Editor 
• Error Code in -10000 Range 

 
9.5.1 Command line too long (Windows) 

プロジェクトのmakefile実行時、各コマンドはローカル ネイティブシェルに渡されます。Windowsでは8191文字と

いう制限があります。従って、数百Cファイルをリンクするプロジェクトでは、この制限を超えて上のエラーが表示

される事があります。 

LinuxとmacOSは、通常非常に長いコマンドラインを扱う事ができます。使用中のシステムでその長さを調べるには、

コマンドラインでgetconf ARG_MAXと入力します。 

応答ファイルを使った回避策 

MPLAB XC8/MPLAB XC32 Cコンパイラのv1.01以降、MPLAB XC16 Cコンパイラのv1.22以降の場合、リンカを呼

び出す際に応答ファイルを使えば、この問題を回避できる場合があります。 

• MPLAB XC8の場合、[Project Properties]*ウィンドウで[Categories]の[XC8 linker]をクリックします。[Option 
categories]で[Additional Options]を選択します。[Use response file to link]横のチェックボックスを選択します。 

• MPLAB XC16の場合、 [Project Properties]*ウィンドウで [Categories]の [xc16-ld]をクリックする。 [Option 
categories]で[General]を選択します。[Use response file to link]横のチェックボックスを選択します。 

• MPLAB XC32の場合、 [Project Properties]*ウィンドウで [Categories]の [xc32-ld]をクリックする。 [Option 
categories]で[General]を選択します。[Use response file to link]横のチェックボックスを選択します。 
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// Inline Code that causes error 
#asm 

movlw 0x20; 
nop; 

 
 

* [Project Properties]ウィンドウを開くには、4.3「[Project Properties]ウィンドウを開く」を参照してください。 

ライブラリによる回避策 

その他全てのコンパイラの場合、MPLAB X IDEライブラリ プロジェクトを作成し、メイン プロジェクトからライブ

ラリ プロジェクトにいくつかのソースファイルを移動します。その後、ライブラリ プロジェクトをメイン プロジェ

クトに追加する事で、この問題を回避できます。 

ライブラリ プロジェクトを作成するには、[File] > [New Project]を選択し、[Microchip Embedded]カテゴリをクリッ

クし、プロジェクトとして[Library Project]を選択します。 

ライブラリをメイン プロジェクトに追加するには、[Project Properties]ウィンドウを開き([File] > [Project 
Properties])、[Categories]の[Libraries]を選択し、[Add Library Project]ボタンをクリックします。 

アーカイブ チェックボックスによる回避策 

現在ではMPLAB XC16とMPLAB XC32は、長いファイルセットをライブラリにアーカイブする際にリンク行が文字

数の制限を超える可能性がある場合に使えるチェックボックスを備えています。「Break into multiple lines」を使っ

てアーカイブ行を短い行に分割し、この制限を回避するようにコンパイラを設定できます。 

このオプションは、[Project Properties]ウィンドウで[xc16-ar]または[xc32-ar]カテゴリを選択した後、[General]オプ

ション カテゴリの[Break into multiple lines]チェックボックスで設定します。 
 

9.5.2 Couldn’t reserve space for MinGW heap 
MPLAB X IDEは、make処理にMinGWを使います。Windowsでは、仮想メモリの割り当てエラーが発生する可能性が

あります。 

Windows 7または8 
仮想メモリの設定を変更するには、[スタート] > [コントロール パネル]をクリックしてコントロール パネルを開きま

す。[システム]をクリックし、[システムとセキュリティ] > [システム] > [システムの詳細設定]または[システムの保護]
を選択します。[詳細設定]タブで、[パフォーマンス]の[設定]ボタンをクリックします。このダイアログで、[詳細設

定]タブをクリックし、[変更]ボタンをクリックします。[カスタムサイズ]に以下の値を入力します。 

• 初期サイズ(MB) = 「現在の割り当て」の値(下段に表示されている値) 
• 最大サイズ(MB) = 「推奨」の値(下段に表示されている値)  

[設定]をクリックし、[OK]をクリックしてからPCを再起動します。Windows 10 

以下を参照してください。 

https://www.geeksinphoenix.com/blog/post/2016/05/10/how-to-manage-windows-10-virtual-memory.aspx 
 

9.5.3 Destination Path Too Long/The filename or extension is too long (Windows) 
Windowsの最大パス長は260文字です。詳細は8.5「パス/ファイル/フォルダ名 の制約」を参照してください。 

 
9.5.4 The project ProjectName is empty 

9.4.4「プロジェクトがエンプティである/プロジェクト ファイルが灰色表示されている」を参照してください。 
 

9.5.5 For 8-bit code, #asm and #endasm cause red bangs in the Editor window 
#asm文と#endasm文はMPLAB XC8 Cプログラム内でインライン アセンブリコードを宣言するのに有効な構造です。

しかしIDEのエディタでは、Cプリパーサはこれらを有効なディレクティブとは認識せず、これらの文の隣に赤の感

嘆符を表示します。しかし、このコードはこのままでも動作します。 

エディタ内の赤の感嘆符を除去する場合、asm()文を使います。これは、全てのMPLAB XC Cコンパイラでインラ

イン アセンブリを使う際に推奨する方法です。 

例: 

https://www.geeksinphoenix.com/blog/post/2016/05/10/how-to-manage-windows-10-virtual-memory.aspx
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unsigned long long Bits8 : 8 attribute ((packed)); 

attribute ((packed)) unsigned long long Bits8 : 8; 

 
 

 

 
 

9.5.6 For 16-bit code, MPLAB XC16 packed attribute statement causes red bangs in the Editor window 
コンパイラのパーサは以下の文をエラーとしてマーク表示します。しかし、これらの文はビルドされます。 

 

修飾子に対するパーサのルールでは順序は決まっていません。通常は修飾子は全て識別子の前に指定します。従って、

以下のどちらかの文を使えばエラーは発生しません。 

 
または 

 

 

9.5.7 Hexmate Conflict Report Address Error 
Hexmateが競合レポートを生成した場合、HEXファイル内の競合アドレスとデータが格納されているメモリの

[Memory]ウィンドウに表示されるアドレスが異なる場合があります。以下に例を示します。 

表9-1 HEXアドレスとメモリアドレスの関係 
 

デバイスファミリ HEXファイル内のアドレス メモリ内のアドレス 

ベースライン 0x100 0x80* 

ミッドレンジ 0x100 0x80* 

PIC18 MCU 0x100 0x100 

16ビットデバイス 0x100 0x80* 

32ビットデバイス 0x100 0x100 
* デバイスによっては、競合レポートに表示されたアドレスはメモリ内のデータアドレスの2倍の値となります。 

 
9.5.8 プログラムエラー 

デバイスをコード保護した後にプログラミングしようとすると、アドレス領域に対してプログラミング エラーが出

力されます。 

[Erase Device Memory Main Project]  機能は、これがプログラミングの問題かどうかを判断するのに役立ちます。

この機能は、ツールバーにアイコンとして追加できます([View] > [Toolbars] > [Customize])。またはMPLAB IPEを使

います。 

1. コード内でコード保護が無効になっている事を確認します。 
2. デバイスメモリを消去します。これによりコンフィグレーション ビットの設定が消去されます。 
3. デバイスを再プログラミングします。 

プログラミングが正常終了した場合、コード保護が原因であった事が分かります。 

unsigned long long attribute ((packed)) Bits8 : 8; 

nop; 
#endasm 

// Workaround for inline assembly - that will not cause error 
// (Multi line asm code) 

asm("\ 
movlw 
0x20;\ nop;\
 nop;"); 

// Workaround for inline assembly - that will not cause Error 

// (Single line asm code) 
asm("movlw 0x20; nop; nop"); 
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9.5.9 Programmer to Goがサポートされていない 
現在、コンフィグレーション(config)ワードが多過ぎるデバイスはProgrammer to Go (PTG)をサポートできません。

PTGはconfigワードが一度に送信される事を期待していますが、MPLAB X IDEはconfigワードが大量にあるデバイス

に対して、各configワードを一度に1つずつ送信します。 
 

9.5.10 エディタ内のマウスオーバーで[Not Recognized]と表示される 
エディタ内で値を表示するためにマウスオーバーを使う場合、以下を確認します。 

1. デバッグモード中([Debug] > [Debug Project])である(デバッグ実行中でないとシンボル値は表示されません。) 
2. マクロにマウスを合わせていない(この方法でマクロの値を見る事はできません。マクロを右クリックして

[Navigate] > [View Macro Expansion]を選択し、[Macro Expansion]ウィンドウを開きます。) 
 

9.5.11 Error Codes in -10000 Range 
「Error codes in the -10000 range」はMicrosoftエラーコードを表します。Microsoftエラーコードを確認するには、

数値を正(-10121は10121)にし、10000を減算します(10121-10000 = 121)。Microsoftエラーコードは以下で確認でき

ます。 

https://msdn.microsoft.com/en-us/library/windows/desktop/ms681382(v=vs.85).aspx 
 
 
9.6 フォーラム 

ここまでの説明で問題が解決しない場合、Microchip社のフォーラムを参照してください。

http://www.microchip.com/forums/f238.aspx 

このフォーラムは、問題に関するディスカッションや投稿された解決策を掲載しています。 

https://msdn.microsoft.com/en-us/library/windows/desktop/ms681382(v=vs.85).aspx
http://www.microchip.com/forums/f238.aspx
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10. デスクトップの詳細 
MPLAB® X IDEデスクトップは、他のデスクトップ アイテムとは独立して動作するサイズ変更可能なウィンドウです。

デスクトップはメニュー、ツールバー、ステータスバー、タブ形式のウィンドウで構成されています。本章ではメニ

ュー、ツールバー、ステータスバーについて説明します。ウィンドウとダイアログについては次章で説明します。 

Note:  NetBeansヘルプトピックで「workspace」と書かれている場合、それは「デスクトップ」の事を意味します。

この「workspace」は、MPLAB IDE v8以前のバージョンの「ワークスペース」の事ではありません。 

図10-1 MPLAB® X IDEのデスクトップ 

 
 
10.1 メニュー 

MPLAB® X IDEの多くの機能は、デスクトップ最上段にあるメニューバーからメニュー項目として選択できます。メ

ニュー項目の右側に「(...)」が付く場合、その項目を選択するとダイアログが開きます。ダイアログの詳細は12.
「MPLAB X IDEのウィンドウとダイアログ」を参照してください。 

 
メニュー項目の横にはショートカット キーが表示されます 

例: [New File]のショートカット キーは<Ctrl>+<N>です。ショートカット キーの詳細は[Help] > [Keyboard Shortcuts 
Card]を参照してください。 

メニュー項目は状況に応じて無効化(灰色表示)される事があります。10.4「メニュー項目とボタンの灰色表示または

非表示」を参照してください。 
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ウィンドウ内で右クリックすると、コンテクスト メニューが表示されます。これらのメニューの詳細は12.15
「[Projects]ウィンドウ」を参照してください。 

メニュー一覧を以下に記載します。 

Note:  [Start Page]で[My MPLAB IDE] > [Extend MPLAB] > [Selecting Simple or Full-Featured Menus]を選択すると、

全てのメニューとメニュー項目を表示できます。それらのメニュー項目には、組み込みシステム開発では使わない項

目も含まれています。 
 

10.1.1 [File]メニュー 
本セクションでは[File]メニューの項目を示します。 

これらのメニュー項目の一部に割り当てられているキーボード ショートカットについては[Help] > [Keyboard 
Shortcuts Card]を参照してください。 

表10-1 [File]メニューの項目 
 

コマンド 動作 

New Project [New Project]ウィザードを使ってプロジェクトを新規作成します。 

New File [New File]ウィザードを使ってファイルを新規作成します。 

Open Project 既存のプロジェクトを開きます。 

Open Recent Project 最近開いた全てのプロジェクトの一覧を表示します。 

Import 以下のいずれかをインポートします。 
• Hex/ELF...(Prebuilt) File – 別のツールを使ってビルドしたファイル 
• MPLAB IDE v8 Project – [Import Legacy Project]ウィザードを起動 
• その他の組み込み – その他の組み込みプラットフォームからのインポート 
• ZIPから – アーカイブしたプロジェクトからのインポート (ファイルを解凍してインポ

ート) 
Close Project 現在のプロジェクトを閉じます。 

Close Other Projects メイン プロジェクト以外の全プロジェクトを閉じます。 

Close All Projects 開いている全てのプロジェクトを閉じます。 

Open File 既存のファイルを開きます。 

Open Recent File ファイルを選択するために、最近開いた全てのファイルの一覧を表示します。 

Project Group 現在のプロジェクトをグループに割り当てます。 

Project Properties [Project Properties]ウィンドウを開きます。 

Save 現在のファイルを保存します。 

Save As 現在のファイルを、パス/名前を変更して保存します。 

Save All 開いている全てのファイルを保存します。 
[Compile on Save]を設定している場合、保存時にプロジェクト ファイルをコンパイル/ビル
ドします。 

Page Setup 印刷用にページを設定します。 

Print 現在のファイルを印刷します(プレビュー付き)。 

Print to HTML 現在のファイルをHTML形式で書き出します。 

Exit MPLAB® X IDEを終了します。 

 
10.1.2 [Edit]メニュー 

本セクションでは[Edit]メニューの項目を示します。 

これらのメニュー項目の一部に割り当てられているキーボード ショートカットについては[Help] > [Keyboard 
Shortcuts Card]を参照してください。 
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表10-2 [Edit]メニューの項目 
 

コマンド 動作 

Undo 以前のエディタ操作を1つずつ遡って取り消します(保存操作は取り消せません)。 

Redo 以前の[Undo]操作を1つずつ元に戻します。 

Cut 現在選択している内容を削除し、クリップボードに移動します。 

Copy 現在選択している内容をクリップボードにコピーします。 

Paste クリップボードの内容を現在の選択位置に挿入します。 

Paste Formatted クリップボードの内容を、書式設定付きで現在の選択位置に挿入します。 

Paste from History コピー履歴の内容を現在の選択位置に挿入します。 

Delete 現在選択している内容を削除します。 

Select All 現在の文書またはウィンドウ内の全ての内容を選択します。 

Select Identifier カーソルに最も近い単語を選択します。 

Find Selection 現在選択している内容に一致するインスタンスを検索します。 

Find Next 一致するテキストのインスタンスを順方向に検索します。 

Find Previous 一致するテキストのインスタンスを逆方向に検索します。 

Find 文字列を検索します。 

Replace 文字列を検索し、一致した文字列を指定した別の文字列に置換します。 

Find Usages 選択したコードが使われている箇所とサブタイプを検索します。 

Find in Projects 指定したテキスト、オブジェクト名、オブジェクト タイプをプロジェクト内で検索し

ます。 
Replace in Projects テキスト、オブジェクト名、オブジェクト タイプをプロジェクト内で置換します。 

Start Macro Recording マクロ用のキー操作の記録を始めます。 

Stop Macro Recording キー操作の記録を終了します。 
 
マクロを管理するには、[Tools] > [Options]を選択し、[Editor]ボタンをクリックし、

[Macros]タブを開きます。 
 

10.1.3 [View]メニュー 
本セクションでは[View]メニューの項目を示します。 

これらのメニュー項目の一部に割り当てられているキーボード ショートカットについては[Help] > [Keyboard 
Shortcuts Card]を参照してください。 

表10-3 [View]メニューの項目 
 

コマンド 動作 

Editors ファイルを表示するエディタを選択します。 
• History – このファイルの編集履歴を表示します。 
• Source – このファイルのソースコードを表示します。 

Split 現在のエディタ ウィンドウを、垂直または水平方向に2分割します。 

Code Folds>Collapse Fold カーソル位置が折り畳み可能なテキスト内である場合、そのセクションを折り

畳みます。 

Code Folds>Expand Fold カーソル位置が折り畳まれたセクションである場合、そのセクションを展開し

て表示します。 
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(続き) 
コマンド 動作 

Code Folds>Collapse All 折り畳み可能なテキスト セクションを全て折り畳みます。 

Code Folds>Expand All 折り畳まれているテキスト セクションを全て展開します。 

Code Folds>Collapse Fold Tree ネスティングされた複数の折り畳みを全て折り畳みます。 

Code Folds>Expand Fold Tree ネスティングされた複数の折り畳みを全て展開します。 

Web Browser 既定値のウェブブラウザを開いて、NetBeansホームページを表示します。 

IDE Log [Output]ウィンドウのタブにログファイルを開きます。 

Toolbars>File, etc. 関連ツールバーを表示します。 

Toolbars>Small Toolbar Icons Uses small icons on the toolbars. 

Toolbars>Reset Toolbars ツールバーを既定値の状態に戻します。 

Toolbars>Customize 既存ツールバーのカスタマイズまたはツールバーを新規作成できます。 

Show Editor Toolbar [File]タブにエディタのツールバーを表示します。 

Show Line Numbers 左の余白に行番号を表示します。 

Show Non-printable Characters 印刷できない文字(非ASCI)であっても表示します。 

Show Breadcrumbs エディタ ウィンドウ下部にブレッドクラム (プロジェクト ファイルからそのフ

ァイルまでのパス)を表示します。 

Show Indent Guide Lines インデントを表す薄い線を表示します。 

Show Diff Sidebar DIFFサイドバーを表示します。 

Show Versioning Labels バージョンラベルを表示します。 

Synchronize Editor with Views 開いている画面にエディタを同期させます。 

Show Only Editor IDEウィンドウ全体にエディタ ウィンドウを表示します。 

Full Screen ウィンドウを全画面表示にします。 
 

10.1.4 [Navigate]メニュー 
本セクションでは[Navigate]メニューの項目を示します。 

これらのメニュー項目の一部に割り当てられているキーボード ショートカットについては[Help] > [Keyboard 
Shortcuts Card]を参照してください。 

表10-4 [Navigate]メニューの項目 
 

コマンド 動作 

Go to File 指定したファイルを検索して開きます。 

Go to Type 指定したクラスまたはインターフェイスを検索して開きます。 

Go to Symbol 指定したシンボル名を検索します。 

Go to Previous Window 1つ前に選択したウィンドウにフォーカスします。 

Go to Source 選択したクラスの定義を含むソースファイルを表示します。 

Go to Declaration カーソル位置のアイテムの宣言位置へ移動します。 

Go to Super Implementation カーソル位置のアイテムのスーパー 実装位置へ移動します。 

Last Edit Location 直前に編集した位置にジャンプします。 

Back 逆方向に移動します。 
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Forward 順方向に移動します。 

Go to Line 指定した行に移動します。 

Toggle Bookmark コード行にブックマークを設定します。 

Bookmark History Popup Next [Bookmark]ウィンドウの次のブックマークに移動します([Window] > [IDE 
Tools] > [Bookmarks])。 

Bookmark History Popup Previous [Bookmark]ウィンドウの1つ前のブックマークに移動します([Window] > 
[IDE Tools] > [Bookmarks])。 

Next Error 次のビルドエラーを含む行にジャンプします。 

Previous Error 1つ前のビルドエラーを含む行にジャンプします。 

Select in Projects [Projects]ウィンドウを開いて、その中で現在の文書を選択します。 

Select in Files [Files]ウィンドウを開いて、その中で現在の文書を選択します。 

Select in Classes [Classes]ウィンドウを開いて、その中で現在の文書を選択します。 

Select in Favorites [Favorites]ウィンドウを開いて、その中で現在の文書を選択します。 
 

10.1.5 [Source]メニュー 
本セクションでは[Source]メニューの項目を示します。 

これらのメニュー項目の一部に割り当てられているキーボード ショートカットについては[Help] > [Keyboard 
Shortcuts Card]を参照してください。 

表10-5 [Source]メニューの項目 
 

コマンド 動作 

Format 選択したコード(何も選択していない場合はファイル全体)をフォーマットします。 

Remove Trailing Spaces 行末のスペースを削除します。 

Shift Left 選択した行をタブ1つ左へシフトします。 

Shift Right 選択した行をタブ1つ右へシフトします。 

Move Up 選択した行を1行上へ移動します。 

Move Down 選択した行を1行下へ移動します。 

Move Code Element Up 選択したコードエレメントを1行上へ移動します。 

Move Code Element Down 選択したコードエレメントを1行下へ移動します。 

Duplicate Up 選択した行を1行上に複製します。 

Duplicate Down 選択した行を1行下に複製します。 

Toggle Comment 選択した行をコメント化(または解除)します。 

Complete Code コード補完ボックスを表示します。 

Insert Code コンストラクタ、ゲッター、セッター等、一般的な構造体の生成に使えるコン

テクスト メニューを開きます。 

Fix Code エディタが提示するヒントを表示します。 
ユーザに提示可能なヒントが存在する場合、IDEは電球アイコンを表示します。 

Show Method Parameters 次のパラメータを選択します。 
このショートカットを使う前に、1つのパラメータを選択(ハイライト表示)してお

く必要があります。 
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Show Documentation カーソル位置のアイテムの説明を表示します。 

Insert Next Matching Word 入力した文字列から始まる(不完全な)単語を、コード内で順方向に検索し、最

初に見つかった単語に基づいて、入力した文字列を補完します。 

Insert Previous Matching Word 入力した文字列から始まる単語を、コード内で逆方向に検索し、最初に

見つかった単語に基づいて、入力した文字列を補完します。 

Inspect 選択中のファイル、パッケージ、プロジェクトのいずれかに関する指定した検査を

実行します。 
Scan for External Changes ファイルをスキャンして、MPLAB® X IDEの外部で加えられた変更を見つけます。 

 

10.1.6 [Refactor]メニュー 
本セクションでは[Refactor]メニューの項目を示します。メニューに表示される項目は、リファクタリングするオブジ

ェクトのタイプ(変数、関数等)によって異なります。詳細は7.6「Cコードのリファクタリング」を参照してください。 

これらのメニュー項目の一部に割り当てられているキーボード ショートカットについては[Help] > [Keyboard 
Shortcuts Card]を参照してください。 

表10-6 [Refactor]メニューの項目 
 

コマンド 動作 

Rename 変数または関数名を変更し、プロジェクト内の全ソースコードを更新します。 

Move クラスを別のパッケージまたはクラスに移動し、 
プロジェクト内の全てのコードを更新します。 

Copy クラスを同じパッケージまたは別のパッケージにコピーします。 

Safely Delete コードエレメントへの参照を確認し、他のコードから参照されていなければそのエレメント

を削除します。 

Change Function 
Parameter 

関数のパラメータの数と名前を変更します。 

Encapsulate Fields C++専用: このオプションを表示するにはC++ソースファイル内でクリックします。 
フィールド用のゲッターメソッドとセッターメソッドを自動的に生成し、オプションで全て

の参照コードを更新して、ゲッターメソッドとセッターメソッドでフィールドにアクセスし

ます。 

以下も参照してください。

http://wiki.netbeans.org/Refactoring 
 

10.1.7 [Production]メニュー 
本セクションでは[Production]メニュー(以前の[Run]メニュー)の項目を示します。 

Note:  [Run]操作はこのメニューから削除されましたが、ツールバーのアイコン として引き続き使用できま

す。これらのメニュー項目の一部に割り当てられているキーボード ショートカットについては[Help] > [Keyboard 
Shortcuts Card]を参照してください。 

表10-7 [Production]メニューの項目 
 

コマンド 動作 

Build Project プロジェクト内の全ファイルをビルドします。 

Clean and Build Project 以前に生成済みのプロジェクト ファイルを全てクリーニング(削除)してから、プロジェ

クト内のファイルをリビルドします。 

http://wiki.netbeans.org/Refactoring
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Batch Build Project プロジェクトの複数のコンフィグレーションをビルドします(組み込みのみ利用可)。 

Set Project Configuration プロジェクト コンフィグレーションを選択します(「既定値」を選択)。 

Set Main Project 開かれているプロジェクトの一覧の中から、メイン プロジェクトを選択します。 

Configuration Bits [Configuration Bits]ウィンドウを開きます。 

Check File ファイルが規格に沿っているかチェックします(XML関連)。 

Validate File ファイルが規格に沿っているか検証します(XML関連)。 

Repeat Build/Run 一時停止から再度実行します。 

Stop Build/Run 実行を終了します。 
 

10.1.8 [Debug]メニュー 
下表に[Debug]メニューの項目を示します。 
表10-8 [Debug]メニューの項目 

 

コマンド 動作 

Debug Project メイン プロジェクトまたは選択したプロジェクトをデバッグします。 

Discrete Debugger 
Operation 

以下のデバッグ作業を1ステップずつ別々に実行します。 
• Build for Debugging(デバッグ実行プログラムによるビルド) 
• Program Device for Debugging(デバッグビルドによるプログラミング) 
• Launch Debugger 
• Live Connect Debug 

これは、スタータキットを使ってデバッグ中に[Memory]ウィンドウの設定を変更す

る場合に便利です。 
Finish Debugger Session デバッグ セッションを終了します。 

Pause デバッグを一時停止します。[Continue]で再開します。 

Continue 「一時停止」したデバッグを再開します。デバッグは次のブレークポイントまたは

プログラムの末尾で再び停止します。 

Step Over プログラムのソースを1行実行します。 
その行が関数コールである場合、呼び出した関数全体を実行後に停止します。 

Step Into プログラムのソースを1行実行します。 
その行が関数コールである場合、呼び出した関数の先頭の命令文を実行した後に停

止します。 
Step Out プログラムのソースを1行実行します。 

現在の関数の実行を完了し、その関数の呼び出しの直後のソース行で停止しま

す。 
Step Instruction マシン命令を1つ実行します。 

その命令が関数コールの場合、その関数を実行してから呼び出し元の制御に戻り

ます。 
Run to Cursor プロジェクトをカーソル位置まで実行して、停止します。 

Reset デバイスをリセットします。 

Set PC at cursor プログラム カウンタ(PC)の値を、カーソル位置の行アドレスに設定します。 
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Focus Cursor at PC カーソルを現在のPCアドレス位置へ移動し、このアドレスをウィンドウの中心に表示

します。 
Stack>Make Callee 
Current 

呼び出される側のメソッドを現在の呼び出しとします。この機能は、[Call Stack]ウィ

ンドウで呼び出しを選択している場合にのみ利用できます。 

Stack>Make Caller Current 呼び出す側のメソッドを現在の呼び出しとします。この機能は、[Call Stack]ウィンド

ウで呼び出しを選択している場合にのみ利用できます。 

Stack>Pop Topmost Call Top Of Stackの呼び出しをポップします。 

Stack>Pop To Current 
Stack Frame 

Top Of Stackから１フレームをポップして捨てます。 

Stack>Pop Last Debugger 
Call 

デバッグツールからの最新のコールをTop Of Stackにポップします。 

Toggle Line Breakpoint プログラム内のカーソル行のブレークポイントを設定/解除します。 

New Breakpoint 指定した行、例外、メソッドに新しいブレークポイントを設定します。 

New Watch 指定したシンボルをウォッチに追加します。 

New Run Time Watch 指定したシンボルを、プログラム実行中に値の変化を観察するウォッチに追加しま

す。 

Disconnect from Debug 
Tool 

MPLAB® X IDEとデバッグツール間の接続を解除します。 
[Run]または[Debug]を選択すると再接続します。 

Run Debugger/  
Programmer Self Test 

デバッグツールのセルフテストを実行します。 
ツールがセルフテスト機能をサポートしている場合、このテストを実行して動作を確

認できます。このためのハードウェアの設定については、そのツールの文書を参照し

てください。 
Hardware Tool Emergency 
Boot Firmware Recovery 

このユーティリティは、ハードウェア ツール ブート ファームウェアを工場出荷時状

態に戻す場合に使います。MPLAB ICD 4またはPICkit 4のヘルプを参照してください。 
 

10.1.9 [Team]メニュー 
本セクションでは[Team]メニューの項目を示します。 

これらのメニュー項目の一部に割り当てられているキーボード ショートカットについては[Help] > [Keyboard 
Shortcuts Card]を参照してください。 

表10-9 [Team]メニューの項目 
 

コマンド 動作 
Shelve Changes まだコミットしていない変更をパッチファイルとして作業フォルダに一時的に保存します。 

Git, Mercurial, 
Subversion 

バージョン管理システムによって表示されるサブメニューが異なります。 
サブメニューの詳細は各製品のマニュアルを参照してください。 

History ファイルの履歴を表示します。ファイルを以前のバージョンに復元する事もできます。 

Find Task バージョン管理システムで問題を見つけます。 

Report Task バージョン管理システムに問題を報告します。 

Create Build Job バージョン管理システムを使ってビルドを作成します。 
 

10.1.10 [Tools]メニュー 
本セクションでは[Tools]メニューの項目を示します。 

これらのメニュー項目の一部に割り当てられているキーボード ショートカットについては[Help] > [Keyboard 
Shortcuts Card]を参照してください。 
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表10-10 [Tools]メニューの項目 
 

コマンド 動作 

Embedded 追加されているプラグインを表示します。サブメニューからプラグインを選択します。 

Licenses コンパイラ ライセンスを管理します。詳細は以下の[Documentation]タブを参照してくださ

い。https://www.microchip.com/mplab/compilers 

• ネットワーク ライセンスのローミング 
• ワークステーション ライセンスのアクティベート 
• ライセンス ステータス 
• ライセンスタイプの変更 

Packs MPLAB Pack Managerを開き、プロジェクトで使っているデバイスに対応しりバージョン管

理されたデバイスパックを選択します。 
Templates [Template Manager]ウィンドウを開きます。 

DTDs and XML 
Schemas 

[DTDs and XML Schemas Manager]を開きます。 

Plugins [Plugins Manager]を開きます。 
詳細は以下のNetBeansヘルプトピックを参照してください。

http://wiki.netbeans.org/InstallingAPlugin 

Plugins Download 選択ダイアログが表示されます。以下が可能です。 

• Visit “Embedded Code Source” Website - プラグインをダウンロードし、後で[Plugin 
Manager]の[Downloaded]タブを使ってインストールする 

• Go to MPLAB X Plugin Manager - [Plugin Manager]で[Available Plugins]のリストからプ

ラグインを直ちにインストールする 
Options [Options]ダイアログを開きます。 

macOSの場合: [MPLAB X IDE] > [Preferences]を使います。 

12.16「[Tools] > [Options]ウィンドウ、[Embedded]」を参照してください。 
 

10.1.11 [Window]メニュー 
本セクションでは[Window]メニューの項目を示します。 

これらのメニュー項目の一部に割り当てられているキーボード ショートカットについては[Help] > [Keyboard 
Shortcuts Card]を参照してください。 

表10-11 [Window]メニューの項目 
 

コマンド 動作 

Projects [Projects]ウィンドウを開きます。8.1「[Projects]ウィンドウの表示」を参照

してください。 

Files [Files]ウィンドウを開きます。8.2「[Files」ウィンドウの表示」を参照して

ください。 

Classes [Classes]ウィンドウを開きます。8.3「[Classes」ウィンドウの表示」を参

照してください。 

Favorites [Favorites]ウィンドウを開きます。8.4「[Favorites]ウィンドウの表示」を参

照してください。 

Services [Services]ウィンドウを開きます。 
このウィンドウの詳細はNetBeansヘルプを参照してください。 

Dashboard [Dashboard]ウィンドウを開きます。 
5.19「ダッシュボードの表示」を参照してください。 

https://www.microchip.com/mplab/compilers
http://wiki.netbeans.org/InstallingAPlugin
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Navigator [Navigator]ウィンドウを開きます。 
このウィンドウの詳細はNetBeansヘルプを参照してください。 

Acton Items [Action Items]ウィンドウを開きます。12.1「［Action Items]ウィンドウ」を参

照してください。 

Tasks [Task List]ウィンドウを開きます。 

Output [Output]ウィンドウを開きます。12.13「[Output]ウィンドウ」を参照してくだ

さい。 

Editor 空のエディタ ウィンドウを開きます。7.1「エディタの使い方」を参照してく

ださい。 

Debugging>Output デバッグ用の[Output]ウィンドウ(Disassembly Listing File)を開きます。 

Debugging>Variables [Local Variables]デバッガ ウィンドウを開きます。4.17「ローカル変数値の変

化の観察」を参照してください。 

Debugging>Watches [Watches]デバッガ ウィンドウを開きます。4.16「シンボル値の変化の観

察」を参照してください。 

Debugging>Call Stack [Call Stack]デバッガ ウィンドウを開きます。5.17「コールスタックの表示」

を参照してください。 

Debugging>Breakpoints [Breakpoints]ウィンドウを開きます。 
4.14「ブレークポイントによるプログラム実行の制御」を参照してくださ

い。 
Debugging>Sessions [Sessions]ウィンドウを開きます。 

Debugging>Sources [Sources]ウィンドウを開きます。 

Debugging>Disassembly [Disassembly]ウィンドウを開きます。12.7「[Disassembly]ウィンドウ」を参

照してください。 

Debugging>PIC AppIO [Application In/Out]ウィンドウを開きます。 
 
MPLAB® REAL ICE™インサーキット エミュレータで使います。 

Debugging>Trace [Trace]ウィンドウを開きます。 
 
シミュレータまたはMPLAB REAL ICEインサーキット エミュレータで使いま

す。 
Debugging>Stopwatch [Stopwatch]ウィンドウを開きます。5.15「ストップウォッチの使用」を参照

してください。 

Debugging>PC Profiling [PC Profiling]ウィンドウを開きます。 
MPLAB® REAL ICE™インサーキット エミュレータで使います。 

Debugging>Triggers [Trigger In]ウィンドウを開きます。 
MPLAB® REAL ICE™インサーキット エミュレータで使います。 

Debugging>Debugger Console コマンドを入力するためのコンソール ウィンドウを開きます。 

Web>Web Browser 既定値のウェブブラウザを開きます。 

Web>CSS [CSS Styles]ウィンドウを開きます。このウィンドウを使うと、CSSファイル

内のHTML要素とセレクタのルールの宣言を編集できます。 

IDE Tools>Bookmarks [Bookmarks]ウィンドウを開きます。開いたプロジェクトのファイルのブック

マークの一覧を表示します。 
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IDE Tools>Notifications [Notifications]ウィンドウを開きます。現在のIDEセッションで発生したIDE
のエラーと警告のリストを表示します。 

IDE Tools>Terminal ローカルまたはリモート用の[Terminal]ウィンドウを開きます。 

IDE Tools>Processes [Processes]ウィンドウを開きます。実行中のプロセスにデバッグツールを

接続できます。 

PIC Memory Views>Memory 指定した[Memory]ウィンドウを開きます。プロジェクト デバイスによって

表示されるメモリが異なります。以下を参照してください。 
12.9 [Memory]ウィンドウ - 8/16ビットデバイス 

12.10 [Memory]ウィンドウ - 32ビットデバイス 
Simulator>Stimulus [Simulator Stimulus]ウィンドウを開きます。 

詳細はMPLAB Xシミュレータのマニュアルを参照してください。 

Simulator>Analyzer [Simulator Analyzer]ウィンドウを開きます。 
詳細はMPLAB Xシミュレータのマニュアルを参照してください。 

Simulator>IOPin [I/O Pins]ウィンドウを開きます。 
詳細はMPLAB Xシミュレータのマニュアルを参照してください。 

Simulator>Register Trace [Simulator Register Trace]ウィンドウを開きます。 
詳細はMPLAB Xシミュレータのマニュアルを参照してください。 

Configure Window> 
Maximize 

アクティブなウィンドウをIDEウィンドウの最大サイズに拡大します。 

Configure Window>Float フローティングのタブ付きIDEウィンドウを開きます。 

Configure Window> 
Float Group 

フローティングのタブ付きIDEウィンドウ グループを開きます。 

Configure Window>Minimize アクティブなウィンドウを最小化します。 

Configure Window> 
Minimize Group 

アクティブなウィンドウ グループを最小化します。 

Configure Window>Dock フローティングのタブをメインウィンドウに復元します。 

Configure Window> 
Dock Group 

フローティングのタブグループをメインウィンドウに復元します。 

Configure Window> 
Clone Document 

同じ文書に対して新規タブを開きます。 

Configure Window> 
Split Window 

アクティブな文書を垂直または水平に分割します。 

Configure Window< 
New Document Tab Group 

エディタ ウィンドウを2つのタブグループに分割し、選択したタブを新規

グループに分けます。 

Configure Window>Collapse 
Document Tab Group 

独立したタブグループを1つのグループに結合します。 

Reset Window ウィンドウを既定値状態にリセットします。 

Close Window ウィンドウ内で現在表示しているタブを閉じます。ウィンドウにタブがな

い場合、そのウィンドウを閉じます。 

Close All Documents ソースエディタで開いている全ての文書を閉じます。 

Close Other Documents 現在アクティブな文書以外の全ての文書を閉じます。 
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(続き) 
コマンド 動作 

Document Groups 名前が付いた文書グループを作成します。 

Documents [Documents]ダイアログ ボックスを開きます。このダイアログでは、現在

開いている文書を保存、閉じる事ができます。 
 

10.1.12 [Help]メニュー 
本セクションでは[Help]メニューの項目を示します。 

これらのメニュー項目の一部に割り当てられているキーボード ショートカットについては[Help] > [Keyboard 
Shortcuts Card]を参照してください。 

表10-12[Help]メニューの項目 
 

コマンド 動作 

Help Contents JavaHelpビューアを開いて、インストールされている全てのヘルプファイルを表示しま

す。 
Tool Help Contents 1つのJavaHelpビューアを開いて、1つのツール ヘルプファイルを表示します。 

Release Notes MPLABがサポートするツールのリリースノートへのリンクのリストを表示しま

す。その他MPLAB X IDEサポート文書へのリンクも表示します。 

Online Docs and Support NetBeansのサポート ウェブページを開きます。 

Keyboard Shortcuts Card キーボード ショートカット マニュアルを表示します。 

MPLAB X Store [MPLAB X Store]タブを開きます。 

Start Page [Start Page]タブを開きます。 

About [about MPLAB® X IDE]ウィンドウを開きます。 

 
 
10.2 ツールバー 

MPLAB X IDEは、現在使用中の機能またはツールに応じて、各種ツールバーを表示します。これらのツールバーを

使うと、頻繁に行う操作に素早くアクセスできます。 

以下はツールバーを操作する時に役立ちます。 

• ツールバーの特長 
• ツールバーのカスタマイズ 
• メニュー項目とボタンの灰色表示または非表示 
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図10-2 View>Toolbars 

 
10.2.1 [File]ツールバー 

[File]ツールバーは以下の機能のアイコンを収めています。これらの機能は[File]メニューからも利用できます。 
 

アイコン アイコンテキスト 機能 
 

 
New File [New File]ウィザードを使ってファイルを新規作成します。 

 

 
New Project [New Project]ウィザードを使ってプロジェクトを新規作成します。 

 

 
Open Project 既存のプロジェクトを開きます。 

 

 
Save All Files 開いている全てのファイルを保存します。 

 
関連リンク 
10.2.11 ツールバーの特長 
10.2.12 ツールバーのカスタマイズ 

 
10.2.2 [Clipboard]ツールバー 

[Clipboard]ツールバーは以下の機能のアイコンを収めています。これらの機能は[Edit]メニューからも利用できます。 
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アイコン アイコンテキスト 機能 
 

 
Cut 現在選択している内容を削除し、クリップボードに移動します。 

 

 
Copy 現在選択している内容をクリップボードにコピーします。 

 

 
Paste クリップボードの内容を現在の位置に挿入します。 

 

関連リンク 
10.2.11 ツールバーの特長 
10.2.12 ツールバーのカスタマイズ 

 
10.2.3 [Status Flags]ツールバー 

[Status Flags]ツールバーは以下の機能を収めています。 
 

イメージ イメージテキスト 説明 
 

 

Program Counter プログラム カウンタ(PC)の現在値 

 

 
Status Flags デバイスのステータスフラグ 

ステータスビットまたはレジスタの詳細は、デバイスのデータシート

を参照してください。 
 

10.2.4 [Undo/Redo]ツールバー 
[Undo/Redo]ツールバーは以下の機能のアイコンを収めています。これらの機能は[Edit]メニューからも利用できます。 

 

アイコン アイコン名 機能 
 

 
Undo エディタ操作を1つずつ取り消します(保存操作は取り消せません)。 

 

 
Redo [Undo]操作を1つずつ元に戻します。 

 
10.2.5 [Run]ツールバー 

[Run]ツールバーは以下の機能のアイコンを収めています。これらの機能は[Run]、[Debug]、[Project]コンテクスト 
メニューからも利用できます。 

 

アイコン アイコンテキスト 機能 
 

 
Set Project Configuration プロジェクト コンフィグレーションを選択します。[default]

または[Customize]を選択します。詳細は[Project Properties]
ウィンドウを参照してください。 

 Build Project 全てのプロジェクト ファイルをビルドします。 
 >Build for Debugging デバッグ用に全てのプロジェクト ファイル (デバッグ実行プ

ログラム含む)をビルドします。[Discrete Debugger 
Operation]のStep 1 

 

 
Clean and Build Project 前回のビルドで作成されたファイルを削除後、全てのプロジェ

クト ファイルをビルドします。 

>Clean and Build for Debugging 前回のビルドで作成されたファイルを削除後、デバッグ用に全

てのプロジェクト ファイル (デバッグ実行プログラム含む)をビ

ルドします。[Discrete Debugger Operation]のStep 1 
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アイコン アイコンテキスト 機能 

 

 
Run Project 選択したプロジェクトをビルドし、ターゲットをプログラミング

後、プロジェクトを実行します。 
 

 
Make and Program Device 
Project 

選択したプロジェクトをビルドし、ターゲットをプログラミング

後、リセット状態に保持します。 

>Program Device for Debugging デバッグビルドでターゲットをプログラミングします。[Discrete 
Debugger Operation]のStep 2 

>Program Device for Production 量産ビルドでターゲットをプログラミングします。 

>Erase Device Memory デバイス プログラムメモリを消去します。 

>Programmer To Go PICkit3 プロジェクト デバッグツールとしてPICkit 3を使ってProgrammer 
To Go (PTG)でターゲットをプログラミングします。 

 

 
Read Device Memory ターゲットデバイスのメモリの内容を読み出し、MPLAB X IDEに

ロードします。 
>Discrete Multi-Partition Read 
Operation 

マルチ パーティション (デュアル パーティション) デバイスで指

定されたフラッシュメモリ パーティションを読み出します。 

>Read Device Memory to a File ターゲット デバイスメモリを読み出し、ファイルに保存します。 

>Read EE/Flash Data Memory to 
a File 

ターゲット デバイスのデータメモリを読み出し、ファイルに保存

します。 
 

 
Hold in Reset/ 
Release from Reset 

選択したプロジェクトをリセット状態でホールドするか、リセッ

トから解放します。 
 

 
Debug Project 選択したプロジェクトをビルドし、ターゲットをプログラミング

後、デバッグします。 

>Launch Debugger デバッガを起動し、ターゲットコードを実行します。[Discrete 
Debugger Operation]のStep 3 

>Live Connect Debug MECデバイスの場合、実行中のターゲットに接続し、メモリの内

容を検査します。量産デバイスでデバッグが可能です。 

>: 下向き矢印アイコンから利用可能 
 

関連リンク 
10.2.11 ツールバーの特長 
10.2.12 ツールバーのカスタマイズ 

 
10.2.6 [Debug]ツールバー 

[Debug]ツールバーは以下の機能のアイコンを収めています。これらの機能は[Debug]メニューからも利用できます。 
 

アイコン アイコンテキスト 機能 
 

 
Finish 
Debugger 
Session 

デバッグ セッションを終了します。 

 

 
Pause デバッグを一時停止します。[Continue]で再開します。 

 

 
Reset プロジェクトをカーソル位置まで実行して、停止します。 
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アイコン アイコンテキスト 機能 

 

 
Continue デバッグを再開します。デバッグは次のブレークポイントまたはプログ

ラムの末尾で再び停止します。 
 

 
Step Over プログラムのソースを1行実行します。その行が関数コールである場合、呼び

出した関数全体を実行した後に停止します。 
 

 
Step Into プログラムのソースを1行実行します。その行が関数コールである場合、呼び

出した関数の先頭の命令文を実行した後に停止します。 
 

 
Step Out プログラムのソースを1行実行します。この行が関数コールの場合、実行後に

呼び出し元に戻ります。 
 

 
Run to Cursor 実行中のプロジェクトをファイル内のカーソル位置まで実行した後にプロ

グラムの実行を停止します。 
 

 
Set PC at cursor プログラム カウンタ(PC)の値を、カーソル位置の行アドレスに設定します。 

 

 
Focus Cursor at PC カーソルを現在のPCアドレス位置へ移動し、このアドレスをウィンドウ

の中心に表示します。 
 

関連リンク 
10.2.11「ツールバーの特長」 
10.2.2「[Clipboard]ツールバー」 

 
10.2.7 [Performance]ツールバー 

[Performance]ツールバーは以下を収めています。 
 

項目 名称 機能 
 

 Memory Usage Display クリックするとガーベジ コレクションを実行できます。これによりメモリを

解放できます。 
 

 
Profile the Application クリックするとアプリケーションのプロファイリングを開始できます。もう

一度クリックするとプロファイリングが停止し、ファイル(.npss)に保存され

ます。 
PCサンプリングとプロファイリングの詳細はMPLAB® REAL ICE™ インサー
キット エミュレータのマニュアルを参照してください。 

 
10.2.8 [MPLAB X Store]ツールバー 

[MPLAB X Store]ツールバーは以下の機能のアイコンを収めています。MPLAB X Storeの機能はヘルプメニューにも

表示されます。 
 

アイコン アイコンテキスト 機能 
 

 
MPLAB X Store クリックすると、IDEに[MPLAB X Store]タブが開きます。製品、サービ

ス、デバイスのご注文について確認できます。 
 

 
Programming 
Center 

クリックすると、ブラウザタブでMicrochip社プログラミング センターの情報を

表示できます。Microchip社は迅速、低コスト、セキュアで実証済みのデバイス 
プログラミングを提供しています。 

 
10.2.9 [How Do I]ツールバー 

この機能はインターネット接続を必要とします。 
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開発者ヘルプで情報を検索できます。テキストボックスに質問を入力できます。以下も参照してください。

https://microchipdeveloper.com/ 

10.1.12[Help]メニュー 
 

10.2.10 エディタ ツールバー 
エディタのツールバーは以下の機能のアイコンを収めています。これらの機能は[Edit]および[Source]メニューから

も利用できます。このツールバーは、現在のソースコード ファイルを表示しているタブの上に表示されます。 

図10-3 エディタ ツールバー 

 

アイコン アイコンテキスト 機能 
 

 
Source ソースコードを表示します。 

 

 
History ソースコードの編集履歴を表示します。 

 

 
Online Data Sheet プロジェクト デバイスのデータシートを開き、ソースコードで選択

(強調表示)されている周辺モジュールとSFRを検索します。 
現在この機能はAVRデバイス専用です。 

 

 
Last Edited 直前に編集した行へジャンプします。 

 

 
Back 逆方向に移動します。 

 

 
Forward 順方向に移動します。 

 

 
Find Selection 選択したテキストと最初に一致するテキストを検索します。 

 

 
Find Previous Occurrence 選択したテキストを逆方向に検索します。 

 

 
Find Next Occurrence 選択したテキストを順方向に検索します。 

 

 
Toggle Highlight Search 検索に一致したテキストの強調表示をON/OFFします。 

 

 
Toggle Rectangular Selection 検索に一致したテキストの行の強調表示をON/OFFします。 

 

 
Previous Bookmark 1つ前のブックマークに移動します(逆方向に循環)。 

 

 
Next Bookmark 次のブックマークに移動します(順方向に循環)。 

 

 
Toggle Bookmark コード行にブックマークを設定します。 

 

 
Shift Left 選択した行をタブ1つ左へシフトします。 

 

 
Shift Right 選択した行をタブ1つ右へシフトします。 

 

 
Start Macro Recording マクロ用のキー操作の記録を始めます。 

https://microchipdeveloper.com/
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(続き) 
アイコン アイコンテキスト 機能 

 

 
Stop Macro Recording キー操作の記録を終了します。 

 

 
Comment 選択したコード行に「//」を追加してコメント行にします。 

 

 
Uncomment 選択したコメント行の「//」を削除してコード行にします。 

 

 
Go to Header/Source 対応するヘッダとソースコードの間を移動します。 

 

関連リンク 
10.2.11 ツールバーの特長 
10.2.12 ツールバーのカスタマイズ 

 
10.2.11 ツールバーの特長 

ツールバーは以下の特長を備えています。 

• カーソルをアイコンに合わせると機能を表示します。 
• ドラッグ操作により、ツールバーを移動できます。 
• ツールバー領域内で右クリックして、ツールバーの表示/非表示を切り換えたり、一部のツールバーの内容を変

更したりする事ができます。 
• [View] > [Toolbars]を選択すると、ツールバーの表示/非表示の切り換え、一部ツールバーの内容の変更、カス

タム ツールバーの作成を実行できます。 
 

10.2.12 ツールバーのカスタマイズ 
[Customize Toolbars]ウィンドウを使うとMPLAB X IDEのツールバーをカスタマイズできます。このウィンドウは

[View] > [Toolbars] > [Customize]で開きます。 
to open the window. 

[Clean Only]、[Run]、[Set PC to Cursor]等のアイコンを使えます。 

ツールバーに機能を追加する方法 

• [Customize Toolbars]ウィンドウからツールバーにアイコンをドラッグします。 

ツールバーから機能を削除する方法 

• ツールバーから[Customize Toolbars]ウィンドウにアイコンをドラッグします。 

独自のツールバーを追加する方法 

• [New Toolbar]をクリックして、新規ツールバーに名前を付けます。 

ツールバー アイコンのサイズを変更する方法 

• アイコンを小さくするには、[Small Toolbar Icons]にチェックを入れます。 
• アイコンを大きくするには、チェックを外します。 

既定値のツールバーに戻す方法 

• [Reset Toolbars]をクリックします。 
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図10-4 [Customize Toolbars]ウィンドウ 

 
 
10.3 ステータスバー 

ステータスバーは、MPLAB IDEセッションの最新のステータス情報を表示します。エディタの情報も表示します。 

図10-5 デバッグ中のステータスバー 

 
 

10.4 メニュー項目とボタンの灰色表示または非表示 
以下のような条件では、メニュー項目、ツールバーボタン、ステータスバー アイテムは灰色で表示(無効化)される

か、表示されません。 

• その項目/ボタンの機能が、選択したデバイスでは利用できないデバイス機能である場合(例: PIC16F877Aは外

部メモリをサポートしない) 
• その項目/ボタンの機能が、選択したツールでは利用できないツール機能である場合(例: MPLAB ICD 3では

[Step Out]は使えない) 
• その項目/ボタンの機能がプロジェクトに関連し、プロジェクトが何も選択されていない場合(例: アクティブな

プロジェクトが存在しないと、プロジェクトのビルド機能は使えない) 
• その項目/ボタンの機能が、選択したデバイスまたはツール向けにサポートされていない場合 
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• その項目/ボタンの機能が既に実行中である場合(例: プログラムの実行中、[Run Project]は灰色表示になる) 
• その項目/ボタンの機能が他の項目/ボタンと排他的な関係にある場合(例: プログラム実行中は[Pause]が使えて

[Continue]は灰色表示、プログラム停止中は[Continue]が使えて[Pause]は灰色表示になる) 

図10-6 灰色表示されたメニュー項目 
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11. MPLAB X IDEのウィンドウの挙動 

MPLAB X IDEの各ウィンドウは、アプリケーション コードの作成とデバッグを支援する機能を備えています。ただ

し、各ウィンドウを活用するにはこれらの機能を理解する必要があります。 
 
 
11.1 MPLAB X IDEのウィンドウの管理 

IDEのウィンドウの管理に関する情報は以下のNetBeansヘルプトピックを参照してください。 

Managing IDE Windows 

その他のウィンドウの情報は以下を参照してください。 
 

11.1.1 ウィンドウのデータの更新 
開いたウィンドウ(読み出し専用のフラッシュメモリのウィンドウを除く)は、プログラムの停止時に更新されます。

プログラムの停止には、実行後の停止とステップ実行があります。停止による更新は以下の事項に影響します。 

• 速度 – 更新には時間がかかります。更新時間を短縮するには、使っていないウィンドウを閉じます。 
• データの上書き – 開いたウィンドウに表示されたファイルレジスタ値は、停止時に読み出されます。読み出し

時のレジスタ動作は、使うデバイスのデータシートを参照してください。 
 

11.1.2 ウィンドウのデータの変更 
MPLAB X IDEのウィンドウのデータは、以下に示すように編集できる場合があります。データを編集できない場合、

この情報を利用して変更する事はできません。 

• データを直接編集する(アイテムをダブルクリックして選択し新規の値を入力します。または、アイテムの隣の

省略記号[...]をクリックしポップアップ ウィンドウに新規の値を入力します。) 
• データをドロップダウン リストから選択する(特定の選択肢のみが利用できる場合) 

 
11.1.3 ウィンドウの列表示 

一部のウィンドウでは、列の表示を変更できます。ウィンドウの右上隅にあるアイコンをクリックします。 
 

 

 
列の表示を変更します。 

 

 
表示する列を変更します。 

https://docs.oracle.com/cd/E40938_01/doc.74/e40142/working_nbeans.htm%23A1147296
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例11-1 v5.20からv5.25への挙動の変化 

下図はサンプルコードのスニペットです。下表に、プログラム メモリウィンドウ(DisAssy列)また

は逆アセンブリ ウィンドウ内の逆アセンブリコードの表示挙動を示します。 

図11-2 サンプルコードのスニペット 

表11-1 v5.20からv5.25への挙動の変化 

 
 

図11-1 表示する列の変更例 

 
11.1.4 ウィンドウのフォーカス 

ウィンドウに確実にフォーカスするには、ウィンドウ フレームだけでなくボタン、表のセル、ドロップダウン、

コンボボックスをクリックします。 
 
 
11.2 ウィンドウに表示されるバンク化されたデータ メモリと値 

この機能は、バンク化されたデータメモリ(RAM)を使う8ビットPIC MCUデバイスでのみ使えます。 

MPLAB X IDE v5.20以前では、レジスタアドレスの表示値は常にバンクオフセットを含んでいます。しかし、参照し

ている命令がプログラム カウンタ(PC)位置にある場合にのみ実際の値を正確に計算できるため、常に正しい値を得

る事はできません。 

MPLAB X IDE v5.25以降では、PCとレジスタアドレスが同一行にある場合のみ、レジスタアドレスはバンクオフセ

ットを含みます。PCがその行にない場合、値はコード内の既定値に戻ります(バンクオフセットなしまたはバンク0)。 
 
 
 
 
 
 

 
 

MPLAB X IDE 15行目の逆アセンブル - PC上でない 15行目の逆アセンブル - PC上 

v5.20以前 CLRF 0x1D74 CLRF 0x1D74 

v5.25以降 CLRF 0x74 CLRF 0x1D74 
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//TODO Add function content 
: 

//TODO Complete project startup logic 
: 

//FIXME Update code for CCI compiler compliance 

 
 

 

12. MPLAB X IDEのウィンドウとダイアログ 
MPLAB X IDEのデスクトップはタブ形式のウィンドウを収めた4つのセクション (ペイン)に分割されます。一部の

ウィンドウは特定の機能を選択するまで表示されません。一部のウィンドウには、特定の情報を入力するためのダ

イアログが関連付けられています。 

例えば、MPLAB X IDEの初回起動時には[Start Page]と[MPLAB X Store]のタブ形式ウィンドウだけが開きます。

プロジェクトを開くと、基本的なウィンドウ(左上ペインに[Projects]と[Files]、左下ペインに[Dashboard]と
[Navigator]、右下ペインに[Output])が開きます。[Start Page]と[MPLAB X Store]のタブ形式ウィンドウは右上のペ

インに移動します。 

MPLAB X IDEでは、NetBeansプラットフォームのウィンドウとMPLAB X IDE専用のウィンドウの両方を使います。

各種ダイアログは、メニューから対応する項目を選択すると開きます。これらのダイアログも、ウィンドウと同様

にNetBeansプラットフォームのダイアログとMPLAB X IDEのダイアログ両方です。NetBeansのウィンドウとダイ

アログの詳細は13.1「NetBeansウィンドウとウィンドウ メニュー」を参照してください。 
 
 
12.1 [Action Items]ウィンドウ 

[Action Items]ウィンドウは[Window] > [Action Items]から開きます。 

[Action Items]ウィンドウには、コンパイラの警告やエラー等各種ファイルおよびプロジェクトで解決する必要のあ

るアクション アイテムの一覧が表示されます。コードにコメントとしてアクション アイテムを書きとめておきま

す。例えば、下図では以下のコード行が表示されています。 

図12-1 [Action Items]ウィンドウの例 

 
フィルタを使うと表示するアクション アイテムを絞り込め、列の見出しをクリックするとソートできます。[Action 
Items]ウィンドウのアイコンから表示されたアクション アイテムの変更と操作が可能です。 

詳細は以下を参照してください。 
http://microchipdeveloper.com/mplabx:tasks-list 

 
12.1.1 [Action Items]ウィンドウの表示 

この画面は以下の列にデータを表示します。 

• [Description] – アクション アイテムの説明 
• [File] – ファイル名 
• [Location] – ファイルの場所 

[Action Items]ウィンドウのアイコンは、ウィンドウの左側に表示されます。 
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表12-1 [Action Items]ウィンドウのアイコン 
 

アイコン

テキスト 
アイコンテキスト 

説明 
 

 
Show action items for 
currently edited file 
only 

IDEは現在エディタで選択されているファイルをスキャンし、見つかったア

クション アイテムを表示します。エディタで別のファイルを開くと、IDEは
そのファイルのアクション アイテムのみ表示します。 

 

 
Show action items 
for the selected 
project 

IDEは現在選択されているプロジェクトの全ファイルをスキャンし、プロジ

ェクト ウィンドウに全アクション アイテムを表示します。 
 

 
Show action items for 
all opened projects 

IDEは開いている全プロジェクトの全ファイルをスキャンし、ウィンドウに

全アクション アイテムを表示します。 
 

 
Click here to select 
a filter 

フィルタを変更または新規に設定できます。このボタンのドロップダウ

ン リストをクリックすると、アクション アイテムのリストに適用するフ

ィルタを選択できます。 
 

 
Group action items 
by category 

アクション アイテムをカテゴリ別にグループ化します。 

 
12.1.2 [Action Items]ウィンドウのメニュー 

ウィンドウ内の行を右クリックすると、このメニューが表示されます。 

表12-2 [Action Items]ウィンドウのコンテクスト メニュー 
 

項目 説明* 
Show コード内のエラー/警告の位置を示します。 

Scope アイテムの範囲(現在のファイル、現在のプロジェクト、全てのプロジェクト)を示します。 

Filter フィルタを表示します。フィルタの変更もできます。 

Refresh ウィンドウの内容を更新します。 

Sort By ウィンドウの内容をソートします。 

 
12.2 [Breakpoints]ウィンドウ 

このウィンドウは[Window] > [Debugging] > [Breakpoints]を選択して開きます。 

［Breakpoints］ウィンドウは、コード内のブレークポイントの管理に使います。[Breakpoints]ウィンドウの使い方

の詳細は以下を参照してください。 

4.14「ブレークポイントによるプログラム実行の制御」. 

[New Breakpoint]ダイアログ 
［Breakpoints］ウィンドウの［Create New Breakpoint］ボタンをクリックすると、ダイアログが開きブレークポ

イントを新規作成できます。4.14.2「［Breakpoint］ダイアログによるブレークポイントの設定」を参照してくださ

い。プロジェクト デバイスで使えるブレークポイント タイプの一覧が表示されます。 

図12-2 ［New Breakpoint］アイコン 

［Breakpoints]ウィンドウのメニュー 

ウィンドウの空いた場所で右クリックすると以下のメニューが表示されます。 
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表12-3 ［Breakpoints］ウィンドウのメニュー - ブレークポイント行が選択されていない場合 
 

項目 説明 

New Breakpoint ［New Breakpoint］ダイアログを開きます。 

Enable All 
Disable All 

全てのブレークポイントを有効または無効にします。 

Delete All 全てのブレークポイントを削除します。 
 

ウィンドウ内で任意のブレークポイント行を右クリックするとメニューが表示されます。 

表12-4 ［Breakpoints］ウィンドウのメニュー - ブレークポイント行が選択されている場合 
 

項目 説明 

Go to Source コード内のブレークポイントの場所を表示します。 

Complex Breakpoint 複合ブレークポイントの場合、このブレークポイントを新しいシーケンスまたはタプ

ルに追加します。シーケンスまたはタプル内の場所も指定します。 

Disable 
Enable 

このブレークポイントの動作を無効または有効にします。 

New Breakpoint ［New Breakpoint］ダイアログを開きます。 

Enable All 
Disable All 

全てのブレークポイントを有効または無効にします。 

Delete 
Delete All 

このブレークポイントまたは全てのブレークポイントを削除します。 

Customize ブレークポイントの動作をカスタマイズします。 
 
 
12.3 [New Breakpoint]ダイアログ 

このダイアログは［Breakpoints］ウィンドウから開きます([Window] > [Debugging] > [Breakpoints])。[New 

Breakpoint]アイコン をクリックするか、コンテクスト メニューから[New Breakpoint]を選択します。 

ブレークポイントで使えるオプションは、選択したブレークポイントのタイプとデバイスで決まります。デバイスに

よって使えないオプションがあります。 

ブレークポイントには以下のタイプがあります。 
 

• 12.3.1 「行ブレークポイント」 

• 12.3.2 「データ ブレークポイント」 

• 12.3.3 「アドレス ブレークポイント」 

• 12.3.4 「イベント ブレークポイント」 

• 12.3.5 「関数ブレークポイント」 

• 12.3.6 「パスカウント動作」 
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図12-3 ［New Breakpoint］ダイアログ - ［Address］ 

 
12.3.1 行ブレークポイント 

コード行で指定するブレークポイントには、以下のオプションを利用できます。 

表12-5 [Breakpoint Type]: [Line] – [Settings] 
 

項目 説明 

Settings ファイル行の隣の[ガーター]をクリックして、新規の行ブレークポイントを作成します。または、エディ

タのコンテクスト メニューから[Toggle Line Breakpoint]を選択します。 
 

12.3.2 データ ブレークポイント 
データメモリのブレークポイントには、以下のオプションが利用できます。 

表12-6 [Breakpoint Type]: [Data] – [Settings] 
 

項目 説明 

Project 開いているプロジェクトをドロップダウン リストから選択します。 
このプロジェクトのコードにブレークポイントが設定されます。 

Symbols グローバル シンボルまたはSFRの名前を入力します。または、[Symbols]をクリックして参

照します。[Breaks on]に従ってこのシンボルをアクセスすると、コード実行の一時停止がト

リガされます。 
Enable Range 
Address 

チェックを入れるとレンジ ブレークポイントが設定されます。チェックを外すとシングル ブ
レークポイントが設定されます。 

Address 
Address (Start) 

[Enable Range Address]の選択に応じて、この項目は[Address]と[Address (Start)]の
どちらかになります。 
データメモリの16進アドレスを入力します。 

[Breaks on]に従ってこのアドレスをアクセスすると、コード実行の一時停止がトリガされま

す。 
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(続き) 
項目 説明 

Address (End) [Enable Range Address]にチェックを入れると、この欄は有効になります。データメモリの

16進アドレスを入力します。 

Breaks on ［Read］, ［Write］, ［Read or Write］: 上で宣言したシンボルまたはアドレスに読み込

み、書き込み、読み込みまたは書き込みのいずれかを実行した場合、ブレークコードが実行

されます。 
［Read Specific Value], [Write Specific Value], [Read or Write Specific Value]: 上で宣言

したシンボルまたはアドレスに、以下に示す特定の値の読み込み、書き込み、読み込みまた

は書き込みのいずれかを実行した場合、ブレークコードが実行されます。 

Note:  dsPIC DSCでは、XおよびYバスに対する読み出しおよび書き込みがあります。 
Value [Breaks on]に[Read Specific Value], [Write Specific Value], [Read or Write Specific Value]の

いずれかを選択する場合、ここに16進値を入力します。 

Value Comparison PIC16F1xxxデバイスの場合のみ以下に示すように「Value」と比較します。 

= Value: 「Value」と等しい 

!= Value: 「Value」と等しくない 

> Value: 「Value」より大きい 

< Value: 「Value」より小さい 

Data Value Mask PIC16F1xxxデバイスの場合のみ 
「Value」と比較する際にマスクを使います。 

0x00～0xhhのレンジの値を入力します。0x00: 

どのビットも比較しません。 

0xhh: 全てのビットを比較します。 
 

表12-7 [Breakpoint Type]: [Data] – [Pass Count] 
 

項目 説明 

Condition [Breaks on]で指定したブレークが発生する条件を設定します。 
Always Break: [Breaks on]条件が成立すると常にブレークします。 

Break occurs Count instructions after Event: [Breaks on]条件発生後、ブレーク前にCount
命令を実行します。 

Event must occur Count times: ブレーク前に、[Breaks on]条件がCountで指定した回数発生す

る必要があります。 
Count [Condition]で指定した条件に従って、イベント後の命令数かイベント数を入力します。12.3.4

「イベント ブレークポイント」を参照してください。 

Trigger 
Options 

PIC16F1xxxデバイスの場合のみトリガする条件を選択します。 

• Do not trigger out when breakpoint is reached 
• trigger out when breakpoint is reached 

Interrupt 
Context 

PIC16F1xxxデバイスの場合のみ 
アドレス/データ ブレークポイント用の割り込みコンテクスト修飾子です。以下のいずれかを選択

します。 

• Always break - ISRとメインコードの両方でブレークします。 
• Break in main line (non-interrupt) context only - メインコード内のみでブレークします。 
• Break in interrupt context only - ISRコード内でのみブレークします。 
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12.3.3 アドレス ブレークポイント 
プログラム/実行メモリのブレークポイントには以下のオプションを利用できます。 

表12-8 [Breakpoint Type]: [Address] – [Settings] 
 

項目 説明 

Project 開いているプロジェクトをドロップダウン リストから選択します。 
このプロジェクトのコードにブレークポイントが設定されます。 

Enable Range 
Address 

チェックを入れるとレンジ ブレークポイントが設定されます。チェックを外すとシングル ブ
レークポイントが設定されます。 

Address 
Address (Start) 

[Enable Range Address]の選択に応じて、この項目は[Address]と[Address (Start)]のどちらか

になります。 
データメモリの16進アドレスを入力します。 

[Breaks on]に従ってこのアドレスをアクセスすると、コード実行の一時停止がトリガされま

す。 
Address (End) [Enable Range Address]にチェックを入れると、この欄は有効になります。データメモリの16

進アドレスを入力します。 

Breaks on Program Memory Execution: 上で指定したアドレスに達した場合、ブレークコードが実

行されます。 
TBLRD Program Memory: 上で指定したアドレスへのテーブル読み出しが発生した場合、

ブレークコードが実行されます。 

TBLWT Program Memory: 上で指定したアドレスへのテーブル書き込みが発生した場合、ブ

レークコードが実行されます。 
 

表12-9 [Breakpoint Type]: [Data] – [Pass Count] 
 

項目 説明 

Condition [Breaks on]で指定したブレークが発生する条件を設定します。 
Always Break: [Breaks on]条件が成立すると常にブレークします。 

Break occurs Count Instructions after Event: [Breaks on]条件発生後、ブレークの前に

Count命令を実行します。 

Event must occur Count times: ブレークの前に、[Breaks on]条件がCountで指定した回

数発生する必要があります。 
Count [Condition]で指定した条件に従って、イベント後の命令数かイベント数を入力します。12.3.4

「イベント ブレークポイント」を参照してください。 

Trigger Options PIC16F1xxxデバイスの場合のみトリガする条件を選択します。 

• Do not trigger out when breakpoint is reached 
• trigger out when breakpoint is reached 

Interrupt Context PIC16F1xxxデバイスの場合のみ 
アドレス/データ ブレークポイント用の割り込みコンテクスト修飾子です。以下のいずれかを選

択します。 

• Always break - ISRとメインコードの両方でブレークします。 
• Break in main line (non-interrupt) context only - メインコード内のみでブレークします。 
• Break in interrupt context only - ISRコード内でのみブレークします。 

「一部のデバイス(PIC16F1xxx MCU)では、拡張イベント ブレークポイントが使えます。」のセクションも参照し

てください。 
 

12.3.4 イベント ブレークポイント 
イベントのブレークポイントには以下のオプションを利用できます。 
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表12-10 [Breakpoint Type]: [Event] 
 

項目* 説明 

Project 開くプロジェクトをドロップダウン リストから選択します。 
このプロジェクトのコードにブレークポイントが設定されます。 

Break on clock mode switch クロックモードが切り換わった時にブレークします。 

Break on Reset instruction デバイスリセット命令が発生した時にブレークします。 

Break on Sleep スリープに移行した時にブレークします。 

Break on stack over/underflow スタック オーバーフロー/アンダーフロー時にブレークします。 

Break on wake up デバイスがスリープから復帰した時にブレークします。 

Break when watchdog timer has expired ウォッチドッグ タイマ時間が終了した時にブレークします。 

Break on execution out of bounds プログラムが通常のプログラムメモリ/空間を逸脱しようとした

時にブレークします。 

Break on MCLR Reset マスタクリアリセット(MCLR)でブレークします。 

Break on trigger in signal トリガインパルスを検出した時にブレークします。 

* 一時停止(ブレーク)するコード実行を引き起こすイベントをリストから選択します。デバイスによって利用でき

ないイベントがあります。 
 

一部のデバイス(PIC16F1xxx MCU)では、拡張イベント ブレークポイントが使えます。 
 

操作 説明 

Break 指定した設定に従って実行をブレーク(停止)します。 

Trigger out 指定した設定に従ってトリガアウト パルスを送出します。 

Break and trigger out 指定した設定に従って実行をブレーク(停止)し、トリガアウト パルスを送出します。 
 

12.3.5 関数ブレークポイント 
関数のブレークポイントには以下のオプションを利用できます。 

表12-11 [Breakpoint Type]: [Function] – [Settings] 
 

項目 説明 

Symbol/Hex Address 関数のシンボルまたはアドレスを入力または選択します。 
 

表12-12 [Breakpoint Type]: [Function] – [Conditions] 
 

項目 説明 

Condition チェックを入れて有効にします。その後、ブレーク条件を入力します。 

Break when hit count 
exceeds 

チェックを入れて有効にします。その後、関数の入力回数を整数で入力します。こ

の回数後にブレークが発生します。 
 

表12-13 [Breakpoint Type]: ［Function］ – ［Actions］ 
 

項目 説明 

Suspend ブレーク時は以下の条件でサスペンドします。 
No thread (continue): プログラムはサスペンドしません。 
Breakpoint thread: 関数スレッドのみサスペンドします。 
All threads: メインプログラムではない全てのスレッドをサスペンドします。 
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(続き) 
項目 説明 

Thread ID ブレークポイント スレッドのIDを設定します。 

Print Text ブレーク発生時に[Output]ウィンドウに表示するテキストを入力します。 
 

12.3.6 パスカウント動作 
パスカウントを使う事で、指定したカウントの後までブレークの実行を遅延させる事ができます。 

Break occurs Count Instructions after Event 

Countは、ブレークポイントの後、停止までに実行する命令数です。例えば、 

• 0: 即座に実行を停止する 
• 1: 追加の1命令後に実行を停止する 
• 10: 追加の10命令後に実行を停止する 

Event must occur Count times 

Countは、停止までに発生するイベント回数です。例えば、 

• 0: 即座に実行を停止する 
• 1: イベントが1回発生したら、次回のイベント(2回目のイベント発生)で実行を停止する 
• 10: イベントが10回発生したら、次回のイベント(11回目のイベント発生)で実行を停止する 

 
 
12.4 [Call Stack]ウィンドウ 

[Window] > [Debugging] > [Call Stack]を選択すると[Call Stack]ウィンドウが開きます。内容はデバッグモード中にの

み表示できます。 

[Call Stack]ウィンドウは、C関数とその引数を、実行中のプログラムで呼び出された順番に一覧表示します。最適化

していないCコードが最も適しています。 

コールスタックは16ビットおよび32ビットデバイスで使えます。このウィンドウは、デバッグの一時停止または停

止時に更新されます。 

図12-4 [Call Stack]ウィンドウ 

一時停止または停止時にこのウィンドウで使えるアイコンは以下の通りです。 
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表12-14 [Call Stack]アイコン 
 

アイコン 説明 
 

 
 

 

ウィンドウの内容を自動または手動で更新します。[Tools] > [Options] > [Embedded] > [Generic 
Settings]の[Disable auto refresh for call stack view during debug sessions]の値(チェックを外す = 偽(既
定値)、チェックを入れる = 真)の影響を受けます。12.16.1「[Generic Settings]タブ」を参照してくださ

い。 
偽 = 自動更新(緑のアイコン): ウィンドウの内容は、一時停止または停止時に自動更新されます。ウィ

ンドウが閉じられている場合、またはフォーカスされていない場合、ウィンドウを選択しこのボタンを

クリックすると更新が表示されます。再度実行および一時停止/停止する必要はありません。 

真 = 手動更新(オレンジのアイコン): ウィンドウの内容は、一時停止または停止しても自動では更新さ

れません。一時停止/停止時にウィンドウの内容を更新するには、このボタンをクリックする必要があ

ります。 
 

 
関数のパラメータ変数の評価の無効化/有効化を選択します。 

 

 
表示する列を変更します。このウィンドウでは、コールスタック フレーム位置の表示/非表示を切り換

える事ができます。 

 
12.5 [Customize Toolbars]ウィンドウ 

[Customize Toolbars]ウィンドウを使うとMPLAB X IDEのツールバーをカスタマイズできます。このウィンドウは

[View] > [Toolbars] > [Customize]と選択して開きます。 
to open the window. 

カスタマイズ手順は10.2.12「ツールバーのカスタマイズ」を参照してください。 
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12.6 [Dashboard]ウィンドウ 
[Dashboard]ウィンドウはチェックサム、コンパイラ バージョン、メモリ使用率、ブレークポイント リソース等の

一般的なプロジェクト情報を表示します。詳細は以下を参照してください。5.19「ダッシュボードの表示」 

 
 
12.7 [Disassembly]ウィンドウ 

[Disassembly]ウィンドウは逆アセンブルCコードを表示します。このウィンドウは[Window] > [Debugging] > 
[Disassembly]と選択して開きます。デバッグモード中である事が必要です。 

デバッグ中は「Step Over」関数がソースコード コンテクストで動作します。逆アセンブル デバッグには「Step In」
関数を使います。逆アセンブル デバッグ中に「Step In」が不要な場合(例えばCALL命令をステップインせずにステ

ップオーバする必要がある場合)、「Run to Cursor」機能を使います。PCを進ませたい行にカーソルを置き、「Run 
to Cursor」/F4ボタンを押します。 

ウィンドウ内で右クリックすると、コンテクスト メニューが表示されます。 

逆アセンブル ファイル全体を素早く表示するには、[Disassembly Listing File]を選択します。プロジェクト デバイス

がRAMバンクを使う場合、以下も参照してください。 
 
11.2「ウィンドウに表示されるバンク化されたデータメモリと値」 
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図12-5 [Disassembly]ウィンドウ 

 
 
12.8 [I/O View]ウィンドウ 

[I/O View]ウィンドウ([Window] > [Debugging] > [IO View])を使うと、現在のプロジェクトのターゲット デバイスの

レジスタ概要を確認できます。操作の概要は以下を参照してください。 

5.20「プロジェクト レジスタの表示([I/O View])」 

[I/O View]ウィンドウのセクション 

このウィンドウは既定値で上下に分割されており、上のセクションに周辺モジュール グループ、下のセクションに

レジスタを表示します。通常、各周辺モジュールは定義済みの設定と値のエニュメレーションを格納し、周辺モジュ

ール画面(上部セクション)でレジスタを展開するとこれらを表示できます。レジスタ画面(下側)は、選択した周辺モ

ジュール グループに属する全てのレジスタを表示します。周辺モジュール未選択時、画面には何も表示されません。

レジスタを展開して、そのレジスタに属する定義済み値グループを表示する事もできます。 
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図12-6 [I/O View]ウィンドウの内容 

表12-15 [I/O View]のアイコン 
 

アイコン 機能 
 

 
グループにフィルタをかける(利用可能な周辺モジュールのグループを絞り込んで表示) 

アイコンをクリックすると[Select]ダイアログが開きます。<Shift>+クリック(連続した複数モジュール)
または<Ctrl>+クリック(個別モジュール)で周辺モジュールを選択します。または、「Register Text 
Filter」ファイルを指定する事もできます。 

 

 
全グループを選択するフィルタ 

 

 
周辺モジュールペインをトグルする 

周辺モジュール(上部)ペインの表示/非表示を切り換えます。 
 

 
レジスタペインをトグルする 

レジスタ(下部)ペインの表示/非表示を切り換えます。 
 

 
標準ビットを表示する(変更されたビットのハイライト表示をトグルする)  
変更されたビットが標準ビット(ハイライトなし)で表示されます。 
青線アイコンをクリックして、赤線アイコンに変更します。 

 

 
変更されたビットをハイライト表示する(標準ビットをトグルする) 
変更されたビットがハイライト表示されます。 
赤線アイコンをクリックして、青線アイコンに変更します。 
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(続き) 
アイ

コン 
機能 

 

 
変更されたビットのハイライト表示をトグルする 

前のアイコンを「変更されたビットをハイライト表示する」として選択した場合、このアイコンをクリッ

クすると変更されたビットのハイライト表示をトグルできます。 

[IO View Settings]ダイアログが開きます。 
 

表12-16 [I/O View]のコンテクスト メニュー 
 

項目 機能 

Expand All ペイン/セクションを全て展開します。 

Expand Row 選択した行を展開します。 

Collapse All ペイン/セクションを全て折り畳みます。 

Adjust Table Columns レジスタペインのみ(テーブル列の幅を調整します) 
 
 
12.9 [Memory]ウィンドウ - 8/16ビットデバイス 

[Memory]ウィンドウ([Window] > [Target Memory Views])は各種デバイスメモリ(SFR、コンフィグレーション ビット

等)を表示します。このウィンドウは[Memory]および[Format]ドロップダウン ボックスを使ってカスタマイズできます。 

詳細は4.18「デバイスメモリの表示と変更」を参照してください。 

関連ダイアログの詳細は12.11「[Memory]ウィンドウのダイアログ」を参照してください。 

図12-7 [Window] > [Target Memory Views] - [PIC16F1939] 

図12-8 [Window] > [Target Memory Views] - [ATtiny817] 

 
 

12.9.1 [Program Memory]ウィンドウ 
[Program Memory]ウィンドウは、現在選択しているプロセッサのプログラムメモリ レンジ内の位置を表示します。

選択したデバイスが外部プログラムメモリをサポートしており有効な場合、その外部プログラムメモリも[Program 
Memory]ウィンドウに表示されます。 
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MPLAB Xのシミュレータでは、プログラムメモリの値が変化した場合またはプロセッサが停止した場合、[Program 
Memory]ウィンドウのデータが更新されます。 

Microchip社のハードウェア デバッグツール(例: MPLAB ICD 4インサーキット デバッガ)では、プログラムメモリの

値が変化した場合、またはプロセッサが停止した場合、[Program Memory]ウィンドウのデータは更新されません。

デバイスメモリの読み出しを実行する必要があります。 

デバッグ用ハードウェア ツールを使う場合、一部のレジスタは予約済みリソースを表すためにデータのニブルごと

に「R」を表示する事があります。 

プロジェクト デバイスがRAMバンクを使う場合、以下も参照してください。 

11.2「ウィンドウに表示されるバンク化されたデータメモリと値」 

図12-9 [Program Memory]ウィンドウの内容 

12.9.1.1 [Program Memory]ウィンドウの表示 
[Program Memory]ウィンドウ下部の[Format]ドロップダウン ボックスから選択する事で、ウィンドウ内のメモリの

表示方法を指定できます。 

デバッグ用ハードウェア ツールを使う場合、一部のレジスタは予約済みリソースを表すためにデータのニブルごと

に「R」を表示する事があります。 

[Code]フォーマット 

[Code]フォーマットは逆アセンブルHEXコードをシンボルで表示します。このウィンドウは以下の列を表示します 

• デバッグ情報 – デバッグに便利な情報です。 
ポインタはプログラム カウンタの現在の位置を示します。 

• Line – 参照行番号です。 
• Address – オペコードの16進アドレスです。 
• Opcode – 16進オペコードです。2バイトまたは3バイトのブロックで表示されます。ほとんどのPIC MCUでは、

これらのブロックはワードを意味します。 
PIC18CXXXデバイスではブロックは2バイトに相当します。dsPIC DSCデバイスではブロックは3バイトに相当

します。 
• Label(シンボリックのみ) – シンボリック フォーマットのオペコードラベルです。 
• DisAssy – オペコード ニーモニックの逆アセンブル バージョンです。 

[Hex]フォーマット 

このフォーマットはプログラムメモリ情報をHEXコードで表示します。このウィンドウは以下の列を表示します 

• Address – 隣の列のオペコードの16進アドレスです。 
• オペコード ブロック – 16進オペコードです。2バイトまたは3バイトのブロックで表示されます。 

大部分のPIC MCUでは、これらのブロックはワードを意味します。PIC18CXXXデバイスではブロックは2バイ

トに相当します。dsPIC DSCデバイスではブロックは3バイトに相当します。 
ハイライト表示のオペコード ブロックはプログラム カウンタの現在の位置を表します。 

• ASCII – 対応するオペコード行のASCII表示です。 

PSV Mixed (dsPIC DSC/PIC24デバイスのみ) 
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このフォーマットはプログラムメモリをオペコードとPSV領域(CORCONレジスタ、PSVビットセット)で表示します。

このウィンドウは以下の列を表示します 

• デバッグ情報 – デバッグに便利な情報です。ポインタはプログラム カウンタの現在の位置を示します。 
• Line – 参照行番号です。 
• Address – オペコードの16進アドレスです。 
• PSV Address – オペコードの16進データ空間アドレスです。 
• Data – データとしてフォーマット化されたオペコードです。 
• Opcode – 16進オペコードです。3バイトのブロックで表示されます。 
• Label – シンボリック フォーマットのオペコードラベルです。 
• DisAssy – オペコード ニーモニックの逆アセンブル バージョンです。 

詳細は『dsPIC30Fファミリ リファレンス マニュアル』(DS70046)を参照してください。 

PSV Data (dsPIC DSC/PIC24デバイスのみ) 

このフォーマットはプログラムメモリをファイルレジスタで表示します(プログラム空間がデータ空間(CORCONレジ

スタ、PSVビットセット)内に表示されている場合)。このウィンドウは以下の列を表示します 

• Address – データの16進プログラム空間アドレスです。 
• PSV Address – データの16進データ空間アドレスです。 
• データブロック – 16進データです。3バイトのブロックで表示されます。 

ハイライト表示のデータブロックはプログラム カウンタの現在の位置を表します。 
• ASCII – 対応するデータ行のASCII表示です。 

詳細は『dsPIC30Fファミリ リファレンス マニュアル』(DS70046)を参照してください。 

12.9.1.2 [Program Memory]ウィンドウのアイコン 
アイコンはウィンドウの左側にあります。 

表12-17 [Program Memory]ウィンドウのアイコン 
 

アイコン アイコンテキスト 機能 
 

 
Refresh by Read 
Device Memory 

デバッグツール バーの[Read Device Memory]アイコンと同じ機能 - デバ

イスメモリをMPLAB X IDEにロードします。 
 

 
Find ウィンドウ内で検索する文字列を指定します。単語単位で一致するか、大文

字と小文字を区別するかを選択します。 
 

 
Find Next [Find]に指定した文字列の次のインスタンスを検索します。 

 

 
Find Previous [Find]に指定した文字列の前のインスタンスを検索します。 

 

 
Go To 指定した行番号またはアドレスに移動します。 

 
12.9.1.3 [Program Memory]ウィンドウのメニュー 

このメモリウィンドウの[CODE]または[PSV MIXED]フォーマットに設定されているデータ領域で右クリックすると、

このメニューが表示されます。デバイスによっては表示されない項目があります。 

表12-18 [Program Memory]ウィンドウのメニュー - Code/PSV Mixed 
 

項目 説明 

Run to Cursor 現在のカーソル位置までプログラムを実行します。 

Step Instruction ステップ命令を1つ実行します。 

Set PC at Cursor プログラム カウンタ(PC)を現在のカーソル位置に設定します。 

Focus Cursor at PC カーソルを現在のPCアドレス位置へ移動し、このアドレスをウィンドウの中心に表示しま

す。 
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(続き) 
項目 説明 

Toggle Breakpoint 既存のブレークポイントをトグルします。 

Symbolic Mode 逆アセンブルHEXコードをシンボルで表示します。 

Verbose Labels [PSV Mixed]フォーマットのみ 
内部コンパイララベルを表示します。 

Fill Memory メモリの[Start Address]～[End Address]に[Data]内の値を書き込みます。[Fill Memory]ダイ
アログで、その他のオプションを指定します。 

Go To [Go To]ダイアログで指定したアドレス/関数に移動します。 

Go To Source Line エディタでソースコード内の対応する行に移動します。 

Find [Find]ダイアログで指定したテキストを検索します。 

Output To File ウィンドウの表示内容をテキストファイルに書き出します。 

Print ウィンドウの内容を印刷します。 
Note:  メモリ容量の大きなデバイスの場合、印刷ページ数が非常に多くなる事がありま
す。その場合、ウィンドウの内容をファイルに出力した後([Print]ダイアログの[General]タ
ブの[Print to File]チェックボックス)、そのファイルから必要なページだけ選んで印刷する
事を推奨します。 

Adjust Table Columns 行を自動的に調節します。 
 

メモリウィンドウの[HEX]または[PSV DATA]フォーマットに設定されているデータ領域で右クリックすると、この

メニューが表示されます。デバイスによっては表示されない項目があります。 

表12-19 [Program Memory]ウィンドウのメニュー - Hex/PSV Data 
 

項目 説明* 
Hex Display Width [Hex]フォーマットのみ 

16進数の表示幅を設定します(選択肢はデバイスによって異なります)。 
Fill Memory メモリの[Start Address]～[End Address]に[Data]内の値を書き込みま

す。[Fill Memory]ダイアログで、その他のオプションを指定します。 
Go To [Go To]ダイアログで指定したアドレス/関数に移動します。 

Find [Find]ダイアログで指定したテキストを検索します。 

Output To File [Output to File]ダイアログを使って、ウィンドウの表示内容をテキストファイルに書き出し
ます。 

Import Table [Import Table]ダイアログを使って、ファイルから[Memory]ウィンドウに表形式のデータをイ
ンポートします。 

Export Table [Export Table]ダイアログを使って、[Memory]ウィンドウからファイルへ表形式のデータをエ
クスポートします。 

Print [Print]ダイアログを使って、このウィンドウの内容を印刷します。 
Note:  メモリ容量の大きなデバイスの場合、印刷ページ数が非常に多くなる事がありま
す。その場合、ウィンドウの内容をファイルに出力した後([Print]ダイアログの[General]タブ
の[Print to File]チェックボックス)、そのファイルから必要なページだけ選んで印刷する事を
推奨します。 

Adjust Table 
Columns 

行を自動的に調節します。 

 
12.9.2 [File Registers]ウィンドウ 

[File Registers]ウィンドウは、選択したデバイスの全ファイルレジスタを表示します。ファイルレジスタの値が変

化した場合、またはプロセッサがデバッガに応答した場合、[File Registers]ウィンドウのデータが更新されます(更
新された値は赤で表示される)。 

一部のデータは色付きセルに表示されます。 



MPLAB X IDEユーザガイド 
MPLAB X IDEのウィンドウとダイアログ 

ユーザガイド DS-50002027E_JP - p. 232 © 2019 Microchip Technology 
 

 

 

 
 

• 青色セルはSFRを示します。 
• 緑色セルはプロジェクトの変数を示します。 
• 灰色セルは予約済みメモリを示します。 

Note:  特定のハードウェア ツールでデバッグ速度を改善するには、このウィンドウを閉じます。代わりに[SFR]ま
たは[Watches]ウィンドウを使います。 

図12-10 [File Registers]ウィンドウの内容 

 
12.9.2.1 [File Registers]ウィンドウの表示 

ウィンドウ下部の[Format]ドロップダウン ボックスで選択してウィンドウ内のメモリ表示方法を変更できます。 

デバッグ用ハードウェア ツールを使う場合、一部のレジスタは予約済みリソースを表すためにデータのニブ

ルごとに「R」を表示する事があります。 

[Hex] 

このフォーマットはファイルレジスタ情報をHEXデータで表示します。このウィンドウは以下の列を表示します。 

• Address – 隣の列のデータの16進アドレスです。 
• データブロック – 16進データです。1バイトまたは2バイトのブロックで表示されます。 
• ASCII – 対応するデータ行のASCII表示です。 

[Symbol] 

このフォーマットは、HEX、10進、バイナリ形式の対応データで各ファイルレジスタをシンボル表示します。

このウィンドウは以下の列を表示します。 

• Address – データの16進アドレスです。 
• Symbol – データのシンボル名です。 
• 基数情報 – Hex、Decimal、Binary、Char 

基数情報はこれらの4列に表示されます。HEXは1バイトまたは2バイトのブロックで表示されます。 

Dual Port (dsPIC33FJ DSC/PIC24HJ MCUのみ) 

このフォーマットはファイルレジスタ情報をHEXデータで表示します。このウィンドウは以下の列を表示します。 

• Address – データの16進アドレスです。 
• DMA Address – シリコンのDMAアドレスからのオフセットです。 
• データブロック – 16進データです。1バイトまたは2バイトのブロックで表示されます。 
• ASCII – 対応するデータ行のASCII表示です。 
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dsPIC33F DSCおよびPIC24H MCUの詳細は、弊社ウェブサイトのデバイス データシートと『dsPIC33F/PIC24Hフ

ァミリ リファレンス マニュアル』の各セクションでご確認ください。 

[XY Data] (dsPIC DSCデバイスのみ) 
このフォーマットはファイルレジスタ情報をHEXデータで表示します。このウィンドウは以下の列を表示します。 

• Address – データの16進Xアドレスです。 
• Y Bus – データの16進Yアドレスです(サポートされている場合)。 
• データブロック – 16進データです。2バイトのブロックで表示されます。 
• ASCII – 対応するデータ行のASCII表示です。 

dsPIC DSCデバイスの詳細は『dsPIC30Fファミリ リファレンス マニュアル』(DS70046)を参照してください。 
 

12.9.2.2 [File Registers]ウィンドウのアイコン 
アイコンはウィンドウの左側にあります。 

表12-20 [File Registers]のアイコン 
 

アイコン アイコンテキスト 機能 
 

 
Find ウィンドウ内で検索する文字列を指定します。単語単位で一致するか、大文字と小文

字を区別するかを選択します。 
 

 
Find Next [Find]に指定した文字列の次のインスタンスを検索します。 

 

 
Find Previous [Find]に指定した文字列の前のインスタンスを検索します。 

 

 
Go To 指定した行番号またはアドレスに移動します。 

 
12.9.2.3 [File Registers]ウィンドウのメニュー 

このメモリウィンドウのデータ領域で右クリックすると、このメニューが表示されます。デバイスによっては表示さ

れない項目があります。 

表12-21 [File Registers]ウィンドウのコンテクスト メニュー 
 

項目 説明 

Hex Display Width [Hex]フォーマットのみ 
16進数の表示幅を設定します(選択肢はデバイスによって異なります)。 

Fill Memory メモリの[Start Address]～[End Address]に[Data]内の値を書き込みます。[Fill Memory]ダイ

アログで、その他のオプションを指定します。 

Go To [Go To]ダイアログで指定したアドレス/関数に移動します。 

Find [Find]ダイアログで指定したテキストを検索します。 

Output To File [Output to File]ダイアログを使って、ウィンドウの表示内容をテキストファイルに書き出しま

す。 
Import Table [Hex]、[Dual Port]、[XY Data]フォーマットのみ 

[Import Table]ダイアログを使って、ファイルから[Memory]ウィンドウに表形式のデータをイ

ンポートします。 
Export Table [Hex]、[Dual Port]、[XY Data]フォーマットのみ 

[Export Table]ダイアログを使って、[Memory]ウィンドウからファイルへ表形式のデータをエ

クスポートします。 
Print [Print]ダイアログを使って、このウィンドウの内容を印刷します。 

Note:  メモリ容量の大きなデバイスの場合、印刷ページ数が非常に多くなる事があります。

その場合、ウィンドウの内容をファイルに出力した後([Print]ダイアログの[General]タブの

[Print to File]チェックボックス)、そのファイルから必要なページだけ選んで印刷する事を推

奨します。 
Adjust Table 
Columns 

行を自動的に調節します。 

http://www.microchip.com/
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12.9.3 [SRAM Data Memory]ウィンドウ 
[SRAM Data Memory]ウィンドウは、選択したATデバイスの全てのSRAMを表示します。レジスタの値が変化した場

合、またはプロセッサがデバッガに応答した場合、このウィンドウのデータが更新されます(更新された値は赤で表

示)。 

デバッグ用ハードウェア ツールを使う場合、一部のレジスタは予約済みリソースを表すためにデータのニブルごと

に「R」を表示する事があります。 

Note:  特定のハードウェア ツールでデバッグ速度を改善するには、このウィンドウを閉じます。代わりに[I/O 
Memory (SFRs)]ウィンドウまたは[Watches]ウィンドウを使います。 

図12-11 [SRAM Data Memory]ウィンドウの内容 

 
12.9.3.1 [SRAM Data Memory]ウィンドウの表示 

ウィンドウ下部の[Format]ドロップダウン ボックスを選択する事で、ウィンドウ内のメモリの表示方法を変更でき

ます。 

[Hex] 

このフォーマットはファイルレジスタ情報をHEXデータで表示します。このウィンドウは以下の列を表示します。 

• Address – 隣の列のデータの16進アドレスです。 
• データブロック – 16進データです。1バイトまたは2バイトのブロックで表示されます。 
• ASCII – 対応するデータ行のASCII表示です。 

[Symbol] 

このフォーマットは、HEX、10進、バイナリ形式の対応データで各ファイルレジスタをシンボル表示します。この

ウィンドウは以下の列を表示します。 

• Address – データの16進アドレスです。 
• Symbol – データのシンボル名です。 
• 基数情報 – Hex、Decimal、Binary、Char  

基数情報は4列に表示されます。HEXは1バイトまたは2バイトのブロックで表示されます。 

12.9.3.2 [SRAM Data Memory]ウィンドウのアイコン 
アイコンはウィンドウの左側にあります。 

表12-22 [SRAM Data Memory]ウィンドウのアイコン 
 

アイコン アイコンテキスト 機能 
 

 
Find ウィンドウ内で検索する文字列を指定します。単語単位で一致するか、大文字と小

文字を区別するかを選択します。 
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(続き) 
アイコン アイコンテキスト 機能 

 

 
Find Next [Find]に指定した文字列の次のインスタンスを検索します。 

 

 
Find Previous [Find]に指定した文字列の前のインスタンスを検索します。 

 

 
Go To 指定した行番号またはアドレスに移動します。 

 

12.9.3.3 [SRAM Data Memory]ウィンドウのメニュー 
このメモリウィンドウのデータ領域で右クリックすると、このメニューが表示されます。デバイスによっては表示さ

れない項目があります。 

表12-23 [SRAM Data Memory]ウィンドウのコンテクスト メニュー 
 

項目 説明 

Hex Display Width [Hex]フォーマットのみ 
16進数の表示幅を設定します(選択肢はデバイスによって異なります)。 

Fill Memory メモリの[Start Address]～[End Address]に[Data]内の値を書き込みます。[Fill Memory]ダイア

ログで、その他のオプションを指定します。 

Go To [Go To]ダイアログで指定したアドレス/関数に移動します。 

Find [Find]ダイアログで指定したテキストを検索します。 

Output To File [Output to File]ダイアログを使って、ウィンドウの表示内容をテキストファイルに書き出し

ます。 
Import Table [Hex]フォーマットのみ 

[Import Table]ダイアログを使って、ファイルから[Memory]ウィンドウに表形式のデータをイ

ンポートします。 
Export Table [Hex]フォーマットのみ 

[Export Table]ダイアログを使って、[Memory]ウィンドウからファイルへ表形式のデータを

エクスポートします。 
Print [Print]ダイアログを使って、このウィンドウの内容を印刷します。 

Note:  メモリ容量の大きなデバイスの場合、印刷ページ数が非常に多くなる事があります。

その場合、ウィンドウの内容をファイルに出力した後([Print]ダイアログの[General]タブの

[Print to File]チェックボックス)、そのファイルから必要なページだけ選んで印刷する事を推

奨します。 
Adjust Table 
Columns 

行を自動的に調節します。 

 
12.9.4 [SFRs]ウィンドウ 

特殊機能レジスタ(SFR)ウィンドウは、選択したプロセッサのSFRの内容を表示します。このウィンドウには各SFR
名と複数のフォーマットが表示されているため、通常のファイルレジスタ ウィンドウよりSFRの表示に便利です。

少数のSFRを表示する場合、[Watches]ウィンドウを推奨します。ハードウェア デバッグツール使用時に速度問題対

策に役立つ事があります(ウィンドウ更新レートが速いため)。 

ブレークが発生すると常に特殊機能レジスタの内容が更新されます。 

デバッグ用ハードウェア ツールを使う場合、一部のレジスタは予約済みリソースを表すためにデータのニブルごと

に「R」を表示する事があります。 

可視レジスタ 

データメモリ レジスタが物理的にデバイス上に実装されていない場合、SFRの一覧に表示されない事があります。

シミュレータ等の一部のツールを使うと、実際のデバイス上に存在しないプリスケーラ等のレジスタを表示できます。 

シングルステップ実行 
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[Freeze Peripherals On Halt]を選択した場合、SFRのI/Oポートビットまたは[Watches]ウィンドウはシングルステッ

プ実行では更新されません。ピンは変更されますが、新規の値を取得するための読み出し要求はフリーズによって阻

止され、次のステップまたは実行コマンドまで更新されません。 

図12-12 [SFRs]ウィンドウの内容 

12.9.4.1 [SFRs]ウィンドウの表示 
ウィンドウ下部の[Format]ドロップダウン ボックスを選択する事で、ウィンドウ内のメモリの表示方法を変更でき

ます。選択肢は以下の通りです。 

• Individual - 全SFRレジスタを一括して表示します。 
• Peripherals - SFRレジスタを機能グループごとに表示します。 

[Individual] 

この表示画面では、SFRはアドレスで表示されます。データは以下の列に表示されます。 
• Address – SFRの16進アドレスです。 
• Name – SFRのシンボル名です。 
• 基数情報 – Hex、Decimal、Binary、Char  

基数情報はこれらの4列に表示されます。HEXは1バイトのブロックで表示されます。 

[Peripheral] 

この表示画面では、SFRは関連するデバイスの周辺モジュールに従ってグループ化されます。データは以下の列に表

示されます。 
• Address – SFRの16進アドレスです。 
• Name – 周辺モジュール名またはSFRのシンボル名です。 
• 基数情報 – Hex、Decimal、Binary、Char  

基数情報はこれらの4列に表示されます。HEXは1バイトのブロックで表示されます。 

[Filter Peripheral]ボタンをクリックして選択した周辺モジュールのみのSFRを表示します。 

12.9.4.2 [SFRs]ウィンドウのアイコン 
アイコンはウィンドウの左側にあります。 
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表12-24 [SFRs]ウィンドウのアイコン 
 

アイコン  機能 
 

 
Find ウィンドウ内で検索する文字列を指定します。単語単位で一致するか、大文字と

小文字を区別するかを選択します。 
 

 
Find Next [Find]に指定した文字列の次のインスタンスを検索します。 

 

 
Find Previous [Find]に指定した文字列の前のインスタンスを検索します。 

 

 
Go To 指定した行番号またはアドレスに移動します。 

 

 
Filter Peripherals [Peripheral]フォーマットのみ 

利用可能な周辺モジュールを絞り込んで表示します。 

アイコンをクリックすると[Select]ダイアログが開きます。<Shift>+クリック

(連続した複数モジュール)または<Ctrl>+クリック(個別モジュール)で周辺モジ

ュールを選択します。 
 

 
Filter Select All 
Peripherals. 

[Peripheral]フォーマットのみ 

全ての周辺モジュールを選択するフィルタ 
 

12.9.4.3 [SFRs]ウィンドウのメニュー 
このメモリウィンドウのデータ領域で右クリックすると、このメニューが表示されます。 

表12-25 [SFRs]ウィンドウのコンテクスト メニュー 
 

項目 説明* 

Find [Find]ダイアログで指定したテキストを検索します。 

Output To File [Output to File]ダイアログを使って、ウィンドウの表示内容をテキストファイルに書き出しま

す。 
Print [Print]ダイアログを使って、このウィンドウの内容を印刷します。 

Note:  メモリ容量の大きなデバイスの場合、印刷ページ数が非常に多くなる事があります。

その場合、ウィンドウの内容をファイルに出力した後([Print]ダイアログの[General]タブの

[Print to File]チェックボックス)、そのファイルから必要なページだけ選んで印刷する事を推

奨します。 
Adjust Table 
Columns 

行を自動的に調節します。 

 
12.9.5 [I/O Memory (SFRs)]ウィンドウ 

[I/O Memory]ウィンドウは、選択したATプロセッサのSFR(特殊機能レジスタ)の内容を表示します。このウィンドウ

には各SFR名と複数のフォーマットが表示されているため、通常のSRAMデータメモリ ウィンドウよりSFRの表示

に便利です。少数のSFRを表示する場合、[Watches]ウィンドウを推奨します。ハードウェア デバッグツール使用時

に速度問題対策に役立つ事があります(ウィンドウ更新レートが速いため)。 

ブレークが発生すると常に特殊機能レジスタの内容が更新されます。 

デバッグ用ハードウェア ツールを使う場合、一部のレジスタは予約済みリソースを表すためにデータのニブルごと

に「R」を表示する事があります。 

可視レジスタ 

データメモリ レジスタが物理的にデバイス上に実装されていない場合、SFRの一覧に表示されない事があります。

シミュレータ等の一部のツールを使うと、実際のデバイス上に存在しないレジスタを表示できます。 

シングルステップ実行 
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[Freeze Peripherals On Halt]を選択した場合、SFRのI/Oポートビットまたは[Watches]ウィンドウはシングルステッ

プ実行では更新されません。ピンは変更されますが、新規の値を取得するための読み出し要求はフリーズによって阻

止され、次のステップまたは実行コマンドまで更新されません。 

図12-13 [I/O Memory]ウィンドウの内容 

12.9.5.1 [I/O Memory]ウィンドウの表示 
ウィンドウ下部の[Format]ドロップダウン ボックスを選択する事で、ウィンドウ内のメモリの表示方法を変更でき

ます。 

[Individual] 

この表示画面では、SFRはアドレスで表示されます。データは以下の列に表示されます。 
• Address – SFRの16進アドレスです。 
• Name – SFRのシンボル名です。 
• 基数情報 – Hex、Decimal、Binary、Char  

基数情報はこれらの4列に表示されます。HEXは1バイトのブロックで表示されます。 

[Peripheral] 

この表示画面では、SFRは関連するデバイスの周辺モジュールに従ってグループ化されます。データは以下の列に表

示されます。 
• Address – SFRの16進アドレスです。 
• Name – 周辺モジュール名またはSFRのシンボル名です。 
• 基数情報 – Hex、Decimal、Binary、Char  

基数情報はこれらの4列に表示されます。HEXは1バイトのブロックで表示されます。 

[Filter Peripheral]アイコンをクリックして選択した周辺モジュールのみのSFRを表示します。 

[CPU Registers] 

この表示画面では、CPUレジスタ(PCとワーキング レジスタRn)はアドレスで表示されます。 
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データは以下の列に表示されます。 

• Address – SFRの16進アドレスです。 
• Name – 周辺モジュール名またはSFRのシンボル名です。 
• 基数情報 – Hex、Decimal、Binary、Char  

基数情報はこれらの4列に表示されます。HEXは1バイトのブロックで表示されます。 

12.9.5.2 [I/O Memory]ウィンドウのアイコン 
アイコンはウィンドウの左側にあります。 

表12-26 [I/O Memory]ウィンドウのアイコン 
 

アイコン  機能 
 

 
Find ウィンドウ内で検索する文字列を指定します。単語単位で一致するか、大文字と

小文字を区別するかを選択します。 
 

 
Find Next [Find]に指定した文字列の次のインスタンスを検索します。 

 

 
Find Previous [Find]に指定した文字列の前のインスタンスを検索します。 

 

 
Go To 指定した行番号またはアドレスに移動します。 

 

 
Filter Peripherals [Peripheral]フォーマットのみ 

利用可能な周辺モジュールを絞り込んで表示します。 

アイコンをクリックすると[Select]ダイアログが開きます。<Shift>+クリック

(連続した複数モジュール)または<Ctrl>+クリック(個別モジュール)で周辺モジ

ュールを選択します。 
 

 
Filter Select All 
Peripherals. 

[Peripheral]フォーマットのみ 

全ての周辺モジュールを選択するフィルタ 
 

12.9.5.3 [I/O Memory]ウィンドウのメニュー 
このメモリウィンドウのデータ領域で右クリックすると、このメニューが表示されます。 

表12-27 [I/O Memory]ウィンドウのコンテクスト メニュー 
 

項目 説明 

Go To [Go To]ダイアログで指定したアドレス/関数に移動します。 

Find [Find]ダイアログで指定したテキストを検索します。 

Show Register 
Tooltips 

レジスタ用ツールチップの表示/非表示を切り換える事ができます。レジスタ名の上にマウ

スカーソルを置くと、情報が表示されます。 

Output To File [Output to File]ダイアログを使って、ウィンドウの表示内容をテキストファイルに書き出し

ます。 
Print [Print]ダイアログを使って、このウィンドウの内容を印刷します。 

Note:  メモリ容量の大きなデバイスの場合、印刷ページ数が非常に多くなる事がありま

す。その場合、ウィンドウの内容をファイルに出力した後([Print]ダイアログの[General]
タブの[Print to File]チェックボックス)、そのファイルから必要なページだけ選んで印刷

する事を推奨します。 
Adjust Table Columns 行を自動的に調節します。 

 
12.9.6 [Configuration Bits]ウィンドウ 

[Configuration Bits]ウィンドウの使い方の詳細は4.19「[Configuration Bits]ウィンドウでのコンフィグレーション値の

設定」で説明しています。 



MPLAB X IDEユーザガイド 
MPLAB X IDEのウィンドウとダイアログ 

ユーザガイド DS-50002027E_JP - p. 240 © 2019 Microchip Technology 
 

 

 

 
 

図12-14 [Configuration Bits]ウィンドウの内容 

12.9.6.1 [Configuration Bits]ウィンドウの表示 
ウィンドウ下部の[Format]ドロップダウン ボックスを選択する事で、ウィンドウ内のメモリの表示方法を変更でき

ます。利用可能なフォーマットはデバイスによって異なります。 

ウィンドウでコンフィグレーション ビットの設定が完了したら[Generate Source Code to Output]ボタンをクリ

ックし、[Output]ウィンドウにデバイス固有のコンフィグレーション コードを書き込む事ができます。その後、エ

ディタ ウィンドウでこのコードをアプリケーションにペーストできます。 

表12-28 [Configuration Bits]ウィンドウの表示 
 

列見出し 定義 

Address コンフィグレーション ワード/バイトのアドレスです。 

Name コンフィグレーション レジスタの名前です。 

Value コンフィグレーション ワード/バイトの現在の値です。 

Field* コード内で設定されたコンフィグレーション ビットのマクロのフィールド部です。 
例えば、WDTEはマクロ_WDTE_OFFのフィールド部です。 

Option* コード内で設定されたコンフィグレーション ビットのマクロのオプション部です。 
例えば、OFFはマクロ_WDTE_OFFのオプション部です。 

Category 対応するコンフィグレーション ワード/バイトのコンフィグレーション ビット名です。 

Setting コンフィグレーション ビットの現在の値です。設定を変更するには、ドロップダウン リストを使

います。それに従ってコンフィグレーション ワード/バイトの値が変更されます。 

* デバイスによってはサポートしていません。 
 

12.9.6.2 [Configuration Bits]ウィンドウのアイコン 
アイコンはウィンドウの左側にあります。 

表12-29 [Configuration Bits]ウィンドウのアイコン 
 

アイコン アイコンテキスト 機能 
 

 
Refresh by 
Read Device 
Memory 

デバッグツール バーの[Read Device Memory]アイコンと同じ機能 - デバイスメモ

リをMPLAB X IDEにアップロードします。 
 

 
Find ウィンドウ内で検索する文字列を指定します。単語単位で一致するか、大文字と

小文字を区別するかを選択します。 
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(続き) 
アイコン アイコンテキスト 機能 

 

 
Find Next [Find]に指定した文字列の次のインスタンスを検索します。 

 

 
Find Previous [Find]に指定した文字列の前のインスタンスを検索します。 

 

 
Paste 生成されたソースコードをエディタのカーソル位置に貼り付けます。 

エディタにフォーカスされていない場合、警告とソースコードが[Output]ウィンド
ウに表示されます。 

 

12.9.6.3 [Configuration Bits]ウィンドウのメニュー 
このメモリウィンドウのデータ領域で右クリックすると、このメニューが表示されます。MCUによっては表示されない項

目があります。 

表12-30 [Configuration Bits]ウィンドウのメニュー 
 

項目 説明 
Generate Source 
Code to Output 

コンフィグレーション ビットを設定します。次に、このオプションを選択して[Output]ウィ
ンドウでコードを生成すると、このコードをプログラムにペーストしてコンフィグレーショ
ン ビットを設定できます。 
ウィンドウのボタンと同じ機能です。 

Insert Source Code 
to Editor 

コンフィグレーション ビットを設定します。次に、このオプションを選択して[Editor]ウィ
ンドウ内でコードを生成すると、このコードをプログラムにペーストしてコンフィグレー
ション ビットを設定できます。 

Reset to Defaults 全てのコンフィグレーション ビットの値をMPLAB X IDEの既定値にリセットします。 

Enable Multiline 
Rows 

列が内容(カテゴリ等)より短い場合、内容の折り返しを許可します。選択しない場合
内容は省略され、省略記号(...)で示されます。 

Output To File [Output to File]ダイアログを使って、ウィンドウの表示内容をテキストファイルに書き出しま
す。 

Print [Print]ダイアログを使って、このウィンドウの内容を印刷します。 
Note:  メモリ容量の大きなデバイスの場合、印刷ページ数が非常に多くなる事がありま
す。その場合、ウィンドウの内容をファイルに出力した後([Print]ダイアログの[General]タ
ブの[Print to File]チェックボックス)、そのファイルから必要なページだけ選んで印刷する
事を推奨します。 

Adjust Table 
Columns 

行を自動的に調節します。 

 
12.9.7 [EE Data Memory]ウィンドウ 

[EE Data Memory]ウィンドウは、EEPROMデータメモリを備えたMCU(例: PIC16F1829)のEEPROMデータを表示し

ます。選択したデバイスのデータ/オペコードHEX情報が表示されます。 

MPLAB Xのシミュレータでは、EEPROMレジスタの値が変化した場合またはプロセッサが停止した場合、[EE Data 
Memory]ウィンドウのデータが更新されます。 

Microchip社のハードウェア デバッグツール(例: MPLAB PICkit 4インサーキット デバッガ)では、EEPROMレジスタ

の値が変化した場合、またはプロセッサが停止した場合、[EE Data Memory]ウィンドウのデータは更新されません。

データを更新するには、デバイスメモリのデバッグ読み出し(デバイス/ヘッダがこれをサポートしている場合)を実行

する必要があります。または、デバッグ セッションを終了した後、デバイスのデータを読み出す必要があります。 

EEPROMデータメモリの開始アドレスは、プログラマで指定する必要があります。下表に、一般的な開始アドレス

を示します。ただし実際のアドレスはデバイスのプログラミング仕様で確認する必要があります。 

表12-31 プログラマ – データEEPROMの開始アドレス 
 

デバイス 一般的な開始アドレス 

ミッドレンジMCU 0x2100 
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(続き) 
デバイス 一般的な開始アドレス 

エンハンスト ミッドレンジMCU 0x1E000 

PIC18F MCU 0xF00000 

PIC24 MCU、dsPIC DSC 0x7FFE00 
 

図12-15 [EE Data Memory]ウィンドウの内容 

12.9.7.1 [EE Data Memory]ウィンドウの表示 
この画面は以下の列にデータを表示します。 

• Address – 隣の列のデータの16進アドレスです。 
• データブロック – 16進データです。メニューから選択できる1バイト、2バイト、4バイトのブロックで表示されます。 
• ASCII – 対応するデータ行のASCII表示です。 

 
12.9.7.2 [EE Data Memory]ウィンドウのアイコン 

アイコンはウィンドウの左側にあります。 

表12-32 [EE Data Memory]ウィンドウのアイコン 
 

アイコン アイコンテキスト 機能 
 

 
Refresh by Read 
Device Memory 

デバッグツール バーの[Read Device Memory]アイコンと同じ機能 - デバ

イスメモリをMPLAB X IDEにアップロードします。 
 

 
Find ウィンドウ内で検索する文字列を指定します。単語単位で一致するか、大文

字と小文字を区別するかを選択します。 
 

 
Find Next [Find]に指定した文字列の次のインスタンスを検索します。 

 

 
Find Previous [Find]に指定した文字列の前のインスタンスを検索します。 

 

 
Go To 指定した行番号またはアドレスに移動します。 

 
12.9.7.3 [EE Data Memory]ウィンドウのメニュー 

このメモリウィンドウのデータ領域で右クリックすると、下表のメニューが表示されます。 
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表12-33 [EE Data Memory]ウィンドウのコンテクスト メニュー 
 

項目 説明* 

Hex Display Width [Hex]フォーマットのみ 
16進数の表示幅を設定します。 

(選択肢はデバイスによって異なります。) 
Fill Memory メモリの[Start Address]～[End Address]に[Data]内の値を書き込みま

す。[Fill Memory]ダイアログで、その他のオプションを指定します。 
Go To [Go To]ダイアログで指定したアドレス/関数に移動します。 

Find [Find]ダイアログで指定したテキストを検索します。 

Output To File [Output to File]ダイアログを使って、ウィンドウの表示内容をテキストファイルに書き出しま

す。 
Import Table [Import Table]ダイアログを使って、ファイルから[Memory]ウィンドウに表形式のデータをイ

ンポートします。 
Export Table [Export Table]ダイアログを使って、[Memory]ウィンドウからファイルへ表形式のデータをエ

クスポートします。 
Print [Print]ダイアログを使って、このウィンドウの内容を印刷します。 

Note:  メモリ容量の大きなデバイスの場合、印刷ページ数が非常に多くなる事がありま

す。その場合、ウィンドウの内容をファイルに出力した後([Print]ダイアログの[General]タブ

の[Print to File]チェックボックス)、そのファイルから必要なページだけ選んで印刷する事を

推奨します。 
Adjust Table 
Columns 

行を自動的に調節します。 

 
12.9.8 [Device Information]ウィンドウ 

[Device Information]ウィンドウは、このメモリ空間をサポートするデバイス(現時点ではPIC18F24K42と多くの

PIC16Fxxxxx)用メモリのDIA (Device Information Area)の内容を表示します。DIAは内部温度インジケータ モジュー

ルの校正データを収めており、Microchip社固有の識別子ワードと、mVで計測された固定参照電圧読み値を保存しま

す。詳細はデバイスのデータシートを参照してください。 

図12-16 [Device Information]ウィンドウ 

 
12.9.8.1 [Device Information]ウィンドウの画面 

この画面は以下の列にデータを表示します。 

• Address – 隣の列のデータの16進アドレスです。 
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• Hex – 16進データです。メニューから選択できる1バイト、2バイト、4バイトのブロックで表示されます。 
• Name – データの対応行のASCII表示です。 

12.9.8.2 [Device Information]ウィンドウのアイコン 
アイコンはウィンドウの左側にあります。 

表12-34 [Device Information]ウィンドウのアイコン 
 

アイコン アイコンテキスト 機能 
 

 
Refresh by Read 
Device Memory 

デバッグツール バーの[Read Device Memory]アイコンと同じ機能 - デバ

イスメモリをMPLAB X IDEにアップロードします。 
 

 
Find ウィンドウ内で検索する文字列を指定します。単語単位で一致するか、大文

字と小文字を区別するかを選択します。 
 

 
Find Next [Find]に指定した文字列の次のインスタンスを検索します。 

 

 
Find Previous [Find]に指定した文字列の前のインスタンスを検索します。 

 

 
Go To 指定した行番号またはアドレスに移動します。 

 
12.9.8.3 [Device Information]ウィンドウのメニュー 

このメモリウィンドウのデータ領域で右クリックすると、このメニューが表示されます。デバイスによっては表示さ

れない項目があります。 

表12-35 [Device Information]ウィンドウのコンテクスト メニュー 
 

項目 説明 

Fill Memory メモリの[Start Address]～[End Address]に[Data]内の値を書き込みま

す。[Fill Memory]ダイアログで、その他のオプションを指定します。 

Go To [Go To]ダイアログで指定したアドレス/関数に移動します。 

Find [Find]ダイアログで指定したテキストを検索します。 

Output To File [Output to File]ダイアログを使って、ウィンドウの表示内容をテキストファイルに書き出しま

す。 
Print [Print]ダイアログを使って、このウィンドウの内容を印刷します。 

Note:  メモリ容量の大きなデバイスの場合、印刷ページ数が非常に多くなる事があります。

その場合、ウィンドウの内容をファイルに出力した後([Print]ダイアログの[General]タブの

[Print to File]チェックボックス)、そのファイルから必要なページだけ選んで印刷する事を推

奨します。 
Adjust Table 
Columns 

行を自動的に調節します。 

 
12.9.9 [Hardware Stack]ウィンドウ 

停止時にハードウェア スタックの内容を表示します。 

[Hardware Stack]ウィンドウは、[Window] > [PIC Memory Views] > [Hardware Stack]と選択して開きます。最初のス

タックレベルは「0」で表します。 



MPLAB X IDEユーザガイド 
MPLAB X IDEのウィンドウとダイアログ 

ユーザガイド DS-50002027E_JP - p. 245 © 2019 Microchip Technology 
 

 

 

 
 

図12-17 [Hardware Stack]ウィンドウの内容 

12.9.9.1 [Hardware Stack]ウィンドウの表示 
スタックのレベル数はデバイスによって異なります。この画面は以下の列にデータを表示します。 

• TOS – Top of Stack現在位置 
• Stack Level – スタック上のアイテム位置 
• Return Address – スタックからのリターンアドレス16進 
• Location – リターンアドレス コードの逆アセンブル 

デバッグ用ハードウェア ツールを使う場合、一部のレジスタは予約済みリソースを表すためにデータのニブルごと

に「R」を表示する事があります。 

12.9.9.2 [Hardware Stack]ウィンドウのアイコン 
一時停止または停止時にこのウィンドウで使えるアイコンは以下の通りです。 

表12-36 [Hardware Stack]ウィンドウのアイコン 
 

アイコン アイコン

テキスト 
説明 

 

 
 

 

Auto 
Refresh 
Manual 
Refresh 

ウィンドウの内容を自動または手動で更新します。 
[Tools] > [Options] > [Embedded] > [Generic Settings]の[Disable auto refresh for call stack 
view during debug sessions]の値(チェックを外す = 偽(既定値)、チェックを入れる = 真)の影

響を受けます。12.16.1「[Generic Settings]タブ」を参照してください。 

偽 = 自動更新(緑のアイコン): ウィンドウの内容は、一時停止または停止時に自動更新され

ます。ウィンドウが閉じられている場合、またはフォーカスされていない場合、ウィンド

ウを選択しこのボタンをクリックすると更新が表示されます。再度実行および一時停止/停
止する必要はありません。 

真 = 手動更新(オレンジのアイコン): ウィンドウの内容は、一時停止または停止しても自動

では更新されません。一時停止/停止時にウィンドウの内容を更新するには、このボタンを

クリックする必要があります。 
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(続き) 
アイコン アイコン

テキスト 
説明 

 

 
Find ウィンドウ内で検索する文字列を指定します。単語単位で一致するか、大文字と小文字を区

別するかを選択します。 
 

 
Find Next [Find]に指定した文字列の次のインスタンスを検索します。 

 

 
Find 
Previous 

[Find]に指定した文字列の前のインスタンスを検索します。 
 

12.9.9.3 [Hardware Stack]ウィンドウのメニュー 
このメモリウィンドウのデータ領域で右クリックすると、このメニューが表示されます。 

表12-37 [Hardware Stack]ウィンドウのコンテクスト メニュー 
 

項目 説明* 

Go To Source Line エディタでソースコード内の対応する行に移動します。 

Output To File [Output to File]ダイアログを使って、ウィンドウの表示内容をテキストファイルに書き出し

ます。 
Print [Print]ダイアログを使って、このウィンドウの内容を印刷します。 

Note:  メモリ容量の大きなデバイスの場合、印刷ページ数が非常に多くなる事がありま

す。その場合、ウィンドウの内容をファイルに出力した後([Print]ダイアログの[General]タ
ブの[Print to File]チェックボックス)、そのファイルから必要なページだけ選んで印刷する

事を推奨します。 
Adjust Table 
Columns 

行を自動的に調節します。 

 
12.9.10 [Linear Data]ウィンドウ 

[Linear Data]ウィンドウは、このタイプのメモリを備えたMCUのフラッシュデータを表示します。選択したデバイ

スのデータ/オペコードHEX情報が表示されます。 

MPLAB Xのシミュレータでは、リニアデータ レジスタの値が変化した場合またはプロセッサが停止した場合、

[Linear Data]ウィンドウのデータが更新されます。 

Microchip社のハードウェア デバッグツール(例: MPLAB ICD 4インサーキット エミュレータ)では、リニアデータ レ
ジスタの値が変化した場合、またはプロセッサが停止した場合、[Linear Data]ウィンドウのデータは更新されません。

データを更新するには、デバイスメモリのデバッグ読み出し(デバイス/ヘッダがこれをサポートしている場合)を実行

する必要があります。または、デバッグ セッションを終了した後、デバイスのデータを読み出す必要があります。 

図12-18 [Linear Data]ウィンドウの内容 

12.9.10.1 [Linear Data]ウィンドウの表示 
この画面は以下の列にデータを表示します。 

• Address – 隣の列のデータの16進アドレスです。 



MPLAB X IDEユーザガイド 
MPLAB X IDEのウィンドウとダイアログ 

ユーザガイド DS-50002027E_JP - p. 247 © 2019 Microchip Technology 
 

 

 

 
 

• データブロック – 16進データです。メニューから選択できる1バイト、2バイト、4バイトのブロックで表示され

ます。 
• ASCII – 対応するデータ行のASCII表示です。 

12.9.10.2 [Linear Data]ウィンドウのアイコン 
アイコンはウィンドウの左側にあります。 

表12-38 [Linear Data]ウィンドウのアイコン 
 

アイコン アイコンテキ

スト 
機能 

 

 
Find ウィンドウ内で検索する文字列を指定します。単語単位で一致するか、大文字と小文字

を区別するかを選択します。 
 

 
Find Next [Find]に指定した文字列の次のインスタンスを検索します。 

 

 
Find Previous [Find]に指定した文字列の前のインスタンスを検索します。 

 

 
Go To 指定した行番号またはアドレスに移動します。 

 
12.9.10.3 [Linear Data]ウィンドウのメニュー 

このメモリウィンドウのデータ領域で右クリックすると、下表のメニューが表示されます。 

表12-39 [Linear Data]ウィンドウのコンテクスト メニュー 
 

項目 説明* 

Fill Memory メモリの[Start Address]～[End Address]に[Data]内の値を書き込みま

す。[Fill Memory]ダイアログで、その他のオプションを指定します。 

Go To [Go To]ダイアログで指定したアドレス/関数に移動します。 

Find [Find]ダイアログで指定したテキストを検索します。 

Output To File [Output to File]ダイアログを使って、ウィンドウの表示内容をテキストファイルに書き出しま

す。 
Import Table [Import Table]ダイアログを使って、ファイルから[Memory]ウィンドウに表形式のデータをイ

ンポートします。 
Export Table [Export Table]ダイアログを使って、[Memory]ウィンドウからファイルへ表形式のデータをエ

クスポートします。 
Print [Print]ダイアログを使って、このウィンドウの内容を印刷します。 

Note:  メモリ容量の大きなデバイスの場合、印刷ページ数が非常に多くなる事があります。

その場合、ウィンドウの内容をファイルに出力した後([Print]ダイアログの[General]タブの

[Print to File]チェックボックス)、そのファイルから必要なページだけ選んで印刷する事を推

奨します。 
Adjust Table 
Columns 

行を自動的に調節します。 

 
12.9.11 [User ID Memory]ウィンドウ 

一部のデバイスは、ユーザがチェックサムまたはその他のコード識別(ID)番号を格納できるメモリ位置を持っていま

す。これらの位置はプログラム/ベリファイ中に読み書き可能です。デバイスによっては、通常の実行中もTBLRDお

よびTBLWT命令を使ってこれらの位置をアクセスできます。 
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図12-19 [User ID Memory]ウィンドウの内容 

12.9.11.1 [User ID Memory]ウィンドウの表示 
この欄に入力する値はデバイスのプログラミング仕様を参照してください。ほとんどのデバイスでは、この値でデバ

イスのIDワードの下位ニブルを設定し、上位ニブルは「0」に設定されます。上位ニブルは、テーブル書き込み等を

使ってプログラム的にのみ書き込む事ができます。 

ウィンドウ下部の[Format]ドロップダウン ボックスを選択する事で、ウィンドウ内のメモリの表示方法を変更できま

す。 

図12-20 標準表示 

標準表示では、以下の列にデータを表示します。 

• Address – ユーザIDの16進アドレスです。 
• User ID – ユーザIDメモリの内容(HEX形式)です。 

図12-21レガシー表示 

レガシー表示では、以下の列にデータを表示します。 

• Address – ユーザIDの16進開始アドレスです。 
• User ID – ユーザIDメモリの内容(HEX形式)です。 

12.9.11.2 [User ID Memory]ウィンドウのアイコン 
アイコンはウィンドウの左側にあります。 

表12-40 [User ID Memory]ウィンドウのアイコン 
 

アイコン アイコンテキスト 機能 
 

 
Find ウィンドウ内で検索する文字列を指定します。単語単位で一致するか、大文字と小文

字を区別するかを選択します。 
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(続き) 
アイコン アイコンテキスト 機能 

 

 
Find Next [Find]に指定した文字列の次のインスタンスを検索します。 

 

 
Find Previous [Find]に指定した文字列の前のインスタンスを検索します。 

 

12.9.11.3 [User ID Memory]ウィンドウのメニュー 
このメモリウィンドウのデータ領域で右クリックすると、下表のメニューが表示されます。 

表12-41 [User ID Memory]ウィンドウのコンテクスト メニュー 
 

項目 説明* 

Output To File [Output to File]ダイアログを使って、ウィンドウの表示内容をテキストファイルに書き出します。 
 
 
12.10 [Memory]ウィンドウ - 32ビットデバイス 

[Memory]ウィンドウ([Window] > [Target Memory Views])は各種のデバイスメモリ(SFR、コンフィグレーション ビッ

ト等)を表示します。このウィンドウは、[Memory]および[Format]ドロップダウン ボックスを使ってカスタマイズで

きます。 

詳細は4.18「デバイスメモリの表示と変更」を参照してください。 

関連ダイアログの詳細は12.11「[Memory]ウィンドウのダイアログ」を参照してください。 

Note:  [Configuration Bits]ウィンドウと[User ID]は、8/16/32ビットデバイスで似ています。唯一の違いは、各ウィン

ドウの値がデバイスで使えるプログラムメモリを反映している事です。 

図12-22 [Window] > [Target Memory Views] - [PIC32MX795F512L] 

図12-23 [Window] > [Target Memory Views] - [ATSAME70Q21B] 

 
 

12.10.1 [Execution Memory]ウィンドウ 
[Execution Memory]ウィンドウは、現在選択している32ビットデバイスのプログラムおよび/またはデータメモリの

レンジ内の位置を表示します。 

MPLAB Xのシミュレータでは、実行メモリの値が変化した場合またはプロセッサが停止した場合、[Execution 
Memory]ウィンドウのデータが更新されます。 

Microchip社のハードウェア デバッグツール(例: MPLAB ICD 4インサーキット エミュレータ)では、実行メモリの値

が変化した場合、またはプロセッサが停止した場合、[Execution Memory]ウィンドウのデータは更新されません。デ

バイスメモリの読み出しを実行する必要があります。 
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図12-24 [Execution Memory]ウィンドウの内容 

12.10.1.1 [Execution Memory]ウィンドウの表示 
ウィンドウ下部の[Format]ドロップダウン ボックスを選択する事で、ウィンドウ内のメモリの表示方法を変更でき

ます。 

デバッグ用ハードウェア ツールを使う場合、一部のレジスタは予約済みリソースを表すためにデータのニブルごと

に「R」を表示する事があります。 

[Code]フォーマット 

このフォーマットは実行メモリ情報をHEXコードで表示します。このウィンドウは以下の列を表示します。 

• Line – メモリアドレスに対応する参照行番号です。 
• Address – オペコードの16進物理アドレスです。 
• Opcode – 16進オペコードです。4バイトのブロックで表示されます。ハイライト表示のオペコードはプログラ

ム カウンタの現在の位置を表します。 
• Label – シンボリック フォーマットのオペコードラベルです。 
• DisAssy – オペコード ニーモニックの逆アセンブル バージョンです。 

[Data]フォーマット 

このウィンドウは以下の列を表示します。 

• Address – 隣の列のデータの16進アドレスです。 
• データブロック – 16進データです。4バイトのブロックで表示されます。 
• ASCII – 対応するデータ行のASCII表示です。 

12.10.1.2 [Execution Memory]ウィンドウのアイコン 
アイコンはウィンドウの左側にあります。 
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表12-42 [Execution Memory]ウィンドウのアイコン 
 

アイコン アイコンテキスト 機能 
 

 
Refresh by Read 
Device Memory 

デバッグツール バーの[Read Device Memory]アイコンと同じ機能 - デバ

イスメモリをMPLAB X IDEにアップロードします。 
 

 
Find ウィンドウ内で検索する文字列を指定します。単語単位で一致するか、大文

字と小文字を区別するかを選択します。 
 

 
Find Next [Find]に指定した文字列の次のインスタンスを検索します。 

 

 
Find Previous [Find]に指定した文字列の前のインスタンスを検索します。 

 

 
Go To 指定した行番号またはアドレスに移動します。 

 
12.10.1.3 [Execution Memory]ウィンドウのメニュー 

[CODE]フォーマットに設定したメモリウィンドウのデータ領域を右クリックすると、このメニューが表示されます。

全ての32ビットMCUで全ての項目が表示されるわけではありません。 

表12-43 [Execution Memory]ウィンドウのコンテクスト メニュー - [Code]フォーマット 
 

項目 説明 

Virtual Address 
(KSEG[0:1]) 

表示する仮想アドレスを選択します。詳細はデバイスのデータシートを参照してください。 

Physical Address 表示する物理アドレスを選択します。 

Run to Cursor 現在のカーソル位置までプログラムを実行します。 

Step Instruction ステップ命令を1つ実行します。 

Set PC at Cursor プログラム カウンタ(PC)を現在のカーソル位置に設定します。 

Focus Cursor at PC カーソルを現在のPCアドレス位置へ移動し、このアドレスをウィンドウの中心に表示しま

す。 
Toggle Breakpoint 既存のブレークポイントのON/OFFを切り換えます。 

Symbolic Mode 逆アセンブルHEXコードをシンボルで表示します。 

Auto Decode 16 bit MIP16 / microMIPS命令デコードを使います。詳細はデバイスのデータシートを参照してく

ださい。 
Fill Memory メモリの[Start Address]～[End Address]に[Data]内の値を書き込みま

す。[Fill Memory]ダイアログで、その他のオプションを指定します。 

Go To [Go To]ダイアログを使って指定したアドレス/関数に移動します。 

Go To Source Line エディタでソースコード内の対応する行に移動します。 

Find [Find]ダイアログで指定したテキストを検索します。 

Output To File [Output to File]ダイアログを使って、ウィンドウの表示内容をテキストファイルに書き出し

ます。 
Print [Print]ダイアログを使って、このウィンドウの内容を印刷します。 

Note:  メモリ容量の大きなデバイスの場合、印刷ページ数が非常に多くなる事がありま

す。その場合、ウィンドウの内容をファイルに出力した後([Print]ダイアログの[General]タ
ブの[Print to File]チェックボックス)、そのファイルから必要なページだけ選んで印刷する

事を推奨します。 
Adjust Table Columns 行を自動的に調節します。 

 
[DATA]フォーマットに設定したメモリウィンドウのデータ領域を右クリックすると、このメニューが表示されます。

全ての32ビットMCUで全ての項目が表示されるわけではありません。 



MPLAB X IDEユーザガイド 
MPLAB X IDEのウィンドウとダイアログ 

ユーザガイド DS-50002027E_JP - p. 252 © 2019 Microchip Technology 
 

 

 

 
 

表12-44 [Execution Memory]ウィンドウのコンテクスト メニュー - [Data]フォーマット 
 

項目 説明 

Virtual Address 
(KSEG[0:1]) 

表示する仮想アドレスを選択します。詳細はデバイスのデータシートを参照してください。 

Physical Address 表示する物理アドレスを選択します。 

Hex Width Display 16進数の表示幅を設定します。(選択肢はデバイスによって異なります。) 

例: 

One byte(例: 00 01 02 ...0E 0F) 

Two bytes (例: 00 02 04 ...0C 0E) 

Four bytes (例: 00 04 08 0C) 

Fill Memory メモリの[Start Address]～[End Address]に[Data]内の値を書き込みます。[Fill Memory]ダイ

アログで、その他のオプションを指定します。 

Go To [Go To]ダイアログで指定したアドレス/関数に移動します。 

Find [Find]ダイアログで指定したテキストを検索します。 

Output To File [Output to File]ダイアログを使って、ウィンドウの表示内容をテキストファイルに書き出し

ます。 
Import Table [Import Table]ダイアログを使って、ファイルから[Memory]ウィンドウに表形式のデータを

インポートします。 
Export Table [Export Table]ダイアログを使って、[Memory]ウィンドウからファイルへ表形式のデータを

エクスポートします。 
Print [Print]ダイアログを使って、このウィンドウの内容を印刷します。 

Note:  メモリ容量の大きなデバイスの場合、印刷ページ数が非常に多くなる事がありま

す。その場合、ウィンドウの内容をファイルに出力した後([Print]ダイアログの[General]タ
ブの[Print to File]チェックボックス)、そのファイルから必要なページだけ選んで印刷する

事を推奨します。 
Adjust Table Columns 行を自動的に調節します。 

 
12.10.2 [Data Memory]ウィンドウ 

[Data Memory]ウィンドウは、現在選択している32ビットデバイスのデータおよび/またはプログラムメモリのレ

ンジ内の位置を表示します。 
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図12-25 [Data Memory]ウィンドウの内容 

12.10.2.1 [Data Memory]ウィンドウの表示 
ウィンドウ下部の[Format]ドロップダウン ボックスを選択する事で、ウィンドウ内のメモリの表示方法を変更でき

ます。 

デバッグ用ハードウェア ツールを使う場合、一部のレジスタは予約済みリソースを表すためにデータのニブルごと

に「R」を表示する事があります。 

[Data]フォーマット 

このウィンドウは以下の列を表示します。 

• Address – 隣の列のデータの16進アドレスです。 
• データブロック – 16進データです。4バイトのブロックで表示されます。 
• ASCII – 対応するデータ行のASCII表示です。 

[Code]フォーマット 

このウィンドウは以下の列を表示します。 

• Line – メモリアドレスに対応する参照行番号です。 
• Address – オペコードの16進物理アドレスです。 
• Opcode – 16進オペコードです。4バイトのブロックで表示されます。 

ハイライト表示のオペコードはプログラム カウンタの現在の位置を表します。 
• Label – シンボリック フォーマットのオペコードラベルです。 
• DisAssy – オペコード ニーモニックの逆アセンブル バージョンです。 

12.10.2.2 [Data Memory]ウィンドウのアイコン 
アイコンはウィンドウの左側にあります。 

表12-45 [Data Memory]ウィンドウのアイコン 
 

アイコン アイコンテキスト 機能 
 

 
Refresh by Read 
Device Memory 

デバッグツール バーの[Read Device Memory]アイコンと同じ機能 - デバイス

メモリをMPLAB X IDEにアップロードします。 
 

 
Find ウィンドウ内で検索する文字列を指定します。単語単位で一致するか、大文字と

小文字を区別するかを選択します。 
 

 
Find Next [Find]に指定した文字列の次のインスタンスを検索します。 
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(続き) 
アイコン アイコンテキスト 機能 

 

 
Find Previous [Find]に指定した文字列の前のインスタンスを検索します。 

 

 
Go To 指定した行番号またはアドレスに移動します。 

 

12.10.2.3 [Data Memory]ウィンドウのメニュー 
このメモリウィンドウのデータ領域で右クリックすると、このメニューが表示されます。全ての32ビットMCUで全

ての項目が表示されるわけではありません。 

表12-46 [Data Memory]ウィンドウのコンテクスト メニュー 
 

項目 説明 

Virtual Address 表示する仮想アドレスを選択します。詳細はデバイスのデータシートを参照してください。 

Physical Address 表示する物理アドレスを選択します。 

Symbolic Mode [Code]フォーマットのみ 
逆アセンブルHEXコードをシンボルで表示します。 

Hex Width Display [Data]フォーマットのみ 
16進数の表示幅を設定します。(選択肢はデバイスによって異なります。) 
例: 
One byte (例: 00 01 02 ...0E 0F) 

Two bytes (例: 00 02 04 ...0C 0E) 

Four bytes (例: 00 04 08 0C) 
Fill Memory メモリの[Start Address]～[End Address]に[Data]内の値を書き込みます。[Fill Memory]ダイ

アログで、その他のオプションを指定します。 

Go To [Go To]ダイアログで指定したアドレス/関数に移動します。 

Go To Source Line [Code]フォーマットのみ 
エディタでソースコード内の対応する行に移動します。 

Find [Find]ダイアログで指定したテキストを検索します。 

Output To File [Output to File]ダイアログを使って、ウィンドウの表示内容をテキストファイルに書き出し

ます。 
Import Table [Import Table]ダイアログを使って、ファイルから[Memory]ウィンドウに表形式のデータを

インポートします。 
Export Table [Export Table]ダイアログを使って、[Memory]ウィンドウからファイルへ表形式のデータを

エクスポートします。 
Print [Print]ダイアログを使って、このウィンドウの内容を印刷します。 

Note:  メモリ容量の大きなデバイスの場合、印刷ページ数が非常に多くなる事がありま

す。その場合、ウィンドウの内容をファイルに出力した後([Print]ダイアログの[General]タ
ブの[Print to File]チェックボックス)、そのファイルから必要なページだけ選んで印刷する

事を推奨します。 
Adjust Table 
Columns 

行を自動的に調節します。 

 
12.10.3 [Peripherals]ウィンドウ 

[Peripherals]ウィンドウは、デバイスの周辺モジュールに関連するSFRの内容を表示します。少数のSFRを表示する

には、[Watches]ウィンドウを使う事を推奨します。ハードウェア デバッグツール使用時の速度の問題の対策に役立

つ事があります(ウィンドウ更新レートが速いため)。 

ブレークが発生すると常にSFRの内容が更新されます。 
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可視レジスタ 

データメモリ レジスタが物理的にデバイス上に実装されていない場合、SFRの一覧に表示されない事があります。

シミュレータ等の一部のツールを使うと、実際のデバイス上に存在しないプリスケーラ等のレジスタを表示できます。 

シングルステップ実行 

[Freeze Peripherals On Halt]を選択した場合、SFRのI/Oポートビットまたは[Watches]ウィンドウはシングルステッ

プ実行では更新されません。ピンは変更されますが、新規の値を取得するための読み出し要求はフリーズによって阻

止され、次のステップまたは実行コマンドまで更新されません。 

図12-26 [Peripherals]ウィンドウの内容 

 
12.10.3.1 [Peripherals]ウィンドウの表示 

ウィンドウ下部の[Format]ドロップダウン ボックスを選択する事で、ウィンドウ内のメモリの表示方法を変更でき

ます。 

デバッグ用ハードウェア ツールを使う場合、一部のレジスタは予約済みリソースを表すためにデータのニブルごと

に「R」を表示する事があります。 

• Individual - 全周辺モジュール レジスタを一括して表示します。 
• Groups - 周辺モジュール レジスタを機能グループごとに表示します。 

以下の列には、両フォーマットのデータが表示されます。 

• Address – SFRの16進物理アドレスです。 
• Virtual – バスマトリクスで定義したSFRの16進仮想アドレスです。 
• Name – SFRのシンボル名です。 
• 基数情報 – Hex、Decimal、Binary、Char  

行の見出しバーを右クリックして画面に基数情報を追加できます。HEXは4バイトのブロックで表示されます。 

12.10.3.2 [Peripherals]ウィンドウのアイコン 
アイコンはウィンドウの左側にあります。 

表12-47 [Data Memory]ウィンドウのアイコン 
 

アイコン アイコンテキスト 機能 
 

 
Find ウィンドウ内で検索する文字列を指定します。単語単位で一致するか、大文字と小文

字を区別するかを選択します。 
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(続き) 
アイコン アイコンテキスト 機能 

 

 
Find Next [Find]に指定した文字列の次のインスタンスを検索します。 

 

 
Find Previous [Find]に指定した文字列の前のインスタンスを検索します。 

 

 
Go To 指定した行番号またはアドレスに移動します。 

 

12.10.3.3 [Peripherals]ウィンドウのメニュー 
このメモリウィンドウのデータ領域で右クリックすると、下表のメニューが表示されます。 

表12-48 [Peripherals]ウィンドウのコンテクスト メニュー 
 

項目 説明 

Find [Find]ダイアログで指定したテキストを検索します。 

Output To File [Output to File]ダイアログを使って、ウィンドウの表示内容をテキストファイルに書き出しま

す。 
Print [Print]ダイアログを使って、このウィンドウの内容を印刷します。 

Note:  メモリ容量の大きなデバイスの場合、印刷ページ数が非常に多くなる事があります。

その場合、ウィンドウの内容をファイルに出力した後([Print]ダイアログの[General]タブの

[Print to File]チェックボックス)、そのファイルから必要なページだけ選んで印刷する事を推

奨します。 
Adjust Table 
Columns 

行を自動的に調節します。 

 
12.10.4 [Configuration Bits]ウィンドウ 

[Configuration Bits]ウィンドウの使い方の詳細は4.19「[Configuration Bits]ウィンドウでのコンフィグレーション値の

設定」で説明しています。 

図12-27 [Configuration Bits]ウィンドウの内容 

12.10.4.1 [Configuration Bits]ウィンドウの表示 
ウィンドウ下部の[Format]ドロップダウン ボックスを選択する事で、ウィンドウ内のメモリの表示方法を変更でき

ます。利用可能なフォーマットはデバイスによって異なります。 

ウィンドウでコンフィグレーション ビットの設定が完了したら、[Generate Source Code to Output]ボタンをク

リックし、[Output]ウィンドウにデバイス固有のコンフィグレーション コードを書き込む事ができます。その後、

エディタ ウィンドウでこのコードをアプリケーションにペーストできます。 
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表12-49 [Configuration Bits]ウィンドウの表示 
 

列見出し 定義 

Address コンフィグレーション ワード/バイトのアドレスです。 

Name コンフィグレーション レジスタの名前です。 

Value コンフィグレーション ワード/バイトの現在の値です。 

Field* コード内で設定されたコンフィグレーション ビットのマクロのフィールド部です。 
例えば、WDTEはマクロ_WDTE_OFFのフィールド部です。 

Option* コード内で設定されたコンフィグレーション ビットのマクロのオプション部です。 
例えば、OFFはマクロ_WDTE_OFFのオプション部です。 

Category 対応するコンフィグレーション ワード/バイトのコンフィグレーション ビット名です。 

Setting コンフィグレーション ビットの現在の値です。設定を変更するには、ドロップダウン リストを使

います。それに従ってコンフィグレーション ワード/バイトの値が変更されます。 

* デバイスによってはサポートしていません。 
 

12.10.4.2 [Configuration Bits]ウィンドウのアイコン 
アイコンはウィンドウの左側にあります。 

表12-50 [Configuration Bits]ウィンドウのアイコン 
 

アイコン アイコンテキスト 機能 
 

 
Refresh by 
Read Device 
Memory 

デバッグツール バーの[Read Device Memory]アイコンと同じ機能 - デバイスメ

モリをMPLAB X IDEにアップロードします。 
 

 
Find ウィンドウ内で検索する文字列を指定します。単語単位で一致するか、大文字と小

文字を区別するかを選択します。 
 

 
Find Next [Find]に指定した文字列の次のインスタンスを検索します。 

 

 
Find Previous [Find]に指定した文字列の前のインスタンスを検索します。 

 

 
Paste 生成されたソースコードをエディタのカーソル位置に貼り付けます。 

エディタがフォーカスされていない場合、警告とこのウィンドウに生成されたソ

ースコードが[Output]ウィンドウに表示されます。 
 

12.10.4.3 [Configuration Bits]ウィンドウのメニュー 
このメモリウィンドウのデータ領域で右クリックすると、このメニューが表示されます。MCUによっては表示され

ない項目があります。 

表12-51 [Configuration Bits]ウィンドウのメニュー 
 

項目 説明 

Generate Source 
Code to Output 

ウィンドウ内でコンフィグレーション ビットを必要に応じて設定します。次に、このオプ

ションを選択して[Output]ウィンドウでコードを生成すると、このコードをプログラムにペ

ーストしてコンフィグレーション ビットを設定できます。 
ウィンドウのボタンと同じ機能です。 

Insert Source Code 
to Editor 

ウィンドウ内でコンフィグレーション ビットを必要に応じて設定します。次に、このオプ

ションを選択して[Editor]ウィンドウ内でコードを生成すると、このコードをプログラムに

ペーストしてコンフィグレーション ビットを設定できます。 
Reset to Defaults 全てのコンフィグレーション ビットの値をMPLAB X IDEの既定値にリセットします。 

Enable Multiline 
Rows 

列が内容(カテゴリなど等)の長さよりも短い場合、内容の折り返しを許可します。選択しな

い場合内容は省略され、省略記号(...)で示されます。 
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(続き) 
項目 説明 

Output To File [Output to File]ダイアログを使って、ウィンドウの表示内容をテキストファイルに書き出しま

す。 
Print [Print]ダイアログを使って、このウィンドウの内容を印刷します。 

Note:  メモリ容量の大きなデバイスの場合、印刷ページ数が非常に多くなる事がありま

す。その場合、ウィンドウの内容をファイルに出力した後([Print]ダイアログの[General]タ
ブの[Print to File]チェックボックス)、そのファイルから必要なページだけ選んで印刷する

事を推奨します。 
Adjust Table 
Columns 

行を自動的に調節します。 

 

12.10.5 [CPU Registers]ウィンドウ 
[CPU Registers]ウィンドウは、デバイスのCPUに関連するSFRの内容を表示します。少数のCPU SFRを表示するに

は、[Watches]ウィンドウを使う事を推奨します。ハードウェア デバッグツール使用時に速度問題対策に役立つ事が

あります(ウィンドウ更新レートが速いため)。 

ブレークが発生すると常にCPUレジスタの内容が更新されます。 

可視レジスタ 

データメモリ レジスタが物理的にデバイス上に実装されていない場合、SFRの一覧に表示されない事があります。

シミュレータ等の一部のツールを使うと、実際のデバイス上に存在しないプリスケーラ等のレジスタを表示できます。 

シングルステップ実行 

[Freeze Peripherals On Halt]を選択した場合、SFRのI/Oポートビットまたは[Watches]ウィンドウはシングルステッ

プ実行では更新されません。ピンは変更されますが、新規の値を取得するための読み出し要求はフリーズによって

阻止され、次のステップまたは実行コマンドまで更新されません。 

図12-28 [CPU Registers]ウィンドウの内容 

 
12.10.5.1 [CPU Registers]ウィンドウの表示 

ウィンドウ下部の[Format]ドロップダウン ボックスを選択する事で、ウィンドウ内のメモリの表示方法を変更でき

ます。選択肢は以下の通りです。 

• Blank - 1つの画面のみ 
• Devices with FPU - FPU(浮動小数点ユニット)付きPIC32デバイスの場合、[Format]の選択肢は以下の通りです。 

– All Registers 
– Only CPU Registers 
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– Only FPU Registers

[Blank]、[All Registers]、[Only CPU Registers]フォーマット 

データは以下の列に表示されます。

• Address – SFRの16進物理アドレスです。

• Name – SFRのシンボル名です。

• 基数情報 – Hex、Decimal、Binary、Char
• Virtual – バスマトリクスで定義したSFRの16進仮想アドレスです。

[Only FPU Registers]フォーマット 

データは以下の列に表示されます。

• Address – SFRの16進物理アドレスです。

• Name – SFRのシンボル名です。

• 基数情報 – HEX
• Floating Point – Float, Double

12.10.5.2 [CPU Registers]ウィンドウのアイコン 
アイコンはウィンドウの左側にあります。

表12-52 [Data Memory]ウィンドウのアイコン 

アイコン アイコンテキスト 機能

Find ウィンドウ内で検索する文字列を指定します。単語単位で一致するか、大文字と小文
字を区別するかを選択します。

Find Next [Find]に指定した文字列の次のインスタンスを検索します。 

Find Previous [Find]に指定した文字列の前のインスタンスを検索します。 

Go To 指定した行番号またはアドレスに移動します。

12.10.5.3 [CPU Registers]ウィンドウのメニュー 
このメモリウィンドウのデータ領域で右クリックすると、下表のメニューが表示されます。

表12-53 [CPU Registers]ウィンドウのコンテクスト メニュー 

項目 説明

Go To [Go To]ダイアログで指定したアドレス/関数に移動します。 
Find [Find]ダイアログで指定したテキストを検索します。 
Show Register 
Tooltip 

レジスタ用ツールチップの表示/非表示を切り換える事ができます。レジスタ名の上にマウス
カーソルを置くと、ポップアップ情報が表示されます。

Output To File [Output to File]ダイアログを使って、ウィンドウの表示内容をテキストファイルに書き出しま
す。

Print [Print]ダイアログを使って、このウィンドウの内容を印刷します。 
Note:  メモリ容量の大きなデバイスの場合、印刷ページ数が非常に多くなる事がありま
す。その場合、ウィンドウの内容をファイルに出力した後([Print]ダイアログの[General]タ
ブの[Print to File]チェックボックス)、そのファイルから必要なページだけ選んで印刷する
事を推奨します。

Adjust Table 
Columns 

行を自動的に調節します。

12.10.6 [External EBI Memory]/[External SQI Memory]/[External DDR Memory]ウィンドウ 
外部メモリウィンドウは、以下のバスタイプごとに外部メモリの内容を表示します。
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• EBI (外部バスインターフェイス) 
• SQI (Serial Quad Interface) 
• DDR(ダブル データレート) 

図12-29 [External SSR Memory]ウィンドウ 

12.10.6.1 External EBI、SQI、DDR Memoryウィンドウの表示 
このウィンドウでは以下の手順で外部メモリの内容を表示します。 

• コード内で関数/変数を外部メモリに割り当てる - 詳細は『MPLAB XC32/XC32++ Cコンパイラ ユーザガイド』

(DS50001686)を参照してください。 
• シンボルをロードする - [File] > [Properties]、[Loading]カテゴリで[Load symbols when programming or building 

for production (slows process)]にチェックを入れます。 
• コードをコンパイルする - プロジェクトをビルドします。 

ウィンドウ下部の[Format]ドロップダウン ボックスを選択する事で、ウィンドウ内のメモリの表示方法を変更できま

す。 

[Code]フォーマット 

このウィンドウは以下の列を表示します。 

• Line – メモリアドレスに対応する参照行番号です。 
• Address – オペコードの16進物理アドレスです。 
• Opcode – 16進オペコードです。4バイトのブロックで表示されます。 

ハイライト表示のオペコードはプログラム カウンタの現在の位置を表します。 
• Label – シンボリック フォーマットのオペコードラベルです。 
• DisAssy – オペコード ニーモニックの逆アセンブル バージョンです。 

[Data]フォーマット 

このウィンドウは以下の列を表示します。 

• Address – 隣の列のデータの16進アドレスです。 
• データブロック – 16進データです。4バイトのブロックで表示されます。 
• ASCII – 対応するデータ行のASCII表示です。 

12.10.6.2 [External EBI Memory]/[External SQI Memory]/[External DDR Memory]ウィンドウのアイコン 
アイコンはウィンドウの左側にあります。 
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表12-54 外部メモリウィンドウのアイコン 
 

アイコン アイコンテキスト 機能 
 

 
Refresh by Read 
Device Memory 

デバッグツール バーの[Read Device Memory]アイコンと同じ機能 - デバ
イスメモリをMPLAB X IDEにアップロードします。 

 

 
Find ウィンドウ内で検索する文字列を指定します。単語単位で一致するか、大文

字と小文字を区別するかを選択します。 
 

 
Find Next [Find]に指定した文字列の次のインスタンスを検索します。 

 

 
Find Previous [Find]に指定した文字列の前のインスタンスを検索します。 

 

 
Go To 指定した行番号またはアドレスに移動します。 

 
12.10.6.3 External EBI、SQI、DDR Memoryウィンドウのメニュー 

[CODE]フォーマットに設定したメモリウィンドウのデータ領域を右クリックすると、このメニューが表示されます。

全ての32ビットMCUで全ての項目が表示されるわけではありません。 

表12-55 [Execution Memory]ウィンドウのコンテクスト メニュー - [Code]フォーマット 
 

項目 説明 
External Address 
(KSEG[2:3]) 

表示するアドレスを選択します。詳細はデバイスのデータシートを参照してください。 

Physical Address 表示する物理アドレスを選択します。 

Run to Cursor 現在のカーソル位置までプログラムを実行します。 

Step Instruction ステップ命令を1つ実行します。 

Set PC at Cursor プログラム カウンタ(PC)を現在のカーソル位置に設定します。 

Focus Cursor at PC カーソルを現在のPCアドレス位置へ移動し、このアドレスをウィンドウの中心に表示しま
す。 

Toggle Breakpoint 既存のブレークポイントのON/OFFを切り換えます。 

Symbolic Mode 逆アセンブルHEXコードをシンボルで表示します。 

Auto Decode 16 bit MIP16 / microMIPS命令デコードを使います。詳細はデバイスのデータシートを参照してく
ださい。 

Fill Memory メモリの[Start Address]～[End Address]に[Data]内の値を書き込みま
す。[Fill Memory]ダイアログで、その他のオプションを指定します。 

Go To [Go To]ダイアログで指定したアドレス/関数に移動します。 

Go To Source Line エディタでソースコード内の対応する行に移動します。 

Find [Find]ダイアログで指定したテキストを検索します。 

Output To File [Output to File]ダイアログを使って、ウィンドウの表示内容をテキストファイルに書き出し
ます。 

Print [Print]ダイアログを使って、このウィンドウの内容を印刷します。 
Note:  メモリ容量の大きなデバイスの場合、印刷ページ数が非常に多くなる事がありま
す。その場合、ウィンドウの内容をファイルに出力した後([Print]ダイアログの[General]タ
ブの[Print to File]チェックボックス)、そのファイルから必要なページだけ選んで印刷する
事を推奨します。 

Adjust Table Columns 行を自動的に調節します。 
 

[DATA]フォーマットに設定したメモリウィンドウのデータ領域を右クリックすると、このメニューが表示されます。

全ての32ビットMCUで全ての項目が表示されるわけではありません。 
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表12-56 [Execution Memory]ウィンドウのコンテクスト メニュー - [Data]フォーマット 
 

項目 説明 

External Address 
(KSEG[2:3]) 

表示するアドレスを選択します。詳細はデバイスのデータシートを参照してください。 

Physical Address 表示する物理アドレスを選択します。 

Hex Width Display 16進数の表示幅を設定します(選択肢はデバイスによって異なります)。 

例: 

One byte (例: 00 01 02 ...0E 0F) 

Two bytes (例: 00 02 04 ...0C 0E) 

Four bytes (例: 00 04 08 0C) 
Fill Memory メモリの[Start Address]～[End Address]に[Data]内の値を書き込みます。[Fill Memory]ダイ

アログで、その他のオプションを指定します。 
Go To [Go To]ダイアログで指定したアドレス/関数に移動します。 

Find [Find]ダイアログで指定したテキストを検索します。 

Output To File [Output to File]ダイアログを使って、ウィンドウの表示内容をテキストファイルに書き出し

ます。 
Import Table [Import Table]ダイアログを使って、ファイルから[Memory]ウィンドウに表形式のデータを

インポートします。 
Export Table [Export Table]ダイアログを使って、[Memory]ウィンドウからファイルへ表形式のデータを

エクスポートします。 
Print [Print]ダイアログを使って、このウィンドウの内容を印刷します。 

Note:  メモリ容量の大きなデバイスの場合、印刷ページ数が非常に多くなる事がありま

す。その場合、ウィンドウの内容をファイルに出力した後([Print]ダイアログの[General]タ
ブの[Print to File]チェックボックス)、そのファイルから必要なページだけ選んで印刷する

事を推奨します。 
Adjust Table Columns 行を自動的に調節します。 

 
12.10.7 [User ID Memory]ウィンドウ 

一部のデバイスは、ユーザがチェックサムまたはその他のコード識別(ID)番号を格納できるメモリ位置を持っていま

す。これらの位置はプログラム/ベリファイ中に読み書き可能です。デバイスによっては、通常の実行中もTBLRDお

よびTBLWT命令を使ってこれらの位置をアクセスできます。 

図12-30 [User ID Memory]ウィンドウの内容 

12.10.7.1 [User ID Memory]ウィンドウの表示 
この欄に入力する値はデバイスのプログラミング仕様を参照してください。ほとんどのデバイスでは、この値でデバ

イスのIDワードの下位ニブルを設定し、上位ニブルは「0」に設定されます。上位ニブルは、テーブル書き込み等を

使ってプログラム的にのみ書き込む事ができます。 
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ウィンドウ下部の[Format]ドロップダウン ボックスを選択する事で、ウィンドウ内のメモリの表示方法を変更でき
ます。 

図12-31 標準表示 

標準表示では、以下の列にデータを表示します。 

• Address – ユーザIDの16進アドレスです。 
• User ID – ユーザIDメモリの内容(HEX形式)です。 

図12-32 レガシー表示 

レガシー表示では、以下の列にデータを表示します。 

• Address – ユーザIDの16進開始アドレスです。 
• User ID – ユーザIDメモリの内容(HEX形式)です。 

12.10.7.2 [User ID Memory]ウィンドウのアイコン 
アイコンはウィンドウの左側にあります。 

表12-57 [User ID Memory]ウィンドウのアイコン 
 

アイコン アイコンテキスト 機能 
 

 
Find ウィンドウ内で検索する文字列を指定します。単語単位で一致するか、大文字と小文

字を区別するかを選択します。 
 

 
Find Next [Find]に指定した文字列の次のインスタンスを検索します。 

 

 
Find Previous [Find]に指定した文字列の前のインスタンスを検索します。 

 
12.10.7.3 [User ID Memory]ウィンドウのメニュー 

このメニューが表示されるように設定したメモリウィンドウのデータ領域を右クリックすると、このメニューが表示

されます。 

表12-58 [User ID Memory]ウィンドウのコンテクスト メニュー 
 

項目 説明* 

Output To File [Output to File]ダイアログを使って、ウィンドウの表示内容をテキストファイルに書き出します。 
 
 
12.11 [Memory]ウィンドウの関連ダイアログ 

[Memory]ウィンドウにはウィンドウデータのフォーマット設定、管理、出力をサポートするダイアログがあります。

これらのダイアログはコンテクスト メニューからアクセスします。 
 

12.11.1 [Memory]ウィンドウ - [Go To]ダイアログ 
ターゲット メモリ内の特定位置に移動します。このダイアログへは一部のターゲットメモリ ウィンドウのコンテク

スト メニューからアクセスします。 
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表12-59 [Go To]ダイアログ 

 

項目 説明 

Go To What 移動する項目を入力します。その項目をクリックして以下の説明を参照します。 
Address: 16進アドレスを入力します。 

Symbol: プログラム シンボルを入力します。 

Line: 行番号を入力します。 

Label: プログラムラベルを選択します。 

Function: プログラム関数を選択します。 

Go to description [Go To What]項目を選択して説明を参照します。 
 

12.11.2 [Memory]ウィンドウ - [Find]ダイアログ 
ターゲット メモリ内の特定位置を検索します。このダイアログへは一部のターゲットメモリ ウィンドウのコンテク

スト メニューからアクセスします。 
 

表12-60 [Find]ダイアログ 
 

項目 説明 

Find What 検索するテキストを入力します。 

Match [Match whole word only]と[Match case]の両方またはどちらか一方を選択します。 

Direction 検索方向([Up]または[Down])を選択します。 

Found Atバー 項目が見つかったら、その位置がこのバーに表示されます。 
 

12.11.3 [Memory]ウィンドウ - [Output to File]ダイアログ 
指定したメモリレンジをファイルに出力します。このダイアログへは一部のターゲットメモリ ウィンドウのコンテ

クスト メニューからアクセスします。 
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表12-61 [Output to File]ダイアログ 

 

項目 説明 

Range ファイルに出力するデータのレンジを指定します。 
[Address]: アドレスレンジ - [Start]/[End]アドレスを入力します。 

Lines: 行レンジ - [Start]/[End]行を入力します。 

Filepath 出力ファイルの場所を参照するか、テキストボックスに入力します。 
 

12.11.4 [Memory]ウィンドウ - Import/Export Tableダイアログ 
表形式でファイル ターゲットメモリからインポート/エクスポートします。このダイアログへは一部のターゲット

メモリ ウィンドウのコンテクスト メニューからアクセスします。 

図12-33 [Export Table]ダイアログ 
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図12-34 Export Tableファイル 

表12-62 Import/Export Tableダイアログ 
 

項目 説明 

Range 表形式でファイルにインポートまたはエクスポートするデータのレンジを入力します。 
Address: アドレスレンジ - [Start]/[End]アドレスを入力します。 

Single Column Format 表を単一の列としてエクスポートします。 

Filepath 出力または入力ファイルの場所を参照するか、テキストボックスに入力します。 
 

12.11.5 [Memory]ウィンドウ - [Print]ダイアログ 
メモリウィンドウの内容を印刷します。このダイアログへは一部のターゲットメモリ ウィンドウのコンテクスト メ
ニューからアクセスします。使える印刷オプションは、選択したプリンタによって異なります。 
図12-35 [Print]ダイアログ 
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図12-36 [Print]ダイアログの出力 

表12-63 [Print]ダイアログ 
 

項目 説明 

[General]タブ 一般的な印刷オプションを設定します。 
Print Service: プリンタ/印刷サービスを選択します。[Properties]をクリックして印刷サービスを

設定します。また、チェックを入れてファイルに印刷します。 

Print Range: 印刷するページの範囲です。 

Copies: 印刷する部数です。 
Page Setup ページのオプションを設定します。 

Media: ページのサイズとソースを指定します。 

Orientation: ページの向きを指定します。 

Margin: ページの余白を指定します。 
Appearance 印刷レイアウトを設定します。 

Color appearance: カラーまたは白黒を指定します。 

Quality: ドラフト、通常、高品質を指定します。 

Sides: 側面と複数側面の向きを指定します。 

Job Attributes: バナーを印刷し、ジョブ名とユーザを指定します。 
 
 
12.12 [Message Center]ウィンドウ 

[Message Center]ウィンドウは、[Window] > [Debugging] > [Output] > [Message Center]と選択して開きます。 

[Message Center]ウィンドウは、全ての[Output]ウィンドウのメッセージを収集し、時系列で1つの画面に表示します。

各種のフィルタを選択して関連するメッセージを表示できます。 



MPLAB X IDEユーザガイド 
MPLAB X IDEのウィンドウとダイアログ 

ユーザガイド DS-50002027E_JP - p. 268 © 2019 Microchip Technology 
 

 

 

 
 

図12-37 [Message Center]ウィンドウ 

表12-64 [Message Center]ボタン 
 

番号 ボタン 機能 

1 Search 検索テキストボックスをトグルします。検索ボックスが表示されている場合、テキストを入力

するとその文字列を[Message Center]ウィンドウ内で検索します。 

2 Filters 既定値では、[Output]ウィンドウに表示される全てのメッセージが[Message Center]ウィンドウ

に表示されます。 
このボタンをクリックすると、[Output]ウィンドウのタブ項目のリストを含むウィンドウが

開きます。リストから項目を選択して、表示メッセージにフィルタをかけます。 
 
 
12.13 [Output]ウィンドウ 

このウィンドウは[Window] > [Output]と選択して開きます。 

[Task]ペインはNetBeansプラットフォームから継承したウィンドウ、MPLAB X IDE専用ウィンドウ等、多くのウィ

ンドウを表示します。[Output]ウィンドウは、MPLAB X IDE出力情報を表示します。情報はウィンドウ内のタブ上に

表示されます。 

表12-65 [Output]ウィンドウのタブ項目 
 

項目 説明 

Debugger Console [User program running]等の主要なデバッグ動作を表示します。 

Tool-specific ツールのファームウェア バージョン、デバイスID、動作ステータスを表示します。 

Build, Load ビルドとプログラムロードに関する情報とステータスを表示します。 

Clean, Build, Load クリーン、ビルド、プログラミングに関する情報とステータスを表示します。 

Peripheral Output シミュレータを使ったデバッグにおいて、UART等の周辺モジュールの出力を表示します。 

 
12.13.1 内容のスクロール 

実行中のプログラミングは出力ウィンドウに表示され、スクロールして行きます。最後に実行された操作はこのウィ

ンドウで一番下に表示されます。 
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内容を表示するためにスクロールアップしてプログラミングを再度実行しても、カーソルは現在の位置から動きませ

ん。これは、下のウィンドウに多くの内容が表示されて位置が分からなくなる事を防ぐためです。新しい内容を表示

するには、自分でスクロールする必要があります。 
 

12.13.2 コンテクスト メニュー 
[Output]ウィンドウで右クリックすると、下表の項目が表示されます。 

表12-66 [Output]ウィンドウのコンテクスト メニュー 
 

項目 説明 

Copy 選択しているテキストをクリップボードにコピーします。 

Paste 現在選択しているテキストをクリップボードから[Output]ウィンドウに貼り付けます。 

Find 現在選択しているテキスト、または入力したテキストを[Output]ウィンドウ内で検索します。正規表

現、大文字/小文字の区別にも対応しています。 

Find Next テキストを順方向に検索します。 

Find Previous テキストを逆方向に検索します。 

Filter テキストまたは正規表現によって出力をフィルタ処理します。 

Wrap Text [Output]ウィンドウの行送りを有効にします。 

Larger Font フォントサイズを大きくします。 

Smaller Font フォントサイズを小さくします。 

Choose Font フォントタイプ、スタイル、サイズを選択します。 

Save As 選択したテキストをファイルに保存します。 

Clear [Output]ウィンドウ内のテキストを全てクリアします。 

Close [Output]ウィンドウを閉じます。 
 
 
12.14 [Project Properties]ウィンドウ 

このウィンドウはいくつかの方法で開く事ができます。4.3「[Project Properties]ウィンドウを開く」を参照してくだ

さい。 

このウィンドウは、プロジェクトのデバイス、ツール、ツール設定を表示または変更するために使います。詳細は以

下を参照してください。 
 

• 4.4 「プロジェクト プロパティの表示と変更」 
• 4.5 「デバッガ/プログラマツール オプションを設定または変更する方法」 
• 4.6 「言語ツールオプションを設定または変更する方法」 
• 5.5 「ロード可能なプロジェクト、ファイル、シンボル」 
• 4.9.5「ライブラリやオブジェクト ファイルの追加と設定」 
• 4.10「ビルドプロパティの設定」 
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図12-38 [Project Properties]ウィンドウ 

 
 

12.15 [Projects]ウィンドウ 
このウィンドウは[Window] > [Projects]と選択して開きます。 

[Projects]ウィンドウはNetBeansプラットフォーム ウィンドウです。しかし、MPLAB X IDEプロジェクトに関連

する論理(仮想)フォルダを表示するために、カスタマイズしています。また、右クリックで開くコンテクスト メ
ニューには、MPLAB X IDE専用の項目を追加しています。 

• [Projects]ウィンドウ – 論理フォルダ 
• [Projects]ウィンドウ – [Project]メニュー 
• [Projects]ウィンドウ – [File]メニュー 
• [Projects]ウィンドウ – [Window]メニュー 
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図12-39 [Projects]ウィンドウのコンテクスト メニュー 

[Projects]ウィンドウ – 論理フォルダ 

MPLAB Xプロジェクト用に論理フォルダを追加しています。そのため、表示された全てのフォルダは以下のファイ

ルタイプのいずれかに分類できます。 

• Header Files – MPLAB X IDEはビルド時にこのカテゴリを使いません。このフォルダは、ヘッダファイルに対

するプロジェクトの依存性を示し、また、これらのファイルに容易にアクセスするために設けられています。

[Projects]ウィンドウでファイルをダブルクリックすると、エディタで開きます。 
• Important Files – 他のどのカテゴリにも属さないファイルは、全てこのフォルダに保存します。 

あるいは、プロジェクトに関連するデータシート(PDF)を、[Projects]ウィンドウ内のこのフォルダに追加してお

けば、ダブルクリックでデータシートを開く事ができます(PDFファイルのリーダーをインストールしておく必

要があります)。 
• Linker Files – リンカスクリプトをプロジェクトに追加する必要はありません。プロジェクトの言語ツールが、

デバイスに適合する汎用リンカスクリプトを自動的に選択するためです。従って、リンカスクリプトをユーザ

が自分で作成しない限りこのフォルダは空になります。 
ファイルは1つだけ保存します。複数のリンカスクリプトを保存した場合、最初の1つだけが有効となります。 

• Source Files – ツールチェーンがファイルコマンドへの入力として受け入れるのは、これらのファイルのみで

す。 
• Libraries – ツールチェーンは、このフォルダ内の全てのファイルとオブジェクト ファイルを最終リンクステッ

プでインクルードします。 
• Loadables – プロジェクトHEXファイルと結合または置換するプロジェクトとファイルです。 

[Projects]ウィンドウ – [Project]メニュー 

[Projects]ウィンドウでプロジェクト名を右クリックすると、[Project]メニューが開きます。下表にメニュー項目を示

します。 

表12-67 [Project]コンテクスト メニューの項目 
 

メニュー項目 概要 

New ファイルを新規作成します。 
MPLAB® X IDEでは組み込みファイルタイプを選択できます。 

Add Existing Item 既存のファイルをプロジェクトに追加します。 
ファイルへのパスは、[Auto] (MPLAB X IDEが選択)、[Absolute]、[Relative]のいずれかに設

定できます。さらに、そのファイルをプロジェクト フォルダにコピーできます。 
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メニュー項目 概要 

Add Existing Items 
from Folders 

指定したフォルダに含まれる全てのファイルを追加します。 
また、特定のフォルダを含めないようにパターンを指定する事もできます。[Default]をク

リックすると既定値のパターンを参照できます。また、[Tools] > [Options]で
[Miscellaneous]ボタンをクリックし、[Files]タブで[Files ignored by the IDE]も参照してく

ださい。 
New Logical Folder 新規の論理フォルダを作成します。 

実際のフォルダの表示は、[Files]ウィンドウを参照してください。 

Locate Headers Cコード プロジェクト ファイル内で呼び出されている全てのヘッダファイル(.h)を検索

し、プロジェクトに追加できるようにチェックリスト ウィンドウに表示します。 
プロジェクトにヘッダを追加する理由は複数あります。 

• PC上でヘッダファイルの保存場所を探す事なく、[Projects]ウィンドウの[Header 
Files]から開く事ができます。 

• [Save Project As]でプロジェクトを作成した場合、ヘッダファイルはユーザが追加し

ない限りプロジェクトには含まれません。従って、ユーザ作成のヘッダファイルが

必要な場合、このプロジェクトはビルドできません。 
• [Package]で圧縮済みプロジェクトを作成した場合、ヘッダファイルはユーザが追

加しない限りプロジェクトには含まれません。従って、ユーザ作成のヘッダファイ

ルが必要な場合、これを解凍したプロジェクトはビルドできません。 

この機能を使うと、Microchip社の全ツールチェーンのユーザ作成ヘッダファイルを検索で

きます。 
Add Item to Important 
Files 

既存のアイテムをプロジェクトに追加します。 
ファイルへのパスは、[Auto] (MPLAB X IDEが選択)、[Absolute]、[Relative]のい

ずれかに設定できます。さらに、そのファイルをプロジェクト フォルダにコピ

ーできます。 

これは、シミュレータ ファイル、データシート(PDF)、その他のファイルを参考資料と

してプロジェクトに追加するのに便利です。 
Export Hex プロジェクトのビルド結果をHEXファイルとしてエクスポートします。 

MPLAB IDE v8ではメモリ オブジェクトの抽出結果をエクスポートします。MPLAB X IDE
ではビルドの結果を納めたHEXファイルをエクスポートします。従って、このファイル

は、コード内のコンフィグレーションとEEPROMに必要な全ての補助的メモリ設定を含む

必要があります。 
Build [Project Properties]ウィンドウで選択したオプションに従ってビルドします。 

Note:  [Debug]または[Run]を実行すると、プロジェクトは自動的にビルドされます。 

Clean and Build [Clean]を実行した後、[Project Properties]ウィンドウで選択したオプションに従

ってビルドします。 
Note:  [Debug]または[Run]を実行すると、プロジェクトは自動的にビルドされます。 

Clean 以前のビルドで生成されたファイルを削除してプロジェクトを空にします。 

Package 現在のプロジェクトを1つのZIPファイルにアーカイブします。 

Set Configuration プロジェクトのコンフィグレーションを設定するために[Project Properties]ウィンドウを開

きます。 
Run プロジェクト コードを実行します。 

Debug プロジェクト コードをデバッグ環境で実行します。 

Step In デバッグ環境で実行中の一時停止したコードを順番に実行します。 

Make and Program 
Device 

ターゲット デバイスをプログラミングした後、プログラムを実行せずにリセット状態に保

持します。 

Set as Main Project このプロジェクトをメイン プロジェクトに設定します。 
これは複数のプロジェクトを使う場合に便利な機能です。 
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メニュー項目 概要 

Open Required 
Projects 

選択したプロジェクトの実行に必要なその他の全てのプロジェクトをロードします。 

Close 選択したプロジェクトを閉じます。 

Rename プロジェクト名を変更します。 

Move プロジェクトを別の場所に移動します。 
プロジェクトと一緒に、プロジェクト フォルダ内のソースファイルも移動します。プロジ

ェクト フォルダ外部のファイルは移動しません。しかしプロジェクトは、プロジェクト フ
ォルダ外のファイルへの参照を維持します。これは設計仕様に基づいた動作です。 

Copy プロジェクトのコピーを作成します。 
ソースファイルがプロジェクト フォルダ内にある場合、ソースファイルも新規の場所にコ

ピーします。プロジェクト フォルダ外にあるファイルはコピーしません。しかしプロジェ

クトは、プロジェクト フォルダ外のファイルへの参照を維持します。これは仕様です。 
Delete プロジェクト ファイルを削除します。 

プロジェクト ファイルは削除しますが、プロジェクト フォルダ内のファイルは削除しませ

ん。[Also delete sources]を選択した場合のみ、全ソースファイルを削除します。 

Code Assistance コード生成支援機能(例: コード折り畳み、コード補完)を選択します。 

Find このプロジェクトのファイル内で特定のテキストを検索します。 

Share on Team 
Server 

チームサーバでこのプロジェクトを共有します。 

Versioning バージョン管理システムを使ってプロジェクトのバージョンを管理します。 

Local History プロジェクトのローカル履歴を表示します。または、そのローカル履歴に戻します。 

Properties プロジェクトのプロパティを設定します。 
MPLAB X IDEの[Project Properties]ウィンドウは、組み込み開発専用にカスタマイズされて

います。 
 

[Projects]ウィンドウ – [File]メニュー 

[Projects]ウィンドウでファイル名を右クリックすると、[File]メニューが開きます。下表にメニュー項目を示しま

す。 

表12-68 [File]コンテクスト メニューの項目 
 

メニュー項目 概要 

Open このファイルをエディタ ウィンドウで開きます。 

Cut ファイルをプロジェクトから削除し、クリップボードに移動します。 

Copy ファイルをクリップボードにコピーします。 

Paste クリップボードのファイルをプロジェクトに貼り付けます。 

Exclude file(s) from 
current configuration 

現在のプロジェクトの設定から除外するファイルを選択します。ファイルを除外した後

でそのファイルをもう一度右クリックすると、[Include file(s) from the current 
configuration]が表示されます。[Project Properties]ウィンドウを開き、[File 
Inclusion/Exclusion]を選択してファイルを含める/除外するのと同じです。 

Compile File 現在のファイルのみをコンパイルします。 

Remove from Project ファイルをプロジェクトから削除します。 
この操作では、ファイルはPCから削除されません。ファイルをプロジェクトとコンピュ

ータから削除するには、<Delete>キーを使います。 
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メニュー項目 概要 

Rename ファイル名を変更します。 

Save as Template 現在のファイルをテンプレート ファイルとして保存します。 

Local History ファイルのローカル履歴を表示します。または、そのローカル履歴に戻します。 

Tools ファイルツールは以下を含みます。 
• Apply Diff Patch: Diffが作成した既存のパッチを適用します。 
• Diff to: 2つのファイルの差分を表示します。 
• Add to Favorites: このファイルを[Favorites]ウィンドウに追加します。 

Properties プロジェクト プロパティとは異なるファイル プロパティを設定します。 
「Exclude from build」にチェックを入れると、このファイルをプロジェクトのビルドか

ら除外します。「Override build options」にチェックを入れると、ここで選択したビル

ドオプションをプロジェクト コンフィグレーション内のビルドオプションよりも優先さ

せます。 
 

[Projects]ウィンドウ – [Window]メニュー 

[Projects]ウィンドウの空いた場所で右クリックすると、[Window]メニューが表示されます。下表に専用のメニュー

項目を示します。 

表12-69 [File]コンテクスト メニューの項目 
 

メニュー項目 概要 

New Project [New Project]ウィザードを起動します。 

New File [New File]ウィザードを起動します。 

Open Project 既存のプロジェクトを開きます。 

Open Recent Project 最近編集したプロジェクトの一覧の中から、既存のプロジェクトを開きます。 

Open Project Group プロジェクト グループの一覧の中から、既存のプロジェクト グループを開きます。 

Run Project メイン プロジェクトを実行します。 

Set Main Project 開かれているプロジェクトの一覧の中から、メイン プロジェクトを設定します。 
 
 
12.16 [Tools] > [Options]ウィンドウ、[Embedded] 

[Tools] > [Options] (macOSでは[MPLAB X IDE] > [Preferences])を選択して[Embedded]ボタンをクリックすると、

下図に示すタブとオプションが表示されます。 

[Options]ウィンドウはNetBeansプラットフォームのウィンドウです。ただし、MPLAB X IDEプロジェクト用にカス

タマイズされています。 

図12-40 [Tools] > [Options] > [Embedded]タブ 

 
12.16.1 [Generic Settings]タブ 

[Tools] > [Options] (macOSでは[MPLAB X IDE] > [Preferences])を選択して[Embedded]ボタン、[Generic Settings]
タブをクリックすると、以下のオプションが表示されます。 
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表12-70 [Generic Settings]タブの項目 
 

項目 説明 

Open source file and locate line 
in editor when debugger halts 

ブレークポイントのように停止したコード行にジャンプし、コードを確認で

きます。 
無効にすると単に実行を停止します。 

Clear tool output window on new 
session (debug, program, upload) 

実行、デバッグ、アップロードを開始する際に、[Output]ウィンドウの内容

をクリアします。 

Halt build on first failure ビルド時に、障害が最初に発生した時点でプロセスを停止します。 
どのエラーが発生したらプロセスを停止するかは、選択したプロジェクト言語

ツールで設定できます。[Project Properties]ウィンドウの[Categories]で言語ツ

ールを選択します。[Option Categories] 
では、エラー、警告、メッセージの設定もできます。 

Maintain active connection to 
hardware tool 

チェックを入れると、実行時以外もハードウェア ツールを常時接続したまま

(MPLAB® IDE v8の挙動)にします。 
この機能を有効にしたままするようにプロジェクトを切り換える場合(例: ブ
ートローダ アプリケーションの開発)、ツールとデバイスの設定が同じであ

る事を確認します。異なる場合、エラーメッセージが表示されます。 

Note:  このオプションは現在のプロジェクトとコンフィグレーションにのみ適

用されます。プロジェクトを切り換えるか、[Project Properties]で項目を変更す

ると、再接続が行われます。 
Read Device Memory to File: 
Export only memory used 

[Read Device Memory to File]アイコン/機能では、ファイルに使われているデ

バイスメモリのみを保存します。 

Silent build ビルドの際に、[Output]ウィンドウにメッセージを表示しません。 

Enable alternate watch list views 
during debug session 

[Watches]ウィンドウに3つのウォッチビュー ダイアモンドを表示し、ウォッ

チビューを観察する変数に関連付けます。ウォッチ ビュー ダイアモンドをク

リックすると、そのビューに関連付けられた変数だけが表示されます。いわ

ばフィルタのような機能です。 
Disable auto refresh for call stack 
view during debug sessions 

有効にすると、一時停止または停止時に内容を自動で更新します。 
ウィンドウが閉じられている場合、またはフォーカスされていない場合、

ウィンドウを選択しこのボタンをクリックすると更新が表示されます。再

度実行および一時停止/停止する必要はありません。 

無効にすると、一時停止または停止時にウィンドウを手動で更新します。

一時停止/停止時にウィンドウの内容を更新するには、このボタンをクリッ

クする必要があります。 
On mouse over structure and 
array expressions, evaluate 
integral members only 

チェックを入れると、コードの構造体または配列の式をマウスオーバーした

際、必須メンバーのみを表示します。 
チェックを外すと、コードの構造体または配列の式をマウスオーバーした

際、全てのメンバーを表示します。 

Show unresolved variable names 
in watch window during debug 
session 

チェックを入れると、[Watches]ウィンドウに未解決変数を表示します。 

Allow switch between pack 
versions 

チェックを入れると、[Project Properties]に表示するパックを切り換える事がで

きます。 

Enable gathering of compiler 
symbols 

コンパイラをバックグラウンドで実行し、コンパイラのビルトイン/プライベ

ート マクロに関する情報を要求します。 

既定値ではこのオプションは無効です。有効にすると、IDEがシンボル情報

を収集する時間が長くなります。 

Note:  コンパイラの内部情報を使わない場合、この機能を有効にする必要は

ありません。 
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項目 説明 

On mouseover source lines in 
editor, evaluate break point status 

評価をトリガする方法を選択します。 
Disable: 評価なし 

Mouse Only, Alt+Mouse, Shirt+Mouse, Shift+Alt+Mouse: これらのキー操作
のいずれかにより、ブレークポイントで値を評価します。 

Hold-off period before memory 
view synchronization: Give 
priority to debug events (step 
over, step in, continue) 

デバイスが停止してからデバイスのデータがメモリウィンドウに同期する
までの間の遅延時間を指定します。 
長い遅延時間を設定すると、更新の前により多くのシングルステップ実行が発
生します。この機能は、ファイルレジスタとデータメモリ等の一般的な[PIC 
Memory Views]のみに適用できます。 

Debug Reset @ 
(following reset action during 
paused debug session) 

デバッグリセット時の動作を選択します(例: [Debug] > [Reset])。 
Main: リセット時にmain()で停止します。 

Reset Vector: リセット時にリセットベクタ位置で停止します。 

Note:  これは、デバイスのハードウェア リセットとは関係ありません。 

Debug start-up 
(following debug project action) 

[Debug] > [Debug Project]のコード実行を指定します。 
Run: 即座に実行を開始します。 

Main: main()で停止します。 

Reset Vector: リセットベクタ位置で停止します。 

Default Charset プロジェクトの既定値の文字セットを選択します。 

 

12.16.2 [Project Options]タブ 
Select [Tools] > [Options] (macOSでは[MPLAB X IDE] > [Preferences])を選択して[Embedded]ボタン、[Project 
Options]タブをクリックすると、以下のオプションが表示されます。 

表12-71 [Project Options]タブの項目 
 

項目 説明 

Make Options プロジェクトをビルドする際に使うmakeオプションを入力します。 
これらのオプションは、ツールチェーンによって異なります。詳細は使用する言語ツールの

文書を参照してください。 
File Path Mode プロジェクト内のファイルパス情報の保存方法を指定します。 

Auto: プロジェクト フォルダ内のファイルへのパスを相対パスとして保存し、プロジェクト 
フォルダ外のファイルへのパスを絶対パスとして保存します。 

Always Relative: 全てのパスを、プロジェクト フォルダに対する相対パスとして保存しま

す。 

Always Absolute: 全てのパスを絶対パスとして保存します。 
Save All Modified 
Files Before Running 
Make 

これを選択した場合、makeを実行する前に、IDE内の全ての未保存ファイルを保存しま

す。このチェックは入れたままにしておく事を推奨します。外した場合、変更したファイ

ルをあらかじめ保存しておかないと、ファイルへの変更がmakeに反映されません。 
Reuse Output Tabs 
from Finished 
Process 

選択すると、[Output]ウィンドウの同じタブに出力メッセージが表示されます。選択しない

場合、新規プロセスごとに新規タブが開きます。 



MPLAB X IDEユーザガイド 
MPLAB X IDEのウィンドウとダイアログ 

ユーザガイド DS-50002027E_JP - p. 277 © 2019 Microchip Technology 
 

 

 

 

(続き) 
項目 説明 

Use parallel make 
(make -j 2n) 

これにチェックを入れると、makeによって複数のプロセスが同時に実行されます。-j(ま
たは--jobs)は並列実行を指定するオプション、2nはプロセス数、nはコンピュータで使
用可能なプロセッサ数です。コンピュータが並列処理をサポートしていない場合、並列
makeは無効化されます。 
また、[Make Options]で2より大きいプロセスを指定する事も可能です例: -j 10)。 

Note:  MPLAB XC16またはMPLAB C30の場合、並列makeを使うには手続きの抽象化を
無効にする必要があります([File] > [Project Properties]、コンパイラ カテゴリ、
[Optimizations]オプション カテゴリで、[Unlimited procedural abstraction]のチェックを外
します)。 

Note:  MPASMXは、ツールチェーンとして使う場合もMPLAB C18プロジェクトの一部と
して使う場合も並列makeでは実行できません。並列make機能は、MPASMXツールチェー
ンを使うプロジェクトまたはC18ツールチェーンを使うプロジェクト(.asmファイルを含
む)では無視されます。 

Force makefile 
regeneration when 
opening a project 

チェックを外すと、プロジェクトが既に開いている場合(例: 別のコンピュータ上でプロジェ
クトを開いている場合)のmakefileの再生成の要否をMPLAB IDEが決定します(これが既定値
です)。 
チェックを入れると、プロジェクトを開いた時にmakefileの再生成を強制的に実行し
ます。makefileを再生成する必要があるにもかかわらず再生成されない場合、この機
能を使います。 

Note:  再生成には若干の時間を要します。 
Use “clean” target 
from Makefile 

チェックを外すとstandard cleanが使われます。すなわち、ビルド時に生成された全てが削
除されます。この方法がより高速です。 
チェックを入れるとmake cleanが使われます。すなわち、clean時にMakeファイルが使
われます。この方法では、削除対象をより詳細に設定できます。 

 

12.16.3 [Build Options]タブ 
[Tools] > [Options] (macOSでは[MPLAB X IDE] > [Preferences])を選択して[Embedded]ボタン、[Build Options] 
タブをクリックすると、以下のオプションが表示されます。 

インストールしていない言語ツールは[Toolchain]リストに表示されません。インストールしたはずの言語ツール

がこのリストに表示されない場合、[Scan for compilers]をクリックします。それでも表示されない場合、[Add]を
クリックして、そのツールをリストに追加します。 

以下の言語ツールはMPLAB X IDEに付属しています。 

• MPASM toolchain – MPASMアセンブラ、MPLINKリンカ、各種ユーティリティを含みます。 

その他のツールは、Microchip社ウェブサイト(www.microchip.com)またはサードパーティから入手できます。 

表12-72 [Build Tools]タブの項目 
 

項目 説明 

Toolchain インストールされている言語ツールのリストを表示します。 
プロジェクトに使うツールを選択し、右側に表示されるパスが正しい事を確認します。 

Base directory: ツールのメインフォルダへのパス 

C compiler: Cコンパイラへのパス(利用可能な場合) 

Assembler: アセンブラへのパス(利用可能な場合) 

Make command: MPLAB® X IDEが生成したmakeコマンドの名前 
Add リストに新しい言語ツールを追加します。[Scan for Build Tools]を使う方法もあります。 

Add Custom 
Compiler 

カスタマイズしたコンパイラを追加します。 
この例では、サポートしているMicrochip社製デバイスを指定する必要があります。 
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項目 説明 

Remove リストから言語ツールを削除します。 
言語ツールそのものはPCから削除されません。 

Default ツールをクリックして[Default]を選択すると、選択したデバイス用の既定値コンパイラ/ア
センブラとなります。 

Scan for Build 
Tools 

インストールされているコンパイラ/アセンブラをスキャンします。これは、システム全体では

なく、複数の既定値フォルダだけをスキャンします。 
それ以外の場所にインストールした場合、手動でコンパイラを追加する必要があります。 

 

12.16.4 [Managed Tools]タブ 
[Tools] > [Options] (macOSでは[MPLAB X IDE] > [Preferences])を選択して[Embedded]ボタン、[Managed Tools]
タブをクリックすると、以下のオプションが表示されます。 

使用するリモート接続を選択します。以下の接続を新たに追加します。 

• Remote USB Tool (プラグインが必要) 
• Remote Ethernet Tool 
• Generic Serial Port 

図12-41 新規の管理ツール 
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12.16.5 [Suppressible Messages]タブ 
[Tools] > [Options] (macOSでは[MPLAB X IDE] > [Preferences])を選択して[Embedded]ボタン、[Suppressible 
Messages]タブをクリックすると、以下のオプションが表示されます。 

抑止するエラーおよび警告メッセージを選択します。表示されたフォルダをダブルクリックして、抑止可能な項目を

表示させてチェックを入れます。 

図12-42 抑止可能なメッセージの一覧 

 
12.16.6 [Diagnostics]タブ 

[Tools] > [Options] (macOSでは[MPLAB X IDE] > [Preferences])を選択して[Embedded]ボタン[Diagnostics] 
タブをクリックすると以下のオプションが表示されます。 

ログファイル等の診断機能を設定します。 

表12-73 [Diagnostics]タブの項目 
 

項目 説明 

Logging Level メッセージログのレベルを設定します。 
OFF: 記録しません。 

SEVERE: 重大な(エラー) メッセージのみ記録します。 

WARNING: 警告メッセージのみ記録します。 

INFO: 情報メッセージのみ記録します。 

CONFIG: コンフィグレーション情報のみ記録します。 
FINE: 一部のモジュール間通信を記録します。 

FINER: FINEよりも詳細にモジュール間通信を記録します。 

FINEST: 全てのモジュール間通信を記録します。 
Log File ログファイルのパスと名前です。 

USB Circular Log MPLAB REAL ICEインサーキット エミュレータ、MPLAB  ICD 3、PICkit 3でのみ利用で

きます。 
Start New Logging 
Session/Pause Logging 

ボタンをクリックすると、新規のログセッションが開始します。または、進行中のロ

グセッションが一時停止します。 

Circular USB log 
file location 

ログファイルを保存する場所(パス)を指定します。 

Circular USB log file 
max size in KBs 

ログファイルのサイズを指定します。 
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12.16.7 [Other]タブ 
[Tools] > [Options] (macOSでは[MPLAB X IDE] > [Preferences])を選択して[Embedded]ボタン、[Other]タブをクリ

ックすると、以下のオプションが表示されます。 

C/C++およびアセンブラ ソースファイルとヘッダファイル用に使えるファイル拡張子のリストを編集します。また、

各ファイルタイプの既定値拡張子(太字で表示)も設定します。 

表12-74 [Other]タブの項目 
 

ファイルの種類 既定値の拡張子 

C/C++ヘッダ H, SUNWCCh, h, hpp, hxx, tcc 

C++ C, c++, cc, cpp, cxx, mm 

C c, i, m 

Fortran なし 
MPLAB X IDEはFortranによるプログラミングをサポートしていません。 

アセンブラ AS, ASM, S, as, asm, s 

アセンブラ インクルード INC, inc 

 
 
12.17 [Tools Options]ウィンドウ、[Plugins] 

このウィンドウは、[Tools] > [Options] (macOSでは[MPLAB X IDE] > [Preferences])と選択して[Plugins]ボタンをク

リックすると開きます。 

[Options]ウィンドウはNetBeansプラットフォームのウィンドウです。ただし、MPLAB X IDEプロジェクト用にカス

タマイズされています。[Tools] > [Plugins]を使ってプラグインをインストールしており、これらのプラグインがオプ

ションを備えている場合、利用可能なプラグイン オプションはこのウィンドウに表示されます。 

図12-43 プラグイン オプション例 

 
12.18 [Trace]ウィンドウ 

[Trace]ウィンドウは[Window] > [Debugging] > [Trace]と選択して開きます。トレースデータを表示するにはデバッグ

モード中である事が必要です。 
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トレースは、[Trace]ウィンドウでコード実行をステップごとに記録し、記録された結果を検討する機能です。現在ト

レース機能を利用できるツールは以下の通りです。 

• シミュレータ 
• MPLAB REAL ICEインサーキット エミュレータ 

ウィンドウでトレース列を右クリックすると、コンテクスト メニュー(以下の1番目の表)が開きます。表示されるメ

ニュー項目は使うツールによって異なります。 

以下の2番目の表に、トレースに関連するダイアログを示します。 

表12-75 [Trace]ウィンドウのコンテクスト メニュー 
 

メニュー項目 概要 

Symbolic Mode [Instruction]列の表示を、リテラルレジスタ アドレス(例: 0x5)とシンボリック レジスタマク

ロ(例: PORTA)の間でトグルします。 

Go To [Go To]ダイアログが開きます。 
Trigger: トリガ行(0)に移動します。 

Top: トレース行の先頭に移動します。 

Bottom: トレース行の末尾に移動します。 

Trace Line: 指定したトレース行に移動します。 
Go To Source Line トレース行を選択してこのオプションを選択すると、ソースコード内の対応する行に移動し

ます。 

Display Time [Cycle]列の表示を以下のように設定します。 
As Hex Cycle Count: サイクル数を16進数で表示します。 

As Decimal Cycle Count: サイクル数を10進数で表示します。 

In Seconds Elapsed: サイクル数を経過秒数で表示します。 

In Engineering Format: サイクル数を適切なエンジニアリング フォーマット(103の累乗)で
表示します。 

Clear Trace File トレース表示内のデータをクリアします。 

Find トレース表示内の項目を検索します。[Find]ダイアログが開きます。 

Output To File トレースデータをファイルに保存します。 
[Define Range]ダイアログが開き、そこから[Save]ダイアログを開きます。 

Print データを印刷します。 
[Print]ダイアログが開きます。 

Adjust Table 
Columns 

トレース表示の列幅をデータに合わせて自動調整します。 

Reload View 一時停止時にトレース表示の元のデータビューを再ロードします。 
 

表12-76 [Trace]ダイアログ 
 

ダイアログ 説明 
Go To 移動するトレース行を指定します。 

Find トレース表示で行番号やその他のデータを検索します。 

Output to File Range ファイルに出力する行範囲を指定します。 
範囲指定後[OK]をクリックして、[Save]ダイアログに進み、データをテキストフ
ァイルに保存します。 

Save データをテキストファイルに保存します。 
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ダイアログ 説明 

Print 印刷前にプリンタ、ページ設定、表示設定を指定します。 
 
 

12.19 [Watches]ウィンドウ 
[Watches]ウィンドウは[Window] > [Debugging] > [Watches]と選択して開きます。シンボル値の変化を観察するには

デバッグモード中である事が必要です。 

グローバル シンボルとSFRを選択してプログラム停止時または(サポートされている場合)実行中の値の変化を観察し

ます。[Watches]ウィンドウの使い方は、4.16「シンボル値の変化の観察」を参照してください。 

• [Watches]の表示 
• [Watches]メニュー 
• [Fractional Integer Properties]ダイアログ 

 
12.19.1 [Watches]の表示 

以下のセクションで表示機能(アイコン、列、操作(ボタン))を説明します。 

アイコン 

アイコンは[Name]行の名前のオブジェクトの左に表示されています。 

表12-77[Name]行のアイコン 
 

アイコン 説明 
 

 ウォッチ オブジェクト 
 

 プログラムメモリのウォッチ オブジェクト 
 

 オブジェクトの静的フィールド 
 

 オブジェクトの非静的フィールド 

 
列 

ウィンドウに表示する列は以下の方法で変更できます。 

• 見出しを右クリックして、表示する見出しをトグルします。 

• ウィンドウの左上にある[Change Visible Columns]アイコンをクリックします 。[Change Visible Columns]ダ
イアログで、表示する見出しをトグルします。 

操作 

各種操作はウィンドウ左側のボタンで行います。 

表12-78 操作ボタンのアイコン 
 

ボタン 操作 
 

 
トグルボタン: 

• メンバー フィールドの詳細名(正規の名前)を表示します。 
• メンバー フィールドの要約名(相対的な名前)を表示します。 

 

 リストファイルからウォッチをインポートします。右クリックしてインポート方法を選択します。 
 

 全てのウォッチをリストファイルにエクスポートします。 
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ボタン 操作 

 

 [Value]フィールドの既定値数値フォーマットを設定します。 

 

12.19.2 [Watches]メニュー 
[Watches]ウィンドウ内の(行ではなく)空いた場所で右クリックすると、基本的な機能を備えた[Watches]ウィンドウ 
メニューが表示されます。 

表12-79 [Watches]ウィンドウ メニュー – ウィンドウ 
 

メニュー項目 概要 

New Watch* ウォッチに新しいシンボルを追加します。 

New Runtime Watch* MPLAB REAL ICEインサーキット エミュレータ、シミュレータのみ 
選択したシンボルに新しいランタイム ウォッチを追加します。 

Export All Watches to List File 観察するシンボルに関する情報をファイル(.xwatch)にエクスポートします。 

Delete All [Watches]ウィンドウから観察対象シンボルを全て削除します。 

* コード内のシンボルを右クリックして、[New Watch]または[New Runtime Watch]に追加する事もできます。 
 

行を右クリックすると、その他の機能を備えた[Watches]ウィンドウ メニューが表示されます。表示されるメニュー

項目は、選択した行がシンボルかどうか、そして使うデバッグツールによって異なります。 

表12-80 [Watches]ウィンドウ メニュー – 行 
 

メニュー項目 概要 

New Watch ウォッチに新しいシンボルを追加します。 

New Runtime Watch MPLAB REAL ICEインサーキット エミュレータのみ 
選択したシンボルに新しいランタイム ウォッチを追加します。 

Run Time Update 
Interval 

MPLAB REAL ICEインサーキット エミュレータのみ 
シンボル値の更新速度を指定します。 

[No Delay]を選択すると、コンピュータが処理できる最大速度で更新します。実行時デー

タにエラーが発生する場合、遅延を追加して更新速度を緩めます。 
Export Selected 
Watches to List File 

観察するシンボルに関する情報をファイル(.xwatch)にエクスポートします。 
<Shift>+クリック(連続した複数行を選択)または<Ctrl>+クリック(複数行を個別に選択)を
使って複数の行を選択できます。 

Export Data ウォッチデータをCSVファイルにエクスポートします。または、文字列リテラルとしてエ

クスポートします。 
Delete 選択したシンボル行をウォッチリストから削除します。行を選択して<Delete>キーを押し

ても削除できます。 

Delete All [Watches]ウィンドウから観察対象シンボルを全て削除します。 

Display Value Column 
as 

選択した行のシンボルの値を、フォーマット一覧のうちの1つで表示します。以下も参照

してください。 
12.19.3「[Fractional Integer Properties]ダイアログ」 

User Defined Size プログラムメモリのシンボルのサイズを一覧から指定します。 
 

12.19.3 [Fractional Integer Properties]ダイアログ 
このダイアログの目的は、dsPICおよびPIC32デバイスがサポートする全ての固定小数点演算モードを評価しやすく

する事です。ポップアップ メニュー項目[Display Value Column as] > [Fractional Integer]からこのダイアログを表示

してこの機能を選択します。その後、必要に応じて[Display Value Column as] > [Fractional Properties]を選択します。 
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表12-81 [Fractional Properties]ダイアログの項目 
 

ダイアログ項目 説明 

Variable 変数の名前です(参照用)。 

N* 整数を表現するために利用可能な総ビット数です。 

Qm 固定小数点データ形式の整数部です。 
「m」は整数を指定するのに使うビット数を表します。 

Qn 固定小数点データ形式の小数部です。 
「n」は小数を指定するのに使うビット数を表します。 

Signed* チェックを入れると、1ビットを使って符号付き値を表します。 

Slider スライダをクリックおよびドラッグして、固定小数点値の計算に適用する固定小数点の位置

(Qm対Qn)を選択します。 

* 変数タイプが未知の場合、これらの項目は編集可能です。 
 

図12-44 [Fractional Properties]ダイアログ 

 
 
12.20 ウィザード 

ウィザードは手順をガイドする一連のダイアログ ウィンドウです。MPLAB X IDEで良く使うウィザードは以下の2つ
です。 

• [New Project]ウィザード(「新規プロジェクトの作成」参照)。 
• [New File]ウィザード(「ファイルの新規作成」参照) 
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図12-45 新規プロジェクト タイプ 
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NetBeansのウィンドウとダイアログ 

 

13. NetBeansのウィンドウとダイアログ 
MPLAB X IDEのウィンドウとダイアログは、NetBeansのウィンドウ/ダイアログとMPLAB X IDE専用のウィンドウ/
ダイアログを組み合わせています。ヘルプトピックは、NetBeans項目を白、MPLAB X IDE項目を黄色の背景で表示

します。 

ここでは、NetBeansのウィンドウとダイアログを解説します。MPLAB X IDE専用のウィンドウとダイアログは12.
「MPLAB X IDEのウィンドウとダイアログ」を参照してください。 

 
 
13.1 NetBeansウィンドウとウィンドウ メニュー 

NetBeansウィンドウの説明は、NetBeansヘルプまたはウェブ上の文書に記載されています(「About This Help File」
または「Preface」参照)。ウィンドウに関するヘルプを開くには、[Window]タブをクリックで選択してから<F1>キ
ーを押します。ヘルプが見つからない場合、[Help] > [Help Contents]を選択してヘルプファイルの[Search]タブをク

リックし、そのウィンドウの情報を検索するか、NetBeansヘルプトピックの目次「Managing IDE Windows」を参照

します。 

大部分のウィンドウは、10.1.11「ウィンドウ メニュー」に記載したメニューから開く事ができます。 

ウィンドウはドッキング/ドッキング解除でき(ウィンドウタブを右クリック)、そのウィンドウ専用のポップアップ 
メニューまたはコンテクスト メニューから例えば以下の項目を選択できます。 

• Fill 
• Goto 
• Edit Cells 

コンテクスト メニューは、ウィンドウ内またはウィンドウ内のいずれかのアイテム上で右クリックすると開きます。

これらのコンテクスト メニューの大部分は、デスクトップ メニューバーからも利用できます(10.1「メニュー」参

照)。 

[Tools] > [Options] (macOSでは[MPLAB X IDE] > [Preferences])を選択して[Miscellaneous] 
ボタン、[Appearance]タブをクリックし、ウィンドウのプロパティを設定します。 

 
 
13.2 NetBeansダイアログ 

NetBeansダイアログの説明は、NetBeansヘルプに記載されています。ダイアログで[Help]ボタンをクリックすると、

そのダイアログに関するヘルプが開きます。このボタンがない場合、<F1>キーを押します。必要なヘルプが見つか

らない場合、[Help] > [Help Contents]を選択し、ヘルプファイルの[Search]タブをクリックすると、ウィンドウ上で

情報を検索できます。 

大部分のダイアログは、10.1「メニュー」に記載したメニューから開く事ができます。 
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// ATtiny817 Configuration Bit Settings 

// 'C' source line config statements 

#include <avr/io.h> 

FUSES = { 
0x00, // WDTCFG{PERIOD=OFF, WINDOW=OFF} 
0x02, // BODCFG{SLEEP=SAMPLED, ACTIVE=DIS, SAMPFREQ=1KHz, LVL=BODLEVEL0} 
0x00, // OSCCFG{OSCLOCK=CLEAR} 
0x00, // Reserved 
0xC4, // TCD0CFG{CMPA=CLEAR, CMPB=CLEAR, CMPC=SET, CMPD=CLEAR, CMPAEN=CLEAR, 

CMPBEN=CLEAR, CMPCEN=SET, CMPDEN=SET} 
0xF6, // SYSCFG0{EESAVE=CLEAR, RSTPINCFG=UPDI, CRCSRC=NOCRC} 
0x00, // SYSCFG1{SUT=0MS} 
0x00, // APPEND 
0x00, // BOOTEND 

}; 

LOCKBITS = { 
0xC5, // LOCKBIT{LB=NOLOCK} 

}; 

 
 

 

14. コンフィグレーション設定のまとめ 
本章では、コード内でコンフィグレーション ビットを設定する方法を、各種の言語ツールと関連デバイス向けに例

を示しながら説明します。コンフィグレーション ビット設定の詳細は言語ツールのマニュアルを参照してください。

一部の言語ツールには、デバイスの全てのコンフィグレーション設定の一覧を記載したコンフィグレーション設定マ

ニュアルが用意されています。それ以外の言語ツールに関しては、デバイスのマクロ用ヘッダファイルを参照してく

ださい。 

コンフィグレーション ビットを設定するもう1つの方法は、[Configuration Memory]ウィンドウを使ってビットを設

定し、[Generate Source Code to Output]をクリックする事です。4.19「[Configuration Bits]ウィンドウでのコンフィ

グレーション値の設定」を参照してください。 

8ビットおよび16ビットデバイス向けのMPLAB Code Configurator (MCC)と32ビットデバイス向けのMPLAB 
Harmonyは、コンフィグレーション ビットとプロジェクト コードの生成に使えるツールです。これらのツールの詳

細はMicrochip社のウェブサイトを参照してください。 

最新のツールチェーン: AVR/Arm GCCコンパイラ、MPLAB XC Cコンパイラ、MPASMアセンブラ 

レガシー ツールチェーン: HI-TECH PICC/PICC18コンパイラ、MPLAB C18コンパイラ、ASM30アセンブラ、

MPLAB C30/MPLAB C32コンパイラ 
 
 
14.1 AVR GCCツールチェーン 

大部分のコンフィグレーション ビットはデバイスのヒューズバイトに格納されています。ヒューズビットをプログ

ラミングするには、Fuse APIを使います。このAPIを使うには、<avr/io.h>ヘッダファイルをインクルードします。

このファイルはAVRヒューズを設定するために必要な全てを備えています。 

コード保護コンフィグレーション ビットまたはロックビットをプログラミングするには、Lockbit APIを使います。

このAPIを使うには、 
<avr/io.h>ヘッダファイルをインクルードします。 

FUSESおよびLOCKBITSマクロの使用例を以下に示します。Fuse APIとLockbit APIの詳細は、以下を参照してください。 

https://www.microchip.com/webdoc/AVRLibcReferenceManual/group avr fuse.html 

https://www.microchip.com/webdoc/AVRLibcReferenceManual/group avr lock.html  

例: ATtiny861 MCU 

上の例は、[Configuration Bits]ウィンドウから生成しました([Window] > [Target Memory Views] > [Configuration 
Bits])。 

https://www.microchip.com/webdoc/AVRLibcReferenceManual/group__avr__fuse.html
https://www.microchip.com/webdoc/AVRLibcReferenceManual/group__avr__lock.html
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初めて[Configuration Bits]ウィンドウを開くと、データは赤で表示されています。つまり、デバイスメモリから読み

出す必要があります。[Read Configuration Bits]アイコン を使います。この[Program Configuration Bits]アイコン

を使ってウィンドウ内でデータを変更し、デバイスに書き戻します。 
設定をコードに保存するには、[Generate Source Code to Output]ボタンをクリックして 

[Output]ウィンドウにコードを置いてコピー&ペーストするか、[Insert Source Code into Editor]アイコン をクリッ

クしてエディタ ウィンドウ内のカーソル位置にコードを挿入します。 

図14-1 例: ATtiny817 MCU 

 
 

14.2 Arm GCCツールチェーン 
大部分のコンフィグレーション ビットはデバイスのGPNVMビットに格納されています。具体的には、GPNVM0は
セキュリティビットを表します。コード保護コンフィグレーション ビットをプログラミングするには、ロックビッ

トを使います。 
コンフィグレーション ビットをプログラミングするには、[Configuration Bits]ウィンドウ([Window] > [Target 
Memory Views] > [Configuration Bits])を使います。初めて[Configuration Bits]ウィンドウを開くと、データは赤で表

示されています。つまり、デバイスメモリから読み出す必要があります。[Read Configuration Bits]アイコン を使

います。この[Program Configuration Bits]アイコン を使ってウィンドウ内でデータを変更し、デバイスに書き戻

します。 

例: ATSAME70Q21 MCU 
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     config expr ;For a single configuration word 

     config addr, expr ;For multiple configuration word 

C:\Program Files\Microchip\MPLABX\mpasmx 

 
 

 

 
 
 
14.3 XCツールチェーン 

コードの移植性を最大限に高める、以下の各文書の「CCI (Common Compiler Interface)」の章、config macroのセ

クションを参照してください。 

• 『MPLAB XC8 C Compiler User’s Guide』(DS50002053)または対応するヘルプファイル 
• 『MPLAB XC16 Cコンパイラ ユーザガイド』(DS50002071)または対応するヘルプファイル 
• 『MPLAB XC32 C/C++コンパイラ ユーザガイド』(DS50001686)または対応するヘルプファイル 

コンフィグレーション ビットの読み出し、変更、書き込みの方法は4.19「[Configuration Bits]ウィンドウでのコンフ

ィグレーション値の設定」を参照してください。 
 
 
14.4 MPASMツールチェーン 

デバイス コンフィグレーション ビットの設定には、2種類のアセンブラ ディレクティブ(_configとconfig)を使い

ます。同一コード内で_configとconfigの両方を使う事はできません。 
 

14.4.1     config 
ディレクティブ「 config」はPIC10/12/16 MCU用に使います。PIC18 MCU (PIC18FXXJを除く)にも使えますが、

「config」を推奨します。以下に構文を示します。 

または 
 

 

addr コンフィグレーション ワードのアドレスです。リテラルでも指定できますが、通常はマクロに

より表現します。 
Note:  マクロは、レジスタ番号順(昇順)に列記する必要があります。 

expr 指定したコンフィグレーション ビットに設定する値を表現する式です。リテラルでも指定で

きますが、通常はマクロまたは複数マクロの論理積(AND)により表現します。 
 

マクロはデバイス インクルード ファイル(*.inc)で定義されます。Windowsの場合、このファイルは以下の既定値フ

ォルダに保存されます。 
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例 – PIC10/12/16 MCUの場合 

#include p16f877a.inc 
;Set oscillator to HS, watchdog time off, low-voltage prog. off 
     CONFIG _HS_OSC & _WDT_OFF & _LVP_OFF 

config setting=value [, setting=value] 

C:\Program Files\Microchip\MPLABX\mpasmx 

例 – PIC18 MCUの場合 

#include p18f452.inc 
;Oscillator switch enabled, RC oscillator with OSC2 as I/O 
pin.CONFIG OSCS=ON, OSC=LP 
;Watch Dog Timer enable, Watch Dog Timer PostScaler count - 1:128 
CONFIG WDT=ON, WDTPS=128 

 
 

ディレクティブの大文字と小文字は区別されないため、 CONFIGと configのどちらでも使えます。マクロの大文

字/小文字は、ヘッダファイル内の記述に合わせる必要があります。 

『MPASM Assembler, MPLINK Object Linker, MPLIB Object Librarian User’s Guide』(DS30003014)の「 config - Set 
Processor Configuration Bits」を参照してください。 

 

 
 

14.4.2 config 
ディレクティブ「config」は、PIC18 MCU (PIC18FXXJを含む)用に使います。以下に構文を示します。 

 

 

setting コンフィグレーション ビットを表現するマクロです。 

value 指定したコンフィグレーション ビットに設定する値を表現するマクロです。コンマで区切る事によ

り、一行で複数の設定を定義できます。1つのコンフィグレーション バイトの設定を複数行に分けて定

義する事もできます。 
 

マクロはデバイス インクルード ファイル(*.inc)で定義されます。Windowsの場合、このファイルは以下の既定値フ

ォルダに保存されます。 
 

ディレクティブの大文字と小文字は区別されないため、 CONFIGと configのどちらでも使えます。マクロの大文字/
小文字は、ヘッダファイル内の記述に合わせる必要があります。 

『MPASM Assembler, MPLINK Object Linker, MPLIB Object Librarian User’s Guide』(DS30003014)の「config 
- Set Processor Configuration Bits (PIC18 MCUs)」を参照してください。 

 

14.5 HI-TECH® PICC™ツールチェーン 
htc.hヘッダファイル内で定義されているマクロを使って、PIC10/12/16 MCUのデバイス コンフィグレーション ワー

ドを設定します: 
     CONFIG(x); 

例 – PIC18 MCUの場合 

#include p18f452.inc 
;Oscillator switch enabled, RC oscillator with OSC2 as I/O pin. 
     CONFIG _CONFIG1, _OSCS_OFF_1 & _RCIO_OSC_1 
;Watch Dog Timer enable, Watch Dog Timer PostScaler count - 1:128 
     CONFIG _CONFIG3, _WDT_ON_3 & _WDTPS_128_3 
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C:\Program Files\HI-TECH Software\PICC\vx.xx\include 

#include <htc.h> 
     CONFIG(WDTDIS & XT & UNPROTECT); // Program config. word 1 
     CONFIG(FCMEN); // Program config. word 2 

     CONFIG(n,x); 

C:\Program Files\HI-TECH Software\PICC\vx.xx\include 

#include <htc.h> 
//Oscillator switch enabled, RC oscillator with OSC2 as I/O pin. 
     CONFIG(1, LP); 
//Watch Dog Timer enable, Watch Dog Timer PostScaler count - 1:128 
     CONFIG(2, WDTEN & WDTPS128); 

#pragma config setting-list 

 

x 指定したコンフィグレーション ビットに設定する値を表現する式です。リテラルでも指定で

きますが、通常はマクロまたは複数マクロの論理積(AND)により表現します。 
 

マクロはデバイス ヘッダファイル(*.h)で定義されます。Windowsの場合、このファイルは以下の既定値フォルダに

保存されます。 
 

vx.xxは、コンパイラのバージョン番号です。 

複数のコンフィグレーション ワードアドレスを持つデバイスでは、 CONFIG()を呼び出すたびに次のコンフィグレ

ーション ワードを変更します。 

マクロの大文字/小文字は、対応するヘッダファイル内の記述に合わせる必要があります。htc.cに対しては大文字

の  CONFIG()を使います(  config()は使えません)。『HI-TECH C for PIC10/12/16 User’s Guide』(DS51865)の
「Configuration Fuses」を参照してください。 
PICCの例 

 

 
 

14.6 HI-TECH® PICC-18™ツールチェーン 
htc.hヘッダファイルで定義されているマクロを使って、PIC18 MCUのデバイス コンフィグレーション ワードを設定

します。 
 

 

n コンフィグレーション レジスタ番号です。 

x 指定したコンフィグレーション ビットに設定する値を表現する式です。リテラルでも指定できますが、通常は

マクロまたは複数マクロの論理積(AND)により表現します。 
 

マクロはデバイス ヘッダファイル(*.h)で定義されます。Windowsの場合、このファイルは以下の既定値フォルダに

保存されます。 
 

vx.xxは、コンパイラのバージョン番号です。 

マクロの大文字/小文字は、対応するヘッダファイル内の記述に合わせる必要があります。htc.cに対しては大文字

の  CONFIG()を使います(  config()は使えません)。『HI-TECH C Tools for the PIC18 MCU Family』の

「Configuration Fuses」を参照してください。 
PICC-18の例 

 

 
 

14.7 C18ツールチェーン 
ディレクティブ「#pragma config」は、アプリケーションで使うデバイスに固有のコンフィグレーション設定(コ
ンフィグレーション ビット)を指定します。 
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C:\program files\microchip\mplabc18\vx.xx\.h 

例 

#include <p18cxxx.h> 
/*Oscillator switch enabled, RC oscillator with OSC2 as I/O 
pin.*/#pragma config OSCS = ON, OSC = LP 
/*Watch Dog Timer enable, Watch Dog Timer PostScaler count - 1:128*/ 
#pragma config WDT = ON, WDTPS = 128 

config reg, value 

C:\Program Files\Microchip\MPLAB ASM30 Suite\Support\device\inc 

例 

.include "p30fxxxx.inc" 
;Clock switching off, Fail-safe clock monitoring off, 
; Use External Clock 
config FOSC, CSW_FSCM_OFF & XT_PLL16 
;Turn off Watchdog Timer 
config FWDT, WDT_OFF 

 

setting-list コンマで区切った「setting-name = value-name」マクロペアです。 
 

マクロはデバイス ヘッダファイル(*.h)で定義されます。Windowsの場合、このファイルは以下の既定値フォルダに

保存されます。 
 

pragmaの大文字と小文字は区別されないため、#PRAGMA CONFIGと#pragma configのどちらでも使えます。 
マクロの大文字/小文字は、ヘッダファイル内の記述に合わせる必要があります。 

『MPLAB C18 C Compiler User’s Guide』(DS50001288)の「Pragms」、「#pragma config」を参照してください。 

 
 
14.8 ASM30ツールチェーン 

デバイス インクルード ファイルで定義されているマクロを使ってコンフィグレーション ビットを設定します。 
 

 

  reg コンフィグレーション レジスタ名を表現するマクロです。 

value 指定したコンフィグレーション ビットに設定する値を表現する式です。リテラルでも指定で

きますが、通常はマクロまたは複数マクロの論理積(AND)により表現します。 
 

マクロはデバイス インクルード ファイル(*.inc)で定義されます。Windowsの場合、このファイルは以下の既定値

フォルダに保存されます。 
 

deviceは、選択した16ビットデバイスの略称です(PIC24H、dsPIC33F)。 

マクロの大文字/小文字は、対応するヘッダファイル内の記述に合わせる必要があります。例えば、ヘッダファイル

で小文字のconfigが使われている場合、大文字のCONFIGは使えません。 

『MPLAB® Assembler, Linker and Utilities for PIC24 MCUs and dsPIC® DSCs User’s Guide』(DS50001317)の
「Output Sections in Configuration Memory」を参照してください。 

 
 
14.9 C30ツールチェーン 

デバイス  コンフィグレーション  ビットの設定には 2 種類のコンパイラマクロ (PIC24F MCU 用と

dsPIC30F/dsPIC33F/PIC24H用)を使います。 
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_confign(value); 

C:\Program Files\Microchip\MPLAB C30\support\PIC24F\h 

_reg(value); 

C:\Program Files\Microchip\MPLAB C30\support\device\h 

例 – dsPIC30F DSC 

#include “p30fxxxx.h” 
//Clock switching and failsafe clock monitoring off, 
// Oscillator in HS mode 
_FOSC(CSW_FSCM_OFF & HS); 
//Watchdog timer off 
_FWDT(WDT_OFF); 
//Brown-out off, Master clear on 
_FBORPOR(PBOR_OFF & MCLR_EN); 

14.9.1 PIC24Fのコンフィグレーション設定 
デバイスヘッダ ファイルで定義されているマクロを使ってコンフィグレーション ビットを設定します。 

 

 

n コンフィグレーション レジスタ番号です。 

value 指定したコンフィグレーション ビットに設定する値を表現する式です。リテラルでも指定で

きますが、通常はマクロまたは複数マクロの論理積(AND)により表現します。 
 

マクロはデバイス ヘッダファイル(*.h)で定義されます。Windowsの場合、このファイルは以下の既定値フォルダに

保存されます。 
 

マクロの大文字/小文字は、対応するヘッダファイル内の記述に合わせる必要があります。例えば、ヘッダファイル

で大文字の_CONFIG1が使われている場合、小文字の_config1は使えません。 

 
 

14.9.2 dsPIC30F/33F/PIC24Hのコンフィグレーション設定 
デバイスヘッダ ファイルで定義されているマクロを使ってコンフィグレーション ビットを設定します。 

 

 

_reg コンフィグレーション レジスタ名を表現するマクロです。 

value 指定したコンフィグレーション ビットに設定する値を表現する式です。リテラルでも指定で

きますが、通常はマクロまたは複数マクロの論理積(AND)により表現します。 
 

マクロはデバイス ヘッダファイル(*.h)で定義されます。Windowsの場合、このファイルは以下の既定値フォルダに

保存されます。 
 

deviceは、選択した16ビットデバイスの略称です(PIC24H、dsPIC30F、dsPIC33F)。マクロの大文字/小文字は、対

応するヘッダファイル内の記述に合わせる必要があります。例えば、ヘッダファイルで大文字の_FOSCが使われてい

る場合、小文字の_foscは使えません。 
『MPLAB® C Compiler for PIC24 MCUs and dsPIC® DSCs User’s Guide』(DS50001284)の「Configuration Bits 
Setup Macros」を参照してください。 

例 – PIC24F MCUの場合 

#include “p24Fxxxx.h” 
//JTAG off, Code Protect off, Write Protect off, COE mode off, WDT off 
_CONFIG1( JTAGEN_OFF & GCP_OFF & GWRP_OFF & COE_OFF & FWDTEN_OFF ) 
//Clock switching/monitor off, Oscillator (RC15) on, 
// Oscillator in HS mode, Use primary oscillator (no PLL) 
_CONFIG2( FCKSM_CSDCMD & OSCIOFNC_ON & POSCMOD_HS & FNOSC_PRI ) 
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# pragma config setting-list 

C:\Program Files\Microchip\MPLAB C32\pic32mx\include\proc 

例 

#include “p32xxxx.h” 
//Enables the Watchdog Timer, 
// Sets the Watchdog Postscaler to 1:128 
#pragma config FWDTEN = ON, WDTPS = PS128 
//Selects the HS Oscillator for the Primary Oscillator 
#pragma config POSCMOD = HS 

 
 

 

 
 
 

14.10 C32ツールチェーン 
ディレクティブ「#pragma config」は、アプリケーションで使うデバイスに固有のコンフィグレーション設定(コ
ンフィグレーション ビット)を指定します。 

 

setting-list: コンマで区切った「setting-name = value-name 」マクロペアです。 
 

マクロはデバイス ヘッダファイル(*.h)で定義されます。Windowsの場合、このファイルは以下の既定値フォルダに

保存されます。 
 

pragmaの大文字と小文字は区別されないため、#PRAGMA CONFIGと#pragma configのどちらでも使えます。

マクロの大文字/小文字は、ヘッダファイル内の記述に合わせる必要があります。 

『MPLAB® C Compiler for PIC32 MCUs User’s Guide』(DS50001686)の「Configuration Bit Access」を参照してく

ださい。 

例 – dsPIC33F/PIC24H 

#include “p33fxxxx.h” 
// Use primary oscillator (no PLL) 
_FOSCSEL(FNOSC_PRI); 
//Oscillator in HS mode 
_FOSC(POSCMD_HS); 
//Watchdog timer off 
_FWDT(FWDTEN_OFF); 
//JTAG off 
_FICD(JTAGEN_OFF); 
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union castaway 
int intval; 
struct { 
char lo; //accessible as caster.lo 
char hi; //accessible as caster.hi 
}; 
} caster; 

 
 

 

15. 用語集 
 

絶対セクション(Absolute Section) 
リンカで変更されない固定(絶対)アドレスを持つGCCコンパイラのセクション。 

 
絶対変数/関数(Absolute Variable/Function) 
OCGコンパイラの@ address構文を使って絶対アドレスに配置される変数または関数。 

 
アクセスメモリ(Access Memory) 
PIC18のみ - PIC18でバンクセレクト レジスタ(BSR)の設定に関わらずアクセスできる特殊なレジスタ。 

 
アクセス エントリポイント(Access Entry Points) 
リンク時に定義されていない可能性のある関数に、セグメントの境界を越えて制御を渡すための手段。ブートセグメ

ントとセキュア アプリケーション セグメントを別々にリンクする方法を提供する。 

 
アドレス(Address) 
メモリ内の位置を一意に特定する値。 

 
アルファベット文字(Alphabetic Character) 
アルファベットの小文字と大文字の総称(a,b,･･･,z,A,B,･･･,Z)。 

 
英数字(Alphanumeric) 
アルファベット文字と0～9の10進数(0,1,･･･,9)の数字の総称。 

 
AND条件ブレークポイント(ANDed Breakpoint) 
プログラムの実行を停止するために設定するAND条件(ブレークポイント1とブレークポイント2が同時に発生した場

合のみプログラム実行を停止する)。AND条件で実行が停止するのは、データメモリのブレークポイントとプログラ

ムメモリのブレークポイントが同時に発生した場合のみ。 

 
匿名構造体(Anonymous Structure) 
16ビットCコンパイラ – 無名の構造体。 

PIC18 Cコンパイラ - C共用体のメンバーである無名の構造体。匿名構造体のメンバーは、その構造体を包含してい

る共用体のメンバーと同じようにアクセスできる。例えば以下のサンプルコードでは、hiとloは共用体casterに含ま

れる匿名構造体のメンバーである。 
 

ANSI 
American National Standards Institute(米国規格協会)の略。米国における標準規格の策定と承認を行う団体。 

 
アプリケーション(Application) 
PIC® MCUで制御されるソフトウェアとハードウェアを組み合わせたもの。 
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アーカイブ/ライブラリ(Archive/Library) 
アーカイブ/ライブラリは、再配置可能なオブジェクト モジュールの集まり。複数のソースファイルをオブジェクト 
ファイルにアセンブルした後、アーカイバ/ライブラリアンを使ってこれらオブジェクト ファイルを1つのアーカイブ

/ライブラリ ファイルにまとめると生成される。アーカイブ/ライブラリをオブジェクト モジュールや他のアーカイブ

/ライブラリとリンクすると、実行コードが生成される。 

 
ASCII 
American Standard Code for Information Interchangeの略。7桁の2進数で1つの文字を表現する文字セットエンコー

ド方式。大文字、小文字、数字、記号、制御文字等を含む。 

 
アセンブリ/アセンブラ(Assembly/Assembler) 
アセンブリとは、2進数のマシンコードをシンボル表現で記述したプログラミング言語。アセンブラとは、アセンブ

リ言語のソースコードをマシンコードに変換する言語ツール。 

 
割り当てセクション(Assigned Section) 
リンカのコマンドファイルで特定のターゲットメモリ ブロックに割り当てられたGCCコンパイラのセクション。 

 
非同期(Asynchronously) 
複数のイベントが同時には発生しない事。一般に、プロセッサ実行中の任意の時点で発生する割り込みに言及する際

に使う。 

 
非同期スティミュラス(Asynchronous Stimulus) 
シミュレータ デバイスへの外部入力をシミュレートするために生成されるデータ。 

 
属性(Attribute) 
GCCのC言語プログラムの変数または関数の特徴を表す情報で、マシン固有の特性を記述する目的で使う。 

 
属性(セクション属性) (Attribute, Section) 
「executable」、「readonly」、「data」等、セクションの特徴を表す情報。アセンブラの.sectionディレクティブで

フラグとして指定できる。 

 
2進数(Binary) 
0と1の数字を使う、2を底とした記数法。一番右の桁が1の位、次の桁が2の位、その次の桁が22 = 4の位を表す。 

 
ブックマーク(Bookmark) 
ファイル内の特定の行に簡単な操作でアクセスできるようにする機能。 

[Editor]ツールバーの[Toggle Bookmarks]を選択してブックマークを追加または削除する。このツールバーの他のアイ

コンをクリックすると、次または前のブックマークに移動する。 

 
C/C++ 
C言語は、簡潔な表現、現代的な制御フローとデータ構造、豊富に用意された演算子等を特長とする汎用プログラミ

ング言語。C++とは、C言語のオブジェクト指向バージョン。 

 
校正メモリ(Calibration Memory) 
PIC MCUの内蔵RCオシレータやその他の周辺モジュールの校正値を格納するための特殊機能レジスタ。 

 
中央演算処理装置(Central Processing Unit) 
デバイス内で、実行する正しい命令をフェッチし、デコードして実行する装置。必要に応じて、算術論理演算装置

(ALU)と組み合わせて命令実行を完了する。プログラムメモリのアドレスバス、データメモリのアドレスバス、スタ

ックへのアクセスを制御する。 
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クリーン(Clean) 
クリーンする事により、アクティブなプロジェクトのオブジェクト ファイル、HEXファイル、デバッグファイル等、

全ての中間ファイルが削除される。これらのファイルは、プロジェクトのビルド時に他のファイルから再構築される。 

 
COFF 
Common Object File Formatの略。このフォーマットのオブジェクト ファイルは、マシンコードの他、デバッグ等に

関する情報を含む。 
 

コマンドライン インターフェイス(Command Line Interface) 
プログラムとユーザのやり取りをテキストの入出力だけで行う方法。 

 
コンパイルド スタック(Compiled Stack) 
コンパイラが管理するメモリの領域で、この領域内で変数に静的に空間を割り当てる。ターゲット デバイス上にソ

フトウェア スタックまたはハードウェア スタックのメカニズムを効率的に実装できない場合、コンパイルド スタッ

クがソフトウェア スタックまたはハードウェア スタックに置き換わる。 

 
コンパイラ(Compiler) 
高級言語で記述されたソースファイルをマシンコードに変換するプログラム。 

 
条件付きアセンブリ(Conditional Assembly) 
アセンブリ言語で、ある特定の式のアセンブル時の値に基づいて含まれたり除外されたりするコード。 

 
条件付きコンパイル(Conditional Compilation) 
プログラムの一部を、プリプロセッサ ディレクティブで指定した特定の定数式が真の場合のみコンパイルする事。 

 
コンフィグレーション ビット(Configuration Bit) 
PIC MCUとdsPIC DSCの動作モードを設定するために書き込む専用ビット。コンフィグレーション ビットは事前プ

ログラミングされている場合とされていない場合がある。 

 
制御ディレクティブ(Control Directive) 
アセンブリ言語コード内で使うディレクティブで、指定した式のアセンブル時の値に基づいてコードを含めるか除外

するかを決定する。 

 
CPU 
「中央演算処理装置」参照 

 
相互参照ファイル(Cross Reference File) 
シンボルテーブルとそのシンボルを参照するファイルリストを参照するファイル。シンボルが定義されている場合、

リストの最初のファイルがシンボル定義の位置となる。残りのファイルはシンボルへの参照を含む。 

 
データ ディレクティブ(Data Directive) 
アセンブラが行うプログラムメモリまたはデータメモリの割り当てを制御するディレクティブ。データ項目をシンボ

ル(意味のある名前)で参照する手段として使う。 

 
データメモリ(Data Memory) 
Microchip社のMCUとDSCでは、データメモリ(RAM)は汎用レジスタ(GPR)と特殊機能レジスタ(SFR)で構成される。

EEPROMデータメモリを内蔵したデバイスもある。 

 
データ監視および制御インターフェイス(DMCI: Data Monitor and Control Interface) 
MPLAB X IDE内のツール。このインターフェイスは、プロジェクト内のアプリケーション変数の動的な入力制御を

提供する。4つの動的に割り当て可能なグラフィック ウィンドウを使って、アプリケーションが生成するデータをグ

ラフィカルに表示できる。 
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デバッグ/デバッガ(Debug/Debugger) 
「ICE/ICD」参照 

 
デバッグ情報(Debugging Information) 
コンパイラとアセンブラでこのオプションを選択すると、アプリケーション コードのデバッグに使える各種レベル

の情報を出力できる。デバッグ オプションの選択の詳細はコンパイラまたはアセンブラのマニュアルを参照。 

 
推奨しない機能(Deprecated Feature) 
後方互換性確保のためにサポートしているだけで現在は使っておらず、いずれ廃止になる事が決まっている機能。 

 
デバイス プログラマ(Device Programmer) 
マイクロ コントローラ等、電気的に書き込み可能な半導体デバイスをプログラミングするためのツール。 

 
デジタルシグナル コントローラ(Digital Signal Controller) 
デジタル信号処理機能をサポートしたMCU。Microchip社のdsPIC DSC等。 

 
デジタル信号処理/デジタルシグナル プロセッサ(Digital Signal Processing/Digital Signal Processor) 
デジタル信号処理(DSP)とは、デジタル信号をコンピュータで処理する事。通常は、アナログ信号(音声または画像)
をデジタル形式に変換(サンプリング)して処理する事をいう。デジタルシグナル プロセッサとは、信号処理用に設計

されたマイクロプロセッサの事。 

 
ディレクティブ(Directive) 
言語ツールの動作を制御するためにソースコードに記述する命令文。 

 
ダウンロード(Download) 
ホストから別のデバイス(例: エミュレータ、プログラマ、ターゲットボード)にデータを送信する事。 

 
DWARF 
Debug With Arbitrary Record Formatの略。ELFファイルのデバッグ情報フォーマット。 

 
EEPROM 
Electrically Erasable Programmable Read Only Memoryの略。電気的に消去可能なタイプのPROM。データの書き込

みと消去をバイト単位で行う。EEPROMは電源をOFFにしても内容を保持する。 

 
ELF 
Executable and Linking Formatの略。この形式のオブジェクト ファイルはマシンコードを含む。デバッグその他の情

報はDWARFで指定する。ELF/DWARFの方がCOFFよりも最適化したコードのデバッグに適している。 

 
エミュレーション/エミュレータ(Emulation/Emulator) 
「ICE/ICD」参照 

 
エンディアン(Endianness) 
マルチバイト オブジェクトにおけるバイトの並び順。 

 
環境(Environment) 
MPLAB PM3 - デバイスのプログラミングに関する設定ファイルを保存したフォルダ。このフォルダをSD/MMCカー

ドに転送できる。 
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エピローグ(Epilogue) 
コンパイラで生成したコードのうち、スタック領域の割り当て解除、レジスタの復帰、ランタイムモデルで指定した

その他のマシン固有の要件を実行するコード部分。関数のユーザコードの後、関数リターンの直前にエピローグを実

行する。 

 
EPROM 
Erasable Programmable Read Only Memoryの略。再書き込みが行えるタイプのROMで、消去は紫外線照射で行うも

のが主流。 

 
エラー/エラーファイル(Error/Error File) 
プログラムの処理を継続できない問題が発生するとエラーとして報告される。可能な場合、エラーは問題が発生した

ソースファイル名と行番号を特定する。エラーファイルは、言語ツールから出力されたエラーメッセージと診断結果

を保存する。 

 
イベント(Event) 
アドレス、データ、パスカウント、外部入力、サイクルタイプ (フェッチ、R/W)、タイムスタンプ等、バスサイクル

を記述したもの。トリガ、ブレークポイント、割り込みを記述するために使う。 

 
実行可能コード(Executable Code) 
読み込んで実行できる形式のソフトウェア。 

 
エクスポート(Export) 
MPLAB IDE/MPLAB X IDEから標準フォーマットでデータを外部に出力する事。 

 
式(Expression) 
算術演算子または論理演算子で区切った定数または記号の組み合わせ。 

 
拡張マイクロ コントローラ モード(Extended Microcontroller Mode) 
拡張マイクロ コントローラ モードでは、内蔵プログラムメモリと外部メモリの両方が利用できる。プログラムメモ

リのアドレスがPIC18の内部メモリ空間より大きい場合、自動的に外部メモリの実行に切り換わる。 

 
拡張モード(Extended Mode) (PIC18 MCU) 
コンパイラの動作モードの1つ。拡張命令(ADDFSR、ADDULNK、CALLW、MOVSF、MOVSS、PUSHL、SUBFSR、
SUBULNK)とリテラル オフセットによるインデックス アドレス指定を利用できる。 

 
外部ラベル(External Label) 
外部リンケージを持つラベル。 

 
外部リンケージ(External Linkage) 
関数または変数が、それを定義したモジュールの外部から参照できる場合、外部リンケージを持つという。 

 
外部シンボル(External Symbol) 
外部リンケージを持つ識別子のシンボル。参照の場合と定義の場合がある。 

 
外部シンボル解決(External Symbol Resolution) 
リンカが全ての入力モジュールの外部シンボル定義を1つにまとめ、全ての外部シンボル参照を解決しようとするプ

ロセス。外部シンボル参照に対応する定義が存在しない場合、リンカエラーとなる。 

 
外部入力ライン(External Input Line) 
外部信号に基づいてイベントを設定するための外部入力信号ロジックプローブ ライン(TRIGIN)。 
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外部RAM (External RAM) 
デバイス外部にある、読み書き可能なメモリ。 

 
致命的エラー(Fatal Error) 
コンパイルがただちに停止するようなエラー。エラーの発生後はメッセージも出力されない。 

 
ファイルレジスタ(File Register) 
汎用レジスタ(GPR)と特殊機能レジスタ(SFR)からなる内蔵のデータメモリ。 

 
フィルタ(Filter) 
トレース ディスプレイまたはデータファイルにどのデータを含めるか/除外するかを選択するもの。 

 
フィックスアップ(Fixup) 
リンカによる再配置後にオブジェクト ファイルのシンボル参照を絶対アドレスに置き換える処理。 

 
フラッシュ(Flash) 
データの書き込みと消去をバイト単位ではなくブロック単位で行えるタイプのEEPROM。 

 
FNOP 
Forced No Operationの略。Forced NOPサイクルは、2サイクル命令の2サイクル目で発生する。PICマイクロ コント

ローラのアーキテクチャはパイプライン構造となっており、現在の命令を実行中に物理アドレス空間の次の命令をプ

リフェッチする。しかし、現在の命令でプログラム カウンタが変化した場合、プリフェッチした命令は明示的に無

視され、Forced NOPサイクルが発生する。 

 
フレームポインタ(Frame Pointer) 
スタックベースの引数とスタックベースのローカル変数の境界となるスタック番地を指し示すポインタ。ここを基準

にすると、現在の関数のローカル変数やその他の値に容易にアクセスできる。 

 
フリー スタンディング(Free-Standing) 
複素数型を使っておらず、ライブラリ(ANSI C89規格第7節)で規定する機能の使用が標準ヘッダ(<float.h>、
<iso646.h>、<limits.h>、<stdarg.h>、<stdbool.h>、<stddef.h>、<stdint.h>)の内容のみに限定され

ている厳密な規格合致プログラムを受理する処理系。 
<stdint.h>. 

 
GPR 
General Purpose Register(汎用レジスタ)の略。デバイスのデータメモリ(RAM)のうち、汎用目的に使える部分。 

 
Halt 
プログラム実行を停止する事。Haltを実行する事は、ブレークポイントで停止する事と同じ。 

 
ヒープ(Heap) 
動的メモリ割り当てに使うメモリ空間。メモリブロックの割り当てと解放は実行時に任意の順序で行う。 

 
HEXコード/HEXファイル(Hex Code/Hex File) 
HEXコードは、実行可能な命令を16進数形式のコードで保存したもの。HEXファイルは、HEXコードを格納したフ

ァイル。 
 

16進数(Hexadecimal) 
0～9の数字とA～F(またはa～f)のアルファベットを使った、16を底とした記数法。16進数のA～Fは、10進数の10～
15を表す。一番右の桁が1の位、次の桁が16の位、その次の桁が162 = 256の位を表す。 
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高級言語(High Level Language) 
プログラムを記述するための言語で、プロセッサから見てアセンブリよりも遠い位置関係にあるもの。 

 
ICE/ICD 
インサーキット エミュレータ/インサーキット デバッガの略。ターゲット デバイスのデバッグとプログラミングを
行うためのハードウェア ツール。エミュレータは、デバッガよりも多くの機能(トレース等)を備える。 

インサーキット エミュレーション/インサーキット デバッグとは、インサーキット エミュレータまたはデバッガを
使った作業の事を指す。 

-ICE/-ICD: インサーキット エミュレーション/デバッグ用の回路を内蔵したデバイス(MCUまたはDSC)。このデバイ
スは必ずヘッダ基板にマウントし、インサーキット エミュレータまたはデバッガによるデバッグ用に使う。 

 
ICSP 
In-Circuit Serial Programmingの略。Microchip社製の組み込みデバイスを、シリアル通信を利用して最小限のデバイ

スピンでプログラミングする方法。 
 

IDE 
Integrated Development Environmentの略。MPLAB IDE/MPLAB X IDEのIDE。 

 
識別子(Identifier) 
関数または変数の名前。 

 
IEEE 
Institute of Electrical and Electronics Engineersの略。 

 
インポート(Import) 
HEXファイル等の外部ソースからMPLAB IDE/MPLAB X IDEにデータを取り込む事。 

 
初期化済みデータ(Initialized Data) 
初期値を指定して定義されたデータ。Cでは、 

int myVar=5; 

として定義した変数は初期化済みデータセクションに格納する。 

 
命令セット(Instruction Set) 
特定のプロセッサが理解できるマシン語命令の集合。 

 
命令(Instruction) 
CPUに対して特定の演算を実行するように指示するビット列。演算の対象となるデータを含める事もできる。 

 
内部リンケージ(Internal Linkage) 
関数または変数が、それを定義したモジュールの外部から参照できない場合、内部リンケージを持つという。 

 
国際標準化機構(International Organization for Standardization) 
コンピューティングや通信を始めとする、多くのテクノロジとビジネス関連の標準規格の策定を行っている団体。 
一般的にISOと呼ぶ。 

 
割り込み(Interrpt) 
CPUに対する信号の一種。この信号が発生すると、現在動作中のアプリケーションの実行を一時停止し、制御を割り

込みサービスルーチン(ISR)に渡してイベントを処理する。ISRの実行が完了すると、通常のアプリケーションの実行

を再開する。 
 

割り込みハンドラ(Interrupt Handler) 
割り込み発生時に専用のコードを実行するルーチン。 
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割り込みサービス要求(IRQ: Interrupt Service Request) 
プロセッサの通常の命令実行を一時的に停止し、割り込みハンドラルーチンの実行開始を要求するイベント。プロセ

ッサによっては複数の割り込み要求イベントを持ち、優先度の異なる割り込みを処理できるものもある。 

 
割り込みサービスルーチン(ISR: Interrupt Service Routine) 
言語ツールの場合: 割り込みを処理する関数。 

MPLAB IDE/MPLAB X IDEの場合: 割り込みが発生すると実行されるユーザ作成コード。通常、発生した割り込みの

種類によってプログラムメモリ内の異なる位置のコードを実行する。 

 
割り込みベクタ(Interrupt Vector) 
割り込みサービスルーチンまたは割り込みハンドラのアドレス。 

 
左辺値(L-value) 
検査または変更が可能なオブジェクトを示す式。左辺値は代入演算子の左側で使う。 

 
レイテンシ(Latency) 
イベントが発生してからその応答までの時間の長さ。 

 
ライブラリ/ライブラリアン(Library/Librarian) 
「アーカイブ/ライブラリ」参照 

 
リンカ(Linker) 
オブジェクト ファイルとライブラリを結合し、モジュール間の参照を解決して実行可能コードを生成する言語ツール。 

 
リンカスクリプト ファイル(Linker Script File) 
リンカのコマンドファイル。リンカのオプションを定義し、ターゲット プラットフォームで利用可能なメモリを記

述する。 

 
リスティング ディレクティブ(Listing Directive) 
アセンブラのリスティング ファイルのフォーマットを制御するディレクティブ。タイトルや改ページ指示等、リス

ティング ファイルに関する各種の設定を行う。 

 
リスティング(Listing File) 
ソースファイルにある各Cソース ステートメント、アセンブリ命令、アセンブラ ディレクティブ、マクロに対して

生成されたマシンコードを記述したASCIIテキストファイル。 

 
リトル エンディアン(Little Endian) 
マルチバイト データで最下位バイト(LSB)を最下位アドレスに格納するデータ並び順方式。 

 
ローカルラベル(Local Label) 
マクロ内でLOCALディレクティブを使って定義されたラベル。ローカルラベルは、マクロの同一インスタンス内で

のみ有効。すなわち、LOCALとして宣言されたシンボルとラベルには、ENDMマクロ以降はアクセスできない。 

 
ロジックプローブ(Logic Probes) 
Microchip社製エミュレータには、最大14のロジックプローブを接続できるものがある。ロジックプローブは、外部

トレース入力、トリガ出力信号、+5 V、共通グランドを提供する。 

 
ループバック テストボード(Loop-Back Test Board) 
MPLAB REAL ICEインサーキット エミュレータの動作をテストするために用いる。 
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LVDS 
Low Voltage Differential Signalingの略。銅線を使って低ノイズ、低消費電力、低振幅でデータを高速(数Gbps)で伝送

する方法。 

標準のI/Oシグナリングでは、データストレージは実際の電圧レベルに依存する。電圧レベルは信号線の長さに影響

を受ける(信号線が長いと抵抗が増え電圧が下がる)。これに対しLVDSでは、電圧レベルでなく差動入力の電位差が

正か負かでのみデータの意味を区別する。従って、長い信号線でもクリアで安定したデータストリームを維持した伝

送が可能。 

出典: http://www.webopedia.com/TERM/L/LVDS.html 

 
マシンコード(Machine Code) 
コンピュータ プログラムをプロセッサが実際に読み出して解釈できる形式で表現したもの。2進数のマシンコードで

記述されたプログラムは、マシン命令のシーケンス(命令間にデータを挟む事もある)からなる。ある特定のプロセッ

サで使える全ての命令の集合を「命令セット」という。 

 
マシン語(Machine Language) 
あるCPUが翻訳を必要とせず実行できる命令の集合。 

 
マクロ(Macro) 
マクロ命令。一連の命令シーケンスを短い名前で表現した命令。 

 
マクロ ディレクティブ(Macro Directive) 
マクロ定義の中で実行とデータ割り当てを制御するディレクティブ。 

 
makeファイル(Makefile) 
プロジェクトのMakeに関する指示をファイルにエクスポートしたもの。このファイルは、MPLAB IDE/MPLAB X 
IDE以外の環境でmakeコマンドを実行してプロジェクトをビルドする際に使う。 

 
Make Project 
アプリケーションを再ビルドするコマンド。前回の完全なコンパイル後に変更されたソースファイルのみを再コンパ

イルする。 

 
MCU 
Microcontroller Unitの略。マイクロコントローラの事。「µC」と表記する事もある。 

 
メモリモデル(Memory Model) 
Cコンパイラの場合、アプリケーションで利用可能なメモリを表現したもの。PIC18Cコンパイラの場合、プログラ

ムメモリを指し示すポインタのサイズに関する規定を記述したもの。 

 
メッセージ(Message) 
言語ツールの動作に問題が発生した事を知らせる文字列。メッセージが表示されても処理は停止しない。 

 
マイクロコントローラ(Microcontroller) 
CPU、RAM、プログラムメモリ、I/Oポート、タイマ等、多くの機能を統合したチップ。 

 
マイクロコントローラ モード(Microcontroller Mode) 
PIC18MCUで設定可能なプログラムメモリ構成の1つ。マイクロコントローラ モードでは、内部実行のみを許可する。

つまり、マイクロコントローラ モードでは内蔵プログラムメモリしか使えない。 

 
マイクロプロセッサ モード(Microprocessor Mode) 
PIC18マイクロコントローラで設定可能なプログラムメモリ構成の1つ。マイクロプロセッサ モードでは、内蔵プロ

グラムメモリは使わない。プログラムメモリ全体を外部にマッピングする。 

http://www.webopedia.com/TERM/L/LVDS.html
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ニーモニック(Mnemonic) 
マシンコードと1対1で対応したテキスト命令。オペコードとも呼ぶ。 

 
モジュール(Module) 
プリプロセッサ ディレクティブ実行後の前処理済みのソースファイル出力。翻訳単位とも呼ぶ。 

 
MPASM™アセンブラ(MPASM Assembler) 
PIC MCU、KeeLoq®デバイス、Microchip社のメモリデバイスに対応したMicrochip社の再配置可能なマクロアセンブ

ラ。 
 

MPLAB (言語ツール名) for (デバイス名) (MPLAB Language Tool for Device) 
特定のデバイスに対応したMicrochip社のCコンパイラ、アセンブラ、リンカ。言語ツールは、アプリケーションで使

うデバイスに対応したものを選択する必要がある。例えばPIC18 MCU用のCコードを作成する場合、「MPLAB C 
Compiler for PIC18 MCU」を使う。 

 
MPLAB ICD 
MPLAB IDE/MPLAB X IDEと組み合わせて使うMicrochip社のインサーキット デバッガ。「ICE/ICD」参照。 

 
MPLAB IDE/MPLAB X IDE 
Microchip社の統合開発環境。エディタ、プロジェクト マネージャ、シミュレータが付属する。 

 
MPLAB PM3 
Microchip社提供のデバイス プログラマ。PIC18マイクロ コントローラとdsPICデジタルシグナル コントローラのプ

ログラムに対応。MPLAB IDE/MPLAB X IDEと一緒に使う事も、単体で使う事も可能。PRO MATE IIの後継製品。 
 

MPLAB REAL ICE™インサーキット エミュレータ 
MPLAB IDE/MPLAB X IDEと組み合わせて使うMicrochip社の次世代インサーキット エミュレータ。「ICE/ICD」参照。 

 
MPLAB SIM 
MPLAB IDE/MPLAB X IDEと組み合わせて使うMicrochip社のシミュレータで、PIC MCUとdsPIC DSCに対応する。 

 
MPLAB Starter Kit for (デバイス名) (MPLAB Starter Kit for Device) 
特定のデバイスでの作業を開始する上で必要となるものを全てセットにしたMicrochip社のスタータキット。書き込

み済みアプリケーションの動作を確認し、一部を変更してカスタム アプリケーションとしてデバッグとプログラミ

ングを行える。 
 

MPLIB™オブジェクト ライブラリアン(MPLIB Object Librarian) 
MPLAB IDE/MPLAB X IDEと組み合わせて使うMicrochip社のライブラリアン。MPLIBライブラリアンは、MPASMア

センブラ(mpasmまたはmpasmwin v2.0)またはMPLAB C18 Cコンパイラで作成したCOFFオブジェクト モジュール

に使うオブジェクト ライブラリアン。 
 

MPLINK™オブジェクト リンカ(MPLINK Object Linker) 
Microchip社のMPASMアセンブラとC18 Cコンパイラに対応したオブジェクト リンカ。Microchip社のMPLIBライブ

ラリアンとの併用も可能。MPLAB IDE/MPLAB X IDEに統合して使うように設計されているが、MPLAB IDE/MPLAB 
X IDE以外の環境でも使える。 

 
MRU 
Most Recently Usedの略。最近使ったファイルとウィンドウの事。MPLAB IDE/MPLAB X IDEのメインメニューで選

択できる。 
 

ネイティブ データサイズ(Native Data Size) 
ネイティブ トレースの場合、[Watches]ウィンドウで使う変数のサイズは選択したデバイスのデータメモリと同じサ

イズ(PIC18の場合は同じバイトサイズ、16ビットデバイスの場合は同じワードサイズ)である必要がある。 
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入れ子の深さ(Nesting Depth) 
マクロに他のマクロを入れ込める階層の数。 

 
ノード(Node) 
MPLAB IDE/MPLAB X IDEのプロジェクトを構成するコンポーネント 

 
非拡張モード(Non-Extended Mode) (PIC18 MCU) 
コンパイラの動作モードの1つ。拡張命令もリテラル オフセットによるインデックス アドレス指定も使わない。 

 
非リアルタイム(Non Real Time) 
ブレークポイントで停止中、またはシングルステップ実行中のプロセッサ、あるいはシミュレータ モードで動作中

のMPLAB IDE/MPLAB X IDEを指す。 

 
不揮発性ストレージ(Non-Volatile Storage) 
電源をOFFにしても内容が失われないストレージ デバイス。 

 
NOP 
No Operationの略。実行してもプログラム カウンタが進むだけで何も動作を行わない命令。 

 
オブジェクト コード/オブジェクト ファイル(Object Code/Object File) 
オブジェクト コードとは、アセンブラまたはコンパイラで生成されるマシンコードの事。オブジェクト ファイルと

は、マシンコードを格納したファイル。デバッグ情報を含む事もある。そのまま実行できるものと、他のオブジェク

ト ファイル(例: ライブラリ)とリンクしてから完全な実行プログラムを生成する再配置可能形式のものがある。 

 
オブジェクト ファイル ディレクティブ(Object File Directive) 
オブジェクト ファイル作成時にのみ使うディレクティブ。 

 
8進数(Octal) 
0～7の数字のみを使う、8を底とした記数法。一番右の桁が1の位、次の桁が8の位、その次の桁が82 = 64の位を表す。 

 
オフチップメモリ(Off-Chip Memory) 
PIC18で選択できるメモリオプション。ターゲットボードのメモリを使うか、または全てのプログラムメモリをエミ

ュレータから供給する。[Options] > [Development Mode]の順にクリックして[Memory]タブでオフチップメモリを選

択する。 

 
オペコード(Opcode) 
Operational Codeの略。「ニーモニック」参照。 

 
演算子(Operators) 
定義可能な式を構成する際に使う「+」や「-」等の記号。各演算子に割り当てられた優先順位に基づいて式を評価す

る。 

 
OTP (One-Time-Programmable) 
One Time Programmableの略。パッケージに窓のないEPROMデバイス。EPROMを消去するには紫外線照射が必要

なため、パッケージに窓のあるデバイスしか消去できない。 

 
パスカウンタ(Pass Counter) 
イベント(特定のアドレスの命令を実行する等)が発生するたびに値をデクリメントするカウンタ。パスカウンタの値

がゼロになると、イベントの条件を満たす。パスカウンタはブレークロジック、トレースロジック、複合トリガダイ

アログの任意のシーケンシャル イベントに割り当てられる。 
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PC 
パーソナル コンピュータまたはプログラム カウンタの略。 

 
ホストPC (PC Host) 
パーソナル コンピュータ。 

 
永続データ(Persistent Data) 
クリアも初期化もされないデータ。デバイスをリセットしてもアプリケーションがデータを保持できるようにするた

めに使う。 

 
ファントムバイト(Phantom Byte) 
dsPICアーキテクチャで、24ビット命令ワードを32ビット命令ワードと見なして扱う場合に使う未実装バイト。

dsPICのHEXファイルに見られる。 

 
PIC MCU 
Microchip社の全てのMCUファミリの総称。 

 
PICkit 2/3 
Microchip社の開発用デバイス プログラマで、Debug Expressによるデバッグ機能を備える。サポートしているデバ

イスの種類は、各ツールのReadmeファイルを参照。 

 
プラグイン(Plug-ins) 
MPLAB IDE/MPLAB X IDEでは、標準コンポーネントにプラグイン モジュールを追加する事で、各種ソフトウェア/
ハードウェア ツールに対応する。一部のプラグインツールは、[Tools]メニューから利用できる。 

 
ポッド(Pod) 
インサーキット エミュレータまたはデバッガの筐体。丸型の場合パック(Puck)と呼ぶ事もある。あるいはプローブ

(Probe)とも呼ぶが、「論理プローブ」と混同せぬよう注意が必要。 

 
パワーオン リセット エミュレーション(Power-on-Reset Emulation) 
データRAM領域にランダムな値を書き込んで、初回電源投入時のRAMの非初期化値をシミュレートするソフトウェ

ア無作為化処理。 

 
プラグマ(Pragma) 
特定のコンパイラにとって意味を持つディレクティブ。一般に、実装で定義した情報をコンパイラに伝達するために

使う。 

 
優先順位(Precedence) 
式の評価順を定義した規則。 

 
量産プログラマ(Production Programmer) 
デバイスを高速にプログラミングできるようにリソースを強化したプログラマ。各種電圧レベルでのプログラミング

に対応し、プログラミング仕様に完全に準拠している。 
量産環境では応用回路が組み立てラインにとどまる時間をなるべく短くする必要があるため、デバイスへの書き込み

時間の短縮が特に重要である。 

 
プロファイル(Profile) 
MPLAB SIMシミュレータにおいて、実行したスティミュラスをレジスタ別に一覧表示したもの。 

 
プログラム カウンタ(Program Counter) 
現在実行中の命令のアドレスを格納した場所。 
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プログラム カウンタユニット(Program Counter Unit) 
16ビットアセンブラ - プログラムメモリのレイアウトを概念的に表現したもの。プログラム カウンタは1命令ワード

で2つインクリメントする。実行可能セクションでは、2プログラム カウンタユニットは3バイトに相当する。読み出

し専用セクションでは、2プログラム カウンタユニットは2バイトに相当する。 

 
プログラムメモリ(Program Memory) 
MPLAB IDE/MPLAB X IDEの場合: デバイス内で命令が保存されるメモリ空間。また、エミュレータまたはシミュレ

ータにダウンロードしたターゲット アプリケーションのファームウェアを格納するメモリ空間もプログラムメモリ

と呼ぶ。 

16ビットアセンブラ/コンパイラの場合: デバイス内で命令が保存されるメモリ空間。 
 

プロジェクト(Project) 
アプリケーションのビルドに必要なファイル(例: ソースコード、リンカスクリプト ファイル)一式と、各種ビルドツ

ールやビルドオプションとの関連付けをまとめたもの。 

 
プロローグ(Prologue) 
コンパイラで生成したコードのうち、スタック領域の割り当て、レジスタの退避、ランタイムモデルで指定したその

他のマシン固有の要件を実行するコード部分。プロローグは、関数のユーザコードの前に実行する。 

 
プロトタイプ システム(Prototype System) 
ユーザのターゲット アプリケーションまたはターゲットボードの事。 

 
Psect 
GCCのセクションに相当するOCGの用語。プログラム セクション(program section)の略語。リンカが1つのまとま

りとして処理するコードまたはデータのブロック。 

 
PWM信号(PWM Signal) 
パルス幅変調(Pulse Width Modulation)信号。一部のPIC MCUは周辺モジュールとしてPWMを内蔵している。 

 
修飾子(Qualifier) 
パスカウンタで使ったり、複合トリガにおける次の動作前のイベントとして使ったりするアドレスまたはアドレスレ

ンジ。 

 
基数(Radix) 
アドレスを指定する際の記数法(16進法、10進法)の底。 

 
RAM 
Random Access Memoryの略。データメモリ。任意の順にメモリ内の情報にアクセスできる。 

 
生データ(Raw Data) 
あるセクションに関連付けられたコードまたはデータを2進数で表現したもの。 

 
読み出し専用メモリ(Read Only Memory) 
恒久的に保存されているデータへの高速アクセスが可能なメモリ ハードウェア。ただし、データの追加や変更は不可。 

 
リアルタイム(Real Time) 
インサーキット エミュレータまたはデバッガがHalt状態から解放されると、プロセッサの実行はリアルタイム モー

ドとなり、通常のチップと同じ挙動をする。リアルタイム モードでは、エミュレータのリアルタイム トレースバッ

ファが有効になり、選択した全てのサイクルを常時キャプチャする。また、全てのブレークロジックが有効になる。

インサーキット エミュレータまたはデバッガでは、有効なブレークポイントで停止するか、またはユーザが実行を

停止するまでプロセッサはリアルタイムで動作する。 
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シミュレータでは、ホストCPUでシミュレート可能な最大速度でマイクロ コントローラの命令を実行する事をリア

ルタイムと呼ぶ。 

 
再帰呼び出し(Recursive Calls) 
直接または間接的に自分自身を呼び出す関数。 

 
再帰(Recursion) 
定義した関数またはマクロがそれ自身を呼び出す事。再帰マクロを作成する際は、再帰から抜けずに無限ループとな

りやすいため注意が必要。 

 
再入可能(Re-entrant) 
1つの関数を複数呼び出して同時に実行できる事。直接または間接再帰、あるいは割り込み処理中の実行によって起

こる事がある。 

 
緩和(Relaxation) 
ある命令を、機能が同じでよりサイズの小さい命令に変換する事。コードサイズを抑えるために便利である。最新の

MPLAB XC16には、CALL命令をRCALL命令に緩和する機能がある。この変換は、現在の命令から+/- 32k命令ワード

以内にあるシンボルを呼び出す場合に行われる。 

 
再配置可能(Relocatable) 
アドレスがメモリの固定番地に割り当てられていないオブジェクト。 

 
再配置可能セクション(Relocatable Section) 
16ビットアセンブラ - アドレスが固定されていない(絶対アドレスでない)セクション。再配置可能セクションには、

再配置と呼ばれるプロセスでリンカがアドレスを割り当てる。 

 
再配置(Relocation) 
リンカが絶対アドレスを再配置可能セクションに割り当てる事。再配置可能セクション内の全てのシンボルを新しい

アドレスに更新する。 

 
ROM 
Read Only Memoryの略。プログラムメモリ。メモリの内容を変更できない。 

 
Run 
エミュレータをHaltから解放するコマンド。エミュレータはアプリケーション コードを実行し、I/Oに対してリアル

タイムに変更、応答を行う。 

 
ランタイムモデル(Run-time Model) 
ターゲット アーキテクチャのリソースの使用を記述したもの。 

 
ランタイム ウォッチRun-time Watch 
アプリケーションの実行につれて変数の値がリアルタイムに変化する[Watch]ウィンドウ。ランタイム ウォッチの設

定方法は各ツールの関連文書を参照。ランタイム ウォッチをサポートしていないツールもある。 

 
シナリオ(Scenario) 
MPLAB SIMシミュレータでスティミュラス制御を具体的に設定したもの。 

 
項目 
OCGのpsectに相当するGCCの用語。リンカが1つのまとまりとして処理するコードまたはデータのブロック。 

 
セクション属性(Section Attribute) 
GCCのセクションの特徴を表す情報(例: accessセクション)。 
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シーケンス ブレークポイント(Sequenced Breakpoint) 
シーケンスで発生するブレークポイント。ブレークポイントのシーケンス実行順はボトムアップです。つまり、シー

ケンスの最後のブレークポイントが最初に発生します。 

 
SQTP (Serialized Quick Turn Programming) 
デバイス プログラマでマイクロ コントローラをプログラミングする際に、各デバイスに異なるシリアル番号を書き

込めるようにする機能。この番号はエントリコード、パスワード、ID番号として使える。 

 
シェル(Shell) 
MPASMアセンブラにおいて、マクロアセンブラへの入力を行うためのプロンプト インターフェイス。MPASMアセ

ンブラにはDOS用シェルとWindows用シェルの2種類がある。 

 
シミュレータ(Simulator) 
デバイスの動作をモデル化するソフトウェア プログラム。 

 
シングルステップ(Single Step) 
コードを1命令ずつ実行するコマンド。1命令を実行するたびに、MPLAB IDE/MPLAB X IDEがレジスタ ウィンドウ、

ウォッチ変数、ステータスの表示を更新するため、命令実行を解析してデバッグできる。Cコンパイラのソースコー

ドもシングルステップ実行できるが、その場合MPLAB IDE/MPLAB X IDEは1命令ずつ実行するのではなく、高級言

語のCで記述されたコードの1行から生成される全てのアセンブリレベル命令をシングルステップで実行する。 

 
スキュー(Skew) 
命令実行に対応する情報は、異なる複数のタイミングでプロセッサバスに表れる。例えば、実行されるオペコードは

直前の命令の実行時にフェッチとしてバスに表れる。ソースデータのアドレスと値、およびデスティネーション デ
ータのアドレスは、オペコードが実際に実行される時にバスに表れる。デスティネーション データの値は次の命令

の実行時にバスに表れる。トレースバッファは、1インスタンスでバス上に存在する情報をキャプチャする。従って、

トレースバッファの1エントリには3つの命令の実行情報が含まれる。1つの命令実行で、ある情報から次の情報まで

にキャプチャされるサイクル数をスキューと呼ぶ。 

 
スキッド(Skid) 
ハードウェア ブレークポイントを使ってプロセッサを停止する場合、ブレークポイント以降の命令を実行してプロ

セッサが停止する事がある。ブレークポイントの後に実行する命令の数をスキッドと呼ぶ。 

 
ソースコード(Source Code) 
人間が記述したコンピュータ プログラム。プログラミング言語で記述されたソースコードは、マシンコードに変換

して実行するか、またはインタプリタで実行される。 

 
ソースファイル(Source File) 
ソースコードを記述したASCIIテキストファイル。 

 
特殊機能レジスタ(SFR) 
I/Oプロセッサ機能、I/Oステータス、タイマ等の各種モードや周辺モジュールを制御するレジスタ専用に使うデータ

メモリ(RAM)領域。 

 
SQTP 
「Serialized Quick Turn Programming」参照 

 
ハードウェア スタック(Stack, Hardware) 
PIC MCUで関数を呼び出す時に戻りアドレスを格納する場所。 
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ソフトウェア スタック(Stack, Software) 
アプリケーションが戻りアドレス、関数パラメータ、ローカル変数を保存するのに使うメモリ。このメモリはプログ

ラムでの命令の実行時に動的に割り当てられる。これによって、再入可能な関数の呼び出しが可能になる。 

 
コンパイルド スタック(Stack, Compiled) 
コンパイラが管理し割り当てるメモリの領域で、この領域内で変数に静的に空間を割り当てる。ターゲット デバイ

ス上にソフトウェア スタックのメカニズムを効率的に実装できない場合、ソフトウェア スタックがコンパイルド ス
タックに置き換わる。このメカニズムでは、関数は再入可能ではなくなる。 

 
スタティックRAM (SRAM) (Static RAM or SRAM) 
Static Random Access Memoryの略。ターゲットボード上の読み書き可能なプログラムメモリ。リフレッシュ動作は

不要。 

 
ステータスバー(Status Bar) 
MPLAB IDE/MPLAB X IDEウィンドウの一番下にあるバーで、カーソル位置、開発モードとデバイス、アクティブな

ツールバー等に関する情報が表示される。 

 
ステップイントゥ(Step Into) 
Single Stepと同じコマンド。Step Overとは異なり、Step IntoではCALL命令が呼び出すサブルーチン内もステップ実

行する。 

 
ステップオーバー(Step Over) 
Step Overを実行すると、サブルーチン内をステップ実行せずにコードをデバッグできる。Step Overでは、CALL命
令があるとCALLの次の命令にブレークポイントが設定される。何らかの理由により、サブルーチンが無限ループに

なる等、正しくリターンしない場合、次のブレークポイントには到達しない。CALL命令の処理以外は、Step Overコ
マンドとSingle Stepコマンドは同じ。 

 
ステップアウト(Step Out) 
現在ステップ実行中のサブルーチンから抜け出すためのコマンド。このコマンドを実行すると、サブルーチンの残り

のコードを全て実行し、サブルーチンの戻りアドレスで実行が停止する。 

 
スティミュラス(Stimulus) 
シミュレータへの入力、すなわち外部信号に対する応答をシミュレートするために生成するデータ。通常、テキスト

ファイルにアクションのリストとしてこのデータを記述する。スティミュラスの種類には非同期、同期(ピン)、クロ

ック動作、レジスタがある。 

 
ストップウォッチ(Stopwatch) 
実行サイクルを計測するためのカウンタ。 

 
記憶域クラス(Storage Class) 
指定されたオブジェクトに対応する記憶場所の持続期間を決定する。 

 
記憶域修飾子(Storage Qualifier) 
宣言されるオブジェクトの特別な属性を示す(例: const)。 

 
シンボル(Symbol) 
プログラムを構成する各種の要素を記述する汎用のメカニズム。関数名、変数名、セクション名、ファイル名、

struct/enum/unionタグ名等がある。MPLAB IDE/MPLAB X IDEでは、主に変数名、関数名、アセンブリラベルをシン

ボルと呼ぶ。リンク実行後は、シンボルの値はメモリ内の値となる。 
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システム ウィンドウ コントロール(System Window Control) 
ウィンドウと一部のダイアログの左上隅にあるコントロール。通常、このコントロールをクリックすると、[最小化]、
[最大化]、[閉じる]等のメニュー項目がポップアップ表示される。 

 
ターゲット(Target) 
ユーザ ハードウェアの事。 

 
ターゲット アプリケーション(Target Application) 
ターゲットボードに読み込んだソフトウェア。 

 
ターゲットボード(Target Board) 
ターゲット アプリケーションを構成する回路とデバイス。 

 
ターゲット プロセッサ(Target Processor) 
ターゲット アプリケーションの基板で使われているMCU。 

 
テンプレート(Template) 
後でファイルに挿入するために作成するテキスト行。MPLABエディタでは、テンプレートはテンプレート ファイル

に保存する。 

 
ツールバー(Toolbar) 
MPLAB IDE/MPLAB X IDEの機能を実行するためのボタン (アイコン)を縦または横に並べたもの。 

 
トレース(Trace) 
プログラム実行を記録するエミュレータまたはシミュレータの機能。エミュレータはプログラム実行のログをトレー

スバッファに記録し、これをMPLAB IDE/MPLAB X IDEのトレース ウィンドウにアップロードする。 

 
トレースメモリ(Trace Memory) 
エミュレータが内蔵するトレース用のメモリ。トレースバッファとも呼ばれる。 

 
トレースマクロ(Trace Macro) 
エミュレータ データからのトレース情報を提供するマクロ。これはソフトウェア トレースのため、トレースを利用

するにはマクロをコードに追加し、コードを再コンパイルまたは再アセンブルし、ターゲット デバイスにこのコー

ドをプログラミングする必要がある。 

 
トリガ出力(Trigger Output) 
任意のアドレスまたはアドレス範囲で生成でき、トレースとブレークポイントの設定から独立したエミュレータ出力

信号の事。トリガ出力の設定数に制限はない。 

 
トライグラフ(Trigraph) 
「??」で始まる3文字のシーケンス。ISO Cで定義されており、1つの文字に置換される。 

 
未割り当てセクション(Unassigned Section) 
リンカのコマンドファイルで特定のターゲット メモリブロックに割り当てられていないセクション。リンカは、未

割り当てセクションを割り当てるターゲット メモリブロックを検出する必要がある。 

 
非初期化データ(Uninitialized Data) 
初期値なしで定義されたデータ。Cでは、 

int myVar; 

 
は、非初期化済みデータセクションに格納される変数を定義する。
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アップロード(Upload) 
エミュレータやプログラマ等のツールからホストコンピュータへ、またはターゲットボードからエミュレータへデー

タを転送する事。 

 
USB 
Universal Serial Busの略。2本のシリアル伝送線でPCと外部周辺機器の通信を行う外部周辺インターフェイス規格。

USB 1.0/1.1は最大12 Mbpsのデータレートをサポートしている。USB 2.0 (ハイスピードUSB)は最大480 Mbpsのデ

ータレートをサポートしている。 

 
ベクタ(Vector) 
リセットまたは割り込みが発生した時にアプリケーションのジャンプ先となるメモリ番地。 

 
Volatile 
メモリ内の変数へのアクセス方法に影響を与えるコンパイラの最適化を抑制する変数修飾子。 

 
警告(Warning) 
警告 
MPLAB IDE/MPLAB X IDEの場合: デバイス、ソフトウェア ファイル、装置に物理的な損傷を与える可能性のある状

況で、ユーザに注意を促すために表示されるメッセージ。 

16ビットアセンブラ/コンパイラの場合: 問題となる可能性のある状態を警告として報告するが、処理は停止されない。 

 
ウォッチ変数(Watch Variable) 
デバッグ セッション中に[Watches]ウィンドウで監視できる変数。 

 
[Watches]ウィンドウ(Watches Window) 
ウォッチ変数の一覧を表示し、ブレークポイントで毎回表示を更新するウィンドウ。 

 
ウォッチドッグ タイマ(WDT: Watchdog Timer) 
PICマイクロ コントローラに内蔵されたタイマの1つで、ユーザが設定した期間が経過するとプロセッサをリセット

する。WDTの有効化/無効化、設定はコンフィグレーション ビットで行う。 

 
ワークブック(Workbook) 
MPLAB SIMシミュレータにおいて、SCLスティミュラスの生成に関する設定を保存したもの。 
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Microchip社のウェブサイト 
Microchip社はウェブサイト(www.microchip.com)を通してオンライン サポートを提供しています。当ウェブサイト

では、お客様に役立つ情報やファイルを簡単に見つけ出せます。以下を含む各種の情報がご覧になれます。 

• 製品サポート - データシートとエラッタ、アプリケーション ノートとサンプル プログラム、設計リソース、ユ

ーザガイドとハードウェア サポート文書、最新のソフトウェアと過去のソフトウェア 
• 技術サポート – よく寄せられる質問(FAQ)、技術サポートのご依頼、オンライン ディスカッション グループ、

Microchip社のコンサルタント プログラムおよびメンバーリスト 
• ご注文とお問い合わせ - 製品セレクタと注文ガイド、最新プレスリリース、セミナー/イベントの一覧、お問い

合わせ先(営業所/販売代理店)の一覧 
 

お客様への通知サービス 
Microchip社のお客様向け変更通知サービスは、お客様にMicrochip社製品の最新情報をお届けする配信サービスです。

ご興味のある製品ファミリまたは開発ツールに関する変更、更新、リビジョン、エラッタ情報をいち早くメールに

てお知らせします。 

http://www.microchip.com/pcnにアクセスし、登録手続きをしてください。 
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